New Version of Separation Modfit 1.34
log in

Advanced search

Message boards : News : New Version of Separation Modfit 1.34

Author Message
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,451,106
RAC: 146,641

Message 62366 - Posted: 22 Sep 2014, 20:04:58 UTC

Hey all,

I just released a new version of separation today that is compiled against older glibc versions. The actual version number is 2.11 for glibc. This is the oldest that Ubuntu currently has on an active LTS. Users who experience errors due to the fact that their glibc versions are older than this should send me a message and I will give them instructions on how to compile the program for their own machines using their version of glibc. Otherwise, I changed the plan class we are using for our GPU versions to enforce a minimum OpenCL version. This will keep CAL cards from getting GPU work units from the server and reduce error rates and thus validation issues.

Sorry for the wall of text but essentially we have an older glibc and a new method for sending out GPU work units.

If there are any issues with this release please post them here and I will try to get back to you quickly.

Thank you all for your continued support,

Jake W.

DJStarfox
Send message
Joined: 29 Sep 10
Posts: 53
Credit: 850,058
RAC: 207

Message 62367 - Posted: 22 Sep 2014, 20:32:53 UTC - in response to Message 62366.

Sounds great. I will test out the new version. In the meantime, the feeder is "not running", so i cannot get any work.

Donald Qualls
Send message
Joined: 13 Apr 11
Posts: 33
Credit: 8,575,501
RAC: 11,173

Message 62372 - Posted: 23 Sep 2014, 10:00:49 UTC - in response to Message 62367.

And the feeder is still not running. I've got eight or ten MilkyWay tasks ready to report, and can neither send them nor get new ones to crunch on. My second machine ("Luddite") is still happily working on stuff it downloaded a couple days ago (1.6 GHz single core Athlon XP 2000+), but my main system ("Kubuntu64") hasn't had anything to crunch on other than GPU tasks for Einstein since sometime last night.

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,451,106
RAC: 146,641

Message 62374 - Posted: 23 Sep 2014, 14:59:41 UTC

Hey Guys,

Sorry about the delayed response. Thank you for all of the reports. Looks like we need to change a few things on the server to get the feeder back up and running. Will try to have it done by the end of the day today. If not then by the end of the day tomorrow. Until then I'm sorry about the inconvenience.

Jake W.

Profile TimeRanger
Send message
Joined: 31 Oct 10
Posts: 74
Credit: 22,910,263
RAC: 28,494

Message 62388 - Posted: 24 Sep 2014, 6:16:16 UTC

ps_mod_fit_86_DR8_Rev_4_3_3s_128wrap_0002_1411504411_31372
ps_mod_fit_86_DR8_Rev_4_3_3s_128wrap_0002_1410552780_1262668
de_modfit_15_3s_132_wrap_7_1410552780_1258688
de_modfit_15_3s_132_wrap_8_1410552780_1110390

All Completed, Can't validate errors

greg_be
Send message
Joined: 18 Aug 09
Posts: 83
Credit: 3,762,342
RAC: 4,338

Message 62389 - Posted: 24 Sep 2014, 6:30:53 UTC

ps_mod_fit_86_DR8_Rev_4_3_3s_128wrap_0002_1411504411_14507_1 Incorrect function.
de_modfit_15_3s_132_wrap_8_1411504411_4573_2 too many exit(0)s

and the rest of the modfits vary with these error messages.
I posted a message over in number crunching asking why my GPU is unable to process these tasks.

I have a few tasks left over in modfit to process, but it looks like I will have to stop processing these tasks as 99% of them error out, unless it is old material?

greg_be
Send message
Joined: 18 Aug 09
Posts: 83
Credit: 3,762,342
RAC: 4,338

Message 62409 - Posted: 27 Sep 2014, 15:44:05 UTC

Jake, with all the problems going on with the modfits, someone should have alerted you to this and maybe you could update us as to what is going on. My GPU just spits 99% of these tasks back. I also unchecked modfit in the preferences but that does not seem to stop your servers from sending me modfit tasks. I don't understand this! I even reset the project and the first modfit died immediately and another ran about 8 minutes and then starts the exit 0 status loop. I aborted everything else. So why is your server sending me modfit tasks when I said not to? And why are they always dying on my system?

SLRE
Send message
Joined: 26 Jan 09
Posts: 12
Credit: 21,897,828
RAC: 22,645

Message 62412 - Posted: 28 Sep 2014, 12:27:39 UTC - in response to Message 62409.

I'm also seeing essentially 100% computation error on 1.34 tasks. Machine is Win 7 running a geforce GT 640.
I'm letting them error naturally so they show up in your logs; they aren't using time.

Michael Bennett
Send message
Joined: 10 Mar 09
Posts: 13
Credit: 4,300,514
RAC: 5,136

Message 62413 - Posted: 28 Sep 2014, 14:04:06 UTC - in response to Message 62366.

Hello Jake, all the modfit 1.34 files are not being processed. That figure is running around 30-50 files in a 24 hour period. Exact number is not known. All other files are fine, including those of Cosmology@home and SETI@home files. I'd like to help you more. -Mike
____________

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,451,106
RAC: 146,641

Message 62422 - Posted: 29 Sep 2014, 13:19:17 UTC

Sorry for the delayed response, the Physics GREs were this Saturday, so I have been a bit busy. I will be resuming regular work today though so I will give you some updates soon.

Jake W.

DJStarfox
Send message
Joined: 29 Sep 10
Posts: 53
Credit: 850,058
RAC: 207

Message 62423 - Posted: 29 Sep 2014, 14:06:16 UTC

I'm still receiving the GLIBC version missing error with this new modified fit app.
http://milkyway.cs.rpi.edu/milkyway/result.php?resultid=837904404

So, looks like the compile for modified fit didn't work right....

The recent nBody app is working though.

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,451,106
RAC: 146,641

Message 62426 - Posted: 29 Sep 2014, 18:15:01 UTC

I have a fix for the glibc version issue. Will be out soon. Sorry it should have been in the last version but wasn't.

Jake W.

Profile Martin
Send message
Joined: 22 Sep 14
Posts: 9
Credit: 2,503,997
RAC: 4,963

Message 62471 - Posted: 5 Oct 2014, 11:09:19 UTC

In the last couple of days I have had 24 Modfit 1.34 tasks downloaded to my computer. So far one has yet to run, and the other 23 failed immediately (0.00 sec CPU time) with "Unknown error - exit code -1073741515".

I am using a Dell XP machine with a 2-core processor. I don't think MOdfit 1.34 likes my computer!

greg_be
Send message
Joined: 18 Aug 09
Posts: 83
Credit: 3,762,342
RAC: 4,338

Message 62478 - Posted: 5 Oct 2014, 13:25:45 UTC - in response to Message 62426.

what is "soon"? I am not going to allow any modfit stuff on my system until this patch is done.

Michael Bennett
Send message
Joined: 10 Mar 09
Posts: 13
Credit: 4,300,514
RAC: 5,136

Message 62489 - Posted: 6 Oct 2014, 3:19:19 UTC - in response to Message 62422.

If I'm the only one having problems with the Sep Modfit 1.34 files then my comment might be superfluous, but I am deleting ~20 to ~30 files in a 24 hour period. I feel I must because if I allow them to run, they will crash at the end. That means hours of CPU time lost to other programs. Not so efficient. The other files process just fine with no problems. I don't see any other chatter on the topic so I can see if there is something I can do to remedy this issue.
Any suggestions?
-Mike

Go Rensselaer!!

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,451,106
RAC: 146,641

Message 62494 - Posted: 6 Oct 2014, 13:30:32 UTC

Soon is today sorry. We try to do releases at the beginning of the week so they're easier for us to support and easier for you guys to check for errors if they're on machines you may not be able to access on the weekends. Sorry for the delay.

Jake W.

greg_be
Send message
Joined: 18 Aug 09
Posts: 83
Credit: 3,762,342
RAC: 4,338

Message 62497 - Posted: 6 Oct 2014, 19:36:08 UTC - in response to Message 62494.

ok thanks Jake, I will enable modfit again on wednesday.
I had it disabled, but stuff is still leaking through and doing exit 0 nonsense.


Post to thread

Message boards : News : New Version of Separation Modfit 1.34


Main page · Your account · Message boards


Copyright © 2017 AstroInformatics Group