rpi_logo
R9 290 is not recognized on linux x64 with proprietary drivers and OpenCL sdk installed
R9 290 is not recognized on linux x64 with proprietary drivers and OpenCL sdk installed
log in

Advanced search

Message boards : Application Code Discussion : R9 290 is not recognized on linux x64 with proprietary drivers and OpenCL sdk installed

Author Message
pixecs
Send message
Joined: 10 Jan 15
Posts: 3
Credit: 53,561
RAC: 0

Message 63005 - Posted: 13 Jan 2015, 17:25:59 UTC

Hello everyone,

Since i switched from CPU to GPU computation ('use CPU' is disabled, 'Use ATI GPU' enabled in MilkyWay@Home preferences) the following message is displayed:

13-Jan-2015 19:07:44 [Milkyway@Home] Requesting new tasks for CPU and AMD/ATI GPU 13-Jan-2015 19:07:47 [Milkyway@Home] Scheduler request completed: got 0 new tasks 13-Jan-2015 19:07:47 [Milkyway@Home] No tasks sent 13-Jan-2015 19:07:47 [Milkyway@Home] ATI GPU R600 (R38xx) does not support OpenCL 13-Jan-2015 19:07:47 [Milkyway@Home] Tasks for CPU are available, but your preferences are set to not accept them 13-Jan-2015 19:07:47 [Milkyway@Home] Tasks for NVIDIA GPU are available, but your preferences are set to not accept them 13-Jan-2015 19:08:53 [Milkyway@Home] Sending scheduler request: To fetch work. 13-Jan-2015 19:08:53 [Milkyway@Home] Requesting new tasks for AMD/ATI GPU 13-Jan-2015 19:08:55 [Milkyway@Home] Scheduler request completed: got 0 new tasks


My computer is a openSUSE 13.1 with R9 290 and proprietary drivers (and OpenCL sdk) installed.

Can anyone point me to how i can 'convince' the application that my GPU is OpenCL capable?

On seti@home & POEM@home the GPU is used without problems with the same settings in preferences menu.

swiftmallard
Avatar
Send message
Joined: 18 Jul 09
Posts: 289
Credit: 302,980,648
RAC: 0

Message 63007 - Posted: 13 Jan 2015, 17:54:27 UTC

See this thread:
http://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=3457#60804

pixecs
Send message
Joined: 10 Jan 15
Posts: 3
Credit: 53,561
RAC: 0

Message 63008 - Posted: 13 Jan 2015, 18:04:26 UTC - in response to Message 63007.

Thank you for your quick response.
I'll check the thread and see if it will work for me.

pixecs
Send message
Joined: 10 Jan 15
Posts: 3
Credit: 53,561
RAC: 0

Message 63012 - Posted: 13 Jan 2015, 18:38:27 UTC - in response to Message 63008.

Up and running!

I downloaded from http://milkyway.cs.rpi.edu/milkyway/download/ the latest milkyway_separation__modified_fit application

i created this app_info.xml

<app_info> <app> <name>milkyway_separation__modified_fit</name> </app> <file_info> <name>milkyway_separation__modified_fit_1.36_x86_64-pc-linux-gnu__opencl_ati_101</name> <executable /> </file_info> <app_version> <app_name>milkyway_separation__modified_fit</app_name> <version_num>136</version_num> <avg_ncpus>0.040000</avg_ncpus> <max_ncpus>0.567833</max_ncpus> <plan_class>opencl_ati_101</plan_class> <file_ref> <file_name>milkyway_separation__modified_fit_1.36_x86_64-pc-linux-gnu__opencl_ati_101</file_name> <main_program/> </file_ref> <coproc> <type>ATI</type> <count>1.0000</count> </coproc> </app_version> </app_info>


and now everything is ok.

Floyd
Send message
Joined: 2 Dec 10
Posts: 12
Credit: 107,787,192
RAC: 0

Message 63018 - Posted: 16 Jan 2015, 3:08:49 UTC - in response to Message 63005.
Last modified: 16 Jan 2015, 3:10:03 UTC

Posted in error


Post to thread

Message boards : Application Code Discussion : R9 290 is not recognized on linux x64 with proprietary drivers and OpenCL sdk installed


Main page · Your account · Message boards


Copyright © 2018 AstroInformatics Group