GPU Issues Mega Thread
log in

Advanced search

Message boards : News : GPU Issues Mega Thread

1 · 2 · 3 · 4 . . . 8 · Next
Author Message
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,928,966
RAC: 177,167

Message 65046 - Posted: 18 Aug 2016, 15:21:40 UTC

Hey everyone,

I am going to spend some time specifically looking into the GPU issues for the next couple days. Can everyone please post the exact issues you are having here? This includes quotes of the error messages you are seeing and any other information you think is useful. I've been going through old forums posts trying to decide where I think the problem is and I am still unsure where the problem is.

Jake

pe
Send message
Joined: 17 Oct 07
Posts: 1
Credit: 3,221,775
RAC: 2,616

Message 65047 - Posted: 18 Aug 2016, 16:43:42 UTC

Hi Jake,

don't know if this helps, but milkyway@home did not seem to find my GPU in the last few days (GPU missing under BOINC status).
The GPU did work fine with other projects like SETI or Asteroids at that time.

Could be related to the Win10 Anniversary Upgrade, or the latest NVIDIA drivers update (GTX 750 Ti here). At least Windows did not mess with the driver, as the nvidia one was still installed.
But after reinstalling the same drivers (no clean install) milkyway is now again using the GPU so far.

Keep up the good work and best regards,
Bernd.
____________

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,428,269
RAC: 27,660

Message 65048 - Posted: 18 Aug 2016, 19:57:59 UTC - in response to Message 65046.

I've been going through old forums posts trying to decide where I think the problem is and I am still unsure where the problem is.


Are you thinking about use of anonymous platform to obtain work for recent AMD's gpus? If server cannot recognize correctly the gpu architecture is impossible to do automatic download of wus.

paula
Send message
Joined: 27 Jul 14
Posts: 1
Credit: 354,251
RAC: 0

Message 65050 - Posted: 18 Aug 2016, 22:59:15 UTC

There are too many computation problems with work units dated 1st August. The longer the work unit the more likely it is to be aborted . Has anyone else reported the same problem ? Is it the age of my computer at fault (6 yrs) or is there a problem with the data in the work units ?

Paula

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,928,966
RAC: 177,167

Message 65052 - Posted: 18 Aug 2016, 23:52:00 UTC

Paula,

Looks like your problems are with N-body, please post them over in number crunching. It is not appropriate to post them here were we are discussing GPU issues.

boboviz,

When you are running without the anonymous platforms, what do you see from the server? Do you get error messages? Does it just send CPU work units and pretend you don't have a GPU? What are you seeing on your end?

Pe,

I think your error was a one off due to Windows. Seems like a super minor problem with a simple fix. Going to focus on the other issues for now.

Jake

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,428,269
RAC: 27,660

Message 65053 - Posted: 19 Aug 2016, 7:48:03 UTC - in response to Message 65052.

When you are running without the anonymous platforms, what do you see from the server? Do you get error messages? Does it just send CPU work units and pretend you don't have a GPU? What are you seeing on your end?


It depends.
Sometimes "got 0 new task" (specially if queue is empty), otherwise like other volunteers "Ati does not support Opencl"
https://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=3824
I have 260x and crunch with Seti, Einstein, Poem, etc without problems

Jusik
Send message
Joined: 28 Jul 15
Posts: 3
Credit: 246,631,347
RAC: 73,401

Message 65054 - Posted: 19 Aug 2016, 14:55:20 UTC
Last modified: 19 Aug 2016, 14:58:38 UTC

Hi Jake,

Are you going to address the issue that AMD cards can process 1.36 WUs only with 11.x, 12.x drivers?

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,928,966
RAC: 177,167

Message 65055 - Posted: 19 Aug 2016, 15:08:55 UTC

Hey Jusik,

It doesn't work with the newest catalyst drivers? This is the first I am hearing of that.

Jake

Jusik
Send message
Joined: 28 Jul 15
Posts: 3
Credit: 246,631,347
RAC: 73,401

Message 65056 - Posted: 19 Aug 2016, 16:44:48 UTC

Jake,

A year ago, when I have started crunching milkyway, only modfit worked with 14+ drivers, others gave computational error. I will try now latest drivers and let you know.

Jusik

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,928,966
RAC: 177,167

Message 65057 - Posted: 19 Aug 2016, 17:02:22 UTC - in response to Message 65056.

Okay. The catalyst drivers are notoriously broken so I am not entirely sure it is our fault that there is an issue. If more people report problems I will look into this one.

Jake

Jusik
Send message
Joined: 28 Jul 15
Posts: 3
Credit: 246,631,347
RAC: 73,401

Message 65058 - Posted: 19 Aug 2016, 18:25:13 UTC

Just installed 16.7.3(Crimson), for my R9 200(280x) and all works fine. Probably it was just an issue with Radeon 5970 I had previously.
So, no issue. Sorry for hassle.

Jusik

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,928,966
RAC: 177,167

Message 65059 - Posted: 19 Aug 2016, 18:35:19 UTC

No hassle. I've been saying I would tackle GPU issues for a while so I want to get them all squared away.

Jake

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 438
Credit: 9,928,966
RAC: 177,167

Message 65060 - Posted: 19 Aug 2016, 19:06:13 UTC

Hey Everyone,

Quick progress report: I am working on updating the BOINC API code we build into our clients to be up to date. Maybe this will fix some of the compatibility issues with more modern GPUs, maybe it won't. Its the only thing I can think of updating at this point that may provide a quick fix. If it doesn't work we will try some more drastic options. Expect these new binaries to be released within a week or so after they have received proper testing and compile on all platforms.

Jake

Vortac
Send message
Joined: 22 Apr 09
Posts: 77
Credit: 1,052,831,093
RAC: 49,694

Message 65061 - Posted: 20 Aug 2016, 15:31:18 UTC - in response to Message 65056.

Jake,

A year ago, when I have started crunching milkyway, only modfit worked with 14+ drivers, others gave computational error. I will try now latest drivers and let you know.

I had the same problem, only modfit workunits worked back then on my 5870. Today, everything is fine, I still have 2x5870 crunching both modfit and regular workunits without any problems.

rcthardcore
Send message
Joined: 30 Dec 08
Posts: 25
Credit: 1,902,573
RAC: 2,143

Message 65062 - Posted: 20 Aug 2016, 18:42:08 UTC

Awhile back I had a slight problem. BOINC was aborting all GPU work units. Found out I had a bad driver install. Reinstalled driver and the problem was solved, so far.

entigy
Send message
Joined: 10 Jun 09
Posts: 5
Credit: 2,705,819
RAC: 0

Message 65063 - Posted: 22 Aug 2016, 16:27:31 UTC

Re-connected to MW to test GPU tasks - epic fail again:

22/08/2016 17:20:33 | | Fetching configuration file from http://milkyway.cs.rpi.edu/milkyway/get_project_config.php
22/08/2016 17:20:51 | Milkyway@Home | Master file download succeeded
22/08/2016 17:20:56 | Milkyway@Home | Sending scheduler request: Project initialization.
22/08/2016 17:20:56 | Milkyway@Home | Requesting new tasks for CPU and Miner ASIC and NVIDIA GPU
22/08/2016 17:20:57 | | App version needs OpenCL but GPU doesn't support it
22/08/2016 17:20:57 | Milkyway@Home | Scheduler request completed: got 1 new tasks
22/08/2016 17:20:57 | Milkyway@Home | New computer location: home
22/08/2016 17:20:57 | Milkyway@Home | [error] App version uses non-existent NVIDIA GPU
22/08/2016 17:20:57 | Milkyway@Home | [error] Missing coprocessor for task de_modfit_fast_15_3s_136_fixedangles2_1_1471352126_7255687_0; aborting

PC Specs as follows:

Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz
NVIDIA GeForce GTX 970 (4095MB) driver: 372.54
Microsoft Windows 10 Professional x64 Edition, (10.00.14905.00)

Profile skier8735
Send message
Joined: 30 Sep 10
Posts: 1
Credit: 5,319,001
RAC: 0

Message 65071 - Posted: 26 Aug 2016, 2:14:10 UTC

I still can't get milkyway to send me work on my new rig with a rx480

Vortac
Send message
Joined: 22 Apr 09
Posts: 77
Credit: 1,052,831,093
RAC: 49,694

Message 65072 - Posted: 26 Aug 2016, 16:05:52 UTC

Yes, GPU work is getting scarce again for my 7970 also

Profile [AF>Le_Pommier>MacBidouille.com]Prof
Send message
Joined: 4 Sep 09
Posts: 17
Credit: 105,564,190
RAC: 43,829

Message 65073 - Posted: 27 Aug 2016, 13:37:25 UTC
Last modified: 27 Aug 2016, 13:41:37 UTC

Hi everybody!

Since "modfit" is discontinued, I remove / add Milkyway to starts on fresh files.
The 1st time I connect the manager, I get the "classicc" message as my R600 AMD gpu isn't recognize!!
Now it only say me : "got 0 new task"

I'm on a Mac Pro 2009, OSX 10.11.6, 24Mo of RAM, AMD 7950 Mac Eddition from Sapphire & BOINC 7.6.22.

Someone can help me??

Thx in advance!!

P.S: I've a look in the milky folder in the project folder of Boinc, it's empty, no files!!

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,428,269
RAC: 27,660

Message 65075 - Posted: 29 Aug 2016, 5:25:31 UTC - in response to Message 65060.

Hey Everyone,

Quick progress report: I am working on updating the BOINC API code we build into our clients to be up to date. Maybe this will fix some of the compatibility issues with more modern GPUs, maybe it won't.


I think this is the solution. It's not a problem of gpu driver, but of boinc server...

1 · 2 · 3 · 4 . . . 8 · Next
Post to thread

Message boards : News : GPU Issues Mega Thread


Main page · Your account · Message boards


Copyright © 2017 AstroInformatics Group