MilkyWay@home Version 1.38 Released
log in

Advanced search

Message boards : News : MilkyWay@home Version 1.38 Released

Previous · 1 · 2 · 3 · 4 · Next
Author Message
aad
Send message
Joined: 30 Mar 09
Posts: 51
Credit: 249,197,092
RAC: 346,391

Message 65204 - Posted: 20 Sep 2016, 18:02:54 UTC - in response to Message 65202.

Thanks Jake.

Just mentioned it because I saw no other reports...

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,449,856
RAC: 27,446

Message 65206 - Posted: 20 Sep 2016, 18:54:32 UTC

I change my profile to accept ONLY Amd/Ati wus, no cpu.
I cancel app_info.xml from project's folder.
I reset the project.
This is the message:

Not requesting tasks: don't need (CPU: ; AMD/ATI GPU: )
Scheduler request completed
Your current settings do not allow tasks from this project. To fix this, you can change Project Preferences on the project's web site.


What's wrong??

Profile BQL_FFM
Send message
Joined: 21 Aug 16
Posts: 6
Credit: 2,036,796
RAC: 0

Message 65208 - Posted: 20 Sep 2016, 19:26:27 UTC - in response to Message 65206.

MilkyWay@Home v1.39 (opencl_nvidia_101) with

* Windows 10 home Core x64 Edition
* Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz
* NVIDIA GeForce GTX 1060 3GB (3072MB) driver: 372.70 OpenCL: 1.2

is fine !

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 440
Credit: 10,354,791
RAC: 203,047

Message 65209 - Posted: 20 Sep 2016, 19:50:37 UTC

hey boboviz,

Not sure what is wrong. Do you have any more information you can share that might help?

Jake

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,449,856
RAC: 27,446

Message 65211 - Posted: 20 Sep 2016, 20:12:40 UTC - in response to Message 65209.
Last modified: 20 Sep 2016, 20:16:40 UTC

hey boboviz,
Not sure what is wrong. Do you have any more information you can share that might help?


Yes, sure.
I have Win 10 64 bit with Amd R7 260x and 16.6 driver version.
Have i have to use xml file? The project's folder now is empty....

Before i use a script and the 1.36 exe downloaded:
<app_info>
<app>
<name>milkyway</name>
</app>
<file_info>
<name>milkyway_1.36_windows_x86_64__opencl_ati_101.exe</name>
<executable />
</file_info>
<app_version>
<app_name>milkyway</app_name>
<version_num>136</version_num>
<avg_ncpus>1</avg_ncpus>
<max_ncpus>1</max_ncpus>
<plan_class>opencl_ati_101</plan_class>
<file_ref>
<file_name>milkyway_1.36_windows_x86_64__opencl_ati_101.exe</file_name>
<main_program/>
</file_ref>
</app_version>
<coproc>
<type>ATI</type>
<count>1.0000</count>
</coproc>
</app_info>

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 440
Credit: 10,354,791
RAC: 203,047

Message 65212 - Posted: 20 Sep 2016, 20:21:30 UTC

Try changing 1.36 to 1.39 and let me know if that makes a difference.

Jake

Sebastian*
Send message
Joined: 8 Apr 09
Posts: 64
Credit: 4,844,150,924
RAC: 4,052,050

Message 65218 - Posted: 20 Sep 2016, 22:04:54 UTC
Last modified: 20 Sep 2016, 22:29:45 UTC

Hello Jake, i tried the new version on my R9 390X with the latest driver. It is requesting Tasks, but getting none. Removed an added the Project again with no success. No error Message so far. Could the error be, that the newer cards support OpenCL 2.0 instead of 1.2? And the software is only checking for 1.2 and is ignoring newer versions?

There is no driver version reported, when i check my computers in Boinc for this computer. All other from HD 4xxx cards to R9 280X cards report a driver version.

Computer ID: 704045

If you can check on the server side, why i don't get any workunits.

Edit: I added a more detailed request at the end of this message.

9/20/2016 11:51:58 PM | | Starting BOINC client version 7.6.22 for windows_x86_64
9/20/2016 11:51:58 PM | | log flags: file_xfer, sched_ops, task
9/20/2016 11:51:58 PM | | Libraries: libcurl/7.45.0 OpenSSL/1.0.2d zlib/1.2.8
9/20/2016 11:51:58 PM | | Data directory: C:\ProgramData\Boinc
9/20/2016 11:51:58 PM | | Running under account Sebastian
9/20/2016 11:51:58 PM | | OpenCL: AMD/ATI GPU 0: Hawaii (driver version 2117.13 (VM), device version OpenCL 2.0 AMD-APP (2117.13), 8192MB, 8192MB available, 3802 GFLOPS peak)
9/20/2016 11:51:58 PM | | OpenCL CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (OpenCL driver vendor: Intel(R) Corporation, driver version 5.2.0.10094, device version OpenCL 1.2 (Build 10094))
9/20/2016 11:51:58 PM | | OpenCL CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz (OpenCL driver vendor: Advanced Micro Devices, Inc., driver version 2117.13 (sse2,avx), device version OpenCL 1.2 AMD-APP (2117.13))
9/20/2016 11:51:58 PM | | Host name: Hydra
9/20/2016 11:51:58 PM | | Processor: 4 GenuineIntel Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz [Family 6 Model 60 Stepping 3]
9/20/2016 11:51:58 PM | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 fma cx16 sse4_1 sse4_2 movebe popcnt aes f16c rdrandsyscall nx lm avx avx2 vmx tm2 pbe fsgsbase bmi1 smep bmi2
9/20/2016 11:51:58 PM | | OS: Microsoft Windows 10: Professional x64 Edition, (10.00.10586.00)
9/20/2016 11:51:58 PM | | Memory: 15.93 GB physical, 18.31 GB virtual
9/20/2016 11:51:58 PM | | Disk: 118.69 GB total, 93.32 GB free
9/20/2016 11:51:58 PM | | Local time is UTC +2 hours
9/20/2016 11:51:58 PM | | Config: GUI RPCs allowed from:
9/20/2016 11:51:58 PM | | 192.168.000.50
9/20/2016 11:51:58 PM | | 192.168.000.62
9/20/2016 11:51:58 PM | | Config: simulate 4 CPUs
9/20/2016 11:51:58 PM | | Config: report completed tasks immediately
9/20/2016 11:51:58 PM | PrimeGrid | URL http://www.primegrid.com/; Computer ID 514902; resource share 100
9/20/2016 11:51:58 PM | | General prefs: from http://milkyway.cs.rpi.edu/milkyway/ (last modified 15-Jun-2016 13:12:51)
9/20/2016 11:51:58 PM | | Host location: none
9/20/2016 11:51:58 PM | | General prefs: using your defaults
9/20/2016 11:51:58 PM | | Reading preferences override file
9/20/2016 11:51:58 PM | | Preferences:
9/20/2016 11:51:58 PM | | max memory usage when active: 8156.68MB
9/20/2016 11:51:58 PM | | max memory usage when idle: 14682.03MB
9/20/2016 11:51:58 PM | | max disk usage: 92.39GB
9/20/2016 11:51:58 PM | | suspend work if non-BOINC CPU load exceeds 50%
9/20/2016 11:51:58 PM | | (to change preferences, visit a project web site or select Preferences in the Manager)
9/20/2016 11:52:08 PM | | Fetching configuration file from http://milkyway.cs.rpi.edu/milkyway/get_project_config.php
9/20/2016 11:52:25 PM | Milkyway@Home | Master file download succeeded
9/20/2016 11:52:30 PM | Milkyway@Home | Sending scheduler request: Project initialization.
9/20/2016 11:52:30 PM | Milkyway@Home | Requesting new tasks for CPU and AMD/ATI GPU
9/20/2016 11:52:33 PM | Milkyway@Home | Scheduler request completed: got 0 new tasks
9/20/2016 11:52:33 PM | Milkyway@Home | No tasks sent
9/20/2016 11:52:33 PM | Milkyway@Home | Tasks for CPU are available, but your preferences are set to not accept them
9/20/2016 11:53:38 PM | Milkyway@Home | Sending scheduler request: To fetch work.
9/20/2016 11:53:38 PM | Milkyway@Home | Requesting new tasks for AMD/ATI GPU
9/20/2016 11:53:43 PM | Milkyway@Home | Scheduler request completed: got 0 new tasks
9/20/2016 11:54:52 PM | Milkyway@Home | update requested by user
9/20/2016 11:54:53 PM | Milkyway@Home | Sending scheduler request: Requested by user.
9/20/2016 11:54:53 PM | Milkyway@Home | Requesting new tasks for AMD/ATI GPU
9/20/2016 11:54:55 PM | Milkyway@Home | Scheduler request completed: got 0 new tasks


9/21/2016 12:22:39 AM | Milkyway@Home | [work_fetch] set_request() for AMD/ATI GPU: ninst 1 nused_total 0.00 nidle_now 1.00 fetch share 1.00 req_inst 1.00 req_secs 1728000.00
9/21/2016 12:22:39 AM | Milkyway@Home | [work_fetch] request: CPU (0.00 sec, 0.00 inst) AMD/ATI GPU (1728000.00 sec, 1.00 inst)
9/21/2016 12:22:42 AM | Milkyway@Home | [work_fetch] backing off AMD/ATI GPU 302 sec
9/21/2016 12:22:42 AM | | [work_fetch] Request work fetch: RPC complete
9/21/2016 12:22:47 AM | | [work_fetch] ------- start work fetch state -------
9/21/2016 12:22:47 AM | | [work_fetch] target work buffer: 864000.00 + 864000.00 sec
9/21/2016 12:22:47 AM | | [work_fetch] --- project states ---
9/21/2016 12:22:47 AM | Milkyway@Home | [work_fetch] REC 0.000 prio 0.000 can't request work: scheduler RPC backoff (55.98 sec)
9/21/2016 12:22:47 AM | PrimeGrid | [work_fetch] REC 1230.459 prio 0.000 can't request work: "no new tasks" requested via Manager
9/21/2016 12:22:47 AM | | [work_fetch] --- state for CPU ---
9/21/2016 12:22:47 AM | | [work_fetch] shortfall 6912000.00 nidle 4.00 saturated 0.00 busy 0.00
9/21/2016 12:22:47 AM | Milkyway@Home | [work_fetch] share 0.000 blocked by project preferences
9/21/2016 12:22:47 AM | PrimeGrid | [work_fetch] share 0.000
9/21/2016 12:22:47 AM | | [work_fetch] --- state for AMD/ATI GPU ---
9/21/2016 12:22:47 AM | | [work_fetch] shortfall 1728000.00 nidle 1.00 saturated 0.00 busy 0.00
9/21/2016 12:22:47 AM | Milkyway@Home | [work_fetch] share 0.000 project is backed off (resource backoff: 296.59, inc 600.00)
9/21/2016 12:22:47 AM | PrimeGrid | [work_fetch] share 0.000
9/21/2016 12:22:47 AM | | [work_fetch] ------- end work fetch state -------
9/21/2016 12:22:47 AM | | [work_fetch] No project chosen for work fetch

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 440
Credit: 10,354,791
RAC: 203,047

Message 65219 - Posted: 20 Sep 2016, 22:31:39 UTC
Last modified: 20 Sep 2016, 22:37:21 UTC

Hey Sebastian,

Not sure why server side you might be not getting work units. It looks like there are plenty available in the queue. I'll look a bit more.

Jake

[edit]
Also, as far as the OpenCL version question, I am just using the built in plan class for OpenCL version 1.1+ so I can't imagine why that would be an issue.
[/edit]

Sebastian*
Send message
Joined: 8 Apr 09
Posts: 64
Credit: 4,844,150,924
RAC: 4,052,050

Message 65221 - Posted: 20 Sep 2016, 23:25:44 UTC

The Computer with the R9 390X isn't even initializing the Project. It does not download the .exe -file or any other files. I copied them in manually, with an app_config file. I got the message, that the app_config file contains no known executables.

There must be something wrong at the initial detection, when Boinc sends, or the server requests infos about the hardware.

Any idea how i can monitor that traffic, to give you some hints?

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,449,856
RAC: 27,446

Message 65226 - Posted: 21 Sep 2016, 6:31:15 UTC - in response to Message 65212.
Last modified: 21 Sep 2016, 6:35:36 UTC

Try changing 1.36 to 1.39 and let me know if that makes a difference.


Ok, i modified the script (1.36 to 1.39) and copied it in the project folder.
I restarted Boinc Manager and this was the message (little different than before.)

Sending scheduler request: Requested by user.
Not requesting tasks: don't need (CPU: ; AMD/ATI GPU: )


So, i stopped ALL cpu wus (Rosetta) and ALL gpu wus (Seti)
Same message:
Not requesting tasks: don't need (CPU: ; AMD/ATI GPU: )


I don't copy the exe 1.39 in the folder. Is this the error??
Activate cpu works in my profile?

Profile apohawk
Avatar
Send message
Joined: 13 Sep 08
Posts: 12
Credit: 72,874,413
RAC: 1,402

Message 65229 - Posted: 21 Sep 2016, 19:17:33 UTC

I still can't get WUs for f9 fury out of the box. :(

2016-09-21 21:07:58 | Milkyway@Home | Sending scheduler request: To fetch work.
2016-09-21 21:07:58 | Milkyway@Home | Requesting new tasks for AMD/ATI GPU
2016-09-21 21:08:00 | Milkyway@Home | Scheduler request completed: got 0 new tasks
____________

aad
Send message
Joined: 30 Mar 09
Posts: 51
Credit: 249,197,092
RAC: 346,391

Message 65230 - Posted: 21 Sep 2016, 20:39:46 UTC
Last modified: 21 Sep 2016, 20:42:28 UTC

Hi Jake,

Since you try the new builds, the invalid-rate is Climbing.
For now it's 2,2% of all my crunched workunits.
They all say ' Completed, can't validate '
My computer crunch them fine in about 20s/ 3 at a time with anounymous platform (1.36)
189 x 20 sec = 3780 sec wasted already on workunits that can't validate because of 'Too many errors (may have bug)'.
example;http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=1317391899
Can you think of a better way to sort the bad results from the good ones?

Aad

waffleironhead
Send message
Joined: 10 Aug 09
Posts: 6
Credit: 4,262,079
RAC: 0

Message 65231 - Posted: 21 Sep 2016, 21:44:24 UTC - in response to Message 65230.

I'm noticing quite a few more invalids from "completed can't validate" since the new version came out. Over 100 right now.

Its hard to tell if there is a problem with the program or my system when the WU are not given a chance to validate.

Would it be too much to up the replication to 10 or more?

Nick Name
Send message
Joined: 27 Jul 14
Posts: 8
Credit: 22,896,698
RAC: 48,529

Message 65232 - Posted: 22 Sep 2016, 2:24:59 UTC
Last modified: 22 Sep 2016, 2:26:55 UTC

I was looking thru my invalid list, which is also unusually high, and came across these hosts *which are producing enormous numbers of invalids.

https://milkyway.cs.rpi.edu/milkyway/results.php?hostid=622817
https://milkyway.cs.rpi.edu/milkyway/results.php?hostid=675155
https://milkyway.cs.rpi.edu/milkyway/results.php?hostid=640076

I probably could have found some more if I had the patience.

The problem with these looks to be 201 (0xc9) EXIT_MISSING_COPROC. I don't know if it's caused by the new app or what, but the server should have stopped sending these machines work long before they trashed this many thousands of work units.

*edited for clarity
____________
Team USA forum
Team USA page

Ulrich Metzner
Avatar
Send message
Joined: 11 Apr 15
Posts: 42
Credit: 16,145,404
RAC: 31,952

Message 65234 - Posted: 22 Sep 2016, 14:26:19 UTC - in response to Message 65232.

...
The problem with these looks to be 201 (0xc9) EXIT_MISSING_COPROC. I don't know if it's caused by the new app or what, but the server should have stopped sending these machines work long before they trashed this many thousands of work units.
...

This is most probably related to Win10 unsolicited updating the graphics drivers without the proper OpenCL components.

Brave new world... :/
____________
Aloha, Uli

scottdog
Send message
Joined: 19 Oct 10
Posts: 2
Credit: 17,043,549
RAC: 10,737

Message 65236 - Posted: 22 Sep 2016, 15:12:00 UTC - in response to Message 65173.

AVG says a virus (IDP.ARES.GENERIC) in 1.38 exe. I show that I am using 1.39 all with computation errors. I am confused?

John
Send message
Joined: 19 Mar 12
Posts: 1
Credit: 7,254,199
RAC: 0

Message 65241 - Posted: 24 Sep 2016, 5:00:47 UTC

i am running BOINC and since 20 September none of my completed work units will transfer. the backlog of completed tasks is getting large on my computer.

sjmielh
Send message
Joined: 9 Aug 09
Posts: 5
Credit: 2,785,105
RAC: 2,559

Message 65243 - Posted: 24 Sep 2016, 7:34:20 UTC - in response to Message 65173.

..
Mac users will still receive the 1.36 application version for the time being while we work on securing a new Mac computer to build and test on for the future...


Hi Jack,

Can you maybe setup a crowdfunding project for this. I would lke to help

Sjmielh

[VENETO] boboviz
Send message
Joined: 10 Feb 09
Posts: 29
Credit: 4,449,856
RAC: 27,446

Message 65244 - Posted: 24 Sep 2016, 8:44:43 UTC - in response to Message 65226.

So, i stopped ALL cpu wus (Rosetta) and ALL gpu wus (Seti)
Same message:
Not requesting tasks: don't need (CPU: ; AMD/ATI GPU: )


I don't copy the exe 1.39 in the folder. Is this the error??
Activate cpu works in my profile?


Solved in the "old" way:
xml file+1.39 opencl exe+accept cpu work
Now i'm crunching: local milkyway 1.39 (opencl_ati_101)

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 440
Credit: 10,354,791
RAC: 203,047

Message 65245 - Posted: 24 Sep 2016, 11:32:42 UTC

Hey everyone,

I actually have a pretty good idea as to why the server isn't sending work units to new GPUs. Turns out my server updating was never updating boinc specific daemons like the scheduler, feeder and a few others. I'm going to try updating those when I get back from Canada and hopefully that solves the problem once and for all.

Jake

Previous · 1 · 2 · 3 · 4 · Next
Post to thread

Message boards : News : MilkyWay@home Version 1.38 Released


Main page · Your account · Message boards


Copyright © 2017 AstroInformatics Group