Welcome to MilkyWay@home

MW stops downloading as it seems to be looking for only GPU wu's

Message boards : Number crunching : MW stops downloading as it seems to be looking for only GPU wu's
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Jay Kz

Send message
Joined: 1 Apr 09
Posts: 4
Credit: 235,809
RAC: 0
Message 28434 - Posted: 27 Jul 2009, 11:22:41 UTC

I can't get the app to download a CPU based wu.
(SETI works finr on both)
Worked fine for weeks, but now it seems to only request GPU wus. No wu's downloaded for the last 4-5 days. :-( Any hints out there??
ID: 28434 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile banditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
Message 28437 - Posted: 27 Jul 2009, 12:17:48 UTC - in response to Message 28434.  

I assume you switched to Boinc 6.6.36 and then you noticed this? It is more picky at how MW runs on it. Try downgrading to an older version, it won't give the Gpu message. Also did you change you settings at all recently? It will only get one wu at a time if the "connect every" is set over 3 days.

I see you have a load of wus so you did get some eventually.
Doesn't expecting the unexpected make the unexpected the expected?
If it makes sense, DON'T do it.
ID: 28437 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Glenn Rogers
Avatar

Send message
Joined: 4 Jul 08
Posts: 165
Credit: 364,966
RAC: 0
Message 28438 - Posted: 27 Jul 2009, 12:21:53 UTC - in response to Message 28434.  
Last modified: 27 Jul 2009, 13:15:47 UTC

You may have to reset the project, Im not having any drama getting cpu wu's.
Which BOINC version are you using? You may find if it's the latest it does some very strange stuff. Get an earlier version.

Are you using an opptimised app? If not get one from here..http://www.zslip.com/
If you dont know which instruction sets your cpu uses you need to get CPUz there is a link to it on zslip.

Hope this helps
ID: 28438 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile GalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
Message 28443 - Posted: 27 Jul 2009, 13:04:09 UTC

I'm tempted to say GRRRRRRRR! (because I've been reloading BOINC versions and GPU drivers quite a few times lately.)

Yes, as Jay says, MW has presumably detected a CUDA GPU and is (I presume) ignoring requests for optimized CPU WUs. It's saying;

"Milkyway@home Requesting new tasks for GPU
"Milkyway@home Scheduler request completed: got 0 new tasks".

I'm trying out 6.6.37 and 6.6.38 to get GPUgrid working since the advice is to use these latest versions if the drivers fail for your GPU (fail for BOINC, not necessarilly anything else).

If anyone can suggest how I can get my NVIDEA GeForce 9600M GT working with GPUgrid, and hopefully with MW CUDA GPU when it eventually arrives, I'd be very grateful.


ID: 28443 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Glenn Rogers
Avatar

Send message
Joined: 4 Jul 08
Posts: 165
Credit: 364,966
RAC: 0
Message 28444 - Posted: 27 Jul 2009, 13:14:01 UTC - in response to Message 28443.  

Sorry mate dont know much about the GPU side of things...So if I read right it would seem that Travis has the CUDA side running. Good luck sorting it if I find anything that may be usefull I'll post here..
ID: 28444 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
computerguy09

Send message
Joined: 11 Feb 09
Posts: 2
Credit: 33,472,193
RAC: 13,785
Message 28454 - Posted: 27 Jul 2009, 18:08:29 UTC - in response to Message 28434.  

BOINC will try to donwload those types of WU that it thinks it needs to keep both the CPU and the GPU busy.

But if it isn't asking for CPU WU's, but is asking for GPU WU's, you may need to run down all the projects, or at least the GPU project to where you don't have any GPU WU's. Then reset the GPU project, so it's debt is 0. Then reset MW as well (assuming you don't have any work in progress there). Then let MW request work, and after you get some CPU work, you can then allow work for the GPU project.

Most of this problem comes from BOINC not having a separate counter for GPU and CPU work, so it just keeps asking for what it thinks it needs.

If MW updated the server side, and setup flags to tell BOINC client that it only can handle CPU work, then this might help things, too!

mark
ID: 28454 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile GalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
Message 28463 - Posted: 27 Jul 2009, 20:41:03 UTC
Last modified: 27 Jul 2009, 20:44:08 UTC

That was a good suggestion about resetting the projects Mark. I'm giving that a try. However, I found some MW WUs had been downloaded, but only after yet another GPUgrid WU had crashed. The screen resolution had changed so I assume my laptop did an auto recover on the GPU and allowed the MW WUs to download in the meantime.

[edit] I've just noticed it is now asking for CPU and GPU tasks;

27/07/2009 21:42:04 Milkyway@home Sending scheduler request: Requested by user.
27/07/2009 21:42:04 Milkyway@home Requesting new tasks for CPU and GPU
27/07/2009 21:42:09 Milkyway@home Scheduler request completed: got 0 new tasks
27/07/2009 21:42:09 Milkyway@home Message from server: No work sent
27/07/2009 21:42:09 Milkyway@home Message from server: (reached per-CPU limit of 6 tasks)
27/07/2009 21:42:09 Milkyway@home Message from server: (Project has no jobs available)


ID: 28463 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1391
Credit: 203,563,566
RAC: 0
Message 28478 - Posted: 28 Jul 2009, 7:52:54 UTC

Gpugrid, 8600GT, Boinc 6.6.28, driver 185.85. Running 24 hours 40% complete, no crashes so far.
Don't drink water, that's the stuff that rusts pipes
ID: 28478 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile GalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
Message 28481 - Posted: 28 Jul 2009, 9:07:12 UTC - in response to Message 28478.  
Last modified: 28 Jul 2009, 9:10:18 UTC

Gpugrid, 8600GT, Boinc 6.6.28, driver 185.85. Running 24 hours 40% complete, no crashes so far.

I presume it was crashing before and you changed Boinc and driver version recently? Are you using Vista by any chance?

ID: 28481 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1391
Credit: 203,563,566
RAC: 0
Message 28488 - Posted: 28 Jul 2009, 12:34:55 UTC
Last modified: 28 Jul 2009, 13:10:26 UTC

Crashed evey day for 10 days. Changed boinc and driver the other day to find a compatible pair. Win XP SP3.

Edit - It's got something to do with the upgrade to Cuda 2.2, newer drivers are needed. Link Suggest querying things further over there as this is the Milkyway forum!
ID: 28488 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile GalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
Message 28492 - Posted: 28 Jul 2009, 17:19:34 UTC - in response to Message 28488.  

Suggest querying things further over there as this is the Milkyway forum!

Sure, thanks for telling me this is the MilkyWay form. I also have my NVIDIA GPU running again, but this is the MilkyWay forum so I won't talk about CUDA here, or what I had to do to get it running. Hey, CUDA is arriving here shortly! Sorry, can't talk about that here...


ID: 28492 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : MW stops downloading as it seems to be looking for only GPU wu's

©2024 Astroinformatics Group