Welcome to MilkyWay@home

Every new WU crashing!!


Advanced search

Message boards : Number crunching : Every new WU crashing!!
Message board moderation

To post messages, you must log in.

AuthorMessage
Virtual Boss*

Send message
Joined: 26 Jul 09
Posts: 11
Credit: 1,240,681
RAC: 0
1 million credit badge12 year member badge
Message 44042 - Posted: 22 Nov 2010, 2:49:34 UTC

After running OK for a long time, one of my computers is having computation errors on every new WU.

stderr out <core_client_version>5.10.45</core_client_version>
<![CDATA[
<message>
There are no child processes to wait for. (0x80) - exit code 128 (0x80)
</message>
]]>

After a new WU is downloaded the status shows "waiting for memory" for a short time and then "computation error" with zero CPU time.

Do the new WU's need more memory than this machine has (256MB) and if so, why is the server sending work to it?

BTW: Still running fine on other projects.

ID: 44042 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1391
Credit: 203,131,912
RAC: 21,785
200 million credit badge13 year member badge
Message 44045 - Posted: 22 Nov 2010, 9:12:55 UTC - in response to Message 44042.  

I'm surprised XP runs at all on 256MB Ram let alone runs Boinc! I see you are also running it on a 286 machine with 5.10.45 client. And yes the newer workunits need more muscle.
Don't drink water, that's the stuff that rusts pipes
ID: 44045 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Zydor
Avatar

Send message
Joined: 24 Feb 09
Posts: 620
Credit: 100,587,625
RAC: 0
100 million credit badge12 year member badgeextraordinary contributions badge
Message 44049 - Posted: 22 Nov 2010, 9:59:03 UTC
Last modified: 22 Nov 2010, 10:11:32 UTC

You might get lucky using 6.10.58 (current recommended version) as .45 had some horrors lurking in it (it was only a development version) - but dont hold you breath, as I suspect .58 BOINC Client will detect the 256Mb and refuse to play :)

It sent work because the schedular asked it to, the schedular did that because 5.10.45 was built quite a bit back when the base limits on hardware were lower than now, so the BOINC Client (.45) detects 256, checks its list (which has the older hardware requirements) and says to the schedular "thats ok - go get some"

Plaudits to you for getting it working at all previously on 256Mb, theoretically that shouldnt have worked ..... if changing to 6.10.58 dont get it going, the chances are extremely remote that it will, its more wild hope than reality, bin it, its not going to happen.

Regards
Zy
ID: 44049 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge14 year member badge
Message 44095 - Posted: 23 Nov 2010, 0:37:33 UTC - in response to Message 44042.  

Are you using an optimized application? The older optimized applications probably won't work anymore, and once we update the GPU applications server side, they definitely won't work anymore.
ID: 44095 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Virtual Boss*

Send message
Joined: 26 Jul 09
Posts: 11
Credit: 1,240,681
RAC: 0
1 million credit badge12 year member badge
Message 44114 - Posted: 23 Nov 2010, 13:56:12 UTC

Thanks to Chris s and Zydor for responding, but I now do not think lack of memory is the problem.

FYI: I have not had any problems at all with 5.10.45 on my (non GPU) computers.
Also FYI: XP officially installs on 64MB or greater, but - I have previously installed XP on a pentium (100MHz) with only 56MB RAM - but it was REALLY slow.


@Travis: No I am not running optmised on this computer, because I could not find an MMX App. (No SSE on this reliable old celeron).

I analysed the stdoutdae.txt file and found where the problem first started.

10-Nov-2010 23:10:35 [Milkyway@home] Sending scheduler request: To fetch work. Requesting 21530 seconds of work, reporting 0 completed tasks
10-Nov-2010 23:10:50 [Milkyway@home] Scheduler request succeeded: got 1 new tasks
10-Nov-2010 23:10:52 [Milkyway@home] Started download of milkyway_0.45_windows_intelx86.exe
10-Nov-2010 23:10:52 [Milkyway@home] Started download of msvcr100.dll
10-Nov-2010 23:12:05 [Milkyway@home] Finished download of milkyway_0.45_windows_intelx86.exe
10-Nov-2010 23:12:05 [Milkyway@home] Started download of msvcp100.dll
10-Nov-2010 23:15:44 [Milkyway@home] Finished download of msvcp100.dll
10-Nov-2010 23:15:44 [Milkyway@home] Started download of p-82-2s-edge.txt
10-Nov-2010 23:15:45 [Milkyway@home] Finished download of p-82-2s-edge.txt
10-Nov-2010 23:15:45 [Milkyway@home] Started download of stars-td82-2stream_10.txt
10-Nov-2010 23:16:55 [Milkyway@home] Finished download of msvcr100.dll
10-Nov-2010 23:16:55 [Milkyway@home] Started download of de_separation_82_2s_10_2_853400_1289395733_search_parameters
10-Nov-2010 23:16:56 [Milkyway@home] Finished download of de_separation_82_2s_10_2_853400_1289395733_search_parameters
10-Nov-2010 23:46:33 [Milkyway@home] Finished download of stars-td82-2stream_10.txt
10-Nov-2010 23:46:34 [Milkyway@home] Starting de_separation_82_2s_10_2_853400_1289395733_0
10-Nov-2010 23:46:34 [Milkyway@home] Starting task de_separation_82_2s_10_2_853400_1289395733_0 using milkyway version 45
10-Nov-2010 23:46:35 [Milkyway@home] Computation for task de_separation_82_2s_10_2_853400_1289395733_0 finished

Since downloading Version 45 every WU has errored in 1-2 seconds.

I will try re-downloading in case the files were corrupted during the initial download, and post the results.

BTW: All my other computers are running older CPU optimsed apps and none of them have had problems (and they are a LOT faster than stock apps).
ID: 44114 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1391
Credit: 203,131,912
RAC: 21,785
200 million credit badge13 year member badge
Message 44118 - Posted: 23 Nov 2010, 16:21:34 UTC

Thanks to Chris s and Zydor for responding, but I now do not think lack of memory is the problem.


No problem, any friend of Miss Moon is a friend of mine. I see you run 9 comps mainly Quads and twin core? Is this oldie a labour of love then? :-)




Don't drink water, that's the stuff that rusts pipes
ID: 44118 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Virtual Boss*

Send message
Joined: 26 Jul 09
Posts: 11
Credit: 1,240,681
RAC: 0
1 million credit badge12 year member badge
Message 44143 - Posted: 24 Nov 2010, 1:30:57 UTC

Since downloading Version 45 every WU has errored in 1-2 seconds.

I will try re-downloading in case the files were corrupted during the initial download, and post the results.


Still erroring

This is not looking good.

I have searched through several hundred WU results looking for other computers running CPU apps.

As expected, there were very few.

But every computer I found running Version 45 is erroring within a second or two. (Both win & linux)

example computers:
165358 235310 236875 237019

With no evidence to the contrary, I can only conclude that version 45 is faulty.

The older optimized applications probably won't work anymore, and once we update the GPU applications server side, they definitely won't work anymore.


It looks like when that happens - I won't be crunching anymore unless I get a DP GPU. :(
ID: 44143 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Every new WU crashing!!

©2021 Astroinformatics Group