Welcome to MilkyWay@home

app 0.57 100% core use...


Advanced search

Message boards : Number crunching : app 0.57 100% core use...
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
ProfileTomaszPawel
Avatar

Send message
Joined: 9 Nov 08
Posts: 41
Credit: 92,786,635
RAC: 0
50 million credit badge10 year member badge
Message 47430 - Posted: 10 Apr 2011, 9:56:34 UTC

Hi! App 0.57 on ATI use 100% of CPU core...

This is strange...
A proud member of the Polish National Team

COME VISIT US at Polish National Team FORUM

ID: 47430 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1387
Credit: 188,890,038
RAC: 25,710
100 million credit badge10 year member badge
Message 47434 - Posted: 10 Apr 2011, 10:06:46 UTC

On my HD5850, win 7 64, I've got 75% GPU, and 25% CPU.

Don't drink water, that's the stuff that rusts pipes
ID: 47434 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTomaszPawel
Avatar

Send message
Joined: 9 Nov 08
Posts: 41
Credit: 92,786,635
RAC: 0
50 million credit badge10 year member badge
Message 47435 - Posted: 10 Apr 2011, 10:08:40 UTC

Because You have quad core - 25% of 4 cores = 100% of 1 core...
A proud member of the Polish National Team

COME VISIT US at Polish National Team FORUM

ID: 47435 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1387
Credit: 188,890,038
RAC: 25,710
100 million credit badge10 year member badge
Message 47440 - Posted: 10 Apr 2011, 10:44:44 UTC
Last modified: 10 Apr 2011, 10:45:55 UTC

Um no quad core here! Just an ATI HD5850 coupled with a Pent 4 D 3.2 with HT. I'm running cpu tasks on Seti as well as on MW, and the 0.57(ATI14) MW app takes 25% CPU time.
Don't drink water, that's the stuff that rusts pipes
ID: 47440 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
TJ

Send message
Joined: 12 Aug 09
Posts: 262
Credit: 92,631,041
RAC: 0
50 million credit badge10 year member badge
Message 47443 - Posted: 10 Apr 2011, 10:56:37 UTC

I think Tomasz is right.

As youloot at teh results page, the Runtime and CUPtime are almost the same.
This was not the case with the previous app.
Greetings from,
TJ
ID: 47443 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chris S
Avatar

Send message
Joined: 20 Sep 08
Posts: 1387
Credit: 188,890,038
RAC: 25,710
100 million credit badge10 year member badge
Message 47444 - Posted: 10 Apr 2011, 11:08:35 UTC

I think we may be talking at cross purposes here guys :-)) The 25% I'm quoting is the "load" that I see in task manager, that is what I call the use of the CPU core.

But in terms of RUN TIME, I get this result.

Run time
170.73

CPU time
115.88

Credit
267.20

Application version
MilkyWay@Home v0.57 (ati14)


Is this what you mean? And yes, it is a lot higher than before.

Don't drink water, that's the stuff that rusts pipes
ID: 47444 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
TJ

Send message
Joined: 12 Aug 09
Posts: 262
Credit: 92,631,041
RAC: 0
50 million credit badge10 year member badge
Message 47448 - Posted: 10 Apr 2011, 11:15:43 UTC - in response to Message 47444.  

I see a load of 100% in the task manager. I can see it also on the thermal controls and I can hear it on the fan's.

I can see it also on the CPU core temperatures.
Greetings from,
TJ
ID: 47448 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBeyond
Avatar

Send message
Joined: 15 Jul 08
Posts: 383
Credit: 502,204,467
RAC: 2,412
500 million credit badge10 year member badge
Message 47479 - Posted: 10 Apr 2011, 13:19:47 UTC - in response to Message 47434.  

On my HD5850, win 7 64, I've got 75% GPU, and 25% CPU.

If you get the GPU to 97%+ you'll see a whole core being used. It's true on every machine and is the #1 issue that needs to be resolved IMO.
ID: 47479 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
cncguru
Avatar

Send message
Joined: 11 Jun 10
Posts: 329
Credit: 1,166,222,661
RAC: 0
1 billion credit badge10 year member badge
Message 47484 - Posted: 10 Apr 2011, 13:28:04 UTC

Oh Yeah,
I have 8 CPU cores and 4 GPU cores and yep 50-60 CPU load.
WAY more than .05CPUs
Same on all so this will really mess with things badly if we want to use our cpu's too!

ID: 47484 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTomaszPawel
Avatar

Send message
Joined: 9 Nov 08
Posts: 41
Credit: 92,786,635
RAC: 0
50 million credit badge10 year member badge
Message 47503 - Posted: 10 Apr 2011, 16:35:23 UTC
Last modified: 10 Apr 2011, 16:35:56 UTC

Definitly new app is cpu hungry - when crunching on cpu other project MW run is much longer...
A proud member of the Polish National Team

COME VISIT US at Polish National Team FORUM

ID: 47503 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matt Arsenault
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 8 May 10
Posts: 576
Credit: 15,979,383
RAC: 0
10 million credit badge10 year member badge
Message 47506 - Posted: 10 Apr 2011, 16:56:38 UTC - in response to Message 47430.  

I fixed this last night (https://github.com/Milkyway-at-home/milkywayathome_client/commit/b83566d399c5b63f717d864a3a45b8a04ff2fa9b), so CPU usage should be normal when I update it. I'm going to try fixing a few more problems before I do that though.
ID: 47506 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 47519 - Posted: 10 Apr 2011, 20:59:44 UTC - in response to Message 47506.  

I fixed this last night (https://github.com/Milkyway-at-home/milkywayathome_client/commit/b83566d399c5b63f717d864a3a45b8a04ff2fa9b), so CPU usage should be normal when I update it. I'm going to try fixing a few more problems before I do that though.


Yes, works like a charm and CPU usage is even lower (1%) than what the old app used to be.


Join Support science! Joinc Team BOINC United now!
ID: 47519 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileMad Matt

Send message
Joined: 19 Sep 09
Posts: 16
Credit: 218,390,676
RAC: 0
200 million credit badge10 year member badge
Message 47521 - Posted: 10 Apr 2011, 21:19:11 UTC - in response to Message 47519.  

When will those new clients be rolled out? I am still seeing CPU usage from 75 to 100 percent here.
ID: 47521 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBladeD
Avatar

Send message
Joined: 2 Nov 10
Posts: 731
Credit: 131,536,342
RAC: 0
100 million credit badge9 year member badge
Message 47693 - Posted: 12 Apr 2011, 4:07:44 UTC - in response to Message 47521.  

When will those new clients be rolled out? I am still seeing CPU usage from 75 to 100 percent here.

+1
ID: 47693 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilearkayn
Avatar

Send message
Joined: 14 Feb 09
Posts: 999
Credit: 74,932,619
RAC: 0
50 million credit badge10 year member badge
Message 47694 - Posted: 12 Apr 2011, 5:02:54 UTC

It is rolled out, still has a CPU usage issue.
ID: 47694 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBeyond
Avatar

Send message
Joined: 15 Jul 08
Posts: 383
Credit: 502,204,467
RAC: 2,412
500 million credit badge10 year member badge
Message 47700 - Posted: 12 Apr 2011, 15:12:27 UTC - in response to Message 47693.  

When will those new clients be rolled out? I am still seeing CPU usage from 75 to 100 percent here.

+1

Think I've figured out part of what's going on with .59. On my machines with 1 ATI GPU the CPU usage is very low. On machines with 2 ATI GPUs the CPU usage is very high even if only 1 GPU is running MilkyWay. I've checked the GPUs of others too and the above seems to be a consistent pattern. The question is why is this happening? Maybe Matt or Crunch3r would have some ideas?
ID: 47700 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
TJ

Send message
Joined: 12 Aug 09
Posts: 262
Credit: 92,631,041
RAC: 0
50 million credit badge10 year member badge
Message 47702 - Posted: 12 Apr 2011, 15:49:48 UTC - in response to Message 47700.  

When will those new clients be rolled out? I am still seeing CPU usage from 75 to 100 percent here.

+1

Think I've figured out part of what's going on with .59. On my machines with 1 ATI GPU the CPU usage is very low. On machines with 2 ATI GPUs the CPU usage is very high even if only 1 GPU is running MilkyWay. I've checked the GPUs of others too and the above seems to be a consistent pattern. The question is why is this happening? Maybe Matt or Crunch3r would have some ideas?



Matt thought he had an solution and posted that but was waiting with the implementation. By then Crunch3r got that working somehow and was happy with it.
Afterwards the update from Matt came but with no joy (to me and some others).
Why was Crunch3r so happy, used he only one ATI-card?
Greetings from,
TJ
ID: 47702 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 47706 - Posted: 12 Apr 2011, 16:29:55 UTC - in response to Message 47702.  

Matt thought he had an solution and posted that but was waiting with the implementation. By then Crunch3r got that working somehow and was happy with it.
Afterwards the update from Matt came but with no joy (to me and some others).
Why was Crunch3r so happy, used he only one ATI-card?


Crunch3r seems to know how to do the programming better than most. He was a part in getting the gpus set up in the first place. (if I remember right) I am not surprised if he gets anything to work when MW cannot.
Doesn't expecting the unexpected make the unexpected the expected?
If it makes sense, DON'T do it.
ID: 47706 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBladeD
Avatar

Send message
Joined: 2 Nov 10
Posts: 731
Credit: 131,536,342
RAC: 0
100 million credit badge9 year member badge
Message 47707 - Posted: 12 Apr 2011, 16:31:48 UTC - in response to Message 47694.  

It is rolled out, still has a CPU usage issue.

Where? There hasn't been an update since Matt's last post.
ID: 47707 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilekashi

Send message
Joined: 30 Dec 07
Posts: 311
Credit: 149,490,184
RAC: 0
100 million credit badge10 year member badge
Message 47708 - Posted: 12 Apr 2011, 16:50:33 UTC - in response to Message 47702.  

Matt thought he had an solution and posted that but was waiting with the implementation. By then Crunch3r got that working somehow and was happy with it.
Afterwards the update from Matt came but with no joy (to me and some others).
Why was Crunch3r so happy, used he only one ATI-card?

Perhaps Crunch3r tested the updated Linux version.
ID: 47708 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : Number crunching : app 0.57 100% core use...

©2020 Astroinformatics Group