Welcome to MilkyWay@home

Change in behavior with mismatched GPUs


Advanced search

Message boards : Number crunching : Change in behavior with mismatched GPUs
Message board moderation

To post messages, you must log in.

AuthorMessage
DanNeely

Send message
Joined: 6 Oct 09
Posts: 39
Credit: 77,524,463
RAC: 0
50 million credit badge10 year member badge
Message 47590 - Posted: 11 Apr 2011, 14:07:27 UTC

I have a 5870 and a 5450 in my system. Owing to a boinc bug my client thought I had two 5870's and would run two WUs at the same time. At the time my runtime results corresponded to running 2 WUs on my 5870 concurrently (and 0 on the 5450), but without the need to fiddle with app_info files with each new app. It also worked for all 3 GPU project I ran: milkyway, collatz, and dnetc. A fringe benefit was that it resulted in slightly lower GPU loading and kept my desktop from lagging.

Recently something changed though. Boinc is now apparently trying to run WUs on the 5450. The strongest indication I have of this is with collatz where I see most WUs completing in about 25 minutes, with a few taking ~8.5 hours. The 20x speed factor matches well with the 20x difference in the number of cores the cards have. MW and dnetC both have one task run properly and a whole bunch more crash within a second or two of starting. I know MW needs DP and won't run on the 5450, and I believe the same is true of dnetc, but since their page is down I can't confirm it.

In a thread from 6 months ago, it was suggested I use a cc_config.xml file to control the behavior. At the time I didn't bother since nothing was causing a problem. I've tried doing it today, but can't get it to work. I fixed the typo in the example file and put in in C:\programdata\boinc\ with both 0 and 1 set, but I continue to see both cards being used in MW/collatz.

I'm currently running the 11.3 ati drivers. This is a recent update, but IIRC MW was working with the 11.3 driver prior to the recent upgrades here.

<cc_config>
<options>
<use_all_gpus>0</use_all_gpus>
</options>
</cc_config>

old thread on the issue: http://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=2016&nowrap=true#43312
ID: 47590 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DanNeely

Send message
Joined: 6 Oct 09
Posts: 39
Credit: 77,524,463
RAC: 0
50 million credit badge10 year member badge
Message 47591 - Posted: 11 Apr 2011, 14:10:30 UTC - in response to Message 47590.  

PS I noticed dnetc not working a week or so back, but don't recall if it was before or after my driver update. It was only a backup project though, so I didn't try and do any troubleshooting at the time.
ID: 47591 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ConflictingEmotions

Send message
Joined: 18 Feb 09
Posts: 9
Credit: 20,005,162
RAC: 0
20 million credit badge10 year member badge
Message 47598 - Posted: 11 Apr 2011, 15:02:11 UTC - in response to Message 47591.  

PS I noticed dnetc not working a week or so back, but don't recall if it was before or after my driver update. It was only a backup project though, so I didn't try and do any troubleshooting at the time.

There seems to be some serious issue with dnetc as per this boincstats thread on it.
ID: 47598 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DanNeely

Send message
Joined: 6 Oct 09
Posts: 39
Credit: 77,524,463
RAC: 0
50 million credit badge10 year member badge
Message 47630 - Posted: 11 Apr 2011, 19:41:53 UTC - in response to Message 47598.  

ok, dnetc's broken in general and is apparently not related to whatever is causing my problems with MW now. I assume it's related to the new apps based on the timing; but since I was away during the rollout period I can't confirm that is when it stopped working.
ID: 47630 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Len LE/GE

Send message
Joined: 8 Feb 08
Posts: 261
Credit: 104,050,322
RAC: 0
100 million credit badge10 year member badge
Message 47650 - Posted: 11 Apr 2011, 22:11:27 UTC - in response to Message 47590.  
Last modified: 11 Apr 2011, 22:12:11 UTC


<cc_config>
<options>
<use_all_gpus>0</use_all_gpus>
</options>
</cc_config>


The option you are looking for is ignore_ati_dev instead of use_all_gpus.
<ignore_ati_dev>0</ignore_ati_dev> to ignore your first ati card
<ignore_ati_dev>1</ignore_ati_dev> to ignore your second ati card
ID: 47650 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DanNeely

Send message
Joined: 6 Oct 09
Posts: 39
Credit: 77,524,463
RAC: 0
50 million credit badge10 year member badge
Message 47654 - Posted: 11 Apr 2011, 22:37:25 UTC - in response to Message 47650.  

Thanks. That has me running MW successfully again. Not sure if it'd be worthwhile on a watts/credit basis, but is there any way I could do similar at the app level so I could keep MW on the 5870 as my primary project, while letting collatz serve as both the 5870's backup and as the 5450's primary?
ID: 47654 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Zydor
Avatar

Send message
Joined: 24 Feb 09
Posts: 620
Credit: 100,587,625
RAC: 0
100 million credit badge10 year member badgeextraordinary contributions badge
Message 47656 - Posted: 11 Apr 2011, 23:09:47 UTC - in response to Message 47654.  
Last modified: 11 Apr 2011, 23:20:23 UTC

..... so I could keep MW on the 5870 as my primary project, while letting collatz serve as both the 5870's backup and as the 5450's primary?


No, because you set the backup by giving "0" as the resource share inside BOINC Manager, which would apply to both cards. However, and this is a bit of work, so you really do *need* to have this, not merely a 'nice to have' ....

You can open a second instance of BOINC, each instance must have its own Data Directory, so when you install the second BOINC instance, make sure you tell it where to install, else it will go to the default settings, and thats where the first instance is :)

Having done that you will need to put the following inside the cc_config for each instance:

<allow_multiple_clients>1</allow_multiple_clients>

Then setup icons for both instances on your desktop. At that point you need to tell each instance which card its to use via its own cc_config using the exclude statements, and install the Project Software into both instances. At that point (phew rofl), you have separated the cards, so you can designate backups for each instance achieving what you want (I hope ... see below).

You really have to *want* this to go through that .... but a second instance does work. Remaining problem is setting up resource share for each instance, as thats is set by machine id .... thats still a problem :) Dont know how you could get round that, maybe someone else could chip in, maybe we cant - however certainly putting in a second instance is a pre-requesite to separate the cards.

Need to be adventurous ... be interesting to see if the resource share/backup could be done with a second instance.

Just thoughts .... maybe worth trying. Second instance will work, its a case of setting the resource shares for each that I am unsure of

Regards
Zy
ID: 47656 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
DanNeely

Send message
Joined: 6 Oct 09
Posts: 39
Credit: 77,524,463
RAC: 0
50 million credit badge10 year member badge
Message 47672 - Posted: 12 Apr 2011, 0:04:43 UTC

Thanks, I figured it'd probably be a pita; but was hoping to be proven wrong.
ID: 47672 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Change in behavior with mismatched GPUs

©2020 Astroinformatics Group