Welcome to MilkyWay@home

application v1.21/v1.22 errors/memory leaks/crashes here


Advanced search

Message boards : Number crunching : application v1.21/v1.22 errors/memory leaks/crashes here
Message board moderation

To post messages, you must log in.

1 · 2 · 3 · 4 · Next

AuthorMessage
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 1998 - Posted: 6 Mar 2008, 23:58:40 UTC

Hi Guys and Gals,

Thanks for all the help and information you've given us this past week while we've been updating the binaries :)

We just updated everyone to 1.21 to keep everything on the same page. We had a small computational error that needed fixing, so the new versions of the applications fixed that. Please let us know if you're having any problems with these in this thread.

There should be a 32 bit linux binary v1.21 available shortly.

--Travis
ID: 1998 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileDoctorNow
Avatar

Send message
Joined: 28 Aug 07
Posts: 146
Credit: 10,276,862
RAC: 0
10 million credit badge10 year member badge
Message 1999 - Posted: 7 Mar 2008, 0:31:38 UTC

Good work so far.
The first 1.21 went thru on Linux 64-Bit for me. :-)
I noticed a more straight progress display now.
Member of BOINC@Heidelberg and ATA!

My BOINCstats
ID: 1999 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 2004 - Posted: 7 Mar 2008, 0:46:36 UTC - in response to Message 1999.  

Good work so far.
The first 1.21 went thru on Linux 64-Bit for me. :-)
I noticed a more straight progress display now.


good news! :) i updated the progress as well to be a bit more linear. did you notice any improvement in performance?
ID: 2004 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
6dj72cn8

Send message
Joined: 26 Dec 07
Posts: 41
Credit: 220,590
RAC: 0
100 thousand credit badge10 year member badge
Message 2006 - Posted: 7 Mar 2008, 0:49:41 UTC - in response to Message 1998.  
Last modified: 7 Mar 2008, 1:03:49 UTC

Running OK on Mac PPC G5 OSX.

The crunch times are unchanged. The first 55% (approx) of the task is pretty slow but it races through last 45%. Given what I have been reading about how much faster the Windows versions now are, is there any way you can optimize the Mac app any further, particularly the first part?

Thanks.
ID: 2006 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileJayargh
Avatar

Send message
Joined: 8 Oct 07
Posts: 289
Credit: 3,690,838
RAC: 0
3 million credit badge10 year member badge
Message 2007 - Posted: 7 Mar 2008, 0:55:24 UTC

Some comparisons: Linux 64 bit performance is improved on a 5150 (by about 20-25 secs)but not on a P4 3.0 xeon. Windows P4 runs 2 minutes faster than Linux P4 32 bit on 2.8g hardware.P43.6 gig Linux 32 bit improved about 30 secs.
ID: 2007 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileJayargh
Avatar

Send message
Joined: 8 Oct 07
Posts: 289
Credit: 3,690,838
RAC: 0
3 million credit badge10 year member badge
Message 2009 - Posted: 7 Mar 2008, 2:18:49 UTC

Taking a relook at same hardware 32 bit -Linux vs Windows I see Linux is faster now by almost 2 min.
ID: 2009 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Hefto99

Send message
Joined: 29 Dec 07
Posts: 9
Credit: 100,140,182
RAC: 0
100 million credit badge10 year member badge
Message 2010 - Posted: 7 Mar 2008, 3:32:59 UTC
Last modified: 7 Mar 2008, 3:36:18 UTC

Hi all,

32-bit Windows application (windows 2000) crashes with following error:

3/7/2008 11:27:08 AM|Milkyway@home|Starting task gs_281_1204857426_46066_0 using astronomy version 121
3/7/2008 11:27:09 AM|Milkyway@home|Computation for task gs_281_1204857426_46066_0 finished
3/7/2008 11:27:09 AM|Milkyway@home|Output file gs_281_1204857426_46066_0_0 for task gs_281_1204857426_46066_0 absent
3/7/2008 11:27:09 AM|Milkyway@home|Starting gs_283_1204858594_47973_0
3/7/2008 11:27:09 AM|Milkyway@home|Starting task gs_283_1204858594_47973_0 using astronomy version 121
3/7/2008 11:27:10 AM|Milkyway@home|Computation for task gs_283_1204858594_47973_0 finished
3/7/2008 11:27:10 AM|Milkyway@home|Output file gs_283_1204858594_47973_0_0 for task gs_283_1204858594_47973_0 absent
3/7/2008 11:27:10 AM|Milkyway@home|Starting gs_280_1204858588_47922_0
3/7/2008 11:27:10 AM|Milkyway@home|Starting task gs_280_1204858588_47922_0 using astronomy version 121
3/7/2008 11:27:12 AM|Milkyway@home|Computation for task gs_280_1204858588_47922_0 finished
3/7/2008 11:27:12 AM|Milkyway@home|Output file gs_280_1204858588_47922_0_0 for task gs_280_1204858588_47922_0 absent
3/7/2008 11:27:12 AM|Milkyway@home|Starting gs_280_1204859966_49995_0
3/7/2008 11:27:12 AM|Milkyway@home|Starting task gs_280_1204859966_49995_0 using astronomy version 121
3/7/2008 11:27:13 AM|Milkyway@home|Computation for task gs_280_1204859966_49995_0 finished
3/7/2008 11:27:13 AM|Milkyway@home|Output file gs_280_1204859966_49995_0_0 for task gs_280_1204859966_49995_0 absent
3/7/2008 11:27:13 AM|Milkyway@home|Starting gs_280_1204859966_49987_0
3/7/2008 11:27:13 AM|Milkyway@home|Starting task gs_280_1204859966_49987_0 using astronomy version 121
3/7/2008 11:27:14 AM|Milkyway@home|Computation for task gs_280_1204859966_49987_0 finished


[edit]The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll [/edit]
ID: 2010 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 2011 - Posted: 7 Mar 2008, 3:33:44 UTC

Run time so far is about the same as 1.19, with a few about a min quicker, 9.5-10.5 min. Progress bar is still slow, but better (gain about 1/10th % each sec untill 55%, then jumps about .6%/sec). I do still have many wu's that are freezing at any given point.
ID: 2011 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Brian D from Georgia

Send message
Joined: 3 Feb 08
Posts: 6
Credit: 6,055,000
RAC: 0
5 million credit badge10 year member badge
Message 2012 - Posted: 7 Mar 2008, 4:08:18 UTC - in response to Message 2010.  
Last modified: 7 Mar 2008, 4:13:22 UTC

Hi all,

32-bit Windows application (windows 2000) crashes with following error:

3/7/2008 11:27:08 AM|Milkyway@home|Starting task gs_281_1204857426_46066_0 using astronomy version 121
3/7/2008 11:27:09 AM|Milkyway@home|Computation for task gs_281_1204857426_46066_0 finished
3/7/2008 11:27:09 AM|Milkyway@home|Output file gs_281_1204857426_46066_0_0 for task gs_281_1204857426_46066_0 absent
3/7/2008 11:27:09 AM|Milkyway@home|Starting gs_283_1204858594_47973_0
3/7/2008 11:27:09 AM|Milkyway@home|Starting task gs_283_1204858594_47973_0 using astronomy version 121
3/7/2008 11:27:10 AM|Milkyway@home|Computation for task gs_283_1204858594_47973_0 finished
3/7/2008 11:27:10 AM|Milkyway@home|Output file gs_283_1204858594_47973_0_0 for task gs_283_1204858594_47973_0 absent
3/7/2008 11:27:10 AM|Milkyway@home|Starting gs_280_1204858588_47922_0
3/7/2008 11:27:10 AM|Milkyway@home|Starting task gs_280_1204858588_47922_0 using astronomy version 121
3/7/2008 11:27:12 AM|Milkyway@home|Computation for task gs_280_1204858588_47922_0 finished
3/7/2008 11:27:12 AM|Milkyway@home|Output file gs_280_1204858588_47922_0_0 for task gs_280_1204858588_47922_0 absent
3/7/2008 11:27:12 AM|Milkyway@home|Starting gs_280_1204859966_49995_0
3/7/2008 11:27:12 AM|Milkyway@home|Starting task gs_280_1204859966_49995_0 using astronomy version 121
3/7/2008 11:27:13 AM|Milkyway@home|Computation for task gs_280_1204859966_49995_0 finished
3/7/2008 11:27:13 AM|Milkyway@home|Output file gs_280_1204859966_49995_0_0 for task gs_280_1204859966_49995_0 absent
3/7/2008 11:27:13 AM|Milkyway@home|Starting gs_280_1204859966_49987_0
3/7/2008 11:27:13 AM|Milkyway@home|Starting task gs_280_1204859966_49987_0 using astronomy version 121
3/7/2008 11:27:14 AM|Milkyway@home|Computation for task gs_280_1204859966_49987_0 finished


[edit]The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll [/edit]


I have 3 nearly identical hosts (P4 3.0Ghz Northwood's). Two are running XP (one Home and one Pro) and 1.21 seems to be working very well on these two. The other host is running W2K and I am seeing the same immediate app crash as the above user. I tried detaching and reattaching but this didn't help. That W2K host was working okay at app 1.19 as far as I know.


ID: 2012 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Emanuel

Send message
Joined: 18 Nov 07
Posts: 280
Credit: 2,442,757
RAC: 0
2 million credit badge10 year member badge
Message 2014 - Posted: 7 Mar 2008, 4:26:55 UTC - in response to Message 2012.  
Last modified: 7 Mar 2008, 4:27:22 UTC

Everything seems to be running smoothly, with a crunch time of about 5 minutes 35 seconds; that's 35 seconds less than I was getting before. CPU is an Athlon 64 running at 2.5GHz and OS is WinXP x86 SP3 RC.
ID: 2014 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile[SG-SPEG] sth

Send message
Joined: 5 Feb 08
Posts: 4
Credit: 30,489,336
RAC: 174,937
30 million credit badge10 year member badge
Message 2017 - Posted: 7 Mar 2008, 6:30:15 UTC

Hello,

don't know if this is helping you:
On one of my W2000 hosts the following message appears immediately after the start of the 1.21 app:

The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll.


Ciao
Stefan

ID: 2017 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 2018 - Posted: 7 Mar 2008, 6:33:01 UTC - in response to Message 2017.  

Hello,

don't know if this is helping you:
On one of my W2000 hosts the following message appears immediately after the start of the 1.21 app:

The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll.




Dave compiled the 1.21 windows apps, so i'll have him take a look into these.
ID: 2018 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
surfnet

Send message
Joined: 16 Dec 07
Posts: 3
Credit: 748,853
RAC: 0
500 thousand credit badge10 year member badge
Message 2021 - Posted: 7 Mar 2008, 7:10:28 UTC

Hello. I'm running Windows ME on 3 of my PCs and all are popping up computation errors for 1.21. They ran fine with 1.19. Thanks. Mike
ID: 2021 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Honza

Send message
Joined: 28 Aug 07
Posts: 31
Credit: 86,152,236
RAC: 0
50 million credit badge10 year member badge
Message 2022 - Posted: 7 Mar 2008, 7:12:11 UTC - in response to Message 2018.  

Dave compiled the 1.21 windows apps, so i'll have him take a look into these.

Running one quad on Win XP, other two are Win 2003 x64. Both 1.21 apps fine, no significant speed difference on 32-bit vs. 64-bit.

ID: 2022 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileChertseyAl
Avatar

Send message
Joined: 31 Aug 07
Posts: 66
Credit: 1,002,668
RAC: 0
1 million credit badge10 year member badge
Message 2024 - Posted: 7 Mar 2008, 8:47:00 UTC - in response to Message 1998.  

1.21 runs very slightly slower than 1.19 on my P4 2.4 XP32, and very slightly faster on my Celeron 2.93 XP32 - Not much in it really.

Progress bar is still running slow on both (about a third slower than it should be).

No problems so far :)

Al.
ID: 2024 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2026 - Posted: 7 Mar 2008, 9:01:42 UTC - in response to Message 2021.  
Last modified: 7 Mar 2008, 9:02:25 UTC

Hello. I'm running Windows ME on 3 of my PCs and all are popping up computation errors for 1.21. They ran fine with 1.19. Thanks. Mike


OK... i've compiled a new linux 32 bit app and both windows apps as well,wich should take care of that issues on Win ME and W2k.

I guess those will be up later today.

The Application Saga Continues (Part 10) is on it's way... LOL ;)







Join Support science! Joinc Team BOINC United now!
ID: 2026 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileDoctorNow
Avatar

Send message
Joined: 28 Aug 07
Posts: 146
Credit: 10,276,862
RAC: 0
10 million credit badge10 year member badge
Message 2027 - Posted: 7 Mar 2008, 9:19:51 UTC - in response to Message 2004.  

Travis wrote:
did you notice any improvement in performance?

Sorry, unfortunately it takes still the same time on 64-Bit Suse than before, about 6,5 minutes.
I wonder what you did on the misnamed 1.19 earlier, it did run in 5,5 minutes.
Member of BOINC@Heidelberg and ATA!

My BOINCstats
ID: 2027 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilerebirther
Avatar

Send message
Joined: 28 Aug 07
Posts: 51
Credit: 8,353,065
RAC: 0
5 million credit badge10 year member badge
Message 2028 - Posted: 7 Mar 2008, 9:40:32 UTC

1.20: 6:10min
1:21: 5:30min

Windows XP SP2, C2D
ID: 2028 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matthias Lehmkuhl

Send message
Joined: 29 Sep 07
Posts: 18
Credit: 4,532,175
RAC: 0
3 million credit badge10 year member badge
Message 2029 - Posted: 7 Mar 2008, 9:54:09 UTC

i run win xp 32 and ubuntu linux 64 bit on the same machine.

linux 64 bit is round 775 sec with 1.21 (no old results to compare)
win xp 32 is round 640 sec with 1.19

linux 64bit:
progress bar is now at 0.5 to 0.5 (form my site you can change to 0.8 to 0.2 -> its near to reality)
no errors on my machine for the first 4 results

win xp 32:
no new results crunched by now, hope the first will start in 11 mins
Matthias

ID: 2029 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matthias Lehmkuhl

Send message
Joined: 29 Sep 07
Posts: 18
Credit: 4,532,175
RAC: 0
3 million credit badge10 year member badge
Message 2030 - Posted: 7 Mar 2008, 12:34:05 UTC

times for win XP 32 bit
1.19 round 630 sec
1.21 round 565 sec

times linux 64 bit
1.21 round 770

same HW

results uploaded without error
restart boinc on linux 64 bit -> milkyway starts form last checkpoint.
restart boinc on win xp 32 bit -> milkyway starts form last checkpoint.
Matthias

ID: 2030 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · 3 · 4 · Next

Message boards : Number crunching : application v1.21/v1.22 errors/memory leaks/crashes here

©2019 Astroinformatics Group