Welcome to MilkyWay@home

application v1.21/v1.22 errors/memory leaks/crashes here


Advanced search

Message boards : Number crunching : application v1.21/v1.22 errors/memory leaks/crashes here
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · Next

AuthorMessage
Angus

Send message
Joined: 8 Nov 07
Posts: 20
Credit: 257,763
RAC: 0
100 thousand credit badge10 year member badge
Message 2034 - Posted: 7 Mar 2008, 15:10:34 UTC
Last modified: 7 Mar 2008, 15:53:48 UTC

ALL 1.21 WUs crash immediately on startup - Win2000 SP4, AMD XP, BOINC 5.10.20:
3/7/2008 4:56:24 AM|Milkyway@home|Starting task gs_280_1204841156_22984_0 using astronomy version 119
3/7/2008 4:56:27 AM|Milkyway@home|[file_xfer] Started upload of file gs_283_1204840568_22193_0_0
3/7/2008 4:56:32 AM|Milkyway@home|[file_xfer] Finished upload of file gs_283_1204840568_22193_0_0
3/7/2008 4:56:32 AM|Milkyway@home|[file_xfer] Throughput 931 bytes/sec
3/7/2008 5:04:29 AM|Milkyway@home|Computation for task gs_280_1204841156_22984_0 finished
3/7/2008 5:04:29 AM|Milkyway@home|Starting gs_281_1204853643_40674_0
3/7/2008 5:04:29 AM|Milkyway@home|[cpu_sched] Starting gs_281_1204853643_40674_0 (initial)
3/7/2008 5:04:29 AM|Milkyway@home|Starting task gs_281_1204853643_40674_0 using astronomy version 121
3/7/2008 5:04:30 AM|Milkyway@home|Deferring communication for 1 min 0 sec
3/7/2008 5:04:30 AM|Milkyway@home|Reason: Unrecoverable error for result gs_281_1204853643_40674_0 (There are no child processes to wait for. (0x80) - exit code 128 (0x80))
3/7/2008 5:04:30 AM|Milkyway@home|Computation for task gs_281_1204853643_40674_0 finished
3/7/2008 5:04:30 AM|Milkyway@home|Output file gs_281_1204853643_40674_0_0 for task gs_281_1204853643_40674_0 absent
3/7/2008 5:04:30 AM|Milkyway@home|Starting gs_284_1204853635_40578_0
3/7/2008 5:04:30 AM|Milkyway@home|[cpu_sched] Starting gs_284_1204853635_40578_0 (initial)
3/7/2008 5:04:30 AM|Milkyway@home|Starting task gs_284_1204853635_40578_0 using astronomy version 121
3/7/2008 5:04:31 AM|Milkyway@home|Deferring communication for 1 min 0 sec
3/7/2008 5:04:31 AM|Milkyway@home|Reason: Unrecoverable error for result gs_284_1204853635_40578_0 (There are no child processes to wait for. (0x80) - exit code 128 (0x80))
3/7/2008 5:04:31 AM|Milkyway@home|[file_xfer] Started upload of file gs_280_1204841156_22984_0_0
3/7/2008 5:04:31 AM|Milkyway@home|Computation for task gs_284_1204853635_40578_0 finished
(and so on until the queue was empty.)


My queue was about half and half 1.19 and 1.21 All the 1.19 WUs finished fine.
ID: 2034 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileDave Przybylo
Avatar

Send message
Joined: 5 Feb 08
Posts: 236
Credit: 49,648
RAC: 0
10 thousand credit badge10 year member badge
Message 2036 - Posted: 7 Mar 2008, 16:07:30 UTC - in response to Message 2034.  

ALL 1.21 WUs crash immediately on startup - Win2000 SP4, AMD XP, BOINC 5.10.20:
3/7/2008 4:56:24 AM|Milkyway@home|Starting task gs_280_1204841156_22984_0 using astronomy version 119
3/7/2008 4:56:27 AM|Milkyway@home|[file_xfer] Started upload of file gs_283_1204840568_22193_0_0
3/7/2008 4:56:32 AM|Milkyway@home|[file_xfer] Finished upload of file gs_283_1204840568_22193_0_0
3/7/2008 4:56:32 AM|Milkyway@home|[file_xfer] Throughput 931 bytes/sec
3/7/2008 5:04:29 AM|Milkyway@home|Computation for task gs_280_1204841156_22984_0 finished
3/7/2008 5:04:29 AM|Milkyway@home|Starting gs_281_1204853643_40674_0
3/7/2008 5:04:29 AM|Milkyway@home|[cpu_sched] Starting gs_281_1204853643_40674_0 (initial)
3/7/2008 5:04:29 AM|Milkyway@home|Starting task gs_281_1204853643_40674_0 using astronomy version 121
3/7/2008 5:04:30 AM|Milkyway@home|Deferring communication for 1 min 0 sec
3/7/2008 5:04:30 AM|Milkyway@home|Reason: Unrecoverable error for result gs_281_1204853643_40674_0 (There are no child processes to wait for. (0x80) - exit code 128 (0x80))
3/7/2008 5:04:30 AM|Milkyway@home|Computation for task gs_281_1204853643_40674_0 finished
3/7/2008 5:04:30 AM|Milkyway@home|Output file gs_281_1204853643_40674_0_0 for task gs_281_1204853643_40674_0 absent
3/7/2008 5:04:30 AM|Milkyway@home|Starting gs_284_1204853635_40578_0
3/7/2008 5:04:30 AM|Milkyway@home|[cpu_sched] Starting gs_284_1204853635_40578_0 (initial)
3/7/2008 5:04:30 AM|Milkyway@home|Starting task gs_284_1204853635_40578_0 using astronomy version 121
3/7/2008 5:04:31 AM|Milkyway@home|Deferring communication for 1 min 0 sec
3/7/2008 5:04:31 AM|Milkyway@home|Reason: Unrecoverable error for result gs_284_1204853635_40578_0 (There are no child processes to wait for. (0x80) - exit code 128 (0x80))
3/7/2008 5:04:31 AM|Milkyway@home|[file_xfer] Started upload of file gs_280_1204841156_22984_0_0
3/7/2008 5:04:31 AM|Milkyway@home|Computation for task gs_284_1204853635_40578_0 finished
(and so on until the queue was empty.)


My queue was about half and half 1.19 and 1.21 All the 1.19 WUs finished fine.




I did some high level optimization on 1.21 which may have adversely affected sub-XP systems. I will revert back to the 1.19 optimization that Cruncher implemented.

Dave Przybylo
MilkyWay@home Developer
Department of Computer Science
Rensselaer Polytechnic Institute
ID: 2036 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ebahapo
Avatar

Send message
Joined: 6 Sep 07
Posts: 66
Credit: 597,040
RAC: 116
500 thousand credit badge10 year member badge
Message 2041 - Posted: 7 Mar 2008, 16:37:07 UTC

1.21 performance is back up, bettering the previous versions.
ID: 2041 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileXJR-Maniac
Avatar

Send message
Joined: 18 Oct 07
Posts: 35
Credit: 4,684,314
RAC: 0
3 million credit badge10 year member badge
Message 2047 - Posted: 7 Mar 2008, 17:48:20 UTC - in response to Message 2018.  
Last modified: 7 Mar 2008, 18:09:02 UTC

Hello,

don't know if this is helping you:
On one of my W2000 hosts the following message appears immediately after the start of the 1.21 app:

The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll.




Dave compiled the 1.21 windows apps, so i'll have him take a look into these.


Same problem here on Win2000 SP4 and WinNT Server SP6. WinXP SP1 works fine.

Yesterday, I suspended all other projects to check v1.19 and it worked fine on all machines, including WinNT 4.

Sometimes, I get a pop up window that locks the system so that no more work will be done until someone clicks OK!

ADVAPI32.dll Versions:

Windows 2000 SP4: 5.0.2195.7038
Windows NT 4 Terminal Server with Citrix Metaframe 1.8: 4.00 (File by Citrix)

Maybe this could be of any interest:

MS Knowledge Base article 142606

or

MSDN article aa378189

LogonUserExA function isn't available in Win2k or WinNT. It's only available for WinXP and Vista.

BTW, what are all those error messages on your website about, complaining about "Undefined variables" or "non given properties". Examples:

Message board posts:
Notice: Undefined variable: out in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 236

View a result:
Notice: Trying to get property of non-object in /export/share0/www/boinc/milkyway/html/inc/result.inc on line 79

View a user profile:
Fatal error: Call to undefined method stdClass::hasImagesAsLinks() in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 109


ID: 2047 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 2049 - Posted: 7 Mar 2008, 18:06:16 UTC - in response to Message 2047.  

Hello,

don't know if this is helping you:
On one of my W2000 hosts the following message appears immediately after the start of the 1.21 app:

The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll.




Dave compiled the 1.21 windows apps, so i'll have him take a look into these.


Same problem here on Win2000 SP4 and WinNT Server SP6. WinXP SP1 works fine.

Yesterday, I suspended all other projects to check v1.19 and it worked fine on all machines, including WinNT 4.

Sometimes, I get a pop up window that locks the system so that no more work will be done until someone clicks OK!

ADVAPI32.dll Versions:

Windows 2000 SP4: 5.0.2195.7038
Windows NT 4 Terminal Server with Citrix Metaframe 1.8: 4.00 (File by Citrix)

Maybe this could be of any interest:

http://support.microsoft.com/kb/142606/EN-US/

BTW, what are all those error messages on your website about, complaining about "Undefined variables" or "non given properties". Examples:

Message board posts:
Notice: Undefined variable: out in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 236

View a result:
Notice: Trying to get property of non-object in /export/share0/www/boinc/milkyway/html/inc/result.inc on line 79

View a user profile:
Fatal error: Call to undefined method stdClass::hasImagesAsLinks() in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 109




could you let us know any workunits that cause a windows popup? we've added code in the new version of the application that should spit out what's causing the error, so if you can point us to the right work units we should be able to diagnose and fix the problem.
ID: 2049 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileXJR-Maniac
Avatar

Send message
Joined: 18 Oct 07
Posts: 35
Credit: 4,684,314
RAC: 0
3 million credit badge10 year member badge
Message 2050 - Posted: 7 Mar 2008, 18:23:36 UTC - in response to Message 2049.  
Last modified: 7 Mar 2008, 18:26:40 UTC

Hello,

don't know if this is helping you:
On one of my W2000 hosts the following message appears immediately after the start of the 1.21 app:

The procedure entry point LogonUserExA could not be located in the dynamic link library ADVAPI32.dll.




Dave compiled the 1.21 windows apps, so i'll have him take a look into these.


Same problem here on Win2000 SP4 and WinNT Server SP6. WinXP SP1 works fine.

Yesterday, I suspended all other projects to check v1.19 and it worked fine on all machines, including WinNT 4.

Sometimes, I get a pop up window that locks the system so that no more work will be done until someone clicks OK!

ADVAPI32.dll Versions:

Windows 2000 SP4: 5.0.2195.7038
Windows NT 4 Terminal Server with Citrix Metaframe 1.8: 4.00 (File by Citrix)

Maybe this could be of any interest:

http://support.microsoft.com/kb/142606/EN-US/

BTW, what are all those error messages on your website about, complaining about "Undefined variables" or "non given properties". Examples:

Message board posts:
Notice: Undefined variable: out in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 236

View a result:
Notice: Trying to get property of non-object in /export/share0/www/boinc/milkyway/html/inc/result.inc on line 79

View a user profile:
Fatal error: Call to undefined method stdClass::hasImagesAsLinks() in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 109




could you let us know any workunits that cause a windows popup? we've added code in the new version of the application that should spit out what's causing the error, so if you can point us to the right work units we should be able to diagnose and fix the problem.



The last WU that crashed whith a popup was this one:

resultid=4795441 (gs_281_1204884506_90429_0)

Also, have a look at my last post, I added somethig I found at MSDN.

ID: 2050 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2052 - Posted: 7 Mar 2008, 18:36:52 UTC - in response to Message 2049.  
Last modified: 7 Mar 2008, 18:39:46 UTC


could you let us know any workunits that cause a windows popup? we've added code in the new version of the application that should spit out what's causing the error, so if you can point us to the right work units we should be able to diagnose and fix the problem.


I'm almost 100% sure that Dave compiled the 1.21 with "unicode" charset instead of "multibyte charset" support.... cuz that's what will make the app crash on w2k and nt4 OS...




Join Support science! Joinc Team BOINC United now!
ID: 2052 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Stick

Send message
Joined: 8 Oct 07
Posts: 33
Credit: 366,086
RAC: 98
100 thousand credit badge10 year member badge
Message 2056 - Posted: 7 Mar 2008, 20:00:50 UTC

I just noticed that v1.21 the "Progress" meter is more linear than v1.19's. That is, as compared to what I reported here for v1.19, my last v1.21 unit took about 9 minutes to do the first 50% and about 2 minutes for the last 50%. Much better!
ID: 2056 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Emanuel

Send message
Joined: 18 Nov 07
Posts: 280
Credit: 2,442,757
RAC: 0
2 million credit badge10 year member badge
Message 2062 - Posted: 7 Mar 2008, 21:05:07 UTC - in response to Message 2052.  

I'm almost 100% sure that Dave compiled the 1.21 with "unicode" charset instead of "multibyte charset" support.... cuz that's what will make the app crash on w2k and nt4 OS...


I realise it's probably good practice to use Unicode.. just wondering though, does Milkyway@home have any great need of it?
ID: 2062 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2063 - Posted: 7 Mar 2008, 21:07:29 UTC - in response to Message 2062.  
Last modified: 7 Mar 2008, 21:09:22 UTC


I realise it's probably good practice to use Unicode.. just wondering though, does Milkyway@home have any great need of it?


Of what ? Using unicode ?
If that's the question... well no. Not that i can think of, though i might be wrong ;)







Join Support science! Joinc Team BOINC United now!
ID: 2063 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Brian D from Georgia

Send message
Joined: 3 Feb 08
Posts: 6
Credit: 6,055,000
RAC: 0
5 million credit badge10 year member badge
Message 2068 - Posted: 7 Mar 2008, 21:22:57 UTC

Three of my hosts running W2K just picked up the 1.22 app and it is working fine. They were crashing on 1.21 immediately and 2 of 3 have just completed their first 1.22 wu and returned it w/o a prob. Good work, so far, so good!


Milkyway@home 3/7/2008 3:53:34 PM 29424 Finished download of parameters_generated_1205012780_27620

Milkyway@home 3/7/2008 4:05:19 PM 29455 Computation for result gs_292_1205012795_27865_0 finished

Milkyway@home 3/7/2008 4:05:19 PM 29456 Starting result gs_292_1205012795_27866_0 using astronomy version 122

Milkyway@home 3/7/2008 4:05:22 PM 29457 Started upload of gs_292_1205012795_27865_0_0

Milkyway@home 3/7/2008 4:05:48 PM 29458 Finished upload of gs_292_1205012795_27865_0_0

Milkyway@home 3/7/2008 4:08:06 PM 29460 Sending scheduler request to http://milkyway.rpi.edu/cgi/cgi

ID: 2068 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2069 - Posted: 7 Mar 2008, 21:26:22 UTC - in response to Message 2068.  
Last modified: 7 Mar 2008, 21:27:11 UTC

Three of my hosts running W2K just picked up the 1.22 app and it is working fine. They were crashing on 1.21 immediately and 2 of 3 have just completed their first 1.22 wu and returned it w/o a prob. Good work, so far, so good!


Well... i had that strange feeling in my guts that 1.22 will work ;)

However, those issues of older win OSes crashing will be gone as of now since we figured out already what triggered it ;)




Join Support science! Joinc Team BOINC United now!
ID: 2069 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile[SG-SPEG] sth

Send message
Joined: 5 Feb 08
Posts: 4
Credit: 20,497,928
RAC: 150,795
20 million credit badge10 year member badge
Message 2072 - Posted: 7 Mar 2008, 21:41:00 UTC

Hi,

currently all hosts (32bit Linux, Win XP, Win 2000, Vista) run without problems with the new app versions.

Thx a lot!


Ciao
Stefan

ID: 2072 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilerebirther
Avatar

Send message
Joined: 28 Aug 07
Posts: 51
Credit: 8,353,065
RAC: 0
5 million credit badge10 year member badge
Message 2074 - Posted: 7 Mar 2008, 21:43:24 UTC

1.20: 6:10min
1:21: 5:30min
1:22: 6:09min

Windows XP SP2, C2D
ID: 2074 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ebahapo
Avatar

Send message
Joined: 6 Sep 07
Posts: 66
Credit: 597,040
RAC: 116
500 thousand credit badge10 year member badge
Message 2075 - Posted: 7 Mar 2008, 21:49:12 UTC - in response to Message 2074.  
Last modified: 7 Mar 2008, 21:49:42 UTC

1.20: 6:10min
1:21: 5:30min
1:22: 6:09min

Windows XP SP2, C2D

I confirm a similar slow-down of 10% from 1.21.

HTH

ID: 2075 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2076 - Posted: 7 Mar 2008, 21:49:25 UTC - in response to Message 2074.  

1.20: 6:10min
1:21: 5:30min
1:22: 6:09min

Windows XP SP2, C2D



Well... to get "backwards" compatibilty we had to sacrifice some speed on 1.22...
That's the way life goes but we won't exclude older OS just for having a faster app ;)

If all settles down without any computation errors we'll have a look at speed improvements again ;)

Dropping g++/cl is one of them ... switching to icc/icl will help a great deal but
we're not there yet.

Hope ya'll uderstand that we have to iron out the bugs first.



Join Support science! Joinc Team BOINC United now!
ID: 2076 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilerebirther
Avatar

Send message
Joined: 28 Aug 07
Posts: 51
Credit: 8,353,065
RAC: 0
5 million credit badge10 year member badge
Message 2077 - Posted: 7 Mar 2008, 21:51:58 UTC - in response to Message 2076.  

1.20: 6:10min
1:21: 5:30min
1:22: 6:09min

Windows XP SP2, C2D



Well... to get "backwards" compatibilty we had to sacrifice some speed on 1.22...
That's the way life goes but we won't exclude older OS just for having a faster app ;)

If all settles down without any computation errors we'll have a look at speed improvements again ;)

Dropping g++/cl is one of them ... switching to icc/icl will help a great deal but
we're not there yet.

Hope ya'll uderstand that we have to iron out the bugs first.



No problem, the main part is that all is running fine here :-)
ID: 2077 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2079 - Posted: 7 Mar 2008, 21:58:12 UTC - in response to Message 2077.  


No problem, the main part is that all is running fine here :-)


Good to hear it's working for you !

and that's exacly what gets first priority... getting all apps working properly ... more tweaks and stuff like that is the second goal.






Join Support science! Joinc Team BOINC United now!
ID: 2079 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matthias Lehmkuhl

Send message
Joined: 29 Sep 07
Posts: 18
Credit: 4,532,175
RAC: 0
3 million credit badge10 year member badge
Message 2084 - Posted: 7 Mar 2008, 22:53:59 UTC

my first linux 32 bit 1.22 is reported on this machine
no errors now.

times
1.19 580 sec
1.22 542 sec

7:50 min for the first 50%, 1:14 min for the second 50%

windows xp is running the last four 1.21
Matthias

ID: 2084 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2085 - Posted: 7 Mar 2008, 23:01:20 UTC - in response to Message 2084.  
Last modified: 7 Mar 2008, 23:10:26 UTC

my first linux 32 bit 1.22 is reported on this machine
no errors now.

times
1.19 580 sec
1.22 542 sec

7:50 min for the first 50%, 1:14 min for the second 50%

windows xp is running the last four 1.21


Thanks buddy ;)

I guess that's the 'official' one now ;)

Seems to work as intended... using a runtime dispatcher and speed increased a bit too.

BTW, thanks for helping test the apps. It's quite welcome!



Join Support science! Joinc Team BOINC United now!
ID: 2085 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · 4 · Next

Message boards : Number crunching : application v1.21/v1.22 errors/memory leaks/crashes here

©2019 Astroinformatics Group