Welcome to MilkyWay@home

App version needs OpenCL but GPU doesn't support it


Advanced search

Message boards : Number crunching : App version needs OpenCL but GPU doesn't support it
Message board moderation

To post messages, you must log in.

AuthorMessage
monty-b

Send message
Joined: 25 Sep 11
Posts: 4
Credit: 23,971,934
RAC: 0
20 million credit badge8 year member badge
Message 54960 - Posted: 1 Jul 2012, 18:34:04 UTC

Hi,

I'm having trouble running Milkyway on my GPU after updating to BOINC 7.028 (64bit).

My GPU is a GeForce GTX 570 (driver version 301.42, CUDA version 4.20, compute capability 2.0, 1280MB, 1129MB available, 1440 GFLOPS peak).

The log reads like this:
01.07.2012 20:21:35 | Milkyway@Home | Requesting new tasks for NVIDIA
01.07.2012 20:21:39 | | App version needs OpenCL but GPU doesn't support it
01.07.2012 20:21:39 | Milkyway@Home | Scheduler request completed: got 25 new tasks
01.07.2012 20:21:39 | Milkyway@Home | [error] App version uses non-existent NVIDIA GPU
01.07.2012 20:21:39 | Milkyway@Home | [error] Missing coprocessor for task de_separation_09_2s_sample_2_1341007502_991786_0; aborting
01.07.2012 20:21:39 | Milkyway@Home | [error] Missing coprocessor for task de_separation_09_2s_sample_2_1341007502_991787_0; aborting
01.07.2012 20:21:39 | Milkyway@Home | [error] Missing coprocessor for task de_separation_09_2s_sample_2_1341007502_991788_0; aborting
01.07.2012 20:21:39 | Milkyway@Home | [error] Missing coprocessor for task de_separation_09_2s_sample_2_1341007502_991789_0; aborting
01.07.2012 20:21:39 | Milkyway@Home | [error] Missing coprocessor for task de_separation_09_2s_sample_2_1341007502_991790_0; aborting
01.07.2012 20:21:39 | Milkyway@Home | [error] Missing coprocessor for task de_separation_09_2s_sample_2_1341007502_991791_0; aborting
(...)

I have tried resetting the project and re-installing thed latest Nvidia driver - nothing seems to work. If anyone could point me in the right direction, I'd be most grateful.

Regards,

- monty
ID: 54960 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Len LE/GE

Send message
Joined: 8 Feb 08
Posts: 261
Credit: 104,050,322
RAC: 0
100 million credit badge10 year member badge
Message 54963 - Posted: 2 Jul 2012, 11:35:30 UTC - in response to Message 54960.  

Can xou post the beginning of the log? Where it shows what hardware the client has found?
ID: 54963 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
monty-b

Send message
Joined: 25 Sep 11
Posts: 4
Credit: 23,971,934
RAC: 0
20 million credit badge8 year member badge
Message 54964 - Posted: 2 Jul 2012, 12:19:40 UTC - in response to Message 54963.  

Hi Len,

sure:
01.07.2012 20:19:42 | | Starting BOINC client version 7.0.28 for windows_x86_64
01.07.2012 20:19:42 | | log flags: file_xfer, sched_ops, task
01.07.2012 20:19:42 | | Libraries: libcurl/7.25.0 OpenSSL/1.0.1 zlib/1.2.6
01.07.2012 20:19:42 | | Data directory: C:\BOINCdata
01.07.2012 20:19:42 | | Running under account monty-b
01.07.2012 20:19:42 | | Processor: 4 GenuineIntel Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz [Family 6 Model 23 Stepping 10]
01.07.2012 20:19:42 | | Processor: 3.00 MB cache
01.07.2012 20:19:42 | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 cx16 sse4_1 syscall nx lm vmx smx tm2 pbe
01.07.2012 20:19:42 | | OS: Microsoft Windows 7: Ultimate x64 Edition, Service Pack 1, (06.01.7601.00)
01.07.2012 20:19:42 | | Memory: 8.00 GB physical, 16.00 GB virtual
01.07.2012 20:19:42 | | Disk: 931.50 GB total, 505.40 GB free
01.07.2012 20:19:42 | | Local time is UTC +2 hours
01.07.2012 20:19:42 | | NVIDIA GPU 0: GeForce GTX 570 (driver version 301.42, CUDA version 4.20, compute capability 2.0, 1280MB, 1129MB available, 1440 GFLOPS peak)

Thank you very much for looking into this!

- monty
ID: 54964 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
monty-b

Send message
Joined: 25 Sep 11
Posts: 4
Credit: 23,971,934
RAC: 0
20 million credit badge8 year member badge
Message 54972 - Posted: 3 Jul 2012, 6:57:47 UTC - in response to Message 54964.  

For anyone with the same problem: Just found out myself - reverting to Boinc 7.0.25 did the trick.
ID: 54972 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilearkayn
Avatar

Send message
Joined: 14 Feb 09
Posts: 999
Credit: 74,932,619
RAC: 0
50 million credit badge10 year member badge
Message 54977 - Posted: 3 Jul 2012, 15:26:41 UTC - in response to Message 54972.  

The only problem with 7.0.25 is it will run Milkyway in high-priority at all times.

Try 7.0.31 and see if it has the proper support.
http://boinc.berkeley.edu/dl/boinc_7.0.31_windows_x86_64.exe
ID: 54977 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
monty-b

Send message
Joined: 25 Sep 11
Posts: 4
Credit: 23,971,934
RAC: 0
20 million credit badge8 year member badge
Message 54997 - Posted: 4 Jul 2012, 8:19:26 UTC - in response to Message 54977.  

Hi arkayn,

I just tried 7.0.31 and it doesn't work for me.
04.07.2012 10:14:10 | | NVIDIA GPU 0: GeForce GTX 570 (driver version 301.42, CUDA version 4.20, compute capability 2.0, 1280MB, 1040MB available, 1440 GFLOPS peak)
04.07.2012 10:14:10 | SETI@home | Found app_info.xml; using anonymous platform
04.07.2012 10:14:10 | | App version needs OpenCL but GPU doesn't support it
04.07.2012 10:14:10 | Milkyway@Home | Application uses missing NVIDIA GPU
04.07.2012 10:14:10 | | Version change (7.0.25 -> 7.0.31)

(...)
04.07.2012 10:15:55 | Milkyway@Home | Sending scheduler request: Requested by user.
04.07.2012 10:15:55 | Milkyway@Home | Not requesting tasks: project is not highest priority
04.07.2012 10:15:56 | Milkyway@Home | Scheduler request completed

So it's back to 7.0.25 for me. Let me know if there is something else you'd like to try out.

Thanks,

- monty
ID: 54997 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
BulletMagnetEd

Send message
Joined: 8 Jul 10
Posts: 15
Credit: 56,973,532
RAC: 37,180
50 million credit badge10 year member badge
Message 55092 - Posted: 12 Jul 2012, 0:08:19 UTC

Thanks! I ran into the same issue after "upgrading" to BOINC 7.0.28, then all the OpenCL tasks I downloaded would no longer run. I actually had to uninstall BOINC 7.0.28, delete all the BOINC folders and reinstall BOINC 7.0.25 fresh. At least it's working now.
ID: 55092 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Amauri

Send message
Joined: 30 Jan 09
Posts: 21
Credit: 8,061,978
RAC: 4,248
5 million credit badge10 year member badge
Message 55263 - Posted: 30 Jul 2012, 1:40:45 UTC - in response to Message 55092.  

The recent NVidia drivers don't report the OpenCL capabilities to Boinc, like these lines in Boinc's "Event Log":

Dom 29 Jul 2012 17:24:08 BRT |  | NVIDIA GPU 0: GeForce GT 640 (driver version unknown, CUDA version 4.20, compute capability 3.0, 2048MB, 134215651MB available, 692 GFLOPS peak)
Dom 29 Jul 2012 17:24:08 BRT |  | OpenCL: NVIDIA GPU 0: GeForce GT 640 (driver version 295.49, device version OpenCL 1.1 CUDA, 2048MB, 134215651MB available)

Installed 302.17 (Linux), and that 2nd. line (OpenCL) isn't there. Without OpenCL support, the GPU app can't run. Reverted to 295.49, and everything is ok.

Can anyone confirm this?
ID: 55263 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
GTO

Send message
Joined: 17 Sep 11
Posts: 1
Credit: 815,513
RAC: 181
500 thousand credit badge8 year member badge
Message 55349 - Posted: 13 Aug 2012, 7:39:30 UTC - in response to Message 55263.  

I use Nvidia drivers 302.17 and Boinc 7.0.27 on Debian GNU Linux and Boinc refuse to use GPU, here is my Boinc log:
lun 13 ago 2012 09:26:57 CEST | | Starting BOINC client version 7.0.27 for i686-pc-linux-gnu
lun 13 ago 2012 09:26:57 CEST | | log flags: file_xfer, sched_ops, task
lun 13 ago 2012 09:26:57 CEST | | Libraries: libcurl/7.26.0 OpenSSL/1.0.1c zlib/1.2.7 libidn/1.25 libssh2/1.4.1 librtmp/2.3
lun 13 ago 2012 09:26:57 CEST | | Data directory: /var/lib/boinc-client
lun 13 ago 2012 09:26:57 CEST | | Processor: 4 AuthenticAMD AMD Phenom(tm) II X4 955 Processor [Family 16 Model 4 Stepping 3]
lun 13 ago 2012 09:26:57 CEST | | Processor: 512.00 KB cache
lun 13 ago 2012 09:26:57 CEST | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
lun 13 ago 2012 09:26:57 CEST | | OS: Linux: 3.2.0-3-686-pae
lun 13 ago 2012 09:26:57 CEST | | Memory: 3.96 GB physical, 4.00 GB virtual
lun 13 ago 2012 09:26:57 CEST | | Disk: 362.83 GB total, 251.20 GB free
lun 13 ago 2012 09:26:57 CEST | | Local time is UTC +2 hours
lun 13 ago 2012 09:26:57 CEST | | VirtualBox version: 3.2.14r75509
lun 13 ago 2012 09:26:57 CEST | | NVIDIA GPU 0: GeForce GTX 460 (driver version unknown, CUDA version 4.20, compute capability 2.1, 1023MB, 961MB available, 941 GFLOPS peak)
lun 13 ago 2012 09:26:57 CEST | | OpenCL: NVIDIA GPU 0 (not used): GeForce GTX 460 (driver version 302.17, device version OpenCL 1.1 CUDA, 1023MB, 961MB available)
lun 13 ago 2012 09:26:57 CEST | | App version needs OpenCL but GPU doesn't support it
lun 13 ago 2012 09:26:57 CEST | Milkyway@Home | Application uses missing NVIDIA GPU
ID: 55349 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Milchband

Send message
Joined: 19 Apr 09
Posts: 26
Credit: 36,442,501
RAC: 141
30 million credit badge10 year member badge
Message 55424 - Posted: 28 Aug 2012, 6:38:41 UTC

I have many valid errors.Why?
Greetings
ID: 55424 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2373
Credit: 445,918,643
RAC: 40,603
300 million credit badge10 year member badgeextraordinary contributions badge
Message 55426 - Posted: 28 Aug 2012, 11:27:58 UTC - in response to Message 55349.  
Last modified: 28 Aug 2012, 11:28:43 UTC

I use Nvidia drivers 302.17 and Boinc 7.0.27 on Debian GNU Linux and Boinc refuse to use GPU, here is my Boinc log:
lun 13 ago 2012 09:26:57 CEST | | Starting BOINC client version 7.0.27 for i686-pc-linux-gnu
lun 13 ago 2012 09:26:57 CEST | | log flags: file_xfer, sched_ops, task
lun 13 ago 2012 09:26:57 CEST | | Libraries: libcurl/7.26.0 OpenSSL/1.0.1c zlib/1.2.7 libidn/1.25 libssh2/1.4.1 librtmp/2.3
lun 13 ago 2012 09:26:57 CEST | | Data directory: /var/lib/boinc-client
lun 13 ago 2012 09:26:57 CEST | | Processor: 4 AuthenticAMD AMD Phenom(tm) II X4 955 Processor [Family 16 Model 4 Stepping 3]
lun 13 ago 2012 09:26:57 CEST | | Processor: 512.00 KB cache
lun 13 ago 2012 09:26:57 CEST | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
lun 13 ago 2012 09:26:57 CEST | | OS: Linux: 3.2.0-3-686-pae
lun 13 ago 2012 09:26:57 CEST | | Memory: 3.96 GB physical, 4.00 GB virtual
lun 13 ago 2012 09:26:57 CEST | | Disk: 362.83 GB total, 251.20 GB free
lun 13 ago 2012 09:26:57 CEST | | Local time is UTC +2 hours
lun 13 ago 2012 09:26:57 CEST | | VirtualBox version: 3.2.14r75509
lun 13 ago 2012 09:26:57 CEST | | NVIDIA GPU 0: GeForce GTX 460 (driver version unknown, CUDA version 4.20, compute capability 2.1, 1023MB, 961MB available, 941 GFLOPS peak)
lun 13 ago 2012 09:26:57 CEST | | OpenCL: NVIDIA GPU 0 (not used): GeForce GTX 460 (driver version 302.17, device version OpenCL 1.1 CUDA, 1023MB, 961MB available)
lun 13 ago 2012 09:26:57 CEST | | App version needs OpenCL but GPU doesn't support it
lun 13 ago 2012 09:26:57 CEST | Milkyway@Home | Application uses missing NVIDIA GPU


I am NOT a Linux guy but for me, in Windows, only Boinc version 7.0.25 would let my Nvidia 560 Ti work, all others gave the error message you are seeing.
ID: 55426 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
pmassey

Send message
Joined: 22 Dec 10
Posts: 8
Credit: 19,792,404
RAC: 0
10 million credit badge9 year member badge
Message 56650 - Posted: 27 Dec 2012, 22:18:30 UTC

I'm getting the same error. Any thoughts would be nice.

12/27/2012 4:13:30 PM |  | No config file found - using defaults
12/27/2012 4:13:30 PM |  | Starting BOINC client version 7.0.28 for x86_64-pc-linux-gnu
12/27/2012 4:13:30 PM |  | log flags: file_xfer, sched_ops, task
12/27/2012 4:13:30 PM |  | Libraries: libcurl/7.24.0 NSS/3.13.5.0 zlib/1.2.5 libidn/1.24 libssh2/1.4.1
12/27/2012 4:13:30 PM |  | Data directory: /home/armanox/boincWorking
12/27/2012 4:13:30 PM |  | Processor: 3 AuthenticAMD AMD Phenom(tm) II X4 B55 Processor [Family 16 Model 4 Stepping 3]
12/27/2012 4:13:30 PM |  | Processor: 512.00 KB cache
12/27/2012 4:13:30 PM |  | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
12/27/2012 4:13:30 PM |  | OS: Linux: 3.6.9-2.fc17.x86_64
12/27/2012 4:13:30 PM |  | Memory: 7.80 GB physical, 4.00 GB virtual
12/27/2012 4:13:30 PM |  | Disk: 32.27 GB total, 6.75 GB free
12/27/2012 4:13:30 PM |  | Local time is UTC -5 hours
12/27/2012 4:13:30 PM |  | VirtualBox version: 4.2.4r81684
12/27/2012 4:13:30 PM |  | NVIDIA GPU 0: Quadro 600 (driver version unknown, CUDA version 5.0, compute capability 2.1, 246784MB, 134214570MB available, 246 GFLOPS peak)
12/27/2012 4:13:30 PM |  | App version needs OpenCL but GPU doesn't support it
12/27/2012 4:13:30 PM | Milkyway@Home | Application uses missing NVIDIA GPU
ID: 56650 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2373
Credit: 445,918,643
RAC: 40,603
300 million credit badge10 year member badgeextraordinary contributions badge
Message 56656 - Posted: 28 Dec 2012, 12:58:10 UTC - in response to Message 55424.  

I have many valid errors.Why?
Greetings


I do not think your Nvidia 130 card can crunch, it is not on the list of valid cards.

As for the other machine with two gpu's in it do you have a 'cc_config.xml' file?
If not you might consider trying one like this:
<cc_config>
<options>
<use_all_gpus>1</use_all_gpus>
<skip_cpu_benchmarks>1</skip_cpu_benchmarks>
</options>
</cc_config>

It looked to me like Boinc was confused when it found two gpu's, but I am CERTAINLY not an expert at reading the stderr.out files!

To use a 'cc_config.xml" file just copy and paste the lines above into NOTEPAD, NOT a word processing program, and save it is a txt type file with the name cc_config.xml and then place it in the c:\ProgramData\Boinc directory. Next just exit out of Boinc and then restart it to get it to read the file on startup.
ID: 56656 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2373
Credit: 445,918,643
RAC: 40,603
300 million credit badge10 year member badgeextraordinary contributions badge
Message 56657 - Posted: 28 Dec 2012, 13:04:46 UTC - in response to Message 56650.  

I'm getting the same error. Any thoughts would be nice.

12/27/2012 4:13:30 PM |  | No config file found - using defaults
12/27/2012 4:13:30 PM |  | Starting BOINC client version 7.0.28 for x86_64-pc-linux-gnu
12/27/2012 4:13:30 PM |  | log flags: file_xfer, sched_ops, task
12/27/2012 4:13:30 PM |  | Libraries: libcurl/7.24.0 NSS/3.13.5.0 zlib/1.2.5 libidn/1.24 libssh2/1.4.1
12/27/2012 4:13:30 PM |  | Data directory: /home/armanox/boincWorking
12/27/2012 4:13:30 PM |  | Processor: 3 AuthenticAMD AMD Phenom(tm) II X4 B55 Processor [Family 16 Model 4 Stepping 3]
12/27/2012 4:13:30 PM |  | Processor: 512.00 KB cache
12/27/2012 4:13:30 PM |  | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
12/27/2012 4:13:30 PM |  | OS: Linux: 3.6.9-2.fc17.x86_64
12/27/2012 4:13:30 PM |  | Memory: 7.80 GB physical, 4.00 GB virtual
12/27/2012 4:13:30 PM |  | Disk: 32.27 GB total, 6.75 GB free
12/27/2012 4:13:30 PM |  | Local time is UTC -5 hours
12/27/2012 4:13:30 PM |  | VirtualBox version: 4.2.4r81684
12/27/2012 4:13:30 PM |  | NVIDIA GPU 0: Quadro 600 (driver version unknown, CUDA version 5.0, compute capability 2.1, 246784MB, 134214570MB available, 246 GFLOPS peak)
12/27/2012 4:13:30 PM |  | App version needs OpenCL but GPU doesn't support it
12/27/2012 4:13:30 PM | Milkyway@Home | Application uses missing NVIDIA GPU


The last three lines say the driver isn't the right one, Boinc found a gpu but it doesn't support the OpenCL format, meaning either your gpu won't work or the drivers are the wrong ones, I would go with the drivers until proven otherwise. Start cruising thru other users accounts and look at what drivers they are using and start trying some. You could also try searching the Nvidia boards, but they are mostly helpful to gamers. The one other thing is are you trying to run the gpu inside a virtual box? That may not work for crunching, I have never seen anyone say they had that working, cpu crunching yes but never gpu crunching.
ID: 56657 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
pmassey

Send message
Joined: 22 Dec 10
Posts: 8
Credit: 19,792,404
RAC: 0
10 million credit badge9 year member badge
Message 56664 - Posted: 29 Dec 2012, 20:00:15 UTC - in response to Message 56657.  



The last three lines say the driver isn't the right one, Boinc found a gpu but it doesn't support the OpenCL format, meaning either your gpu won't work or the drivers are the wrong ones, I would go with the drivers until proven otherwise. Start cruising thru other users accounts and look at what drivers they are using and start trying some. You could also try searching the Nvidia boards, but they are mostly helpful to gamers. The one other thing is are you trying to run the gpu inside a virtual box? That may not work for crunching, I have never seen anyone say they had that working, cpu crunching yes but never gpu crunching.



I will check the driver versions. BOINC reports virtual box version if it finds vbox installed on the system. I'm certainly not trying to crunch a VM.

I'm also noticing BOINC having an issue with how much RAM it think my cards have. It says my Quadro 600 has 246GB of video RAM - and over 100TB of video RAM availible. Quite impressive for a low end card! (Also thinks the Quadro FX 1800 in another computer has 4GB of video RAM).
"Apollo was astonished, Dionysus thought me mad. But they heard my story further and they wondered and were sad."
ID: 56664 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
James L. Neill

Send message
Joined: 28 Aug 11
Posts: 7
Credit: 29,826,521
RAC: 143,458
20 million credit badge8 year member badge
Message 56949 - Posted: 18 Jan 2013, 16:16:47 UTC - in response to Message 56664.  

I have been having almost exactly the same problem and tried various things to solve it. Naturally nothing has worked as yet! Playing with the permissions of the boinc account seemed a logical step to make even giving boinc "root" privileges did not work.

I suspect a driver issue somewhere along the line and will try using the Nvidia - 310.19 drivers directly as they are not available through RPMFusion yet.

I also run Einstein and cuda works there but for both the cuda and cpu applications the progress bar does not work; it is either 0 or 100%!

Any assistance would be gratefully appreciated.

James

Fri 18 Jan 2013 13:34:34 GMT |  | No config file found - using defaults
Fri 18 Jan 2013 13:34:34 GMT |  | Starting BOINC client version 7.0.29 for x86_64-pc-linux-gnu
Fri 18 Jan 2013 13:34:34 GMT |  | log flags: file_xfer, sched_ops, task
Fri 18 Jan 2013 13:34:34 GMT |  | Libraries: libcurl/7.27.0 NSS/3.14.0.1 zlib/1.2.7 libidn/1.26 libssh2/1.4.2
Fri 18 Jan 2013 13:34:34 GMT |  | Data directory: /var/lib/boinc
Fri 18 Jan 2013 13:34:34 GMT |  | Processor: 2 AuthenticAMD AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ [Family 15 Model 67 Stepping 3]
Fri 18 Jan 2013 13:34:34 GMT |  | Processor: 1.00 MB cache
Fri 18 Jan 2013 13:34:34 GMT |  | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good nopl extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy
Fri 18 Jan 2013 13:34:34 GMT |  | OS: Linux: 3.7.2-201.fc18.x86_64
Fri 18 Jan 2013 13:34:34 GMT |  | Memory: 7.80 GB physical, 32.00 GB virtual
Fri 18 Jan 2013 13:34:34 GMT |  | Disk: 7.87 GB total, 2.23 GB free
Fri 18 Jan 2013 13:34:34 GMT |  | Local time is UTC +0 hours
Fri 18 Jan 2013 13:34:34 GMT |  | NVIDIA GPU 0: GeForce GTX 570 (driver version unknown, CUDA version 5.0, compute capability 2.0, 1280MB, 9410MB available, 1478 GFLOPS peak)
Fri 18 Jan 2013 13:34:34 GMT |  | NVIDIA GPU 1: GeForce GTX 570 (driver version unknown, CUDA version 5.0, compute capability 2.0, 1279MB, 9115MB available, 1478 GFLOPS peak)
Fri 18 Jan 2013 13:34:34 GMT |  | App version needs OpenCL but GPU doesn't support it
Fri 18 Jan 2013 13:34:34 GMT | Milkyway@Home | Application uses missing NVIDIA GPU
Fri 18 Jan 2013 13:34:34 GMT |  | App version needs OpenCL but GPU doesn't support it
Fri 18 Jan 2013 13:34:34 GMT | Milkyway@Home | Application uses missing NVIDIA GPU
Fri 18 Jan 2013 13:34:34 GMT | SETI@home | URL http://setiathome.berkeley.edu/; Computer ID 6884915; resource share 100
Fri 18 Jan 2013 13:34:34 GMT | Einstein@Home | URL http://einstein.phys.uwm.edu/; Computer ID 6433620; resource share 100
Fri 18 Jan 2013 13:34:34 GMT | Milkyway@Home | URL http://milkyway.cs.rpi.edu/milkyway/; Computer ID 493180; resource share 100

ID: 56949 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Boris Vanin

Send message
Joined: 6 Mar 12
Posts: 1
Credit: 23,568
RAC: 0
10 thousand credit badge8 year member badge
Message 64390 - Posted: 18 Mar 2016, 7:00:55 UTC

It seems like a problem is Miltyway specific.

I've got same problem:
Starting BOINC client version 7.6.6 for x86_64-pc-linux-gnu
CUDA: NVIDIA GPU 0: GeForce GTX 560 Ti (driver version 340.96, CUDA version 6.5, compute capability 2.1, 1023MB, 662MB available, 1275 GFLOPS peak)

Milkyway@Home | [error] App version uses non-existent NVIDIA GPU

Einstain@Home project uses my GPU and has no problem.
ID: 64390 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
alanb1951

Send message
Joined: 16 Mar 10
Posts: 49
Credit: 45,916,793
RAC: 53,567
30 million credit badge10 year member badgeextraordinary contributions badge
Message 64391 - Posted: 20 Mar 2016, 5:04:38 UTC

Does Einstein@Home use CUDA or OpenCL on NVIDIA - I think it uses CUDA...

Whilst I realize that the resolution is likely to be dependent on the Linux flavour and the availability of relevant driver versions, I'm on Ubuntu 15.10 and there I have drivers v352 from the repository, and it includes a package called the "Generic OpenCL ICD Loader" which includes an OpenCL library. (I'm also using BOINC 7.6.31, but I don't think that makes any real difference...)

If you have the OpenCL library (and anything else it might need...) your startup log should have two lines similar to the below, not just the CUDA line...

Sun 20 Mar 2016 04:55:16 GMT | | CUDA: NVIDIA GPU 0: GeForce GTX 960M (driver version 352.63, CUDA version 7.5, compute capability 5.0, 2048MB, 1685MB available, 1505 GFLOPS peak)
Sun 20 Mar 2016 04:55:16 GMT | | OpenCL: NVIDIA GPU 0: GeForce GTX 960M (driver version 352.63, device version OpenCL 1.2 CUDA, 2048MB, 1685MB available, 1505 GFLOPS peak)

A drivers issue indeed, but more about how much one installs, rather than which version, I suspect.

Good luck finding solutions...

Cheers - Al.
ID: 64391 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2373
Credit: 445,918,643
RAC: 40,603
300 million credit badge10 year member badgeextraordinary contributions badge
Message 64393 - Posted: 20 Mar 2016, 11:56:16 UTC - in response to Message 64390.  

It seems like a problem is Miltyway specific.

I've got same problem:
Starting BOINC client version 7.6.6 for x86_64-pc-linux-gnu
CUDA: NVIDIA GPU 0: GeForce GTX 560 Ti (driver version 340.96, CUDA version 6.5, compute capability 2.1, 1023MB, 662MB available, 1275 GFLOPS peak)

Milkyway@Home | [error] App version uses non-existent NVIDIA GPU

Einstain@Home project uses my GPU and has no problem.


You are using an older driver for your 560, driver version 340.96, I am using Windows but driver version 350.12 as the oldest, I am also using 361.43, 361.75 and 355.60 on my 760's and they crunch just fine. You might check and see if they have newer gpu drivers for you.

Over at Collatz I have a 560 crunching just fine using the driver version 361.91, still on Windows though.

When I check Nvidia.com and Linux 64bit drivers I see they have version 361.28 as a set of release drivers, meaning non beta.
ID: 64393 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : App version needs OpenCL but GPU doesn't support it

©2020 Astroinformatics Group