Welcome to MilkyWay@home

Trying to run six Tahiti gpu's at once


Advanced search

Message boards : Number crunching : Trying to run six Tahiti gpu's at once
Message board moderation

To post messages, you must log in.

AuthorMessage
Tim B

Send message
Joined: 7 Jan 12
Posts: 6
Credit: 1,054,886,044
RAC: 88
1 billion credit badge10 year member badgeextraordinary contributions badge
Message 64030 - Posted: 23 Oct 2015, 16:01:37 UTC
Last modified: 23 Oct 2015, 16:01:47 UTC

Hi
Trying to problem solve my cruncher with three 7990 graphics cards.
the machine in question seems to run well on most projects but when I try
MW@H with all six gpu's enabled I get stuck WU"s after a time. Ive tried
win 7 win8.1 win 10 + new and old drivers and Bionc manager vesions.
any help would be appreciated as this machine is going to be upgraded with one
more 7990 graphics card to give a total of eight Tahiti gpu's which would be
one mighty MW cruncher.
thanks
ID: 64030 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2797
Credit: 463,253,471
RAC: 7,000
300 million credit badge13 year member badgeextraordinary contributions badge
Message 64031 - Posted: 24 Oct 2015, 9:39:58 UTC - in response to Message 64030.  

Hi
Trying to problem solve my cruncher with three 7990 graphics cards.
the machine in question seems to run well on most projects but when I try
MW@H with all six gpu's enabled I get stuck WU"s after a time. Ive tried
win 7 win8.1 win 10 + new and old drivers and Bionc manager vesions.
any help would be appreciated as this machine is going to be upgraded with one
more 7990 graphics card to give a total of eight Tahiti gpu's which would be
one mighty MW cruncher.
thanks


The only help I can give you is that my own setup which is a 7970:
AMD AMD Radeon HD 7870/7950/7970/R9 280X series (Tahiti) (3072MB) driver: 1.4.1848 OpenCL: 1.2

but only a single gpu, runs just fine on Win7 64bit Ultimate. I run one unit at a time and am getting about 150K RAC per day out of it. I am pretty sure it could run 2 units at once, but I am not interested in passing my own teammate right now.
ID: 64031 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Tim B

Send message
Joined: 7 Jan 12
Posts: 6
Credit: 1,054,886,044
RAC: 88
1 billion credit badge10 year member badgeextraordinary contributions badge
Message 64032 - Posted: 24 Oct 2015, 9:57:58 UTC - in response to Message 64031.  

Thanks for that
I see some other people are running up to three Tahiti based graphics cards
but I don't see any one running more than that .if I could find someone who
has had success with six or eight gpu's on MW@H that would be good.I was going
to make this machine a dedicated MW only machine just because how fast the Tahiti gpu is on it.
ID: 64032 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2797
Credit: 463,253,471
RAC: 7,000
300 million credit badge13 year member badgeextraordinary contributions badge
Message 64036 - Posted: 25 Oct 2015, 11:16:28 UTC - in response to Message 64032.  

Thanks for that
I see some other people are running up to three Tahiti based graphics cards
but I don't see any one running more than that .if I could find someone who
has had success with six or eight gpu's on MW@H that would be good.I was going
to make this machine a dedicated MW only machine just because how fast the Tahiti gpu is on it.


Maybe you could try 2 separate instances of Boinc then, each running 3 gpu's. They would need to be installed in different directories, but could both be running MW I think.
ID: 64036 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Tim B

Send message
Joined: 7 Jan 12
Posts: 6
Credit: 1,054,886,044
RAC: 88
1 billion credit badge10 year member badgeextraordinary contributions badge
Message 64038 - Posted: 25 Oct 2015, 16:50:35 UTC - in response to Message 64036.  

Interesting
I give that a go .I figured out how to open two instances of boinc from the primary installation and have it running . if that fails I will try putting it into two different directories but im not shore how to configure it to run three gpu's each .
ID: 64038 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2797
Credit: 463,253,471
RAC: 7,000
300 million credit badge13 year member badgeextraordinary contributions badge
Message 64040 - Posted: 26 Oct 2015, 11:46:08 UTC - in response to Message 64038.  

Interesting
I give that a go .I figured out how to open two instances of boinc from the primary installation and have it running . if that fails I will try putting it into two different directories but im not shore how to configure it to run three gpu's each .


First you use a cc_config.xml file in each Boinc to use all the gpu's, then you tell it to exclude gpu 0, 1 and 2 from the first Boinc setup, then exclude gpu 3, 4 and 5 from the 2nd Boinc setup.

<cc_config>
<options>
<use_all_gpus>1</use_all_gpus>
<exclude_gpu>
<url>http://milkyway.cs.rpi.edu/milkyway/</url>
<device_num>0</device_num>
[<type>NVIDIA|ATI|intel_gpu</type>]
</exclude_gpu>
<exclude_gpu>
<url>http://milkyway.cs.rpi.edu/milkyway/</url>
<device_num>1</device_num>
[<type>NVIDIA|ATI|intel_gpu</type>]
</exclude_gpu>
<exclude_gpu>
<url>http://milkyway.cs.rpi.edu/milkyway/</url>
<device_num>2</device_num>
[<type>NVIDIA|ATI|intel_gpu</type>]
</exclude_gpu>
</options>
</cc_config>

Then as long as you don't sign up for any other gpu projects gpu's 0, 1 and 2, in the cc_config.xml above, will NOT crunch for MilkyWay in this copy of Boinc. Copy and paste the above file into each of the Boinc directories and you should be good to go. Remember to change the 2nd one to exclude gpu's 3, 4 and 5 instead of 0, 1 and 2 so that only 3 crunch using the 2nd copy of Boinc.
ID: 64040 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Tim B

Send message
Joined: 7 Jan 12
Posts: 6
Credit: 1,054,886,044
RAC: 88
1 billion credit badge10 year member badgeextraordinary contributions badge
Message 64073 - Posted: 8 Nov 2015, 13:38:25 UTC - in response to Message 64040.  

Just finished testing primegrind and got the same problem ,wu's stuck at 100%
It took about eight hours to happen.MW does it in about one hour.so it looks
like the problem is not just with MW. thank for the info Mikey .the part that you said about installing two copy's of boinc manager had me scratching my head. I tried an could only install one copy.is it possible to install two copy's ?
ID: 64073 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2797
Credit: 463,253,471
RAC: 7,000
300 million credit badge13 year member badgeextraordinary contributions badge
Message 64076 - Posted: 9 Nov 2015, 19:00:13 UTC - in response to Message 64073.  

Just finished testing primegrind and got the same problem ,wu's stuck at 100%
It took about eight hours to happen.MW does it in about one hour.so it looks
like the problem is not just with MW. thank for the info Mikey .the part that you said about installing two copy's of boinc manager had me scratching my head. I tried an could only install one copy.is it possible to install two copy's ?


Yes just be sure to choose separate directories from the default installation choices.
ID: 64076 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Trying to run six Tahiti gpu's at once

©2022 Astroinformatics Group