Welcome to MilkyWay@home

New AMD 480 GPU


Advanced search

Message boards : Number crunching : New AMD 480 GPU
Message board moderation

To post messages, you must log in.

AuthorMessage
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 64798 - Posted: 4 Jul 2016, 19:36:55 UTC

Are any numbers about DP performance available? I could not find any test that has any information about that.
I've seen @ Einstein, that the standard clocked card is ~ twice as fast as my HD7950 and consumes a bit less power, but this is a SP project.
ID: 64798 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 64811 - Posted: 5 Jul 2016, 15:18:52 UTC

Hey Werkstatt,

It seems these cards are currently having problems with power draw over the PCI-E rails. It is pulling up to 95W continuous draw through the 75W rated PCI-E port. AMD is supposed to be releasing a new driver version that will throttle the card and prevent it from overdrawing power in the near future. Until this update, I would recommend caution when running them flat out on scientific computing projects unless you have a high end motherboard capable of handling this kind of power draw.

source

Jake
ID: 64811 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilekhryl

Send message
Joined: 11 Feb 11
Posts: 57
Credit: 69,475,644
RAC: 0
50 million credit badge10 year member badge
Message 64815 - Posted: 5 Jul 2016, 18:10:53 UTC
Last modified: 5 Jul 2016, 18:29:55 UTC

someone on another forum claimed that SP/DP ratio of the rx480 chip is 1/16th, so with a listed SP of 5161 (wikipedia) it d be far worse than the top performers (7970/280x), which seem to remain the best cards for milkyway - in case the statement about 1/16th of SP performance turns out to be correct

update:

from the seti-germany forum:
Tja, keine Ahnung ob's bei Milkyway ein Problem gibt, aber ich bekomme keine AMD/ATI WUs...

Edit:
Irgendwie scheint Milkyway meine Graka als "R6xx" zu erkennen. Und die wäre nicht OpenCL kompatibel.

Da muss wohl noch nachgebessert werden, eh wir Milky auf der RX480 crunchen können...


'well... no idea if there s a problem at milkyway's side, but i cannot get any AMD/ATI workunits.
edit: it would appear as if milkyway recognized my card as "r6xx" - which is not compatible to OpenCL.
there is some work to be done before we can crunch milkyway with the rx480, it seems.'
ID: 64815 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 64817 - Posted: 6 Jul 2016, 12:33:01 UTC

I am trying to figure out why the card is being misidentified, but it might take a couple days.

Jake
ID: 64817 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 64818 - Posted: 6 Jul 2016, 14:36:21 UTC

Thanks for all the info, looks its worth to wait some time until the situation is cleared.

Alexander
ID: 64818 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileZanth
Avatar

Send message
Joined: 18 Feb 09
Posts: 158
Credit: 99,970,195
RAC: 150,812
50 million credit badge12 year member badge
Message 64920 - Posted: 21 Jul 2016, 4:35:34 UTC - in response to Message 64817.  

Luckily, I've not had any problems with my card, It's been running full boar on Moo Wrapper and no crashes. I would love to get it going here without having to do the app_config stuff. :D
ID: 64920 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65155 - Posted: 16 Sep 2016, 17:23:51 UTC

Are the problems solved?
Are there concrete numbers about the performance? Maybe I will replace my old HD4800 with a RX470 next time if this card gets work.
ID: 65155 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65160 - Posted: 17 Sep 2016, 8:08:02 UTC - in response to Message 65155.  

Are the problems solved?

I've seen in the news thread that there are still problems.
ID: 65160 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 65281 - Posted: 26 Sep 2016, 16:46:57 UTC

Hey Werkstatt,

I am hopeful that the updates I have done today and over the past week will allow MilkyWay@home to recognize and crunch on these new cards. I would pay attention to the news board over the next couple days and see if the issues have been resolved. I am hopeful they are.

Jake
ID: 65281 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65318 - Posted: 27 Sep 2016, 17:52:47 UTC

THX for the info.
A couple of minutes ago I rejoined my A10-7700 APU - it's working!
http://milkyway.cs.rpi.edu/milkyway/results.php?hostid=705141
2m39s for a wu, not bad for a APU!
ID: 65318 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 65320 - Posted: 27 Sep 2016, 18:08:04 UTC

Hey Werkstatt,

Interesting, I didn't think the APUs had double precision capability yet. Guess I was wrong. Glad to see you are crunching along now! Hopefully, I will be able to tune the server to keep up with the new work unit demand from everyone.

Jake
ID: 65320 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65323 - Posted: 27 Sep 2016, 18:25:34 UTC

I'm really happy that it works, did not work a year ago.
Running win10 64Bit version, gpu detection reorts:
27.09.2016 19:31:24 | | OpenCL: AMD/ATI GPU 0: AMD Radeon(TM) R7 Graphics (driver version 2117.9 (VM), device version
OpenCL 2.0 AMD-APP (2117.9), 2559MB, 2559MB available, 553 GFLOPS peak)

Maybe i can mix APU and GPU ...
ID: 65323 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 65324 - Posted: 27 Sep 2016, 18:29:44 UTC - in response to Message 65323.  

Werkstatt,

You might be able to, I imagine you would need a custom app_config file or something.

Jake
ID: 65324 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65329 - Posted: 27 Sep 2016, 20:18:08 UTC

I'm running now 2wu's according to a app_config.xlm file.
GPU load, as reported from GPU-Z, was and is ~100%, but the gaps between are gone.
Temp is typically near 30 degrees C with peaks up to 37 deg.
Will make my decision for a new RX card in the next days.
ID: 65329 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileMumak
Avatar

Send message
Joined: 8 Apr 13
Posts: 89
Credit: 517,085,245
RAC: 0
500 million credit badge8 year member badgeextraordinary contributions badge
Message 65371 - Posted: 3 Oct 2016, 9:26:22 UTC
Last modified: 3 Oct 2016, 9:33:13 UTC

RX 480 works for me.
Some times for comparison:
HD7950: ~13-14 s
Fury X: ~15-17 s
RX 480: ~20-21 s


Not bad..
ID: 65371 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65372 - Posted: 3 Oct 2016, 20:44:05 UTC - in response to Message 65371.  

THX for the info.
ID: 65372 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : New AMD 480 GPU

©2022 Astroinformatics Group