Welcome to MilkyWay@home

Server error: feeder not running


Advanced search

Message boards : Number crunching : Server error: feeder not running
Message board moderation

To post messages, you must log in.

AuthorMessage
brewsmithy

Send message
Joined: 31 Aug 10
Posts: 8
Credit: 2,647,655
RAC: 0
2 million credit badge11 year member badge
Message 64833 - Posted: 7 Jul 2016, 11:53:24 UTC

Good morning crunchers!

Yesterday my finished jobs stopped uploading with the error Server error: feeder not running. A quick look at the server status page verifies this problem.

http://milkyway.cs.rpi.edu/milkyway/server_status.php

Who do we contact to try to get this fixed as it effects all of us boincing for Milkyway@home?

Cheers

B
ID: 64833 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 64839 - Posted: 7 Jul 2016, 14:04:57 UTC

Hey Brewsmithy,

You usually contact me but yesterday was a particularly busy day around the office. I made some changes and didn't realize the feeder died. One of the scientists in our research group (not one working on MW@home) defended his PhD thesis yesterday so we were all quite busy.

Jake
ID: 64839 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
brewsmithy

Send message
Joined: 31 Aug 10
Posts: 8
Credit: 2,647,655
RAC: 0
2 million credit badge11 year member badge
Message 64841 - Posted: 8 Jul 2016, 0:41:05 UTC - in response to Message 64839.  

Hey Brewsmithy,

You usually contact me but yesterday was a particularly busy day around the office. I made some changes and didn't realize the feeder died. One of the scientists in our research group (not one working on MW@home) defended his PhD thesis yesterday so we were all quite busy.

Jake



Jake,

Thank you, and everyone else who makes Milkyway@home possible, thank you for your hard work.

Cheers!!
B
ID: 64841 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileKeith Myers
Avatar

Send message
Joined: 24 Jan 11
Posts: 500
Credit: 421,197,250
RAC: 918,668
300 million credit badge11 year member badgeextraordinary contributions badge
Message 64845 - Posted: 8 Jul 2016, 14:36:39 UTC - in response to Message 64841.  

Looks like we have a feeder server not running again. SSP shows all servers up but I am receiving the 7/8/2016 7:33:26 AM | Milkyway@Home | Server error: feeder not running
message. Could one of the project scientists give it a kick again, Please??
ID: 64845 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 64846 - Posted: 8 Jul 2016, 14:47:18 UTC

I am playing with server settings so I am restarting the BOINC daemons a bunch. It's all good no worries.

Jake
ID: 64846 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCliff
Avatar

Send message
Joined: 28 Nov 14
Posts: 51
Credit: 86,696,721
RAC: 0
50 million credit badge7 year member badge
Message 65525 - Posted: 24 Oct 2016, 11:24:48 UTC - in response to Message 64846.  
Last modified: 24 Oct 2016, 11:25:12 UTC

Hi Jake,
I am playing with server settings so I am restarting the BOINC daemons a bunch. It's all good no worries.

Jake

Best of luck with that, hope you can find the problem ok. I noticed a load of MySQL errors whenever there's an upload problem, and the web site is messed up and putting out 3 or 4 MySQL errors about lines xx etc
Regards,
Cliff.
--
Been there Done That, still no Damn T-Shirt
ID: 65525 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCliff
Avatar

Send message
Joined: 28 Nov 14
Posts: 51
Credit: 86,696,721
RAC: 0
50 million credit badge7 year member badge
Message 65534 - Posted: 25 Oct 2016, 10:58:23 UTC - in response to Message 64846.  

Hi Jake,
spotted the following when the server was down:-
Warning: mysqli::__construct(): (08004/1040): Too many connections in /boinc/milkyway/html/inc/db_conn.inc on line 42
Warning: mysqli::query(): Couldn't fetch mysqli in /boinc/milkyway/html/inc/db_conn.inc on line 64 Database Error
Warning: mysqli::query(): Couldn't fetch mysqli in /boinc/milkyway/html/inc/db_conn.inc on line 64 Database Error
Warning: mysqli::__construct(): (08004/1040): Too many connections in /boinc/milkyway/html/inc/db.inc on line 31

Dunno if its any help..
Regards,
Cliff.
--
Been there Done That, still no Damn T-Shirt
ID: 65534 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCliff
Avatar

Send message
Joined: 28 Nov 14
Posts: 51
Credit: 86,696,721
RAC: 0
50 million credit badge7 year member badge
Message 65600 - Posted: 6 Nov 2016, 15:03:42 UTC
Last modified: 6 Nov 2016, 15:03:57 UTC

Hi,
Well looks like the problem persists almost non stop.
Yesterday I got 9WU..
I've gotten into the habit of trying to see if the site is actually UP, then trying to get WU..
However its pretty much 'cant open database' no work available' or an endless 'hang' before a 'cant contact' message.
And there seem to be quite a lot of WU waiting validation.

Does anyone have any idea when the current problems will be overcome?
Regards,
Cliff.
--
Been there Done That, still no Damn T-Shirt
ID: 65600 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2583
Credit: 462,764,320
RAC: 8
300 million credit badge12 year member badgeextraordinary contributions badge
Message 65603 - Posted: 6 Nov 2016, 16:31:51 UTC - in response to Message 65600.  

Hi,
Well looks like the problem persists almost non stop.
Yesterday I got 9WU..
I've gotten into the habit of trying to see if the site is actually UP, then trying to get WU..
However its pretty much 'cant open database' no work available' or an endless 'hang' before a 'cant contact' message.
And there seem to be quite a lot of WU waiting validation.

Does anyone have any idea when the current problems will be overcome?


Guessing after the weekend?
ID: 65603 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 139,344,691
RAC: 93
100 million credit badge13 year member badge
Message 65604 - Posted: 6 Nov 2016, 20:22:40 UTC

The problems have shifted a little bit.
At the moment the work generation is the bottleneck.
ID: 65604 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 0
50 million credit badge8 year member badgeextraordinary contributions badge
Message 65610 - Posted: 7 Nov 2016, 18:12:40 UTC

Hey Everyone,

I am working on resolving these issues. I spent much of the weekend working on implementing work unit bundling. Hopefully I will have it built and tested by the end of the week. This will require a new client release as well as an update to the server. It is a lot of work, but I think it will ultimately be worth it. Thank you all for your patience.

Jake
ID: 65610 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCliff
Avatar

Send message
Joined: 28 Nov 14
Posts: 51
Credit: 86,696,721
RAC: 0
50 million credit badge7 year member badge
Message 65613 - Posted: 7 Nov 2016, 20:56:17 UTC - in response to Message 65603.  



Does anyone have any idea when the current problems will be overcome?


Guessing after the weekend?[/quote]
erm.. Which weekend?:-) One after xmas?

Cheers,
Cliff
ID: 65613 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Server error: feeder not running

©2022 Astroinformatics Group