GPU Issues Mega Thread
log in

Advanced search

Message boards : News : GPU Issues Mega Thread

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 . . . 8 · Next
Author Message
Profile Keith Myers
Avatar
Send message
Joined: 24 Jan 11
Posts: 113
Credit: 89,453,408
RAC: 23,700

Message 65140 - Posted: 14 Sep 2016, 4:45:49 UTC - in response to Message 65139.

As far as I know, NONE of the Microsoft supplied video drivers support OpenCL. You need to install only the official graphic card vendor supplied drivers. Go to the AMD driver download site and grab the latest drivers directly from AMD. Also to prevent this from happening again with the Windows 10 automatic updates, set the automatic update to NOT update drivers.
____________

Sebastian*
Send message
Joined: 8 Apr 09
Posts: 64
Credit: 4,723,738,449
RAC: 1,037,529

Message 65141 - Posted: 14 Sep 2016, 6:29:41 UTC

Hi Joseph.

I have to agree to Keith Myers, but there is a problem with your HD 4xxx series cards and Windows 10. There are, and will never be, drivers from AMD for your HD 4xxx series cards for Windows 10. Check yourself on the AMD driver page.

I brought online a computer with 3 HD 4850s. I run Windows 7 with the latest driver for the HD 4xxx series cards. (Catalyst 13.9) It seems to run quiet well from what i can see.

Windows 8.1 is the lastest OS AMD supports drivers for. If you considering changing your OS.

Or you could search for just the OpenCL SDK from AMD. But i am not sure if it still exists (it is integrated into the driver now), or if it will give the Microsoft drivers OpenCL support. I would give it a try before you remove your OS.

Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 423
Credit: 7,486,492
RAC: 0

Message 65149 - Posted: 15 Sep 2016, 18:09:14 UTC

Hey Everyone,

Just want to give everyone a status update on the new separation version I am working on. I currently have it compiled for every platform except for Mac OSX. Our build machine we use for Mac decided it wanted to die so I am working on getting access to a new one. Until then, I might release without a Mac version on Monday, assuming the applications work during testing. If we are planning still planning to release on Monday, I will post again tomorrow to confirm.

Jake

zioriga
Send message
Joined: 30 Aug 07
Posts: 13
Credit: 13,782,710
RAC: 3,951

Message 65154 - Posted: 16 Sep 2016, 13:37:42 UTC

I found the same problem with windows 10 anniversary
and after the reinstallation of the nvidia driver, everything runs correctly on my gtx 1080

Sebastian*
Send message
Joined: 8 Apr 09
Posts: 64
Credit: 4,723,738,449
RAC: 1,037,529

Message 65156 - Posted: 16 Sep 2016, 22:37:56 UTC

Thank you for the information Jake.

I don't know how far you are with your bughunting on the gpu detection stuff. I just tried to connect a R9 390X to Milkyway and got:

9/16/2016 11:54:20 PM | Milkyway@Home | Message from server: ATI GPU R600 (R38xx) does not support OpenCL

However the GPU was detected correctly by Boinc, exept for the shown Gigaflops. They were around 3000 instead of nearly 6000. But i don't give too much about it, since the R9 280X GPUs are detected with the double Gigaflops they really have.

zioriga, you said now your GTX 1080 is working correctly, but i haven't seen any valid workunits on your account. You have some units running, but not uploaded yet. Would like to see, if it runs correctly.

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65157 - Posted: 16 Sep 2016, 23:45:55 UTC

I never get any Milkyway GPU tasks, BOINC never asks for them. My Milkyway account is set to take GPU tasks. My main computer has a decent Radeon R9 290, which happily does POEM, SETI, and Einstein tasks, but looking in the notes, BOINC has never requested Milkyway tasks for it. Any idea why? It always just says "requesting work for CPU".

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65158 - Posted: 16 Sep 2016, 23:57:54 UTC - in response to Message 65157.

Update: I just suspended the other 4 projects, and then BOINC did request GPU work from Milkyway (although there was none available at the time). Now Milkyway is way behind on points as it only gets my CPU, and I've given it much more weight than the others, but it will not ask for GPU work while the other projects are enabled. Any idea what's going on?

Sebastian*
Send message
Joined: 8 Apr 09
Posts: 64
Credit: 4,723,738,449
RAC: 1,037,529

Message 65159 - Posted: 17 Sep 2016, 4:48:02 UTC

Milkyway has a problem with GPU detection for newer cards than the R9 280X (HD 7970) You should get the same message i did, because Milkyway thinks you have another GPU.

The good news is, that Jake is working on a solution to that problem.

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65162 - Posted: 17 Sep 2016, 12:33:52 UTC - in response to Message 65159.
Last modified: 17 Sep 2016, 12:42:18 UTC

It seems to be a BOINC problem, which I accidentally fixed. Suspending the other four projects forced it to try to get GPU work from Milkyway. Then resuming them seems to have left it still asking.

It keeps saying "Scheduler request completed: got 0 new tasks" which I assume just means there isn't any GPU work available just now. I get that sometimes with SETI - sometimes it gives me work and sometimes it doesn't.

I don't get any message like yours. I do get complaints from another project on an old Nvidea which has drivers which are too old (newer drivers don't support that card), but not for Milkyway on my Radeon.

rcthardcore
Send message
Joined: 30 Dec 08
Posts: 25
Credit: 1,763,057
RAC: 188

Message 65164 - Posted: 17 Sep 2016, 23:18:16 UTC

Just got a bunch of N-body tasks that require 8 CPUs. WTF is that? 8 CPUs?
Aborted them. Sent them back. Changed preferences.

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65165 - Posted: 17 Sep 2016, 23:22:59 UTC - in response to Message 65164.

I have PCs running 4 CPU tasks. If I had an 8 thread CPU (eg i7) I would allow those. What is the problem with it?

rcthardcore
Send message
Joined: 30 Dec 08
Posts: 25
Credit: 1,763,057
RAC: 188

Message 65166 - Posted: 17 Sep 2016, 23:48:03 UTC

I have an I7. Don't know what happened. Yesterday everything was working fine. Today, it is all screwed up. Switched back to GPU. Must have been a server glitch.

Vortac
Send message
Joined: 22 Apr 09
Posts: 77
Credit: 1,051,155,742
RAC: 1,891,458

Message 65167 - Posted: 18 Sep 2016, 9:36:26 UTC - in response to Message 65164.

Just got a bunch of N-body tasks that require 8 CPUs. WTF is that? 8 CPUs?
Aborted them. Sent them back. Changed preferences.

Your i7 CPU probably has 4 physical cores or 8 logical cores. It's normal to receive 8-threaded N-body tasks in that case.

Profile Tex1954
Send message
Joined: 22 Apr 11
Posts: 59
Credit: 597,492,842
RAC: 261,424

Message 65168 - Posted: 18 Sep 2016, 12:31:49 UTC - in response to Message 65167.
Last modified: 18 Sep 2016, 12:32:48 UTC

Well, my GPU issue is I can't keep them busy anymore...

The server seems to have slowed down. I can't cache enough WU's to keep busy!

I run 2 WU per card and have two 7970's and one R9 280X doing Milkyway...

It always pauses 1 minute after each update and buy the time 1 minute expires, the WU's are already all done OR the setup requests more work and gets none/little several times in a row!!!

Win-F13

96220 Milkyway@Home 9/15/2016 3:25:03 AM Reporting 16 completed tasks
96221 Milkyway@Home 9/15/2016 3:25:03 AM Requesting new tasks for AMD/ATI GPU
96222 Milkyway@Home 9/15/2016 3:25:04 AM Scheduler request completed: got 0 new tasks
96223 Milkyway@Home 9/15/2016 3:25:09 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_3_1471352126_34821001_1 finished

96322 Milkyway@Home 9/15/2016 3:29:30 AM Requesting new tasks for AMD/ATI GPU
96323 Milkyway@Home 9/15/2016 3:29:32 AM Scheduler request completed: got 7 new tasks
96324 Milkyway@Home 9/15/2016 3:29:34 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322413_0
96325 Milkyway@Home 9/15/2016 3:29:34 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322405_0
96326 Milkyway@Home 9/15/2016 3:29:34 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322406_0
96327 Milkyway@Home 9/15/2016 3:29:34 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322410_0
96328 Milkyway@Home 9/15/2016 3:29:52 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322413_0 finished
96329 Milkyway@Home 9/15/2016 3:29:52 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322405_0 finished
96330 Milkyway@Home 9/15/2016 3:29:52 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322406_0 finished
96331 Milkyway@Home 9/15/2016 3:29:52 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322410_0 finished
96332 Milkyway@Home 9/15/2016 3:29:52 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_2_1471352126_36322419_0
96333 Milkyway@Home 9/15/2016 3:29:52 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322404_0
96334 Milkyway@Home 9/15/2016 3:29:52 AM Starting task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322407_0
96335 Milkyway@Home 9/15/2016 3:30:04 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322407_0 finished
96336 Milkyway@Home 9/15/2016 3:30:10 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_2_1471352126_36322419_0 finished
96337 Milkyway@Home 9/15/2016 3:30:10 AM Computation for task de_modfit_fast_19_3s_136_ModfitConstraints1_1_1471352126_36322404_0 finished
96338 Milkyway@Home 9/15/2016 3:30:38 AM Sending scheduler request: To report completed tasks.
96339 Milkyway@Home 9/15/2016 3:30:38 AM Reporting 7 completed tasks
96340 Milkyway@Home 9/15/2016 3:30:38 AM Requesting new tasks for AMD/ATI GPU
96341 Milkyway@Home 9/15/2016 3:30:40 AM Scheduler request completed: got 2 new tasks
96342 Milkyway@Home 9/15/2016 3:30:42 AM Starting task de_modfit_fast_15_3s_136_fixedangles3_3_1471352126_36322870_0
96343 Milkyway@Home 9/15/2016 3:30:42 AM Starting task de_modfit_fast_15_3s_136_fixedangles3_3_1471352126_36322868_0

Win-F21

104581 Milkyway@Home 9/15/2016 3:34:05 AM Reporting 10 completed tasks
104582 Milkyway@Home 9/15/2016 3:34:05 AM Requesting new tasks for AMD/ATI GPU
104583 Milkyway@Home 9/15/2016 3:34:06 AM Scheduler request completed: got 3 new tasks


This has been going on for days now...

HELP!

8-)

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65169 - Posted: 18 Sep 2016, 15:09:45 UTC - in response to Message 65168.

I can't get any at all. How do you get WUs for GPU on Milkyway? I'm running 5 projects, with no local cache, and every time it needs a new WU, Milkyway has none available, so it gets one of the others.

I just tried sticking a 3+10 day cache on it, but all that happened is it rapidly downloaded loads of Einstein and SETI tasks.

I have the weight for Milkyway ramped right up so it should take those in preference, but I never get any!

sean
Send message
Joined: 19 Sep 16
Posts: 4
Credit: 721,303
RAC: 0

Message 65170 - Posted: 19 Sep 2016, 8:51:56 UTC

I have 2 r9 290x cards that are not being picked up by Milkyway. However they do pick up when I run SETI which leads me to believe it is an issue with how Milkyway detects them any ideas on how to fix this so I can run the GPUs to help build the milky way ?

Sebastian*
Send message
Joined: 8 Apr 09
Posts: 64
Credit: 4,723,738,449
RAC: 1,037,529

Message 65171 - Posted: 19 Sep 2016, 9:43:40 UTC

Jake Weiss is working on the GPU detection issues. Currently no newer cards than the R9 280X or 7970 are detected by Milkyway@home. Nvidia cards seem to work well, as older AMD/ATI cards do.

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65172 - Posted: 19 Sep 2016, 10:24:59 UTC - in response to Message 65171.
Last modified: 19 Sep 2016, 10:27:26 UTC

You all keep saying they are "not detected" - how do you know the difference between not detected and no work available? I get no error message at all, just "got 0 new tasks", exactly the same as if there was no work available.

I also have a very old Nvidia (Geforce 9500 GS) running, but that also says "got 0 new tasks".

colonywest
Send message
Joined: 23 Jun 15
Posts: 2
Credit: 15,100,538
RAC: 4,986

Message 65177 - Posted: 19 Sep 2016, 21:19:33 UTC

None of the GPU tasks are running for me. They all abort with "computation error" within a few seconds.

System:

CPU: AMD FX-8320E (not overclocked) with 16GB RAM
RAM: 16GB
OS: Fedora 24 64-bit (latest updates)
BOINC client: 7.6.22
GPUs: 2xGTX 680, 2xGTX 660 - no SLI on anything
NVIDIA driver: 367.44

This setup has worked previously with an older kernel and older NVIDIA driver.

Peter Hucker
Send message
Joined: 5 Jul 11
Posts: 103
Credit: 15,265,491
RAC: 1,245

Message 65178 - Posted: 19 Sep 2016, 21:40:46 UTC

Eventually got the notice "ATI GPU R600 (R38xx) does not support OpenCL", so I assume I just wait for the fix for my R9 290.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 . . . 8 · Next
Post to thread

Message boards : News : GPU Issues Mega Thread


Main page · Your account · Message boards


Copyright © 2017 AstroInformatics Group