Welcome to MilkyWay@home

OpenCL errors with 1.40 app on r9-280x


Advanced search

Message boards : Number crunching : OpenCL errors with 1.40 app on r9-280x
Message board moderation

To post messages, you must log in.

AuthorMessage
ProfileMaurice Goulois
Avatar

Send message
Joined: 4 Mar 09
Posts: 9
Credit: 37,650,222
RAC: 47,211
30 million credit badge12 year member badge
Message 65897 - Posted: 18 Nov 2016, 3:43:26 UTC
Last modified: 18 Nov 2016, 3:46:04 UTC

Hello,

since a few days, this machine (ubuntu 15.04/boinc 7.2.42/fglrx 14.41 r9-280x) with application 1.40, has a majority of opencl compilation errors as in this workunit :

"/tmp/OCL26050T5.cl", line 227: error: identifier "inf" is undefined
          tmp = mad((real) Q_INV_SQR, z * z, tmp);   /* (q_invsqr * z^2) + (x^2 + y^2) */
                           ^

1 error detected in the compilation of "/tmp/OCL26050T5.cl".

Frontend phase failed compilation.


This setup goes well on seti, primegrid, collatz...

Since the recent server upgrade, I've removed any xml config file for milkyway, and getting application downloaded automatically.


Any clue?
ID: 65897 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
bluestang

Send message
Joined: 13 Oct 16
Posts: 106
Credit: 1,051,731,997
RAC: 21
1 billion credit badge5 year member badge
Message 65904 - Posted: 18 Nov 2016, 14:48:23 UTC - in response to Message 65897.  

Abort all GPU WUs that are not version 1.43. Bundling of WUs just was done and there were issues until Jake fixed it in v1.43 for the GPUs I believe.
ID: 65904 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 2 Oct 16
Posts: 155
Credit: 588,837,592
RAC: 1,394,291
500 million credit badge5 year member badge
Message 65907 - Posted: 18 Nov 2016, 18:02:30 UTC

v1.4 is the correct version in Linux. It has works fine for me with a 280x on Mint 17.3. I would have to check the driver versions. I went through several trying to get it to initially work.
ID: 65907 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : OpenCL errors with 1.40 app on r9-280x

©2022 Astroinformatics Group