Welcome to MilkyWay@home

GPU units hanging


Advanced search

Message boards : Number crunching : GPU units hanging
Message board moderation

To post messages, you must log in.

Previous · 1 · 2

AuthorMessage
ProfileKevint
Avatar

Send message
Joined: 22 Nov 07
Posts: 285
Credit: 1,076,786,368
RAC: 0
1 billion credit badge14 year member badge
Message 17977 - Posted: 8 Apr 2009, 20:59:58 UTC



How do you have your <ncpus>xx<\ncpus> in cc_config.xml set?

I have seen this problem on several of my boxes, sometimes I have had to just run ATI MW exclusively. For no apparent reason it does like to play well with other projects on some boxes. I have my setting ncpus=cpucores+1 sometimes helps.

On other boxes, I can run 1 other WU.. . I choose CPDN because they have long WU's.

I believe this is happening because BOINC does not recognize ATI/CAL and has real trouble with figuring out what app to run on what core.

I know this is not a lot of help, but it works for me.




.
ID: 17977 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileNeal Chantrill
Avatar

Send message
Joined: 17 Jan 09
Posts: 98
Credit: 72,182,367
RAC: 0
50 million credit badge13 year member badge
Message 17978 - Posted: 8 Apr 2009, 21:01:44 UTC
Last modified: 8 Apr 2009, 21:22:06 UTC

Thanks for the advice, will give it a go.

This is what mine looks like:-

<app_info>
<app>
<name>milkyway</name>
</app>
<file_info>
<name>astronomy_0.19_ATI_x64e.exe</name>
<executable/>
</file_info>
<file_info>
<name>brook.dll</name>
<executable/>
</file_info>
<app_version>
<app_name>milkyway</app_name>
<version_num>19</version_num>
<flops>1.0e11</flops>
<avg_ncpus>0.1</avg_ncpus>
<max_ncpus>1</max_ncpus>
<cmdline>n3 w1.01</cmdline>
<file_ref>
<file_name>astronomy_0.19_ATI_x64e.exe</file_name>
<main_program/>
</file_ref>
<file_ref>
<file_name>brook.dll</file_name>
</file_ref>
</app_version>
</app_info>

Not pretending to actually know what I'm doing when I'm editting it.
ID: 17978 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLabbie
Avatar

Send message
Joined: 29 Aug 07
Posts: 327
Credit: 116,463,193
RAC: 0
100 million credit badge14 year member badge
Message 17995 - Posted: 8 Apr 2009, 22:24:00 UTC

I had been having this same problem off and on. Last night I finally got fed up with it and resest the project, recopied the 0.19e files to the MW project folder, and did not make any changes to the app_info.xml file (I had previously). I have not had any problems since. It's running three at a time (which is the default), and is completing 3 WUs in a little over a minute (wall time) on a 4850.

Calm Chaos Forum...Join Calm Chaos Now
ID: 17995 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileKevint
Avatar

Send message
Joined: 22 Nov 07
Posts: 285
Credit: 1,076,786,368
RAC: 0
1 billion credit badge14 year member badge
Message 18003 - Posted: 8 Apr 2009, 22:35:48 UTC - in response to Message 17978.  

Thanks for the advice, will give it a go.

This is what mine looks like:-

<app_info>


that is your app info file, found in the project folder.

The cc_config.xml file is a different file. It is found in the same folder as your client_state.xml folder.

<cc_config>
<options>
<ncpus>5</ncpus>
</options>
</cc_config>

.
ID: 18003 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileNeal Chantrill
Avatar

Send message
Joined: 17 Jan 09
Posts: 98
Credit: 72,182,367
RAC: 0
50 million credit badge13 year member badge
Message 18008 - Posted: 8 Apr 2009, 22:47:00 UTC
Last modified: 8 Apr 2009, 23:29:49 UTC

Ooh ok. Having a look.

Couldn't even find that section using the search tool. I opened it up using notepad and nothing even resembling it. Scratching my head here.
ID: 18008 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge14 year member badge
Message 18024 - Posted: 9 Apr 2009, 2:22:10 UTC

cc_config.xml needs to be created using notepad and saving it with the .xml extension.
ID: 18024 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileNeal Chantrill
Avatar

Send message
Joined: 17 Jan 09
Posts: 98
Credit: 72,182,367
RAC: 0
50 million credit badge13 year member badge
Message 18055 - Posted: 9 Apr 2009, 16:57:58 UTC - in response to Message 18024.  

cc_config.xml needs to be created using notepad and saving it with the .xml extension.



Can I place this anywhere within the file? Sorry for what must seem silly questions.
ID: 18055 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge14 year member badge
Message 18067 - Posted: 9 Apr 2009, 20:43:40 UTC

Yes and remember to save it to the same directory as where client_state.xml is located.

This link may help.
ID: 18067 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileNeal Chantrill
Avatar

Send message
Joined: 17 Jan 09
Posts: 98
Credit: 72,182,367
RAC: 0
50 million credit badge13 year member badge
Message 18070 - Posted: 9 Apr 2009, 20:58:39 UTC

Thanks for that. I have tried that and will see how I get on.

:o)
ID: 18070 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileKevint
Avatar

Send message
Joined: 22 Nov 07
Posts: 285
Credit: 1,076,786,368
RAC: 0
1 billion credit badge14 year member badge
Message 18076 - Posted: 9 Apr 2009, 21:19:30 UTC - in response to Message 18008.  
Last modified: 9 Apr 2009, 21:21:51 UTC

Ooh ok. Having a look.

Couldn't even find that section using the search tool. I opened it up using notepad and nothing even resembling it. Scratching my head here.




This is the complete contents of my cc_config.xml for my quads with GPU cards.
On my duo core boxes ncpus = 3, Single core boxes ncpus=2

<cc_config>
<options>
<ncpus>5</ncpus>
</options>
</cc_config>




Remember you ether have to restart BOINC or in BOINC manager -

Advanced
Read config file


You can make changes to the cc_config file on the fly by re-reading the config file in BOINC manager.
.
ID: 18076 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
jedirock
Avatar

Send message
Joined: 8 Nov 08
Posts: 178
Credit: 6,140,854
RAC: 0
5 million credit badge13 year member badge
Message 18131 - Posted: 10 Apr 2009, 2:24:27 UTC - in response to Message 18076.  

Remember you ether have to restart BOINC or in BOINC manager -

Advanced
Read config file


I've always had to do:

Advanced->Read config file
Advanced->Read local prefs file

to get changes to the cc_config to apply, but it does work.
ID: 18131 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileNeal Chantrill
Avatar

Send message
Joined: 17 Jan 09
Posts: 98
Credit: 72,182,367
RAC: 0
50 million credit badge13 year member badge
Message 18320 - Posted: 11 Apr 2009, 17:39:50 UTC

Quick update. I unstalled the new BOINC 6.6.20 client and not locked up since, how strange. Anyway, a big thank you to everyone that helped in our hour of need.

I think we can consider this thread closed.

{:o)
ID: 18320 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2

Message boards : Number crunching : GPU units hanging

©2022 Astroinformatics Group