Welcome to MilkyWay@home

Catalyst 9.4 question


Advanced search

Message boards : Number crunching : Catalyst 9.4 question
Message board moderation

To post messages, you must log in.

AuthorMessage
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 18801 - Posted: 15 Apr 2009, 12:56:16 UTC
Last modified: 15 Apr 2009, 12:57:13 UTC

Just a short question:
Has anybody tried the Catalyst 9.4 driver (with copied and renamed dlls)? If yes, which GPU, which OS and was it running stable?

There appear to be some problems at least with the Radeon HD4890. The graphics driver just crashes and get restarted after loading the GPU for some seconds to some minutes (quite random, probability rises with the load). Looks almost like the behaviour of the Cat9.3 before the hotfix that corrected this problem for XP32 und XP64 (Vista had no problem with 9.3).
I've got reports of three HD4890 cards that were tried in five different systems, but it runs neither under XP32 nor XP64. And this is not a general stability problem. Furmark or other stresstests are running fine.

I just want to know if that problem also applies to the other 4800 or 3800 series cards and if it is isolated to WinXP (like the CAL bug of Cat9.3 before the hotfix).
So if you've tried the Cat9.4, don't hesitate to tell about your results ;)
ID: 18801 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
STE\/E

Send message
Joined: 29 Aug 07
Posts: 486
Credit: 573,906,610
RAC: 0
500 million credit badge14 year member badge
Message 18805 - Posted: 15 Apr 2009, 13:51:49 UTC

When i tried the Cat 9.4 it installed fine with the 4890 Cards I had but when I pulled them & put a 4870 back in it's place the Cat 9.4 Driver wouldn't work & I had to revert back to the 8.12 Driver to run the WU's again.

The 9.4 Installer would say I didn't have a Compatible Video Card when the 4870 was Installed ...
ID: 18805 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 18810 - Posted: 15 Apr 2009, 14:22:30 UTC - in response to Message 18805.  

When i tried the Cat 9.4 it installed fine with the 4890 Cards I had but when I pulled them & put a 4870 back in it's place the Cat 9.4 Driver wouldn't work & I had to revert back to the 8.12 Driver to run the WU's again.

But If I understood you right, you had also problems with the stability of the Cat9.4 driver with MW and a HD4890 on WinXP64, isn't it?
ID: 18810 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
STE\/E

Send message
Joined: 29 Aug 07
Posts: 486
Credit: 573,906,610
RAC: 0
500 million credit badge14 year member badge
Message 18814 - Posted: 15 Apr 2009, 14:55:26 UTC - in response to Message 18810.  
Last modified: 15 Apr 2009, 14:57:20 UTC

When i tried the Cat 9.4 it installed fine with the 4890 Cards I had but when I pulled them & put a 4870 back in it's place the Cat 9.4 Driver wouldn't work & I had to revert back to the 8.12 Driver to run the WU's again.

But If I understood you right, you had also problems with the stability of the Cat9.4 driver with MW and a HD4890 on WinXP64, isn't it?


Yes, the 4890 wouldn't run with any other Driver than the 8.60 from Diamond or the 9.4 from ATI & then it was only for 4-5 Wu's & then I'd get the Video Driver Re-set issue.

I was just pointing out that the Cat 9.4 Driver wouldn't work with the 4870 when I put it back in the Box in place of the 4890 & had to install the 8.12 Drivers to get the 4870 to work again.
ID: 18814 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Brickhead
Avatar

Send message
Joined: 20 Mar 08
Posts: 108
Credit: 2,562,515,681
RAC: 0
2 billion credit badge13 year member badgeextraordinary contributions badge
Message 18818 - Posted: 15 Apr 2009, 15:58:31 UTC

4870X2, 4870/1G, 4850/1G. All with Windows XP x64, Cat 9.4 and MW 0.19e.

I've noticed no difference from previous Cat versions at their best, apart from a few cases of all MW WUs freezing until BOINC restart or even reboot. But for all I know, that might not be driver-related.
ID: 18818 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 18819 - Posted: 15 Apr 2009, 16:02:40 UTC - in response to Message 18818.  

4870X2, 4870/1G, 4850/1G. All with Windows XP x64, Cat 9.4 and MW 0.19e.

I've noticed no difference from previous Cat versions at their best, apart from a few cases of all MW WUs freezing until BOINC restart or even reboot. But for all I know, that might not be driver-related.

That would mean only the 4890 cards are affected :(

Guess I have to ask AMD about that.
ID: 18819 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileSimplex0
Avatar

Send message
Joined: 11 Nov 07
Posts: 232
Credit: 178,229,009
RAC: 0
100 million credit badge14 year member badge
Message 18820 - Posted: 15 Apr 2009, 16:05:18 UTC
Last modified: 15 Apr 2009, 16:06:38 UTC

I am using Catalyst 9.4 now but when I overclock the CPU I am forced
to underclock the Radeon 4870 card to make it run stable, if not it will reboot
after running a few Milkyway GPU work units.

I am running Milkyway@home, Seti@home, Climateprediction.net, World Community Grid, lhcathome, Einstein@Home, Cosmology@Home and boincsimap.

At the moment I underclock the 4870 card 20% and it looks good so fare
but I have only tested 6 GPU work units.

This is my computer currently running OC to 3600GHz, FSB=1600

Motherboard = ASUS P5K-E Wifi-AP
Memory = 2 X Corsair CM2X2048-6400

Domain name comodore64
Local Standard Time UTC +2 hours
Name comodore64
Created 11 Aug 2008 15:26:46 UTC
total credit 64,648
Average credit 371.36
Cross project credit
CPU type GenuineIntel
Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz [Intel64 Family 6 Model 15 Stepping 11]
Number of processors 4
Operating System Microsoft Windows Vista
Home Premium x64 Editon, Service Pack 1, (06.00.6001.00)
Memory 4094.18 MB
Cache 244.14 KB
Swap space 8361.64 MB
Total disk space 10.74 GB
Free Disk Space 8.59 GB
Measured floating point speed 3417.52 million ops/sec
Measured integer speed 10468.26 million ops/sec
Average upload rate 37.25 KB/sec
Average download rate 205.56 KB/sec
Average turnaround time 2.27 days
Maximum daily WU quota per CPU 100/day
Tasks 12
Number of times client has contacted server 1109
Last time contacted server 15 Apr 2009 14:34:03 UTC
% of time BOINC client is running 65.3508 %
While BOINC running, % of time host has an Internet connection 97.9341 %
While BOINC running, % of time work is allowed 99.8934 %
Average CPU efficiency 0.971469
Task duration correction factor 0.08292
ID: 18820 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Brickhead
Avatar

Send message
Joined: 20 Mar 08
Posts: 108
Credit: 2,562,515,681
RAC: 0
2 billion credit badge13 year member badgeextraordinary contributions badge
Message 18822 - Posted: 15 Apr 2009, 16:09:19 UTC - in response to Message 18819.  

That would mean only the 4890 cards are affected :(

I chose my wording carefully: "I haven't noticed". I'm not always watching, and a VPU recovery might have gone unnoticed. But nothing of the severity PB reports, no.
ID: 18822 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Brickhead
Avatar

Send message
Joined: 20 Mar 08
Posts: 108
Credit: 2,562,515,681
RAC: 0
2 billion credit badge13 year member badgeextraordinary contributions badge
Message 18832 - Posted: 15 Apr 2009, 18:03:56 UTC

Er... I think you can add 4850/1G to the list of cards with Cat 9.4 problems.

I noticed another case of frozen MW WUs, and decided to investigate. Disabled the "problem camouflage" called VPU recovery and restarted BOINC: OS freeze, no less! Hard reboot, same story within few minutes.

Replaced 9.4 with 8.12 and all is well (also on the 4870 cards still using 9.4).
ID: 18832 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
MontagsMeeting

Send message
Joined: 12 Mar 09
Posts: 61
Credit: 9,214,340
RAC: 0
5 million credit badge12 year member badge
Message 18836 - Posted: 15 Apr 2009, 18:53:17 UTC
Last modified: 15 Apr 2009, 19:12:07 UTC

I've two 4850/512 with 9.4 under Vista 64 on two i7 920 systems running without any problems as with 9.3, 9.2 and so on
edit: they're running 0.19e with 2 tasks on each gpu, the cpus run seti

the only thing i can't do is to use any remote desktop software, because both systems crash or not after using ms rdp or vnc or teamviewer
ID: 18836 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
UBT - Ben

Send message
Joined: 8 Mar 08
Posts: 17
Credit: 4,411,459
RAC: 0
3 million credit badge13 year member badge
Message 18839 - Posted: 15 Apr 2009, 19:11:11 UTC - in response to Message 18836.  

It's running fine here on the 9.4 drivers (one i had made copies of the .dll files).

Running Vista x64 SP1
9.4 Catalyst Driver
ID: 18839 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 18882 - Posted: 15 Apr 2009, 22:06:00 UTC

Just trying to find a pattern, the feedback so far appears to indicate that it runs on Vista, but with XP and teh Cat9.4 there are problems.

That coincides with the Cat 9.3, only a hotfix enabled the correct function of the CAL interface (used by the GPU app) on XP32 and XP64 systems.
ID: 18882 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileSimplex0
Avatar

Send message
Joined: 11 Nov 07
Posts: 232
Credit: 178,229,009
RAC: 0
100 million credit badge14 year member badge
Message 19412 - Posted: 18 Apr 2009, 20:56:44 UTC

Yes. I can now confirm after more than 100 work units
that it runs fine using Vista64.
ID: 19412 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 19436 - Posted: 18 Apr 2009, 22:52:38 UTC - in response to Message 18836.  

the only thing i can't do is to use any remote desktop software, because both systems crash or not after using ms rdp or vnc or teamviewer

Remote desktop does not work at GPUGrid or CUDA-SETI either ;)

The problem is that Windows loads a virtual display driver for the remote session. The GPU applications don't get access to the hardware in that case. Actually you can get it to work with VNC, you only have to disable the mirror driver (same problem as with the virtual display driver of a remote desktop session). It is a bit slow then, but it runs.
ID: 19436 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileverstapp
Avatar

Send message
Joined: 26 Jan 09
Posts: 589
Credit: 497,834,261
RAC: 0
300 million credit badge12 year member badge
Message 19443 - Posted: 18 Apr 2009, 23:14:02 UTC

TightVNC works well.
Cheers,

PeterV

.
ID: 19443 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge13 year member badge
Message 19773 - Posted: 21 Apr 2009, 10:37:17 UTC
Last modified: 21 Apr 2009, 10:37:37 UTC

If an ATI HD48*0 is being used just for crunching MW, does the version of Catalyst driver make any difference to RAC ?

Is there any benefit, for example, of ungrading from 8.12 to 9.4 to generate a faster turnover of WUs ?

ID: 19773 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileverstapp
Avatar

Send message
Joined: 26 Jan 09
Posts: 589
Credit: 497,834,261
RAC: 0
300 million credit badge12 year member badge
Message 19779 - Posted: 21 Apr 2009, 11:07:24 UTC

If they won't send me any WUs then what does it matter how fast I turn them over. :)
When I got my 3870s and 4870 I first tried 9.3, but didn't know about the XP hotfix so it didn't work. So after a bit of DriverCleaner Dot Net I installed 8.12 and its worked well since.
Cheers,

PeterV

.
ID: 19779 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilearkayn
Avatar

Send message
Joined: 14 Feb 09
Posts: 999
Credit: 74,932,619
RAC: 0
50 million credit badge12 year member badge
Message 19791 - Posted: 21 Apr 2009, 12:29:33 UTC

I am using Cat 9.4 on my 4830. As far as I can tell it is running just fine.

Windows 7-64 as the OS.
ID: 19791 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Emanuel

Send message
Joined: 18 Nov 07
Posts: 280
Credit: 2,442,757
RAC: 0
2 million credit badge14 year member badge
Message 19817 - Posted: 21 Apr 2009, 15:34:57 UTC - in response to Message 19779.  

So after a bit of DriverCleaner Dot Net I installed 8.12 and its worked well since.

Just wanted to mention, as a free alternative you could try DriverSweeper. I'm not sure which is more up-to-date (if AMD have changed the driver structure recently), although I think DriverCleaner (.NET) supports a greater number of drivers.
ID: 19817 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Deedub

Send message
Joined: 30 Apr 09
Posts: 1
Credit: 648,998
RAC: 0
500 thousand credit badge12 year member badge
Message 21885 - Posted: 11 May 2009, 1:44:25 UTC

Can anybody confirm the HD4870X2 working on both cores for MW@Home on WinXP x86?
ID: 21885 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Catalyst 9.4 question

©2021 Astroinformatics Group