Welcome to MilkyWay@home

Posts by Paul

1) Message boards : Number crunching : Linux RX 5700 XT All GPU WU Fail (Message 70335)
Posted 11 Jan 2021 by Paul
Post:
Aha! Okay, yes, thank you. I buy that explanation. Many thanks!

As is traditional for AMD, driver upgrades are equally likely to create problems as fix them. It would be great if this all worked with the OSS stack. That worked for a brief time back in 2016, IIRC, and that made life so much easier.

Okay, well, E@H had a problem with the WU pipeline, but now it's fixed, so, I guess I will just leave it off. Hopefully, by the time I turn it on the next time, it will be better.
2) Message boards : Number crunching : Linux RX 5700 XT All GPU WU Fail (Message 70329)
Posted 8 Jan 2021 by Paul
Post:
I'm not sure what you mean. My system is crunching Einstein@Home GPU WUs just fine. Also, I'm specifically asking about AMD 5700 XT, so nVidia driver peculiarities do not apply.

It's not a platform problem, although it could be an incompatibility between Milkyway apps and my platform. That's what I'm trying to get at from the community.

I'm using the (OSS) AMDGPU drivers. But I have installed AMDGPU-PRO OpenCL components. This is a configuration that has worked for the last 4 or 5 years. Others in the BOINC community recommended it to me.
3) Message boards : Number crunching : Linux RX 5700 XT All GPU WU Fail (Message 70326)
Posted 7 Jan 2021 by Paul
Post:
I turned off GPU for my 5700 XT a while ago, but I don't remember why. I tried it again just now and all the GPU wu I get "finish" in 3 seconds. Experience tells me those jobs are failing, but the logs should be available on the server soon, to verify.

Is this the same for everyone? Or is it just my system?
4) Message boards : Number crunching : Linux AMD RX480 GPU Still Crashing MW App (Message 66575)
Posted 28 Aug 2017 by Paul
Post:
Hi All,

Could someone please help me figure out what is going on with MW GPU app? It's been broken for over a year, but I've upgraded every component since this problem started and nothing has fixed it.

I'm sure you know, but it's very difficult to diagnose these app failures, but, after the failed task is returned, I see this in the task log:

<core_client_version>7.8.0</core_client_version>
<![CDATA[
<message>
process exited with code 193 (0xc1, -63)
</message>
<stderr_txt>
<search_application> milkyway_separation 1.46 Linux x86_64 double OpenCL </search_application>
Reading preferences ended prematurely
BOINC GPU type suggests using OpenCL vendor 'Advanced Micro Devices, Inc.'
Setting process priority to 0 (13): Permission denied
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Switching to Parameter File 'astronomy_parameters.txt'
<number_WUs> 5 </number_WUs>
<number_params_per_WU> 20 </number_params_per_WU>
Using AVX path
Found 2 platforms
Platform 0 information:
Name: Clover
Version: OpenCL 1.1 Mesa 17.1.7
Vendor: Mesa
Extensions: cl_khr_icd
Profile: FULL_PROFILE
Platform 1 information:
Name: Portable Computing Language
Version: OpenCL 2.0 pocl 0.14, LLVM 4.0.0
Vendor: The pocl project
Extensions: cl_khr_icd
Profile: FULL_PROFILE
Didn't find preferred platform
Using device 0 on platform 0
Found 1 CL device
Device 'AMD POLARIS10 (DRM 3.15.0 / 4.12.8-300.fc26.x86_64, LLVM 4.0.0)' (AMD:0x1002) (CL_DEVICE_TYPE_GPU)
Board:
Driver version: 17.1.7
Version: OpenCL 1.1 Mesa 17.1.7
Compute capability: 0.0
Max compute units: 36
Clock frequency: 1288 Mhz
Global mem size: 8588091392
Local mem size: 32768
Max const buf size: 2147483647
Double extension: cl_khr_fp64
SIGSEGV: segmentation violation

Exiting...

</stderr_txt>
]]>




©2021 Astroinformatics Group