Welcome to MilkyWay@home

Posts by eiernacken1983

1) Message boards : Number crunching : Finally getting new tasks only seconds after running out. May not be worth the hassle. (Message 69593)
Posted 11 Mar 2020 by eiernacken1983
Post:
I built that "mod" with Visual Studio 2013. I am not sure what version the official release was built with. That "100" DLL might be 2010 version. Berkeley has a problem maintain compatibility with Linux and after 2013 Microsoft made so many changes that Berkeley gave up on using "the latest and greatest". Just my opinion, worth 2c. But I know for a fact that VS2013 was the last version of Visual Studio compatible with BOINC.

The VS 2013 runtimes are here
https://www.techspot.com/downloads/6776-visual-c-redistributable-package.html

Supposedly new releases are compatible with older so you might want to put in the latest version (listed as an option on that page)

One of my kids is in Germany. He keeps ordering stuff from amazon, it arrives here in texas and I have to mail it through customs to him. Is the VAT so high that it is cheaper to order from USA amazon.com than get it direct from amazon.de ? The customs form warns against sending coffee or dried beef. Unfortunately that means problems getting Keurig K-Cups and Oma's beef jerky which is usually what he wants.

[edit] Forgot to mention: running boinc manually was just to be able to spot warning messages.


My strange combination of ambition (ambitios about good progress of the Project which made me updating the Project manually every hour to skip 10 minute idle time) and laziness (too lazy to follow your instructions) makes me answering with a delay of almost 4 weeks. But I am not answering to ask for further support but just to say thank you because …………. it finally works.

There were some problems: In the beginning I misunderstood your instructions and thought I had to download the latest Version of VS runtimes. I was lucky beacause by accident I installed VS 2013 before I installed VS 2015 - 2019 on my first machine. After installing and replacing boinc.exe with your version it worked instantly. On my second machine I just installed VS 2015 - 2019 and it did not work. It only took me 2 minutes to recognize what was different on the first device. So I installed VS 2013, too. Again, it worked instantly, which is kind of prove that VS 2013 is required. I am kind of relieved now that the manual actualization each hour is over now.

I hope your kid enjoys beeing in Germany. VAT is generally 19 % but only 7 % for food and other basic stuff (books, drugs/medicine and hundreds of exceptions). Dried Beef is not popular here, so there is no supply.

THANK YOU AGAIN for your support!

Summary for others who want to try the Workaround and have the same Problem like me:
If BOINC cannot connect to client after replacing original boinc.exe with the modified boinc.exe, install VS 2013 (but not the version 2015 to 2019 (available on https://www.techspot.com/downloads/6776-visual-c-redistributable-package.html)).
2) Message boards : Number crunching : Finally getting new tasks only seconds after running out. May not be worth the hassle. (Message 69542)
Posted 17 Feb 2020 by eiernacken1983
Post:

So i made sure no other copies of boinc were running. I even deacivated boinc in the autostart menu and restarted the pc. So boinc was not running at all. !


By AutoStart I assume you mean the windows tasks manager "Startup".

I assume the following:

1. Boinc is not running as you rebooted with it disabled in that task manager startup tab


...
[/code]

You should see something like the above.
Lemme know if it worked.


Thank you for your long answer :-)

I followed your instructions. Here are my results :-)

Your assumptions 1. to 4. are right (exception: german system, so c:\program files\boinc is c:\programme\boinc on my system; but the relative location matches your assumptions)

So BOINC not running, (double checked it in task manager) I went to the command promt as administrator

c:\programme\BOINC>.\boinc.exe --version
--> I got a german error message stating "execution of the code can not be continued because MSCR120.dll was not found. Problem migth be solved be reinstalling the program"
So obviously your boinc.exe needs MSVCR120.dll. My system only has MSVCR100.dll (installation was in Dec 2019)

c:\programme\BOINC>.\boinccmd.exe --version
--> built from BOINC 7.14.2 (like you already stated)

c:\programme\BOINC>.\boinc_orig.exe --version
--> 7.14.2

c:\programme\Boinc>boinccmd --quit
--> can't connect to local host (like you already stated)

c:\programme\Boinc>boinccmd --status
--> can't connect to local host (like you already stated)

So there is a problem with the MSVCR120.dll which is MSVCR100.dll on my system.
3) Message boards : Number crunching : Finally getting new tasks only seconds after running out. May not be worth the hassle. (Message 69535)
Posted 13 Feb 2020 by eiernacken1983
Post:
I did all of this and when i try to run my boinc manager after replacing the original Boinc executable the boinc manager launches but can not connect to the client.
As i mentioned i have had this working previously a few weeks ago so i am sure i am following all the steps correctly and yes my boinc was already installed 64bit version 7.14.2 and working properly running several projects including milkyway.


Try the following
(1) Boincmgr: Bring up boincmgr and click on the Help and then the About and make a note of the version number
you should have orig_boinc.exe and also boinccmd.exe
run the original using orig_boinc --version
then run boinccmd --version

All should be 7.14.2 except the mod which is 7.15.0

(2) Make sure you are not running two copies of the boinc client. Bring up the windows tasks manager and look for boinc. If you see more than one then terminate them both. I assume you are not manually executing the boinc program as that would be a problem.
Make sure that boincmgr is not running. Bring up the task manager and look for boinc. It should not show up. Then run boincmgr. It should automatically start boinc and you should see both boinc and the manager.
I am not an expert on firewalls. Conceivable, a firewall product might keep the manager from seeing the client but that seems unlikely when both are on the same system.

(3) put the original version of the boinc client back at \C:\Program Files\boinc and see if it works. I assume you have the 64 bit version.
If it does not work then suggest download and use the free Revo Uninstaller. Dell support uses this product for remote repairs. During the uninstall Revo will ask if you want to remove all traces of boinc from the register and the disk so be sure to select the advance scan and then click on first "select" and then "Delete". Suggest you put in 7.16.3. but my program works with both. If you cannot get my "mod" to work then just use the batch file that Peter posted here with the original 7.14.2 or 7.16.3
https://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=4424&postid=69200
[edit] actually, peter did not create that script. I don't remember who did but it works fine though it is a PITA as it needs to be started every time a reboot.


As your little fix sounded nice I tried to apply it. Unfortunately it didn't work on my two computers.

What did I do:
1. Downloaded the boinc.exe via the link you provided earlier
2. Shutdown of boin and boinc mgr
3. Renamed boinc.exe in boinc_old.exe in the original boinc folder
4. Copied your boinc.exe from step 1 to the exact same folder
5. started boinc manager

Result: exact same outcome like some posts above: boincmanager was not able to connect to the client.

So i made sure no other copies of boinc were running. I even deacivated boinc in the autostart menu and restarted the pc. So boinc was not running at all. I repeated steps 3 to 5. Result: no connection to client

When I change back original boinc.exe everything works fine (except the issue with getting new tasks instantly).

So is there a thing that I did obviously wrong? Did I take an old version of boinc.exe or additionly do I have to edit some of the config files in order to get your fix working?

Thank you in advance for any answers!




©2020 Astroinformatics Group