Welcome to MilkyWay@home

Posts by Maurice Goulois

1) Message boards : News : Award Badges Going Live Soon! (Message 73805)
Posted 9 Jun 2022 by ProfileMaurice Goulois
Post:
Same here :)

Edit : after posting, it appears correct in my signature below ??

I guess I need to wait the stats update to check on other forums if this populates or not :)
2) Message boards : Number crunching : WU's failing on nvidia opencl and not amd (Message 66763)
Posted 4 Nov 2017 by ProfileMaurice Goulois
Post:
Seems some of his co-crunchers have succeeded with opencl nvidia, so the factors involved might more complex than I thought at first sight :)

Investigating :)
3) Message boards : Number crunching : WU's failing on nvidia opencl and not amd (Message 66760)
Posted 3 Nov 2017 by ProfileMaurice Goulois
Post:
Reported by AF member Alan, latest WUs as this one, fail with:

Error creating context (-5): CL_OUT_OF_RESOURCES
Error getting device and context (-5): CL_OUT_OF_RESOURCES
Failed to calculate likelihood
21:59:52 (3240): called boinc_finish(-5)


It appears that his co-crunchers (forgot the correct term :)) with nvidia GPUs do fail or have validation inconclusive, but the amd ones do succeed.

FYI
4) Message boards : Number crunching : OpenCL errors with 1.40 app on r9-280x (Message 65897)
Posted 18 Nov 2016 by ProfileMaurice Goulois
Post:
Hello,

since a few days, this machine (ubuntu 15.04/boinc 7.2.42/fglrx 14.41 r9-280x) with application 1.40, has a majority of opencl compilation errors as in this workunit :

"/tmp/OCL26050T5.cl", line 227: error: identifier "inf" is undefined
          tmp = mad((real) Q_INV_SQR, z * z, tmp);   /* (q_invsqr * z^2) + (x^2 + y^2) */
                           ^

1 error detected in the compilation of "/tmp/OCL26050T5.cl".

Frontend phase failed compilation.


This setup goes well on seti, primegrid, collatz...

Since the recent server upgrade, I've removed any xml config file for milkyway, and getting application downloaded automatically.


Any clue?
5) Message boards : News : Updated Server Daemons and Libraries (Message 65710)
Posted 12 Nov 2016 by ProfileMaurice Goulois
Post:
Hi Jake and everybody

This machine with R9-280x and ubuntu 15.04
		12/11/2016 04:36:36	OpenCL: AMD/ATI GPU 0: Tahiti (driver version 1598.5 (VM), device version OpenCL 1.2 AMD-APP (1598.5), 3035MB, 3035MB available, 2816 GFLOPS peak)	
8			12/11/2016 04:36:36	OpenCL CPU: Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz (OpenCL driver vendor: Advanced Micro Devices, Inc., driver version 1598.5 (sse2,avx), device version OpenCL 1.2 AMD-APP (1598.5))	
12			12/11/2016 04:36:36	OS: Linux: 3.19.0-31-generic	
13			12/11/2016 04:36:36	Memory: 7.74 GB physical, 7.88 GB virtual	
14			12/11/2016 04:36:36	Disk: 908.52 GB total, 839.97 GB free	

needed a config file before upgrade and doesnt need it anymore.

Crunching on automatically downloaded new app versions. Nice :)

However,

État: Tous (529) · En cours (84) · Validation en attente (0) · Validation non concluante (71) · Valide (70) · Invalide (303) · Erreur (1)

On 529, minus 84 to be done, 71 inconclusives, 70 valids, 303 invalids :(
6) Message boards : Number crunching : app_info.xml to run MW@H GPU WU's for R9 3xx cards (Message 64092)
Posted 13 Nov 2015 by ProfileMaurice Goulois
Post:
For linux+ati recent model, thanks to cyrusNGC_224@P3D for his app_info.xml from here, which just does exactly what I needed; just changed version of latest apps and voila :)
7) Message boards : Number crunching : app_info.xml to run MW@H GPU WU's for R9 3xx cards (Message 64086)
Posted 10 Nov 2015 by ProfileMaurice Goulois
Post:
Your're quite right, I'm not used to these config files and it happens that I'm mixing them often. Renamed in app_info.xml, will see, server seems having problems right now.
Thanks for pointing that :)
8) Message boards : Number crunching : app_info.xml to run MW@H GPU WU's for R9 3xx cards (Message 64083)
Posted 10 Nov 2015 by ProfileMaurice Goulois
Post:
Hey :) it's Separation (ModifiedFit) I'm requesting, seems there are some
9) Message boards : Number crunching : app_info.xml to run MW@H GPU WU's for R9 3xx cards (Message 64079)
Posted 10 Nov 2015 by ProfileMaurice Goulois
Post:
Desperately trying to get work here for my R9-280X (which I bought with mw in mind according to its dp perfs) on this machine http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=637333 running Ubuntu 15.04 64bits. Boinc start log:
1			09/11/2015 15:18:12	cc_config.xml not found - using defaults	
2			09/11/2015 15:18:12	Starting BOINC client version 7.2.42 for x86_64-pc-linux-gnu	
3			09/11/2015 15:18:12	log flags: file_xfer, sched_ops, task	
4			09/11/2015 15:18:12	Libraries: libcurl/7.38.0 OpenSSL/1.0.1f zlib/1.2.8 libidn/1.28 librtmp/2.3	
5			09/11/2015 15:18:12	Data directory: /home/maurice/BOINC	
6			09/11/2015 15:18:12	OpenCL: AMD/ATI GPU 0: Tahiti (driver version 1598.5 (VM), device version OpenCL 1.2 AMD-APP (1598.5), 3035MB, 3035MB available, 2816 GFLOPS peak)	
7			09/11/2015 15:18:12	OpenCL CPU: Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz (OpenCL driver vendor: Advanced Micro Devices, Inc., driver version 1598.5 (sse2,avx), device version OpenCL 1.2 AMD-APP (1598.5))	
8			09/11/2015 15:18:12	Host name: vmserver2	
9			09/11/2015 15:18:12	Processor: 4 GenuineIntel Intel(R) Core(TM) i5-4460  CPU @ 3.20GHz [Family 6 Model 60 Stepping 3]	
10			09/11/2015 15:18:12	Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eage	
11			09/11/2015 15:18:12	OS: Linux: 3.19.0-31-generic	
12			09/11/2015 15:18:12	Memory: 7.74 GB physical, 7.88 GB virtual	
13			09/11/2015 15:18:12	Disk: 908.52 GB total, 850.92 GB free	
14			09/11/2015 15:18:12	Local time is UTC +1 hours	
15			09/11/2015 15:18:12	VirtualBox version: 4.3.26_Ubuntur98988	
16	Milkyway@Home	09/11/2015 15:18:12	Found app_config.xml	


Using an adaptation of the app_config.xml from iconized in this thread:

<app_info>
<platform>x86_64-pc-linux-gnu</platform>
<app>
<name>milkyway_separation__modified_fit</name>
<user_friendly_name>Milkyway@HomeSeparation(ModifiedFit)</user_friendly_name>
</app>

<file_info>
<name>milkyway_separation__modified_fit_1.36_x86_64-pc-linux-gnu__opencl_ati_101</name>
<executable/>
</file_info>

<app_version>
<app_name>milkyway_separation__modified_fit</app_name>
<version_num>136</version_num>

<avg_ncpus>0.1</avg_ncpus>
<max_ncpus>0.1</max_ncpus>
<flops>2e11</flops>
<plan_class>opencl_amd_ati</plan_class>
<coproc>
<type>ATI</type>
<count>1</count></coproc>
<dont_throttle/>

<file_ref>
<file_name>milkyway_separation__modified_fit_1.36_x86_64-pc-linux-gnu__opencl_ati_101</file_name>
<main_program/>
</file_ref>
</app_version>
</app_info>

Executable (for linux-opencl-ati 64bits) downloaded and placed in project directory; chmoded +x; ldd not missing library.

But only getting
1893	Milkyway@Home	10/11/2015 05:26:54	Requesting new tasks for ATI	
1894	Milkyway@Home	10/11/2015 05:26:56	Scheduler request completed: got 0 new tasks	
1895	Milkyway@Home	10/11/2015 05:26:56	No work available	

Other projects tested and ok (collatz, moo!, einstein, poem...) the opencl apps are working
Seems some work is there at least for a few wu; how can I solve this? thanks

Or, what's wrong with this setup? :)
10) Message boards : News : Windows Users-please abort Nbody tasks (Message 63645)
Posted 30 May 2015 by ProfileMaurice Goulois
Post:
Hi :)

Do you prefer Windows crunchers to stay with Nbody app deselected, and announce when we shoudl resume work on this app? or would using the current version with errors help you in the development?




©2022 Astroinformatics Group