rpi_logo
Profiles?
Profiles?
log in

Advanced search

Message boards : Number crunching : Profiles?

Author Message
Profile Michael Goetz
Avatar
Send message
Joined: 1 Mar 09
Posts: 3
Credit: 540,770
RAC: 0

Message 66858 - Posted: 15 Dec 2017, 23:55:38 UTC

Several years ago I was crunching at Milkyway@Home for a while, and then recently I decided to add a profile to all the BOINC projects I had participated at.

There was a minor hiccup at some sites because they require a minimum RAC to create a profile, and mine had dropped to 0 in the intervening years, so I needed to run a few tasks. That's PERFECTLY reasonable; I run another BOINC project and spam profiles, spam teams, and spam forum posts are a big problem. Requiring credit is the single most effective way to block such spam.

However, when I went to create a profile here, the profile creation page (create_profile.php) doesn't create the whole page -- it stops before writing the "Submit" button, so you can't submit the form (at least without hacking the page.)

I tried this in both Chrome and IE, and both browsers lack the Submit button.

Is this intentional? Or is it a bug?

Profile Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 501
Credit: 34,647,251
RAC: 415

Message 66861 - Posted: 16 Dec 2017, 2:08:08 UTC

Hey Michael,

I'll take a look at it when I get into the office on Monday. Something tells me it broke during an update at some point.

Jake

Profile Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 501
Credit: 34,647,251
RAC: 415

Message 66869 - Posted: 18 Dec 2017, 17:42:09 UTC
Last modified: 18 Dec 2017, 18:32:18 UTC

All fixed. It looks like when we migrated over to the new ReCaptcha it broke.

Jake

Profile Michael Goetz
Avatar
Send message
Joined: 1 Mar 09
Posts: 3
Credit: 540,770
RAC: 0

Message 66870 - Posted: 18 Dec 2017, 18:16:08 UTC - in response to Message 66869.

Thanks!

Profile Bill F
Send message
Joined: 4 Jul 09
Posts: 12
Credit: 1,170,900
RAC: 588

Message 66982 - Posted: 21 Jan 2018, 7:04:31 UTC
Last modified: 21 Jan 2018, 7:05:50 UTC

still having this issue ... after editing my profile and submitting it the error message says that my ReCaptcha is not valid. Well I was not offered box to check so yes I just it is and ....

yes ReCaptcha is broke again.

Bill F
Dallas TX
____________

Profile BETA
Avatar
Send message
Joined: 13 Dec 08
Posts: 2
Credit: 500,068
RAC: 7

Message 67271 - Posted: 21 Mar 2018, 11:09:55 UTC
Last modified: 21 Mar 2018, 11:13:46 UTC

When updating my profile i get an error message as well saying my ReCaptcha is not valid. No offered ReCaptcha on the edit page.
Is it broken again?
____________

Profile Bill F
Send message
Joined: 4 Jul 09
Posts: 12
Credit: 1,170,900
RAC: 588

Message 67272 - Posted: 22 Mar 2018, 19:06:01 UTC - in response to Message 67271.

It appears that if you are not using the correct browser and it is not configured just so you can't see the reCaptcha.

I have been working with a Moderator / volunteer to resolve my issue but 3 browsers and two PC's later I still can't edit my profile.

Bill F
Dallas
____________

Profile Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 501
Credit: 34,647,251
RAC: 415

Message 67273 - Posted: 23 Mar 2018, 19:13:40 UTC

Hey BETA and Bill,

I am still working on this issue. I have not been able to reproduce the issue on my end still so it will take a little while to figure out what is going on.

Sorry for the long delay on fixing this issue.

Jake

Profile Bill F
Send message
Joined: 4 Jul 09
Posts: 12
Credit: 1,170,900
RAC: 588

Message 67274 - Posted: 24 Mar 2018, 3:01:46 UTC - in response to Message 67273.

Jake,

BETA has been around since 2008 and I have been around since 2009. I suspect that we will be patient and stick around. Take your time and swat the bug.

Thanks
Bill F
____________

Profile Marsinph
Send message
Joined: 13 Nov 10
Posts: 6
Credit: 5,852,559
RAC: 107,298

Message 67295 - Posted: 3 Apr 2018, 12:39:26 UTC

Hello,
perfect the same for me : no any cptcha visible !
____________

Profile nedmanjo
Avatar
Send message
Joined: 31 Jan 16
Posts: 1
Credit: 5,259,329
RAC: 3,221

Message 67317 - Posted: 9 Apr 2018, 0:15:03 UTC - in response to Message 67271.

Having the same issue. reCaptcha does not display on IE, Firefox or Edge but the reCaptcha does display on all of my other projects. Seems the issue is unique to Milkyway.
____________


Profile Contact
Avatar
Send message
Joined: 28 Aug 07
Posts: 10
Credit: 555,076
RAC: 1,352

Message 67329 - Posted: 13 Apr 2018, 19:34:57 UTC - in response to Message 67273.

I was comparing Milkyway's "create_profile.php" page code to another BOINC project's code.

That other project's page did not include (in Line 253)
<script>var RecaptchaOptions = { theme : 'white' };</script>

But did include
<div class="g-recaptcha" data-sitekey="#"></div>

Which seems to bring up the reCAPTCHA "I'm not a robot" checkbox and will hopefully avoid the Your reCAPTCHA response was not correct. Please try again error that we get now.

I also came across this:
calls to reCAPTCHA v1 API will not work after March 31, 2018
____________

Profile Contact
Avatar
Send message
Joined: 28 Aug 07
Posts: 10
Credit: 555,076
RAC: 1,352

Message 67349 - Posted: 18 Apr 2018, 2:38:14 UTC - in response to Message 67329.

I missed the most important fact that you must paste this snippet before the closing </head> tag on your page template:
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
along with:
<div class="g-recaptcha" data-sitekey="#"></div>
in the body
I copied the code for your create_profile page with those changes (and used my site key) and it looks good:

http://boincsynergy.ca/test_create_profile.php

Having said all that, the way it is now is one way to stop spammers :)

Profile Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 501
Credit: 34,647,251
RAC: 415

Message 67360 - Posted: 19 Apr 2018, 14:58:51 UTC
Last modified: 19 Apr 2018, 15:09:09 UTC

Hey Contact,

I'll give it a try. I still have not actually been able to reproduce the issue on my end over several different systems running different configurations of hardware and software. Hopefully this fixes it for you.

Jake

[Edit]

So I looked at the page again and as far as I can tell, we are including everything where it belongs. I removed the var Recaptcha.... bit and maybe that will fix it. Let me know.

[/Edit]

Profile Contact
Avatar
Send message
Joined: 28 Aug 07
Posts: 10
Credit: 555,076
RAC: 1,352

Message 67363 - Posted: 19 Apr 2018, 15:56:27 UTC - in response to Message 67360.

Thanks for looking into this Jake. I see what you have removed, but it's still not working for me.
I think as a final step you need to add
<script src="https://www.google.com/recaptcha/api.js" async defer></script>
before the </head> tag.

The head code that you have now is
<head>

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" >
<title>Edit your profile</title>
<link rel=stylesheet type="text/css" href="http://milkyway.cs.rpi.edu/milkyway/main.css" media="all">
<link rel=stylesheet type="text/css" href="http://milkyway.cs.rpi.edu/milkyway/white.css">
<link rel=alternate type="application/rss+xml" title="MilkyWay@Home RSS 2.0" href="http://milkyway.cs.rpi.edu/milkyway/rss_main.php">

</head>


But it should be:
<head>

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" >
<title>Edit your profile</title>
<link rel=stylesheet type="text/css" href="http://milkyway.cs.rpi.edu/milkyway/main.css" media="all">
<link rel=stylesheet type="text/css" href="http://milkyway.cs.rpi.edu/milkyway/white.css">
<link rel=alternate type="application/rss+xml" title="MilkyWay@Home RSS 2.0" href="http://milkyway.cs.rpi.edu/milkyway/rss_main.php">
<script src="https://www.google.com/recaptcha/api.js" async defer></script>

</head>

____________

Profile Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist
Send message
Joined: 25 Feb 13
Posts: 501
Credit: 34,647,251
RAC: 415

Message 67364 - Posted: 19 Apr 2018, 16:01:58 UTC
Last modified: 19 Apr 2018, 16:04:36 UTC

Contact,

You are talking about on the edit profile page. Oh! The original question was about the create profile page, which is different. I didn't even look at the edit profile page. I am sorry.

I will get the edit page fixed up right now. I see there is no reCaptcha there now.

Jake

[Edit]

All fixed.

[/Edit]

Profile Contact
Avatar
Send message
Joined: 28 Aug 07
Posts: 10
Credit: 555,076
RAC: 1,352

Message 67365 - Posted: 19 Apr 2018, 16:20:39 UTC - in response to Message 67364.

That's done it!
You have sorted through my confusion and Profiles can now be updated!

Profile Bill F
Send message
Joined: 4 Jul 09
Posts: 12
Credit: 1,170,900
RAC: 588

Message 67368 - Posted: 20 Apr 2018, 3:25:29 UTC

The Force was truly with you !

Light has prevailed over darkness !

Truth and Justice come in first !

You have slain the Dragon !

Yep ... IT WORKS !!!

Thank you for being persistent.

Bill F
Dallas TX
____________


Post to thread

Message boards : Number crunching : Profiles?


Main page · Your account · Message boards


Copyright © 2018 AstroInformatics Group