Welcome to MilkyWay@home

BOINC 6.10 support with ATI


Advanced search

Message boards : Number crunching : BOINC 6.10 support with ATI
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
sesef

Send message
Joined: 14 Nov 08
Posts: 16
Credit: 1,753,367
RAC: 0
1 million credit badge10 year member badge
Message 29477 - Posted: 18 Aug 2009, 19:02:27 UTC

When milky admins will upgrade server to newest version with ATI applications support?
ID: 29477 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Divide Overflow
Avatar

Send message
Joined: 16 Feb 09
Posts: 109
Credit: 11,089,510
RAC: 0
10 million credit badge10 year member badge
Message 29482 - Posted: 18 Aug 2009, 20:23:30 UTC - in response to Message 29477.  

Probably after it's released. Official BOINC support for ATI is still in development.
ID: 29482 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 29484 - Posted: 18 Aug 2009, 20:43:11 UTC - in response to Message 29482.  
Last modified: 18 Aug 2009, 20:43:44 UTC

Probably after it's released. Official BOINC support for ATI is still in development.


Really ?

http://boinc.berkeley.edu/trac/timeline


Now scroll down that page and start reading at
15:54 Changeset [18846] by davea

boinc_6.10.0_windows_intelx86.exe
boinc_6.10.0_windows_x86_64.exe

Join Support science! Joinc Team BOINC United now!
ID: 29484 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
jedirock
Avatar

Send message
Joined: 8 Nov 08
Posts: 178
Credit: 6,140,854
RAC: 0
5 million credit badge10 year member badge
Message 29485 - Posted: 18 Aug 2009, 21:48:33 UTC - in response to Message 29484.  

Probably after it's released. Official BOINC support for ATI is still in development.


Really ?

Just because stuff has been committed, it doesn't mean the support is finished. Likely, there'll be bugs.

Also, DA said back in February that ATI support was likely a month away. Rom said the same thing yesterday. We'll see how that turns out.
ID: 29485 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge10 year member badge
Message 29486 - Posted: 18 Aug 2009, 22:04:53 UTC

Well done Crunch3r. Truly awesome job! I look forward to playing with this tonight once I get home from w#$^.
ID: 29486 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBruce
Avatar

Send message
Joined: 28 Apr 08
Posts: 1415
Credit: 2,716,428
RAC: 0
2 million credit badge10 year member badge
Message 29488 - Posted: 18 Aug 2009, 23:37:16 UTC - in response to Message 29484.  
Last modified: 18 Aug 2009, 23:46:14 UTC

@ Crunch3r
Good job I noticed a big improvement on the Cuda. My computer has been a little sluggish with Cuda running(Collatz) noticed a big improvement in my computers performance immediately. Kool Thanx
;-p
ID: 29488 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileverstapp
Avatar

Send message
Joined: 26 Jan 09
Posts: 589
Credit: 497,834,261
RAC: 0
300 million credit badge10 year member badge
Message 29491 - Posted: 19 Aug 2009, 1:39:42 UTC

>We'll see how that turns out.
I'll keep running Cluster's app for the moment.
Cheers,

PeterV

.
ID: 29491 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Divide Overflow
Avatar

Send message
Joined: 16 Feb 09
Posts: 109
Credit: 11,089,510
RAC: 0
10 million credit badge10 year member badge
Message 29494 - Posted: 19 Aug 2009, 2:54:06 UTC - in response to Message 29484.  

@ Crunch3r
Congrats on getting some well deserved recognition and your name up in lights. I'm sure your GPU detection code advanced things considerably. The official release may actually happen before Christmas now. :)


ID: 29494 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge10 year member badgeextraordinary contributions badge
Message 29498 - Posted: 19 Aug 2009, 9:42:56 UTC - in response to Message 29491.  

I'll keep running Cluster's app for the moment.

It doesn't exclude each other. Quite the opposite ;)
ID: 29498 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Bill592
Avatar

Send message
Joined: 19 May 09
Posts: 30
Credit: 1,062,540
RAC: 0
1 million credit badge10 year member badge
Message 29503 - Posted: 19 Aug 2009, 18:51:10 UTC

Howdy !

I installed 6.10.0 to give it a try. It did not detect my Radeon 4850
(XFX Brand) for some reason but, it is working just fine.

Crunching away.

Bill



8/19/2009 12:50:43 PM Starting BOINC client version 6.10.0 for windows_intelx86
8/19/2009 12:50:43 PM log flags: task, file_xfer, sched_ops
8/19/2009 12:50:43 PM Libraries: libcurl/7.19.4 OpenSSL/0.9.8k zlib/1.2.3
8/19/2009 12:50:43 PM Data directory: D:\Program Files\Boinc\Application Data
8/19/2009 12:50:43 PM Processor: 2 GenuineIntel Intel(R) Core(TM)2 CPU X6800 @ 2.93GHz [x86 Family 6 Model 15 Stepping 5]
8/19/2009 12:50:43 PM Processor: 4.00 MB cache
8/19/2009 12:50:43 PM Processor features: fpu tsc sse sse2 mmx
8/19/2009 12:50:43 PM OS: Microsoft Windows XP: Professional x86 Edition, Service Pack 3, (05.01.2600.00)
8/19/2009 12:50:43 PM Memory: 2.00 GB physical, 9.85 GB virtual
8/19/2009 12:50:43 PM Disk: 417.90 GB total, 288.70 GB free
8/19/2009 12:50:43 PM Local time is UTC -5 hours
8/19/2009 12:50:43 PM Can't load library nvcuda.dll
8/19/2009 12:50:43 PM No usable CAL devices found
8/19/2009 12:50:43 PM No coprocessors
8/19/2009 12:50:43 PM Einstein@Home Found app_info.xml; using anonymous platform
8/19/2009 12:50:43 PM Milkyway@home Found app_info.xml; using anonymous platform
8/19/2009 12:50:43 PM Not using a proxy
ID: 29503 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge10 year member badge
Message 29504 - Posted: 19 Aug 2009, 19:27:35 UTC

20/08/2009 5:04:26 AM Can't load library nvcuda.dll
20/08/2009 5:04:26 AM ATI GPU 0: RV770 (CAL version , 1024MB, 1088GFLOPS)
20/08/2009 5:04:26 AM ATI GPU 1: RV770 (CAL version , 512MB, 1088GFLOPS)

GPU 0 is a 4870
GPU 1 is a 4850
ID: 29504 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
zombie67 [MM]
Avatar

Send message
Joined: 29 Aug 07
Posts: 115
Credit: 265,168,970
RAC: 76
200 million credit badge10 year member badge
Message 29516 - Posted: 20 Aug 2009, 11:59:25 UTC

To: boinc_projects, boinc_dev

BOINC now supports ATI GPUs.
The client detects them and manages their work queue as it does for NVIDIA GPUs.
This will be in the 6.10 client, which should be released in a month or so.
The server code now also accommodates ATI GPUs.

In addition, the coprocessor model has been extended
to allow jobs to use a fraction of a GPU.
For example, a job that will at most half of a GPU's processors
and at most half of its RAM should be specified as using 0.5 of the GPU
(this is done in the app_plan() function; the fraction in general
will depend on the characteristics of the particular GPU).
The BOINC client will try to run multiple jobs on a GPU
if their usage fractions total 1 or less.

Milkyway@home will be offering an ATI app fairly soon.
I encourage other projects to investigate this possibility also.
Let me know if any questions or problems.

-- David


ID: 29516 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 29546 - Posted: 21 Aug 2009, 13:17:48 UTC

I have 6.10.0 running on a laptop and it seems to be running better with a couple of CUDA WUs going further than the crashes I have been having recently. So that's good. So far running OK with 6.10.0.

I tried it with an ATI GPU and it started off well, grunching two GPU MW and crunching one CPU CPDN. But then it wouldn't download any more MW. I haven't had much time to have a good look at it and hope to give it another go soon. But it's great to see the ATI detection - nice one Crunch3r.




ID: 29546 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileuBronan
Avatar

Send message
Joined: 9 Feb 09
Posts: 166
Credit: 27,520,813
RAC: 0
20 million credit badge10 year member badge
Message 29553 - Posted: 21 Aug 2009, 15:01:01 UTC

21-8-2009 16:54:25 Local time is UTC +2 hours
21-8-2009 16:54:26 Can't load library nvcuda.dll
21-8-2009 16:54:26 ATI GPU 0: RV770 (CAL version , 1024MB, 1088GFLOPS)
21-8-2009 16:54:26 ATI GPU 1: RV770 (CAL version , 1024MB, 1088GFLOPS)
21-8-2009 16:54:26 Milkyway@home Found app_info.xml; using anonymous platform
21-8-2009 16:54:26 SETI@home Found app_info.xml; using anonymous platform
21-8-2009 16:54:26 Not using a proxy
21-8-2009 16:54:26 Version change (6.4.7 -> 6.10.0)

looks good to me it finds both my XFX 4850 cards immediate
I cant run any other project on my cpu's since i have a really hard time getting my ati's enough units to run all the time.
Basically i get only 1 unit every minute while i should get at least 2 or 4 so i guess its time for MW admins to set the cpu limit to 9 or so
Instead of the really low 6
Its new, its relative fast... my new bicycle
ID: 29553 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Divide Overflow
Avatar

Send message
Joined: 16 Feb 09
Posts: 109
Credit: 11,089,510
RAC: 0
10 million credit badge10 year member badge
Message 29554 - Posted: 21 Aug 2009, 15:04:19 UTC

I tried 6.10.0 for a while and noticed some errors being reported. As with other late 6 versions, the "CPU time" starts for all work immediately upon download and evidently some of the tasks were timing out. I saw several error out with "Maximum elapsed time exceeded" messages. I guess Crunch3r's off the hook for this one though. ;)
ID: 29554 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileuBronan
Avatar

Send message
Joined: 9 Feb 09
Posts: 166
Credit: 27,520,813
RAC: 0
20 million credit badge10 year member badge
Message 29555 - Posted: 21 Aug 2009, 15:14:13 UTC

the only issue i have is that i am constant not getting any new work :

21-8-2009 17:10:38 Milkyway@home Sending scheduler request: To fetch work.
21-8-2009 17:10:38 Milkyway@home Not reporting or requesting tasks
21-8-2009 17:10:43 Milkyway@home Scheduler request completed: got 0 new tasks

Its new, its relative fast... my new bicycle
ID: 29555 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLabbie
Avatar

Send message
Joined: 29 Aug 07
Posts: 327
Credit: 116,463,193
RAC: 0
100 million credit badge10 year member badge
Message 29556 - Posted: 21 Aug 2009, 15:14:30 UTC - in response to Message 29553.  

21-8-2009 16:54:25 Local time is UTC +2 hours
21-8-2009 16:54:26 Can't load library nvcuda.dll
21-8-2009 16:54:26 ATI GPU 0: RV770 (CAL version , 1024MB, 1088GFLOPS)
21-8-2009 16:54:26 ATI GPU 1: RV770 (CAL version , 1024MB, 1088GFLOPS)
21-8-2009 16:54:26 Milkyway@home Found app_info.xml; using anonymous platform
21-8-2009 16:54:26 SETI@home Found app_info.xml; using anonymous platform
21-8-2009 16:54:26 Not using a proxy
21-8-2009 16:54:26 Version change (6.4.7 -> 6.10.0)

looks good to me it finds both my XFX 4850 cards immediate
I cant run any other project on my cpu's since i have a really hard time getting my ati's enough units to run all the time.
Basically i get only 1 unit every minute while i should get at least 2 or 4 so i guess its time for MW admins to set the cpu limit to 9 or so
Instead of the really low 6


Whst is your cache set at? Having a cache set higher thsn the MW 3 day deadline can result in that behavior.



Calm Chaos Forum...Join Calm Chaos Now
ID: 29556 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileuBronan
Avatar

Send message
Joined: 9 Feb 09
Posts: 166
Credit: 27,520,813
RAC: 0
20 million credit badge10 year member badge
Message 29557 - Posted: 21 Aug 2009, 15:18:45 UTC
Last modified: 21 Aug 2009, 15:19:52 UTC

hmm checked i have it set at 2 days extra work
and connect at 0,00
in the last 30 minutes i got 2 units from MW server
Its new, its relative fast... my new bicycle
ID: 29557 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge10 year member badge
Message 29558 - Posted: 21 Aug 2009, 15:25:38 UTC - in response to Message 29555.  

the only issue i have is that i am constant not getting any new work :

21-8-2009 17:10:38 Milkyway@home Sending scheduler request: To fetch work.
21-8-2009 17:10:38 Milkyway@home Not reporting or requesting tasks
21-8-2009 17:10:43 Milkyway@home Scheduler request completed: got 0 new tasks

Increase your MW resource share to over 50%.....
ID: 29558 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileuBronan
Avatar

Send message
Joined: 9 Feb 09
Posts: 166
Credit: 27,520,813
RAC: 0
20 million credit badge10 year member badge
Message 29559 - Posted: 21 Aug 2009, 15:44:00 UTC
Last modified: 21 Aug 2009, 15:45:46 UTC

resource share set at 1000 %
all other projects set at 5% and set to inactive and no new work
editted the app_info.xml to n1 f20 w1.1
lol gpu load 50 and 61 % xD
Its new, its relative fast... my new bicycle
ID: 29559 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : Number crunching : BOINC 6.10 support with ATI

©2019 Astroinformatics Group