Welcome to MilkyWay@home

CUDA Application for 32 bit Windows


Advanced search

Message boards : Number crunching : CUDA Application for 32 bit Windows
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · Next

AuthorMessage
Profiledarkstarz1

Send message
Joined: 11 Mar 08
Posts: 10
Credit: 10,647,326
RAC: 0
10 million credit badge10 year member badge
Message 30236 - Posted: 5 Sep 2009, 13:08:12 UTC
Last modified: 5 Sep 2009, 13:11:56 UTC

Not sure if this is the correct thread to report this, but

(quote)
If computation errors are being generated by the CUDA application please reference the results and the error message so the problem can be diagnosed. With the tremendous amount of variety in products, drivers, and operating systems it is high unlikely for everything to go smoothly these first few weeks, the Milkyway@Home team sincerely appreciates your patience in reaching this milestone and we look forward to your feedback.


Just checked 'Tasks' since 02Sep, and have 87 tasks errored out, all with the same message :

Name de_s222_3s_best_3p_03r_21_1717067_1252147180_0
Workunit 94133909
Created 5 Sep 2009 10:39:41 UTC
Sent 5 Sep 2009 10:40:52 UTC
Received 5 Sep 2009 12:20:26 UTC
Server state Over
Outcome Client error
Client state Compute error
Exit status 1 (0x1)
Computer ID 63953
Report deadline 8 Sep 2009 10:40:52 UTC
Run time 4.484375
stderr out <core_client_version>6.6.36</core_client_version>
<![CDATA[
<message>
Incorrect function. (0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
Device index specified on the command line was 0
Looking for a Double Precision capable NVIDIA GPU
The device GeForce GTX 260 specified on the command line can be used
Error executing gpu__integral_kernel3 error message: unknown error

</stderr_txt>
]]>

Validate state Invalid
Claimed credit 0.0277992840025637
Granted credit 0
application version 0.20

I'm running Boinc client 6.6.36 for Windows_X86_64 on a Q6700 o/c'd to 2.8GHz, 8GB ram, Vista Home Prem x64 ed. SP1, Cuda Device = GeForce GTX260, Driver version 190.62, Comp.Cap=1.3, 896MB, est 104GFlops, using milkyway_0.20_windows_intelx86_cuda23.exe

Am I doing something wrong, or is this a known bug ? Any advice gratefully received !

Mike, Bristol, UK

(edit) also getting this in messages

05/09/2009 14:07:50 Milkyway@home Output file de_s222_3s_best_3p_03r_22_1762150_1252151522_0_0 for task de_s222_3s_best_3p_03r_22_1762150_1252151522_0 absent
ID: 30236 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileHydropower
Avatar

Send message
Joined: 2 Apr 09
Posts: 16
Credit: 1,517,499
RAC: 0
1 million credit badge10 year member badge
Message 30245 - Posted: 5 Sep 2009, 18:27:46 UTC - in response to Message 30236.  
Last modified: 5 Sep 2009, 18:28:30 UTC

Things to test with error 0x01:
- Overclocked ? use default clock settings (Q6700 o/c'd to 2.8GHz well...)
- Overheated ? increase airflow to the GPU when temps are over 80 degrees (NVIDIA)
- Broken ? Run the OCCT program (try google) with the error checking option.

Most likely caues in my experience.
ID: 30245 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBymark
Avatar

Send message
Joined: 6 Mar 09
Posts: 51
Credit: 490,285,933
RAC: 98,764
300 million credit badge10 year member badge
Message 30280 - Posted: 6 Sep 2009, 13:26:45 UTC
Last modified: 6 Sep 2009, 13:35:36 UTC

6.9.2009 16:11:25|Milkyway@home|Message from server: Can't use NVIDIA GPU app for MilkyWay@Home: NVIDIA driver version 19038 or later needed

Why does not mine computer report the right driver 19038 is installed?
Help!

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=55327
ID: 30280 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLogan
Avatar

Send message
Joined: 15 Aug 08
Posts: 163
Credit: 3,876,869
RAC: 0
3 million credit badge10 year member badge
Message 30281 - Posted: 6 Sep 2009, 13:43:06 UTC - in response to Message 30280.  

6.9.2009 16:11:25|Milkyway@home|Message from server: Can't use NVIDIA GPU app for MilkyWay@Home: NVIDIA driver version 19038 or later needed

Why does not mine computer report the right driver 19038 is installed?
Help!

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=55327


Becouse your BOINC version is older and don't reports the dirver version in the sched_request_milkyway.cs.rpi.edu_milkyway.xml file.

<coproc_cuda>
<count>1</count>
<name>GeForce GTX 260</name>
<drvVersion>19038</drvVersion>
<cudaVersion>2089878405</cudaVersion>
<totalGlobalMem>939196416</totalGlobalMem>
<sharedMemPerBlock>16384</sharedMemPerBlock>
<regsPerBlock>16384</regsPerBlock>
<warpSize>32</warpSize>
<memPitch>262144</memPitch>
<maxThreadsPerBlock>512</maxThreadsPerBlock>
<maxThreadsDim>512 512 64</maxThreadsDim>
<maxGridSize>65535 65535 1</maxGridSize>
<totalConstMem>65536</totalConstMem>
<major>1</major>
<minor>3</minor>
<clockRate>1566000</clockRate>
<textureAlignment>256</textureAlignment>
<deviceOverlap>1</deviceOverlap>
<multiProcessorCount>27</multiProcessorCount>
</coproc_cuda>

Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)
ID: 30281 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBruce
Avatar

Send message
Joined: 28 Apr 08
Posts: 1415
Credit: 2,716,428
RAC: 0
2 million credit badge10 year member badge
Message 30301 - Posted: 6 Sep 2009, 23:39:09 UTC
Last modified: 6 Sep 2009, 23:43:00 UTC

i7 920 / Vista 64 bit home basic / gtx 27589mb /6 gigs ram/ boinc 6.10.3
I have my preferences set to GPU only for this computer yet it wont download any GPU WUs, but it has seen fit to give me a full cache of CPU WUs.It did download AND RUN one GPU task when i attached to the project(took just under 6 mins) it asks for GPU work three or four times in a row then starts asking for and getting CPU WUs.Can anyone tell me what I'm doing wrong? I have the ssse.4.2 opti app installed, would that be my problem? ;-(
ID: 30301 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 30307 - Posted: 7 Sep 2009, 0:32:51 UTC - in response to Message 30301.  

i7 920 / Vista 64 bit home basic / gtx 27589mb /6 gigs ram/ boinc 6.10.3
I have my preferences set to GPU only for this computer yet it wont download any GPU WUs, but it has seen fit to give me a full cache of CPU WUs.It did download AND RUN one GPU task when i attached to the project(took just under 6 mins) it asks for GPU work three or four times in a row then starts asking for and getting CPU WUs.Can anyone tell me what I'm doing wrong? I have the ssse.4.2 opti app installed, would that be my problem? ;-(


I assume since your using the 6.10 boinc that you've looked over that topic. It's all I can think of. Could be one of you settings is off some, n= (or however).
ID: 30307 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBruce
Avatar

Send message
Joined: 28 Apr 08
Posts: 1415
Credit: 2,716,428
RAC: 0
2 million credit badge10 year member badge
Message 30312 - Posted: 7 Sep 2009, 1:10:33 UTC - in response to Message 30307.  

Well I'm not sure what to do with this mess, maybe I'll wat for the next boinc version. I'm getting very frustrated trying to get this thing to run both GPU and CPU. I know my hardware is good enough and all my drivers are up to date. Any tips would be appreciated, getting tired going to bed! G'night all.
;-p See ya tomorrow!!
ID: 30312 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilelaviathan

Send message
Joined: 28 Oct 07
Posts: 27
Credit: 4,465,201
RAC: 0
3 million credit badge10 year member badge
Message 30318 - Posted: 7 Sep 2009, 7:58:41 UTC - in response to Message 30312.  

Well I'm not sure what to do with this mess, maybe I'll wat for the next boinc version. I'm getting very frustrated trying to get this thing to run both GPU and CPU. I know my hardware is good enough and all my drivers are up to date. Any tips would be appreciated, getting tired going to bed! G'night all.
;-p See ya tomorrow!!


Run a virtual machine and install boinc on it and run your CPU based project with it ;)

I would not recommend using VMWare as it seems to have issues getting 100% use on multicore CPU's.
ID: 30318 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JD

Send message
Joined: 9 Aug 09
Posts: 4
Credit: 101,365
RAC: 0
100 thousand credit badge10 year member badge
Message 30329 - Posted: 7 Sep 2009, 15:47:20 UTC

"Can't use NVIDIA GPU app for MilkyWay@Home: Your GPU lacks the needed features"

a) Ok, but how come I don't get any MilkyWay tasks ever?
b) I don't believe the above message because I'm able to run SETI@Home task for NVIDIA Cuda.

john_donaldson@sbcglobal.net
ID: 30329 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
JD

Send message
Joined: 9 Aug 09
Posts: 4
Credit: 101,365
RAC: 0
100 thousand credit badge10 year member badge
Message 30330 - Posted: 7 Sep 2009, 15:52:09 UTC - in response to Message 30329.  

>a) Ok, but how come I don't get any MilkyWay tasks ever?

What I mean is, "fine you don't want to give me GPU tasks that's your problem. BUT why don't you give me CPU tasks??"
ID: 30330 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLogan
Avatar

Send message
Joined: 15 Aug 08
Posts: 163
Credit: 3,876,869
RAC: 0
3 million credit badge10 year member badge
Message 30333 - Posted: 7 Sep 2009, 15:54:32 UTC - in response to Message 30329.  
Last modified: 7 Sep 2009, 16:16:30 UTC

"Can't use NVIDIA GPU app for MilkyWay@Home: Your GPU lacks the needed features"

a) Ok, but how come I don't get any MilkyWay tasks ever?
b) I don't believe the above message because I'm able to run SETI@Home task for NVIDIA Cuda.

john_donaldson@sbcglobal.net


MW CUDA app only accepts GTX2XX cards CUDA 2.3 capables with 190.38 drivers or greater.

Set 'your preferences' in 'your account' section from the project web page, checking only CPU work.

Use GPUs for Computation? NO Note: If you plan on using a NVIDIA GPU please see this thread.
Use CPU for Computation? YES

[edit]and reset the project[/edit]
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)
ID: 30333 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 30334 - Posted: 7 Sep 2009, 16:09:31 UTC - in response to Message 30330.  

>a) Ok, but how come I don't get any MilkyWay tasks ever?

What I mean is, "fine you don't want to give me GPU tasks that's your problem. BUT why don't you give me CPU tasks??"

I've had the same problem. I have a CUDA NVIDIA in my laptop, but it is not Computational level 2.3, or whatever the term is. I would like to crunch MW CPU whilst using my GPU for something else. So I set GPU=no, CPU=Yes.

But I get no MW WUs at all.

I've tried 5.10.45 and get my MW CPU WUs, but can't use my NVIDIA. Except for seeing what I'm typing on the screen ;)


ID: 30334 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 30336 - Posted: 7 Sep 2009, 17:40:50 UTC - in response to Message 30333.  

[edit]and reset the project[/edit]


I'm now running 6.6.36 and getting MW CPU as well as Collatz GPU.


ID: 30336 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBruce
Avatar

Send message
Joined: 28 Apr 08
Posts: 1415
Credit: 2,716,428
RAC: 0
2 million credit badge10 year member badge
Message 30340 - Posted: 7 Sep 2009, 19:01:12 UTC

Still no CUDA!!! I have done a complete re-install of EVERYTHING, I'm using 6.10.3 - 64 bit version/driver version 190.62/Vista Home Basic 64 bit/ preferences are set to yes for GPU and CPU AND tests,I have opti app ssse4.2 installed also. My video card is a gtx 275 896mb, this card can run a CUDA task in just under 6 mins,it downloaded 1 GPU task when I reattached, it then asked for GPU WUs 3 times in a row and got "no tasks sent", it then asked for CPU WUs and got a full compliment of 48 tasks, now whenever it asks for GPU WUs it tells me I have my 48 tasks (6 per core) and "no work sent". Then it willreport CPU tasks and get whatever it needs to make up for completed cpu wu's,leaving no room for GPU WUs. Tried setting preferences to NO CPU/YES GPU, still kept getting CPU WU's!!! ANY SUGGESTIONS?
;-p
ID: 30340 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLogan
Avatar

Send message
Joined: 15 Aug 08
Posts: 163
Credit: 3,876,869
RAC: 0
3 million credit badge10 year member badge
Message 30341 - Posted: 7 Sep 2009, 19:09:45 UTC - in response to Message 30340.  
Last modified: 7 Sep 2009, 19:14:14 UTC

Still no CUDA!!! I have done a complete re-install of EVERYTHING, I'm using 6.10.3 - 64 bit version/driver version 190.62/Vista Home Basic 64 bit/ preferences are set to yes for GPU and CPU AND tests,I have opti app ssse4.2 installed also. My video card is a gtx 275 896mb, this card can run a CUDA task in just under 6 mins,it downloaded 1 GPU task when I reattached, it then asked for GPU WUs 3 times in a row and got "no tasks sent", it then asked for CPU WUs and got a full compliment of 48 tasks, now whenever it asks for GPU WUs it tells me I have my 48 tasks (6 per core) and "no work sent". Then it willreport CPU tasks and get whatever it needs to make up for completed cpu wu's,leaving no room for GPU WUs. Tried setting preferences to NO CPU/YES GPU, still kept getting CPU WU's!!! ANY SUGGESTIONS?
;-p

Uninstall Opti app if you want to crunch with GPU. Rename or delete the app_info.xml file and you will get CUDA app and CUDA work.

The 'anonym platform' that your system reports when you have an opti app, only allows to you to crunch whit the apps specified in the app_info.xml file...


Best regards.
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)
ID: 30341 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBruce
Avatar

Send message
Joined: 28 Apr 08
Posts: 1415
Credit: 2,716,428
RAC: 0
2 million credit badge10 year member badge
Message 30343 - Posted: 7 Sep 2009, 19:14:06 UTC - in response to Message 30341.  
Last modified: 7 Sep 2009, 19:15:40 UTC

So I cant use opti app to Run CPU? I was hoping to run cpu and gpu, but cpu is too slow without opti app.If I rename file will it still run opti app?
ID: 30343 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLogan
Avatar

Send message
Joined: 15 Aug 08
Posts: 163
Credit: 3,876,869
RAC: 0
3 million credit badge10 year member badge
Message 30344 - Posted: 7 Sep 2009, 19:24:16 UTC - in response to Message 30343.  

So I cant use opti app to Run CPU? I was hoping to run cpu and gpu, but cpu is too slow without opti app.If I rename file will it still run opti app?


Let me think on it and test it...
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)
ID: 30344 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBruce
Avatar

Send message
Joined: 28 Apr 08
Posts: 1415
Credit: 2,716,428
RAC: 0
2 million credit badge10 year member badge
Message 30346 - Posted: 7 Sep 2009, 19:36:44 UTC - in response to Message 30344.  

So I cant use opti app to Run CPU? I was hoping to run cpu and gpu, but cpu is too slow without opti app.If I rename file will it still run opti app?


Let me think on it and test it...

Ok I'll check back in awhile. Thanks for your help Logan.
;-p
ID: 30346 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
scibuff

Send message
Joined: 12 Apr 09
Posts: 3
Credit: 43,167
RAC: 0
10 thousand credit badge10 year member badge
Message 30350 - Posted: 7 Sep 2009, 21:02:52 UTC

Hi guys, my Boinc app finished about 20 CUDA Milkyway@Home jobs all ended by "computational error". Could you please guide me through the process of how to collect and send you the necessary data so that the issue could be looked at? Thank you. SciBuff
ID: 30350 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileLogan
Avatar

Send message
Joined: 15 Aug 08
Posts: 163
Credit: 3,876,869
RAC: 0
3 million credit badge10 year member badge
Message 30351 - Posted: 7 Sep 2009, 21:08:19 UTC - in response to Message 30350.  

Hi guys, my Boinc app finished about 20 CUDA Milkyway@Home jobs all ended by "computational error". Could you please guide me through the process of how to collect and send you the necessary data so that the issue could be looked at? Thank you. SciBuff


<core_client_version>6.6.36</core_client_version>
<![CDATA[
<message>
Incorrect function. (0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
Device index specified on the command line was 0
Looking for a Double Precision capable NVIDIA GPU
The device Device Emulation (CPU) from the command line cannot be used because a device supporting compute capability 1.3 (Double Precision) is required
Found 1 CUDA cards
Found a Device Emulation (CPU)
Device cannot be used, it does not have compute capability 1.3 support
No compute capability 1.3 cards have been found, exiting...

</stderr_txt>
]]>
??????
Logan.

BOINC FAQ Service (Ahora, también disponible en Español/Now available in Spanish)
ID: 30351 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · Next

Message boards : Number crunching : CUDA Application for 32 bit Windows

©2020 Astroinformatics Group