Welcome to MilkyWay@home

I can't run MW if there are ATI and NVIDIA GPUs installed both


Advanced search

Message boards : Number crunching : I can't run MW if there are ATI and NVIDIA GPUs installed both
Message board moderation

To post messages, you must log in.

AuthorMessage
Crab

Send message
Joined: 6 Oct 09
Posts: 25
Credit: 4,849,998
RAC: 0
3 million credit badge12 year member badge
Message 33704 - Posted: 25 Nov 2009, 21:54:38 UTC

Hello!
today i add nvidia card to my system and boinc refuses to run MW on secondary ATI card then.
boinc told: 26.11.2009 0:32:10 NVIDIA GPU 0: GeForce GT 240 (driver version 19562, CUDA version 3000, compute capability 1.2, 1024MB, 257 GFLOPS peak)

and MW gets none WU.

before this upgrade it was all ok. boinc told GPU 0: Ati .... and MW starts to get and crunch WUs.

so, i think this is because BOINC does't recognize another GPU (ati).
what i have to do to fix it?

Thanks in advance!
ID: 33704 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileverstapp
Avatar

Send message
Joined: 26 Jan 09
Posts: 589
Credit: 497,834,261
RAC: 0
300 million credit badge13 year member badge
Message 33705 - Posted: 25 Nov 2009, 21:57:01 UTC

>what i have to do to fix it?
Throw the Nvidia card in the bin. :)
Cheers,

PeterV

.
ID: 33705 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Crab

Send message
Joined: 6 Oct 09
Posts: 25
Credit: 4,849,998
RAC: 0
3 million credit badge12 year member badge
Message 33707 - Posted: 25 Nov 2009, 22:04:30 UTC - in response to Message 33705.  
Last modified: 25 Nov 2009, 22:05:19 UTC

in this case i can't crunch while i doing something on my computer because i must stop MW for it's graphics lags during crunch )
ID: 33707 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCappy [Team Musketeers]
Avatar

Send message
Joined: 3 Oct 07
Posts: 71
Credit: 33,212,009
RAC: 0
30 million credit badge14 year member badge
Message 33708 - Posted: 25 Nov 2009, 22:06:23 UTC

inst the 240 a single percision card???? if so it wont work on MW.

MW only takes Double percision cards.
ID: 33708 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Crab

Send message
Joined: 6 Oct 09
Posts: 25
Credit: 4,849,998
RAC: 0
3 million credit badge12 year member badge
Message 33711 - Posted: 25 Nov 2009, 22:18:23 UTC - in response to Message 33708.  

>inst the 240 a single percision card???? if so it wont work on MW.

i know it.
once again:
a have two GPU in my system: first - ATI and second Nvidia and i want to set ATI as dedicated MW cruncher and nvidia as dedicated card for 3d application and so on.
it is impossible to do something when alone ATI is crunch MW because of graphics lags (delayed response)
ID: 33711 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCappy [Team Musketeers]
Avatar

Send message
Joined: 3 Oct 07
Posts: 71
Credit: 33,212,009
RAC: 0
30 million credit badge14 year member badge
Message 33715 - Posted: 25 Nov 2009, 22:52:21 UTC

oh ok i missunderstood ya,, sry :( interresting...

Slicker over at Collatz might have a answer for ya....

i know he is crunching with both ATI and Nvidia cards

in a couple diffrent box's... maybe he might have a work

around for what your trying to do so boinc only see's

the ATI card so its the only 1 that crunch's ????

i know he had a hell of a time getting both cards to crunch

(ATI/Nvidia) in the same box so he prolly ran across a way

to do what you want.... go pm him on Collatz's MB and ask,,

cant hurt
ID: 33715 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfilePaul D. Buck

Send message
Joined: 12 Apr 08
Posts: 621
Credit: 161,934,067
RAC: 0
100 million credit badge14 year member badge
Message 33720 - Posted: 25 Nov 2009, 23:07:36 UTC

With the latest versions of BOINC you can tell BOINC to NOT use specific GPUs
ID: 33720 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Crab

Send message
Joined: 6 Oct 09
Posts: 25
Credit: 4,849,998
RAC: 0
3 million credit badge12 year member badge
Message 33727 - Posted: 25 Nov 2009, 23:22:58 UTC - in response to Message 33720.  

>With the latest versions of BOINC you can tell BOINC to NOT use specific GPUs

yes, this is what im searching for. i have version 6.10.18 (latest avaiable). but how to tell it not to use nvidia?

thanks!

2 Cappy: thanks alot! i'll ask him if can't fix it in reasonable time ;)
ID: 33727 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge14 year member badge
Message 33732 - Posted: 26 Nov 2009, 0:19:14 UTC

If you have the optimised ap then read the readme file.

Exclusion of GPUs: x (default none)
If a certain GPU should not be used by the app, one can exclude it. The GPU number has to be in
the range 0..31. The first GPU in the system has the number 0. This option can be used multiple
times. Per default, all double precision capable ATI GPUs are used. You don't have to exclude
cards supporting only single precision, it is done automatically.

Example:
<cmdline>x1 x2</cmdline>
The app will not use the second and the third GPU in the system.
ID: 33732 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileJockMacMad TSBT
Avatar

Send message
Joined: 28 Jan 09
Posts: 31
Credit: 85,934,108
RAC: 0
50 million credit badge13 year member badge
Message 33735 - Posted: 26 Nov 2009, 0:36:47 UTC
Last modified: 26 Nov 2009, 0:39:47 UTC

A couple of things are you on XP or Windows 7?

Is your monitor plugged into the ATI or the nVidia (I presume the nVidia as you want to see the desktop on it).

Do you have a dummy vga plug in the ATI card or a monitor? i.e. is there something plugged into the card.

I am guessing your monitor is plugged into the nVidia but there is nothing plugged into the ATI. Therefore when you start BOINC up it sees the nVidia but not the ATI. If this is the case you can try extending the desktop uto the ATI and failing that you will need a dummy vga plug for it or another monitor plugged in.

When you start BOINC up does it report both cards in the messages tab? On my windows 7 box I see the appear nVidia 1st (which has the monitor attached) and on the very next line the ATI card shows (using a dummy vga).

Also you say the ATI is 1st and the nVidia is second have you checked the PCI-E slot numbers on the MB to make sure they really are that way round and it ws not not the case that the ATI was in slot 2 all along? (Depends on the MB if that would work but I have seen).

I also found I could install the full nVidia tools but had only to install the ATI drivers and not Catalyst as they clashed. Saying that I have now managed to get around that with the latest Catalyst running on there now with some nVidia drivers around 191.xx.

Hope that in some way helps :)
ID: 33735 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Donnie
Avatar

Send message
Joined: 19 Jul 08
Posts: 67
Credit: 272,086,462
RAC: 0
200 million credit badge13 year member badge
Message 33737 - Posted: 26 Nov 2009, 1:06:46 UTC - in response to Message 33704.  
Last modified: 26 Nov 2009, 1:14:21 UTC

Hello!
today i add nvidia card to my system and boinc refuses to run MW on secondary ATI card then.
boinc told: 26.11.2009 0:32:10 NVIDIA GPU 0: GeForce GT 240 (driver version 19562, CUDA version 3000, compute capability 1.2, 1024MB, 257 GFLOPS peak)

and MW gets none WU.

before this upgrade it was all ok. boinc told GPU 0: Ati .... and MW starts to get and crunch WUs.

so, i think this is because BOINC does't recognize another GPU (ati).
what i have to do to fix it?

Thanks in advance!


From what I could find, if you don't want to run a particular card with 6.10.13+, you can add a config file. I don't know how or where it goes since I don't use it. You will need a dummy plug on the secondary ATI slot and extend it into your desktop or plug in another monitor!

In Boinc 6.10.13+ you can disable any GPU from use by Boinc by putting a line in your cc_config.txt file (you can ignore more than one if you want).

NVIDIA -
Disable first NVIDIA GPU use:
<ignore_cuda_dev>0</ignore_cuda_dev>

Disable second NVIDIA GPU use:
<ignore_cuda_dev>1</ignore_cuda_dev>


ATI -
Disable first ATI GPU use:
<ignore_ati_dev>0</ignore_ati_dev>

Disable second ATI GPU use:
<ignore_ati_dev>1</ignore_ati_dev>


Also found this. It might be placed in the high level BOINC folder, I don't know.

Client_configuration
ID: 33737 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Crab

Send message
Joined: 6 Oct 09
Posts: 25
Credit: 4,849,998
RAC: 0
3 million credit badge12 year member badge
Message 33740 - Posted: 26 Nov 2009, 2:04:44 UTC - in response to Message 33735.  

>A couple of things are you on XP or Windows 7?

XP

>Is your monitor plugged into the ATI or the nVidia (I presume the nVidia as you want to see the desktop on it).

monitor is plugged to nvidia of course.

>Do you have a dummy vga plug in the ATI card or a monitor? i.e. is there something plugged into the card.

yes. the problem was what desktop was not extended to ati, so windows disables ati gpu. now it is ok, desktop is extended to ati, and ati crunching =)

thanks all! =)
ID: 33740 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : I can't run MW if there are ATI and NVIDIA GPUs installed both

©2022 Astroinformatics Group