Welcome to MilkyWay@home

known issues


Advanced search

Message boards : Number crunching : known issues
Message board moderation

To post messages, you must log in.

AuthorMessage
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 1307 - Posted: 3 Jan 2008, 10:40:14 UTC
Last modified: 13 Mar 2008, 23:27:35 UTC

In an attempt to keep everyone in the know and making debugging everything a bit easier, i'm going to make this post sticky, and edit it as bugs get found/fixed. So feel free to post to here to let me know whats going wrong and i can update it. This will let new users know what our problems are and hopefully make everyones life easier.

So far (i'm sure i'm missing a couple here):

1. The workunit limit (for the time being) is 20, there's not too much i can do about this at the moment, because of how things work server side. Any larger and most of the work people would be doing would be outdated and useless.

2. On windows machines, occasionally a workunit will break and this will display a popup message causing boinc to freeze. We're still not quite sure why this is happening yet.

3. There are some php errors on the forums, the only one i know about thats still happening is:
Notice: Object of class Category could not be converted to int in /export/share0/www/boinc/milkyway/html/inc/forum_mysql_dbh.inc on line 51

4. Some workunits appear to just freeze. We're not quite sure whats causing this but we're looking into it.

5. Changing a profile picture doesnt work, gives:
Warning: imagejpeg() [function.imagejpeg]: Unable to open '../user_profile/user_profile/images/385.jpg' for writing: No such file or directory in /export/share0/www/boinc/milkyway/html/inc/profile.inc on line 272
Warning: imagejpeg() [function.imagejpeg]: Unable to open '../user_profile/user_profile/images/385_sm.jpg' for writing: No such file or directory in /export/share0/www/boinc/milkyway/html/inc/profile.inc on line 273
Profile Saved

This is a work in progress, so i'm sure i've missed quite a few, so please just post them and i'll add them to the list.

**EDIT 3/13**
removed the memory leak error, the stats update error and the progress bar error as i think we've gotten these fixed. also cleaned up a few of the posts so this thread makes more sense.
ID: 1307 · Rating: 1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 1517 - Posted: 17 Jan 2008, 0:16:04 UTC

When I view my profile, this is at the top:

Fatal error: Call to undefined method stdClass::hasImagesAsLinks() in /export/share0/www/boinc/milkyway/html/inc/text_transform.inc on line 109
ID: 1517 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 1620 - Posted: 29 Jan 2008, 14:13:32 UTC

I got this at the top of the page when I started a new topic under the science section:

Notice: Object of class Category could not be converted to int in /export/share0/www/boinc/milkyway/html/inc/forum_mysql_dbh.inc on line 51
ID: 1620 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Odysseus

Send message
Joined: 10 Nov 07
Posts: 95
Credit: 9,777,256
RAC: 20,967
5 million credit badge10 year member badge
Message 1861 - Posted: 5 Mar 2008, 2:41:23 UTC
Last modified: 5 Mar 2008, 2:41:49 UTC

Still getting “Notice: Undefined property: stdClass::$connect_frac in /export/share0/www/boinc/milkyway/html/inc/host.inc on line 132” on my computer summaries, but the rest of the page content seems fine.
ID: 1861 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfilePhiladelphia
Avatar

Send message
Joined: 9 Nov 07
Posts: 131
Credit: 180,454
RAC: 0
100 thousand credit badge10 year member badge
Message 2140 - Posted: 9 Mar 2008, 22:53:25 UTC - in response to Message 1861.  

Still getting “Notice: Undefined property: stdClass::$connect_frac in /export/share0/www/boinc/milkyway/html/inc/host.inc on line 132” on my computer summaries, but the rest of the page content seems fine.



I get the following error as well, but as you said, everything else looks fine, but then again, what do I know, lol.


CLICK TO HELP BUILD
ID: 2140 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2149 - Posted: 10 Mar 2008, 19:46:47 UTC - in response to Message 2140.  


I get the following error as well, but as you said, everything else looks fine, but then again, what do I know, lol.



Don't worry buddy ;)

hopefully that one will get solved along with the server upgrade later


Join Support science! Joinc Team BOINC United now!
ID: 2149 · Rating: -1 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfilePhiladelphia
Avatar

Send message
Joined: 9 Nov 07
Posts: 131
Credit: 180,454
RAC: 0
100 thousand credit badge10 year member badge
Message 2158 - Posted: 11 Mar 2008, 2:41:50 UTC - in response to Message 2149.  


I get the following error as well, but as you said, everything else looks fine, but then again, what do I know, lol.



Don't worry buddy ;)

hopefully that one will get solved along with the server upgrade later


I'm all good with it.

WU's are processing and getting credit - more of an FYI for the folks at MilkyWay.
CLICK TO HELP BUILD
ID: 2158 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 2352 - Posted: 18 Mar 2008, 13:02:10 UTC

Get this on the main page now:

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /export/share0/www/boinc/milkyway/html/inc/uotd.inc on line 36

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /export/share0/www/boinc/milkyway/html/inc/uotd.inc on line 39
ID: 2352 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileDoctorNow
Avatar

Send message
Joined: 28 Aug 07
Posts: 146
Credit: 10,276,862
RAC: 0
10 million credit badge10 year member badge
Message 2356 - Posted: 18 Mar 2008, 13:23:51 UTC - in response to Message 2352.  

Get this on the main page now:

Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /export/share0/www/boinc/milkyway/html/inc/uotd.inc on line 36

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /export/share0/www/boinc/milkyway/html/inc/uotd.inc on line 39

Yes, the user-database must be broken.
Try to click on any profile pic, you get errors everywhere...
Member of BOINC@Heidelberg and ATA!

My BOINCstats
ID: 2356 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Misfit
Avatar

Send message
Joined: 27 Aug 07
Posts: 915
Credit: 1,503,319
RAC: 0
1 million credit badge10 year member badge
Message 2420 - Posted: 20 Mar 2008, 5:14:53 UTC

Known issue: I think your forums are about to break.
me@rescam.org
ID: 2420 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilerebirther
Avatar

Send message
Joined: 28 Aug 07
Posts: 51
Credit: 8,353,747
RAC: 0
5 million credit badge10 year member badge
Message 2430 - Posted: 20 Mar 2008, 22:25:03 UTC

Credits back to normal soon?
ID: 2430 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 2436 - Posted: 21 Mar 2008, 0:25:37 UTC - in response to Message 2430.  
Last modified: 21 Mar 2008, 0:32:42 UTC

Credits back to normal soon?

Credits are normal. We're working on gettign it "in line" ... however the mac app is still as slow as before so that'll be the next thing to focus on after the server upgrade is done 100%.

Join Support science! Joinc Team BOINC United now!
ID: 2436 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim Wilkins

Send message
Joined: 1 Jan 08
Posts: 40
Credit: 1,676,165
RAC: 0
1 million credit badge10 year member badge
Message 2438 - Posted: 21 Mar 2008, 12:12:46 UTC

The Mac Intel App seems not to checkpoint. With the short running times, is it supposed to?

Thanks.
Jim
ID: 2438 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge10 year member badge
Message 2609 - Posted: 24 Mar 2008, 0:12:00 UTC

The create/edit profile works now, but the view others profile doesn't seem to have any more than it did a couple months ago.
Doesn't expecting the unexpected make the unexpected the expected?
If it makes sense, DON'T do it.
ID: 2609 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 2793 - Posted: 24 Mar 2008, 23:17:33 UTC - in response to Message 2438.  

The Mac Intel App seems not to checkpoint. With the short running times, is it supposed to?

Thanks.
Jim


it should be checkpointing, i'll take a look into this.
ID: 2793 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileMichael Roberts
Avatar

Send message
Joined: 25 Dec 07
Posts: 10
Credit: 217,283
RAC: 0
100 thousand credit badge10 year member badge
Message 3767 - Posted: 13 Jun 2008, 7:59:05 UTC
Last modified: 13 Jun 2008, 8:01:08 UTC

I woke up to a workunit which has been running for about ten hours still with zero progress, so v1.23 hasn't fixed the "some workunits just freeze" problem. I will leave it suspended for a day or so in case there is any useful information we can extract from it.
ID: 3767 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge10 year member badge
Message 3768 - Posted: 13 Jun 2008, 8:05:00 UTC - in response to Message 3767.  

I woke up to a workunit which has been running for about ten hours still with zero progress, so v1.23 hasn't fixed the "some workunits just freeze" problem. I will leave it suspended for a day or so in case there is any useful information we can extract from it.


You can safely abort that wu. It's caused by a bad set of wus (gs_600).




Join Support science! Joinc Team BOINC United now!
ID: 3768 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileMichael Roberts
Avatar

Send message
Joined: 25 Dec 07
Posts: 10
Credit: 217,283
RAC: 0
100 thousand credit badge10 year member badge
Message 3769 - Posted: 13 Jun 2008, 8:13:15 UTC - in response to Message 3768.  

You can safely abort that wu. It's caused by a bad set of wus (gs_600).


Thanks for the quick reply. Done that. Happy again!
ID: 3769 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileRudy Toody

Send message
Joined: 29 Jul 08
Posts: 9
Credit: 100,721,007
RAC: 0
100 million credit badge10 year member badge
Message 4547 - Posted: 30 Jul 2008, 15:51:33 UTC

1.23 WU progress hits 50% at 3+ hours and hits 100% about 10 seconds later.
ID: 4547 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : known issues

©2020 Astroinformatics Group