Welcome to MilkyWay@home

Simultaneously CPU & GPU


Advanced search

Message boards : Number crunching : Simultaneously CPU & GPU
Message board moderation

To post messages, you must log in.

AuthorMessage
ProfileSutaru Tsureku

Send message
Joined: 30 Apr 09
Posts: 99
Credit: 25,702,921
RAC: 1,063
20 million credit badge10 year member badge
Message 40377 - Posted: 13 Jun 2010, 19:39:55 UTC
Last modified: 13 Jun 2010, 19:49:38 UTC

I want to let run the CPU & GPU simultaneously.

If with stock also with app_info.xml file, I get only GPU WUs if CPU&GPU are checked in the preferences.

If the CPU idle, I need to change the preferences to only CPU, need to wait that 2 GPU results are finished, ULed and reported and then I have again two CPU WUs DLed and running. Then I need to check again also GPU for to get GPU WUs.

I guess this isn't wanted.. ;-)


[EDIT: Duo-CPU with one GPU. I can have max. 12 WUs in BOINC (Message from server: (reached limit of 12 tasks in progress)).]
ID: 40377 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vid Vidmar*
Avatar

Send message
Joined: 29 Aug 07
Posts: 81
Credit: 60,360,858
RAC: 0
50 million credit badge10 year member badge
Message 40381 - Posted: 14 Jun 2010, 8:41:29 UTC - in response to Message 40377.  

Hi Sutaru.
Is this what you are looking for?
BR,
ID: 40381 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileSutaru Tsureku

Send message
Joined: 30 Apr 09
Posts: 99
Credit: 25,702,921
RAC: 1,063
20 million credit badge10 year member badge
Message 40393 - Posted: 15 Jun 2010, 9:17:12 UTC - in response to Message 40381.  
Last modified: 15 Jun 2010, 9:21:27 UTC

Hi, thanks for reply.

No, I didn't meant the app_info.xml file.
I made already my own. ;-) Message 40371

My 'problem' is, I have both (CPU & GPU) apps in the app_info.xml file.
The MilkyWay settings are CPU & GPU.
But I get only GPU WUs.

For example, I crunched all MW WUs, so I had an empty cache.
For some minutes I enabled again 'new tasks' and BOINC DLed immediately 12 GPU WUs. No CPU WU.
For to let BOINC DL again CPU WUs, I need to change the project preferences to only CPU.
Then in future..
After a result of a GPU WU was UL/reported, BOINC DL a CPU WU.
After a result of a GPU WU was UL/reported, BOINC DL a CPU WU.
.....
After a result of a GPU WU was UL/reported, BOINC DL a CPU WU.

If BOINC have again enough CPU WUs (for example 10), I need to check again GPU (both CPU & GPU) in the preferences that BOINC DL GPU WUs.


I'm the only one which have this 'problem'?
Or maybe this is wanted from the project?
ID: 40393 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vid Vidmar*
Avatar

Send message
Joined: 29 Aug 07
Posts: 81
Credit: 60,360,858
RAC: 0
50 million credit badge10 year member badge
Message 40398 - Posted: 15 Jun 2010, 12:25:29 UTC - in response to Message 40393.  

Hm, no, I haven't seen anything like that on my cpu/gpu mixed cruncher, however that box also crunches PrimeGrid and thus always has cpu work at hand. Which BOINC version are you running BTW?
BR,
ID: 40398 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileSutaru Tsureku

Send message
Joined: 30 Apr 09
Posts: 99
Credit: 25,702,921
RAC: 1,063
20 million credit badge10 year member badge
Message 40403 - Posted: 15 Jun 2010, 16:39:37 UTC - in response to Message 40398.  

My host isn't hidden.. ;-)
I use the latest recommended BOINC V6.10.56 .

Only to understand well.
You have also an app_info.xml file with both entries (CPU & GPU).
You have checked CPU & GPU in your project preferences.

Your PC got MilkyWay CPU WUs in past?

I guess my 'problem' isn't seen often, because 99,9 % of the MilkyWay members crunch only on the GPU.. ;-)

ID: 40403 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 134,943,967
RAC: 8,802
100 million credit badge10 year member badge
Message 40404 - Posted: 15 Jun 2010, 17:25:42 UTC

Hi Sutaru,

a couple of weeks ago I had a similar problem. I got CPU and GPU WU's, but I wanted only GPU WU's.
I posted my problem here and I got an answer, which helped me to solve it. MW needs accurate settings for home, office etc, even if you haven't set any preferences for that.
In my case the preferences for home etc had CPU and GPU checked. I unchecked the CPU, have still no preferences set on my PC's, and I don't get CPU WU's any more.
Good luck!

Regards,
Alexander
ID: 40404 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge10 year member badge
Message 40412 - Posted: 15 Jun 2010, 19:07:20 UTC

If you use an app_info I don't think you can get both simultaneously. Try renaming your app_info to something else and restarting BOINC, ensure you have both CPU and GPU checked on the web site and just let MW use the stock apps. It might just happen.
ID: 40412 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vid Vidmar*
Avatar

Send message
Joined: 29 Aug 07
Posts: 81
Credit: 60,360,858
RAC: 0
50 million credit badge10 year member badge
Message 40414 - Posted: 15 Jun 2010, 20:14:59 UTC - in response to Message 40403.  
Last modified: 15 Jun 2010, 20:18:47 UTC

My host isn't hidden.. ;-)
I use the latest recommended BOINC V6.10.56 .

Only to understand well.
You have also an app_info.xml file with both entries (CPU & GPU).
You have checked CPU & GPU in your project preferences.

Your PC got MilkyWay CPU WUs in past?
...


That is correct. With that app_info.xml I run both CPU and GPU apps successfuly ever since I posted it here on these boards (did I mention that with it I run 2 WUs on each GPU at once?). But once again I must admit that I didn't try running MW solo with it. Hope, you get it sorted out soon.
BR

[edit] TGG luckily, you are wrong. ;) [/edit]
ID: 40414 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
James Nunley

Send message
Joined: 29 Nov 07
Posts: 39
Credit: 74,300,629
RAC: 0
50 million credit badge10 year member badge
Message 40417 - Posted: 15 Jun 2010, 20:40:15 UTC

In my experience running a cpu workunit causes the gpu to run slower to the point where you would actually be doing less work for milkyway by running on the cpu and gpu at the same time.

Try timing some gpu units with no load on the cpu and then with load and you will see what I mean. The cpu units do not make up for the loss of gpu performance.

This is with my system of a E7200 O/C to 3.16 and an HD4850 O/C to 725Mhz

Check yours and see if it is the same.
ID: 40417 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Haris Dublas

Send message
Joined: 25 Feb 10
Posts: 49
Credit: 10,136,474
RAC: 0
10 million credit badge10 year member badge
Message 40428 - Posted: 16 Jun 2010, 6:02:20 UTC
Last modified: 16 Jun 2010, 6:06:10 UTC

If you set boinc to "Use at most 80-90% CPU time", your gpu times wont be affected much. There's no need to leave a cpu core/thread free. Doing concurrent wus also lessens the cpu usage spikes a little bit, leaving your cpu cores free is just a waste of resources (unless you want to save power consumption or for keeping your overall system temps low).
ID: 40428 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Chaosquo

Send message
Joined: 3 May 10
Posts: 14
Credit: 15,793,156
RAC: 0
10 million credit badge10 year member badge
Message 40429 - Posted: 16 Jun 2010, 7:26:03 UTC - in response to Message 40428.  

I have set BOINC to only use 80% CPU time (for another project) and I get a slowdown of 10% for the GPU. I think it is a problem of priority/congestion ..
ID: 40429 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Haris Dublas

Send message
Joined: 25 Feb 10
Posts: 49
Credit: 10,136,474
RAC: 0
10 million credit badge10 year member badge
Message 40431 - Posted: 16 Jun 2010, 8:52:27 UTC

Since you are using a 5850, the tasks finish in less than 2 mins so I guess you need a lower setting on the cpu time.
ID: 40431 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Vid Vidmar*
Avatar

Send message
Joined: 29 Aug 07
Posts: 81
Credit: 60,360,858
RAC: 0
50 million credit badge10 year member badge
Message 40436 - Posted: 16 Jun 2010, 11:17:35 UTC - in response to Message 40417.  

For GPU app. I specify b-1 command line option, which enables aggressive GPU polling, resulting in 90%+ GPU usage and perhaps 2% CPU (for polling). So, there is absolutely no significant loss. Even now, with MW @ 1/4 GPU RS and DNETC @ 3/4 GPU RS I get a RAC of 75k+ here and 275k+ over there. That's a RAC of 350k+ on this machine with a 4870 and a 5870 in it.
BR
ID: 40436 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfilePurple Rabbit
Avatar

Send message
Joined: 9 Nov 08
Posts: 44
Credit: 109,426,841
RAC: 7,745
100 million credit badge10 year member badge
Message 40451 - Posted: 16 Jun 2010, 23:04:25 UTC - in response to Message 40403.  
Last modified: 16 Jun 2010, 23:17:16 UTC

...<snip>
Your PC got MilkyWay CPU WUs in past?

I guess my 'problem' isn't seen often, because 99,9 % of the MilkyWay members crunch only on the GPU.. ;-)

I am running both CPU and (occasionally) GPU Milkyway tasks concurrently with an app_info file. On my Q6600/GTX-260 host I get both types of tasks. The CPU tasks can be few and far between however :)

I found on Collatz (where I do the same thing) that the CPU task fetch seemed to be inhibited by the number of other tasks (from other projects) I had going. One day, quite by accident, I reduced the number of other project tasks and suddenly I got new Collatz CPU tasks!

Milkyway seems to give me one CPU task for each CPU task I give it back. I tend to have only one CPU task at a time, but many GPU tasks. I think this is a BOINC "thing". We're supposed to like this?
ID: 40451 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Simultaneously CPU & GPU

©2020 Astroinformatics Group