Welcome to MilkyWay@home

Slow processing of workunits


Advanced search

Message boards : Application Code Discussion : Slow processing of workunits
Message board moderation

To post messages, you must log in.

AuthorMessage
Flaming Candles

Send message
Joined: 15 Jul 09
Posts: 7
Credit: 20,189
RAC: 0
10 thousand credit badge10 year member badge
Message 40947 - Posted: 16 Jul 2010, 16:37:09 UTC

I've been crunching some units and they seem to be crunching for one second then not crunching for the next second. Like a clock, on, off, on, off.
This to me seems a bit wasteful as it looks like I'll never get the units completed in the time allocated, but could be just a glitch (in particular to my system) but I've been instructed to place the issue here to see if anyone else has the same problem.

Application:MilkyWay@Home 0.19

The units names are:-

de_12_3s_2_314359_1278454442_1 Report Deadline 14/07/2010
de_14_3s_2_620517_1278525061_0 Report Deadline 15/07/2010

Time to completion approx. 29Hrs per unit

I received the units approximately nine days before the deadline and progress of the units was 15% after four days running milkyway@home exclusively, and with boinc running while computer is in use. The average CPU usage was around 8.5%, even after several hours of crunching.
Computer specs:
Operating System
System Model Windows Vista Home Premium Service Pack 2 (build 6002)
Install Language: English (United States)
System Locale: English (United Kingdom)
TOSHIBA Satellite A300
Enclosure Type: Other

Processor
2.10 gigahertz Intel Core2 Duo
64 kilobyte primary memory cache
64-bit ready
Multi-core (2 total)
Not hyper-threaded
Board: TOSHIBA Satellite A300
Bus Clock: 200 megahertz
3070 Megabytes Usable Installed Memory
ATI Mobility Radeon HD 3470 [Display adapter]

16/07/2010 17:33:27||Running CPU benchmarks
16/07/2010 17:33:27||Suspending computation - running CPU benchmarks
16/07/2010 17:33:58||Benchmark results:
16/07/2010 17:33:58|| Number of CPUs: 2
16/07/2010 17:33:58|| 1930 floating point MIPS (Whetstone) per CPU
16/07/2010 17:33:58|| 4113 integer MIPS (Dhrystone) per CPU
16/07/2010 17:33:59||Resuming computation

I'm looking for a solution as I don't want my computer to be crunching units only for them to be disregarded and/or deleted because of them being overdue.

Thanks in advance

Mark B
ID: 40947 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileThe Gas Giant
Avatar

Send message
Joined: 24 Dec 07
Posts: 1947
Credit: 240,884,648
RAC: 0
200 million credit badge10 year member badge
Message 40955 - Posted: 16 Jul 2010, 22:21:17 UTC

Check your preferences to always use the CPU and/or GPU. Leave applications in memory. Check you aren't throttling your by selecting use at most 100% cpu time.

Install an optimised application to speed up crunching time.
ID: 40955 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Flaming Candles

Send message
Joined: 15 Jul 09
Posts: 7
Credit: 20,189
RAC: 0
10 thousand credit badge10 year member badge
Message 40963 - Posted: 17 Jul 2010, 14:09:22 UTC - in response to Message 40955.  

Yep, processor usage is set to use at most 100% of the processors, and 100% of CPU time. Memory usage is set use 100% when computer is in use, and 100% when computer is idle. It's also set to use at most 100% of swap space. Leave applications in memory box is ticked.

As for optimised application, to what are you referring?
ID: 40963 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 135,252,965
RAC: 17,397
100 million credit badge10 year member badge
Message 40965 - Posted: 17 Jul 2010, 16:52:57 UTC - in response to Message 40963.  

Yep, processor usage is set to use at most 100% of the processors, and 100% of CPU time. Memory usage is set use 100% when computer is in use, and 100% when computer is idle. It's also set to use at most 100% of swap space. Leave applications in memory box is ticked.

As for optimised application, to what are you referring?


Try this:
http://www.arkayn.us/milkyway/index.html

Regards
Alexander
ID: 40965 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Flaming Candles

Send message
Joined: 15 Jul 09
Posts: 7
Credit: 20,189
RAC: 0
10 thousand credit badge10 year member badge
Message 40970 - Posted: 17 Jul 2010, 21:59:29 UTC - in response to Message 40965.  

I've had a look at arkayn and here's what CPU-Z has to say, Instructions: MMX, SSE (1,2,3,3S,4.1), EM64T, VT-x

So for the optimised apps should I use the SSE3?
ID: 40970 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilearkayn
Avatar

Send message
Joined: 14 Feb 09
Posts: 999
Credit: 74,932,619
RAC: 0
50 million credit badge10 year member badge
Message 40972 - Posted: 17 Jul 2010, 23:12:29 UTC

ID: 40972 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Flaming Candles

Send message
Joined: 15 Jul 09
Posts: 7
Credit: 20,189
RAC: 0
10 thousand credit badge10 year member badge
Message 40984 - Posted: 18 Jul 2010, 16:54:21 UTC - in response to Message 40972.  

Installed as per the instructions, in the meantime I've stopped all other projects from receiving new tasks, so as soon as the current WUs from other projects are finished I should get some new milkyway@home tasks and find out if it's done the trick.
ID: 40984 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Flaming Candles

Send message
Joined: 15 Jul 09
Posts: 7
Credit: 20,189
RAC: 0
10 thousand credit badge10 year member badge
Message 40999 - Posted: 19 Jul 2010, 22:57:48 UTC - in response to Message 40984.  

Whoooooooohooooooo First new WU completed: de_15_3s_2_982999_1279556448_0

19/07/2010 WU received, time to completion just over 27 hours. Report deadline 27/07/2010

Actual time to completion just over 6 hours. Average processer usage 33.2%, much more than before (8.5%!)

This means (I hope) that any and all further WU my computer completes will now be ahead of schedule and not WAY overdue without getting a message from the server saying something along the lines of, file (insert task no.) no longer needed, file deleted.

My thanks to all of you, it's done the trick!

PS I didn't get the anonymous platform message but that's the application that's showing up on the all tasks webpage.

http://i1017.photobucket.com/albums/af291/Sparky362/Tasks.jpg
ID: 40999 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 135,252,965
RAC: 17,397
100 million credit badge10 year member badge
Message 41079 - Posted: 26 Jul 2010, 17:59:36 UTC - in response to Message 40999.  

Whoooooooohooooooo


Congratulations!
Now imagine, you replace your ATI graphic card with an actual HD48xx or (better) HD58xx card. You could finish one wu not in 6 hours, but in 6 minutes or with a high-end card in ~2 minutes.
Your Woohoo would take three lines ...

Alexander
ID: 41079 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileskildude
Avatar

Send message
Joined: 13 Jan 08
Posts: 52
Credit: 59,802,242
RAC: 0
50 million credit badge10 year member badge
Message 41402 - Posted: 11 Aug 2010, 14:43:17 UTC - in response to Message 41079.  

yeah a HD2XXX in definitely not fit for use on MW. Try Collatz sine it only requires the single precision.
Blah blah blah you know the rest
ID: 41402 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
pstehno
Avatar

Send message
Joined: 16 Jun 10
Posts: 6
Credit: 7,402,186
RAC: 0
5 million credit badge10 year member badge
Message 43070 - Posted: 21 Oct 2010, 19:21:58 UTC

I've noticed the new MW0.40 work units take forever to process. Well at least now they don't end with errors.
ID: 43070 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Application Code Discussion : Slow processing of workunits

©2020 Astroinformatics Group