Welcome to MilkyWay@home

Validation Errors on LInux CPU WUs


Advanced search

Message boards : Number crunching : Validation Errors on LInux CPU WUs
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
GlennG

Send message
Joined: 17 Nov 08
Posts: 18
Credit: 130,650,263
RAC: 0
100 million credit badge10 year member badge
Message 42594 - Posted: 5 Oct 2010, 20:37:29 UTC

Starting a short time ago, all of my WUs are running for 1 second and then being reported as failing validation. I haven't changed anything in forever. I am using an optimized linux app by Gispel, but that has been stable for many months. Any ideas??

Glenn
ID: 42594 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
rphstout

Send message
Joined: 11 Feb 10
Posts: 8
Credit: 11,459,648
RAC: 0
10 million credit badge10 year member badge
Message 42595 - Posted: 5 Oct 2010, 20:41:23 UTC - in response to Message 42594.  

Starting a short time ago, all of my WUs are running for 1 second and then being reported as failing validation. I haven't changed anything in forever. I am using an optimized linux app by Gispel, but that has been stable for many months. Any ideas??

Glenn


Yup, same here: increasing numbers of "Validate error" and "Completed, marked as invalid" on the GPU WU's.

ID: 42595 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 137,505,040
RAC: 48,931
100 million credit badge10 year member badge
Message 42597 - Posted: 5 Oct 2010, 22:11:50 UTC - in response to Message 42595.  
Last modified: 5 Oct 2010, 22:28:25 UTC

ID: 42597 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 42599 - Posted: 5 Oct 2010, 22:42:24 UTC - in response to Message 42597.  

That's very strange. The output of the invalid ones is weird, but they should have validated.

I'll take a look into it.

--Travis
ID: 42599 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemdhittle*
Avatar

Send message
Joined: 25 Jun 10
Posts: 284
Credit: 260,490,091
RAC: 0
200 million credit badge10 year member badge
Message 42600 - Posted: 5 Oct 2010, 22:52:08 UTC
Last modified: 5 Oct 2010, 22:53:19 UTC

Hi Travis,

I have quite a few of these workunits that won't validate on any machine.

http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=161266420


And some of these that ran for 3 to 6 SECONDs on NVIDIA cards and validated, but ran for 91 seconds on an ATI card and failed validation.

http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=161285788
ID: 42600 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 42601 - Posted: 5 Oct 2010, 23:13:27 UTC - in response to Message 42599.  

I'm not quite sure what the error is, but I've updated the error logs to have more informative exception reporting which should help me find it.

So if you see any other workunits that have this problem please link them in here so I can figure out what's going on.

--Travis
ID: 42601 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
KWH*
Avatar

Send message
Joined: 24 Aug 10
Posts: 181
Credit: 83,100,546
RAC: 0
50 million credit badge10 year member badge
Message 42602 - Posted: 5 Oct 2010, 23:14:20 UTC

I'm getting a ton of validation errors too but I'm in Win7. Am I wasting CPU time here??
ID: 42602 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 42604 - Posted: 6 Oct 2010, 0:26:26 UTC - in response to Message 42602.  

I'm getting a ton of validation errors too but I'm in Win7. Am I wasting CPU time here??


I'm going to update the windows app and see if that helps anything. Hopefully have a new one out tonight or tomorrow.
ID: 42604 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
KWH*
Avatar

Send message
Joined: 24 Aug 10
Posts: 181
Credit: 83,100,546
RAC: 0
50 million credit badge10 year member badge
Message 42605 - Posted: 6 Oct 2010, 0:31:58 UTC - in response to Message 42604.  

Thanks. Is there anything I need to do on my end?
ID: 42605 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
MP3

Send message
Joined: 27 Mar 10
Posts: 1
Credit: 1,125,190
RAC: 812
1 million credit badge10 year member badge
Message 42606 - Posted: 6 Oct 2010, 0:36:59 UTC

Please have a look at my task http://milkyway.cs.rpi.edu/milkyway/results.php?userid=96192

Just restarted and getting Validate error, Completed, marked as invalid and those succesffuly worth quite a lot of credit for few seconds work.

On Win7 as well.
ID: 42606 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
John Clark

Send message
Joined: 4 Oct 08
Posts: 1734
Credit: 64,228,409
RAC: 0
50 million credit badge10 year member badge
Message 42607 - Posted: 6 Oct 2010, 1:00:48 UTC
Last modified: 6 Oct 2010, 1:01:53 UTC

I am using the CPU (WinXP pro 32bit) and the 0.19 WUs seem to be rushing through and give a mixture of validated and validate errors (probably 6-+% to validating error).

I did both a project reset and a detatch-reattach but still get the same on this host
Go away, I was asleep


ID: 42607 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 42608 - Posted: 6 Oct 2010, 1:08:09 UTC - in response to Message 42605.  

Thanks. Is there anything I need to do on my end?


There shouldn't be.
ID: 42608 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
KWH*
Avatar

Send message
Joined: 24 Aug 10
Posts: 181
Credit: 83,100,546
RAC: 0
50 million credit badge10 year member badge
Message 42611 - Posted: 6 Oct 2010, 3:11:59 UTC - in response to Message 42608.  

Yikes! Now it's getting worse!
ID: 42611 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
KWH*
Avatar

Send message
Joined: 24 Aug 10
Posts: 181
Credit: 83,100,546
RAC: 0
50 million credit badge10 year member badge
Message 42612 - Posted: 6 Oct 2010, 3:14:53 UTC - in response to Message 42611.  

I'm going to shut everything off since it's garbage. No sense wasting resources.
ID: 42612 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Brian Priebe

Send message
Joined: 27 Nov 09
Posts: 108
Credit: 430,760,953
RAC: 0
300 million credit badge10 year member badgeextraordinary contributions badge
Message 42614 - Posted: 6 Oct 2010, 3:28:04 UTC

I agree that things are badly broken and not just in LINUX land: I see the exact same thing in Windows. Am NNT'ing this project on all machines until the problem is fixed.
ID: 42614 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilearkayn
Avatar

Send message
Joined: 14 Feb 09
Posts: 999
Credit: 74,932,619
RAC: 0
50 million credit badge10 year member badge
Message 42615 - Posted: 6 Oct 2010, 3:34:23 UTC

We even have invalid WU validating against each other and causing the actual valid result to be marked invalid.

http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=161348033
http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=161349399
http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=161357816

I have several others that cannot validate because of too many errors.
ID: 42615 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 42617 - Posted: 6 Oct 2010, 4:15:21 UTC - in response to Message 42615.  
Last modified: 6 Oct 2010, 4:18:43 UTC

I'm going to stop this separation search and start a new ones. I think maybe Matt N. used some bad parameter files. I have no idea why the GPU applications would be having these kinds of issues.

--Travis
ID: 42617 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileTravis
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist

Send message
Joined: 30 Aug 07
Posts: 2046
Credit: 26,480
RAC: 0
10 thousand credit badge10 year member badge
Message 42618 - Posted: 6 Oct 2010, 4:22:07 UTC - in response to Message 42617.  

I started up the new searches, let me know if these are having the same error.
ID: 42618 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cthulhu

Send message
Joined: 22 Jan 10
Posts: 3
Credit: 71,094,774
RAC: 0
50 million credit badge10 year member badge
Message 42620 - Posted: 6 Oct 2010, 5:41:56 UTC - in response to Message 42618.  

I've had about 65 validate, 20 go to pending, and no invalids since your post at about 4:22 UTC, Travis. Seems to be working so far for 5870 gpu only on Win7. I'm keeping my fingers crossed that this beast is slain!

Brent
ID: 42620 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWerkstatt

Send message
Joined: 19 Feb 08
Posts: 350
Credit: 137,505,040
RAC: 48,931
100 million credit badge10 year member badge
Message 42622 - Posted: 6 Oct 2010, 9:10:16 UTC

Looks like everything is OK again. WU's of the last 3 hours are all validated.
ID: 42622 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : Number crunching : Validation Errors on LInux CPU WUs

©2020 Astroinformatics Group