Welcome to MilkyWay@home

Nvidia OpenCL updated

Message boards : News : Nvidia OpenCL updated
Message board moderation

To post messages, you must log in.

Previous · 1 · 2

AuthorMessage
Profile Sutaru Tsureku

Send message
Joined: 30 Apr 09
Posts: 101
Credit: 29,871,882
RAC: 674
Message 46239 - Posted: 14 Feb 2011, 21:09:35 UTC - in response to Message 46234.  
Last modified: 14 Feb 2011, 21:18:39 UTC

Thanks for info.

But now I'm confused and I get the question, why published MW@h a new nVIDIA app (OpenCL) and the old nVIDIA app (CUDA23) crunch happy the currently WUs?

The new nVIDIA OpenCL app use the whole Fermi chip (GTX4xx/5xx)?

Maybe an admin of MW@h could answer if it's allowed to use still the old nVIDIA CUDA23 app (which would be the only way for me to crunch MW@h)?
Thanks.

Maybe it's possible to send out the old CUDA23 app to hosts with < 197.x driver and the new OpenCL app to hosts with >/= 197.x driver?
ID: 46239 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Sutaru Tsureku

Send message
Joined: 30 Apr 09
Posts: 101
Credit: 29,871,882
RAC: 674
Message 46240 - Posted: 14 Feb 2011, 21:17:34 UTC - in response to Message 46234.  

Please read this http://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=1505&nowrap=true#46230
Cuda should still work.


BTW.
IIRC, this isn't the stock 0.24_cuda23 app of MW@h.
It's Crunch3r's Fermi mod which have arkayn on his DL site.

But I guess the stock 0.24_cuda23 app of MW@h should work then on old </= GTX2xx GPUs.

But it would be nice to know from an admin, if it's still allowed to use the stock/mod CUDA23 app.

ID: 46240 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matt Arsenault
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 8 May 10
Posts: 576
Credit: 15,979,383
RAC: 0
Message 46241 - Posted: 15 Feb 2011, 1:02:09 UTC - in response to Message 46229.  

Other than the few WU that were too large and errored out, I seem to be running OpenCL WU on my 64 bit Linux 0.54 app successfully. Just looked at two WU, just reported and they validated. Maybe Matt needs to look at the build of the 0.52 Windows app and see if he missed something like the obvious goof he made on the Linux 0.52 app.
No, the Linux one was a huge mistake which would never work for anyone. This Windows problem is more subtle, and I haven't been able to reproduce it. It seems like it crashes very early on fairly consistently for some people, but works for some people. It has been working fine on my systems.
ID: 46241 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matt Arsenault
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 8 May 10
Posts: 576
Credit: 15,979,383
RAC: 0
Message 46242 - Posted: 15 Feb 2011, 1:02:55 UTC - in response to Message 46240.  

Please read this http://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=1505&nowrap=true#46230
Cuda should still work.


BTW.
IIRC, this isn't the stock 0.24_cuda23 app of MW@h.
It's Crunch3r's Fermi mod which have arkayn on his DL site.

But I guess the stock 0.24_cuda23 app of MW@h should work then on old
But it would be nice to know from an admin, if it's still allowed to use the stock/mod CUDA23 app.
It should work for now. At some point after I get the new ATI application ready things will start breaking for old stuff.
ID: 46242 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Keith Myers
Avatar

Send message
Joined: 24 Jan 11
Posts: 708
Credit: 543,285,752
RAC: 140,308
Message 46252 - Posted: 16 Feb 2011, 1:09:11 UTC

Matt, there seems to be a lot of OpenCL tasks today that error out almost immediately on the Linux 0.54 app. Yet, some tasks in the same group of 24 downloads process correctly. I don't know if there is a mix of bad tasks from the oversized ones still being distributed but this might tie into the supposed computation errors on the Windows 0.52 app.

Keith
ID: 46252 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile [AF>EDLS]GuL
Avatar

Send message
Joined: 5 Jun 08
Posts: 21
Credit: 245,803,013
RAC: 0
Message 46267 - Posted: 17 Feb 2011, 6:03:12 UTC - in response to Message 46072.  

All my linux hosts seem to be failing all tasks with the new 0.52 OpenCL app.
I made a really dumb mistake in the Linux build. Should be fixed now (0.54).

Many thanks, it seems to be working now
ID: 46267 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Link
Avatar

Send message
Joined: 19 Jul 10
Posts: 589
Credit: 18,926,785
RAC: 4,539
Message 46345 - Posted: 23 Feb 2011, 15:15:21 UTC - in response to Message 46242.  

At some point after I get the new ATI application ready things will start breaking for old stuff.

Is it already known if the new ATI application will have the same requirements as the old one i.e. will it run on all ATI GPUs listed in the GPU Requirements Thread?
ID: 46345 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Matt Arsenault
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 8 May 10
Posts: 576
Credit: 15,979,383
RAC: 0
Message 46347 - Posted: 25 Feb 2011, 4:43:51 UTC - in response to Message 46345.  

At some point after I get the new ATI application ready things will start breaking for old stuff.

Is it already known if the new ATI application will have the same requirements as the old one i.e. will it run on all ATI GPUs listed in the GPU Requirements Thread?
Yes, it should.
ID: 46347 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile cenit

Send message
Joined: 16 Mar 09
Posts: 58
Credit: 1,129,612
RAC: 0
Message 46982 - Posted: 5 Apr 2011, 21:03:08 UTC - in response to Message 46347.  

At some point after I get the new ATI application ready things will start breaking for old stuff.

Is it already known if the new ATI application will have the same requirements as the old one i.e. will it run on all ATI GPUs listed in the GPU Requirements Thread?
Yes, it should.

except for the fact that OpenCL runs only on HD 4xxx and higher (so no more 3xxx)...
In addition, if you use any OpenCL 1.1 instruction, then only HD 5xxx and above will work...
ID: 46982 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Crunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
Message 46983 - Posted: 5 Apr 2011, 21:53:37 UTC - in response to Message 46982.  

At some point after I get the new ATI application ready things will start breaking for old stuff.

Is it already known if the new ATI application will have the same requirements as the old one i.e. will it run on all ATI GPUs listed in the GPU Requirements Thread?
Yes, it should.

except for the fact that OpenCL runs only on HD 4xxx and higher (so no more 3xxx)...
In addition, if you use any OpenCL 1.1 instruction, then only HD 5xxx and above will work...


Well, according to http://milkyway.cs.rpi.edu/milkyway/forum_thread.php?id=1477&nowrap=true#46691, he's not using opencl, which is a very good thing!!

Instead, CAL++ (or calpp) is being used,which supports 38xx cards as well ;)

Join Support science! Joinc Team BOINC United now!
ID: 46983 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2

Message boards : News : Nvidia OpenCL updated

©2024 Astroinformatics Group