Welcome to MilkyWay@home

OpenCL video card assignment issue


Advanced search

Message boards : Number crunching : OpenCL video card assignment issue
Message board moderation

To post messages, you must log in.

AuthorMessage
v10rider

Send message
Joined: 8 Jan 11
Posts: 8
Credit: 60,640,526
RAC: 0
50 million credit badge9 year member badge
Message 52996 - Posted: 10 Feb 2012, 4:19:27 UTC

I run both a GTX470 and AMD6970 in the same machine. I use the nvidia for SETI(or others when not working) and the AMD for MW. However with the new opencl WU's they are getting assigned to the nvidia card and the 6970 sits idle. Is there a way to not download the opencl wu's or is there another way to solve this issue?
ID: 52996 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilearkayn
Avatar

Send message
Joined: 14 Feb 09
Posts: 999
Credit: 74,932,619
RAC: 0
50 million credit badge10 year member badge
Message 52997 - Posted: 10 Feb 2012, 4:31:28 UTC

Easiest way is to go into project preferences and uncheck the option to use Nvidia.

Or use an app_info that only has the AMD app specified in it.
http://www.arkayn.us/forum/index.php?action=downloads;sa=view;down=59
ID: 52997 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileS@NL - Mellowman
Avatar

Send message
Joined: 9 Dec 07
Posts: 65
Credit: 8,015,709
RAC: 0
5 million credit badge10 year member badge
Message 52998 - Posted: 10 Feb 2012, 4:40:15 UTC - in response to Message 52996.  
Last modified: 10 Feb 2012, 4:42:34 UTC

You could use the alpha version of BOINC 7.xx with the <exclude></exclude> parameter IIRC, or you could run a dual directory setup. This means setting up an extra directory for BOINC (e.g. BOINC2) and run the project you want to run on the Nvidia in 1 directory and the project you want to run on the AMD in the other directory. Just never attach 1 project to both cards if your going to run this way. It can or will give problems, at least on my setup, but I'm using 2 Nvidia cards so that might be the problem.

I can't tell you now how to setup a 2 client/directory setup, because it's 5:34 in the morning and I'm ready to go to bed, but maybe someone else might be able to help you with that.

I myself haven't installed BOINC 7.xx because it's still in alpha stage, but the <exclude></exclude> parameter is very handy to assign certain project to just one GPU. So if you're not scared to run the alpha version, you might give that a try, but it can still contain bugs as it is an alpha version.

Maybe someone else can tell you more about BOINC 7.xx.

I hope this helps to explain the possibilities you have and it's up to you which way you go with it.

Edit: Arkayn posted while I was typing but he came with a good, valid and easier solution.

Anthony.

The longer I live, the more reasons I develop for wanting to die.
ID: 52998 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
v10rider

Send message
Joined: 8 Jan 11
Posts: 8
Credit: 60,640,526
RAC: 0
50 million credit badge9 year member badge
Message 52999 - Posted: 10 Feb 2012, 4:49:04 UTC - in response to Message 52997.  

Thanks arkayn but I only have use AMD checked, use CPU and NVIDIA are unchecked. I may have to try the app_info route.
ID: 52999 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
v10rider

Send message
Joined: 8 Jan 11
Posts: 8
Credit: 60,640,526
RAC: 0
50 million credit badge9 year member badge
Message 53068 - Posted: 11 Feb 2012, 0:50:53 UTC - in response to Message 52999.  

Thanks again arkayn, your opencl app and app_info are working great so far. I just hope it wasn't a mistake upgrading to Boinc 7.
ID: 53068 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
robertmiles

Send message
Joined: 30 Sep 09
Posts: 210
Credit: 22,337,484
RAC: 0
20 million credit badge10 year member badgeextraordinary contributions badge
Message 53101 - Posted: 12 Feb 2012, 2:22:57 UTC

I am often getting this notice:

Milkyway@Home: Notice from server
GPU lacks necessary double precision extension

Does this mean that the method for finding OpenCL GPUs is capable of finding GPUs on the motherboard that are not even supposed to be in use when the one on the graphics board can be used instead? If so, how can we find enough information about those GPUs to be able to tell BOINC not to use them? The first few lines of my BOINC log file gives the information about the GPU on my GTS 450 graphics board, but does not even mention finding a second GPU with less capability.

Many of my Milkyway@Home 1.02 workunits are completing properly.

Seen from BOINC 7.0.3, under 64-bit Windows Vista SP2
ID: 53101 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cliff Harding
Avatar

Send message
Joined: 2 Jul 09
Posts: 26
Credit: 15,938,982
RAC: 249,146
10 million credit badge10 year member badge
Message 53115 - Posted: 12 Feb 2012, 16:40:08 UTC - in response to Message 53068.  

Thanks again arkayn, your opencl app and app_info are working great so far. I just hope it wasn't a mistake upgrading to Boinc 7.


What version were you using prior to the upgrade? I was using 6.12.34 prior to ugrading to 7.0.8 -> 7.0.15 on my A-SYS without any problems except that one of my devices EVGA GTS250 was not double precision compatible and the WUs were aborting. With the exclude_gpu option in the cc_config.xml file for that device I was able to prevent it for getting opencl work. This option will work for your situation as well.


I don't buy computers, I build them!
ID: 53115 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
robertmiles

Send message
Joined: 30 Sep 09
Posts: 210
Credit: 22,337,484
RAC: 0
20 million credit badge10 year member badgeextraordinary contributions badge
Message 53121 - Posted: 12 Feb 2012, 22:41:36 UTC

I now suspect that the OpenCL video card assignment is capable of finding and trying to use the low-end GPUs often found on motherboards, but normally disabled when a graphics card is usable. Some of the versions of BOINC do not even report the presence of such a low-end GPU so that the user can disable BOINC use of it.
ID: 53121 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBeyond
Avatar

Send message
Joined: 15 Jul 08
Posts: 383
Credit: 502,204,694
RAC: 22
500 million credit badge10 year member badge
Message 53376 - Posted: 22 Feb 2012, 20:00:46 UTC - in response to Message 52996.  

I run both a GTX470 and AMD6970 in the same machine. I use the nvidia for SETI(or others when not working) and the AMD for MW. However with the new opencl WU's they are getting assigned to the nvidia card and the 6970 sits idle. Is there a way to not download the opencl wu's or is there another way to solve this issue?

I delayed switching one of my machines over after reading about this but today took the plunge, upgraded the ATI drivers to 12.1 (Win7-64) and switched MW to use the automatic open_cl app. I'm using BOINC 6.12.43 and it works fine, running MW on the HD5870 and HD4770 cards while crunching PG on the GTX460. So far no hitches at all.
ID: 53376 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBeyond
Avatar

Send message
Joined: 15 Jul 08
Posts: 383
Credit: 502,204,694
RAC: 22
500 million credit badge10 year member badge
Message 53381 - Posted: 22 Feb 2012, 22:29:04 UTC - in response to Message 53376.  

I run both a GTX470 and AMD6970 in the same machine. I use the nvidia for SETI(or others when not working) and the AMD for MW. However with the new opencl WU's they are getting assigned to the nvidia card and the 6970 sits idle. Is there a way to not download the opencl wu's or is there another way to solve this issue?

I delayed switching one of my machines over after reading about this but today took the plunge, upgraded the ATI drivers to 12.1 (Win7-64) and switched MW to use the automatic open_cl app. I'm using BOINC 6.12.43 and it works fine, running MW on the HD5870 and HD4770 cards while crunching PG on the GTX460. So far no hitches at all.

Now added an app-info.xml to run 2x WUs and that works fine too.
ID: 53381 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileJoseph Stateson
Avatar

Send message
Joined: 18 Nov 08
Posts: 233
Credit: 1,277,266,415
RAC: 20
1 billion credit badge10 year member badge
Message 53493 - Posted: 29 Feb 2012, 14:26:43 UTC - in response to Message 53376.  
Last modified: 29 Feb 2012, 14:28:19 UTC

I delayed switching one of my machines over after reading about this but today took the plunge, upgraded the ATI drivers to 12.1 (Win7-64) and switched MW to use the automatic open_cl app. I'm using BOINC 6.12.43 and it works fine, running MW on the HD5870 and HD4770 cards while crunching PG on the GTX460. So far no hitches at all.


FWIW, I had to go back to 11.6 as my HD4890 started failing on the collatz project. My HD5850 handled 12.1 upgrade just fine.

If you are running collatz I am curious if your 4770 handles it OK.

As far as MW, my system that had the 4890 and 12.1 kept giving this message
    Milkyway@Home 2012-02-29 6:03:28 AM Message from server: Catalyst driver version is not OK for OpenCL application with this GPU


I have not seen this message since I went back to 11.6.

ID: 53493 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sunny129
Avatar

Send message
Joined: 25 Jan 11
Posts: 271
Credit: 346,072,284
RAC: 0
300 million credit badge9 year member badgeextraordinary contributions badge
Message 53510 - Posted: 1 Mar 2012, 22:31:26 UTC - in response to Message 53121.  

I now suspect that the OpenCL video card assignment is capable of finding and trying to use the low-end GPUs often found on motherboards, but normally disabled when a graphics card is usable. Some of the versions of BOINC do not even report the presence of such a low-end GPU so that the user can disable BOINC use of it.

this is definitely the case...to briefly view the hell i went through trying to get the new OpenCL app to run strictly on my HD 5870 while leaving the HD 4290 IGP enabled and dedicated to the display, see THIS THREAD.
ID: 53510 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : OpenCL video card assignment issue

©2020 Astroinformatics Group