Welcome to MilkyWay@home

Using GPU to the mx


Advanced search

Message boards : Cafe MilkyWay : Using GPU to the mx
Message board moderation

To post messages, you must log in.

AuthorMessage
David Bohn

Send message
Joined: 16 Aug 10
Posts: 15
Credit: 32,160,978
RAC: 0
30 million credit badge11 year member badge
Message 59417 - Posted: 22 Jul 2013, 19:07:41 UTC

I have been having power blips recently and decided to to invest in a UPS for my desktop. I have an AMD 945 quad CPU and an ATI 4870 GPU. Well measuring the watts used during different configurations I discovered that if I set the preferences to use 90% of the processors then my watt usage fell well below 300 watts, if I lower the % of the processors to 60%, effectively only using 2 cores, then my wattage jumps up to the 320-335 range (exceeding a 550kVa ups range). My conclusion is that the GPU was being starved for data because there were insufficient CPU cycles to supply it with data. Any other thoughts and/or ideas?

The long and short of it is that using to much CPU slows down GPU processing.
And yes I purchased a 1000 kVa UPS.
ID: 59417 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilemikey
Avatar

Send message
Joined: 8 May 09
Posts: 2561
Credit: 462,762,741
RAC: 293
300 million credit badge12 year member badgeextraordinary contributions badge
Message 59419 - Posted: 22 Jul 2013, 20:23:56 UTC - in response to Message 59417.  

I have been having power blips recently and decided to to invest in a UPS for my desktop. I have an AMD 945 quad CPU and an ATI 4870 GPU. Well measuring the watts used during different configurations I discovered that if I set the preferences to use 90% of the processors then my watt usage fell well below 300 watts, if I lower the % of the processors to 60%, effectively only using 2 cores, then my wattage jumps up to the 320-335 range (exceeding a 550kVa ups range). My conclusion is that the GPU was being starved for data because there were insufficient CPU cycles to supply it with data. Any other thoughts and/or ideas?

The long and short of it is that using to much CPU slows down GPU processing.
And yes I purchased a 1000 kVa UPS.


This is common with gpu's at other projects and Nvidia's here, but I have not seen it with ATI gpu's here before.

One thing to remember is that the batteries in those UPS's need replacing periodically, so save your pennies for the next 2 years or so.
ID: 59419 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Cafe MilkyWay : Using GPU to the mx

©2021 Astroinformatics Group