Welcome to MilkyWay@home

Separation Modified Fit v1.26 Release


Advanced search

Message boards : News : Separation Modified Fit v1.26 Release
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 573
Credit: 56,634,187
RAC: 421,250
50 million credit badge6 year member badgeextraordinary contributions badge
Message 59702 - Posted: 27 Aug 2013, 17:24:47 UTC

Hi all,

I am going to be releasing a new version of MilkyWay Separation Modified Fit today. The new version will include:
- The Modified Fit included last release which is giving very promising results.
- A new background model (Broken Power Law instead of Hernquist)
- Windows 32-bit Support
- Compatibility fix for Linux 32 and 64 bit.

We plan on continuing to put up runs with the Modified Fit alone, and comparing the results to the results from Matt Newby's last paper. Simultaneously, we will be putting up runs with the new background fit in an attempt to improve the accuracy of our model. If anyone has any questions about the new release feel free to post them here.

The runs to test this release are:
de_modift_15_3s_bplwithwraptest_2
ps_modift_15_3s_bplwithwraptest_2

If any errors come up with these runs please post them here.

Thank you,

Jake W.
ID: 59702 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileRAMen
Avatar

Send message
Joined: 8 Apr 08
Posts: 45
Credit: 161,943,995
RAC: 0
100 million credit badge10 year member badge
Message 59703 - Posted: 27 Aug 2013, 18:12:08 UTC
Last modified: 27 Aug 2013, 18:12:52 UTC

Failing on XP
http://milkyway.cs.rpi.edu/milkyway/result.php?resultid=553473210

OWN every thing I need
EARN.. enough to live !!!
WANT a solar array on the roof so I can run a BOINC farm( DREAM on!!)
NO wife
NO kids
NO troubles

ID: 59703 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sunny129
Avatar

Send message
Joined: 25 Jan 11
Posts: 271
Credit: 346,072,284
RAC: 0
300 million credit badge8 year member badgeextraordinary contributions badge
Message 59707 - Posted: 28 Aug 2013, 1:14:53 UTC

i had errors at first, but it was my own fault. i run on an anonymous platform, and so the application didn't automatically update for me.

i thought there was a relatively easy way to update the application for anonymous platform users too, but i couldn't figure it out of there was one...perhaps i'm just rusty and have a faded memory, b/c its been a while i've had to manually update a BOINC project application. at first i just closed BOINC and changed some entries (i changed 1.24 to 1.26 and 124 to 126) in the app_info.xml, but apparently that doesn't really let the project server know that my host needs the new v1.26 app. in fact, upon restarting BOINC i got a message stating that the app_info.xml file referencing a nonexistent application. now that much made sense, b/c only the regular v1.02 app and the modified fit v1.24 app were in the project directory. so i tried resetting the project, but that didn't help either.

what i ended up having to do was close BOINC, remove the app_info.xml file and the application binaries from the project directory, restart BOINC, and reset Milkyway@Home. only then did BOINC download the new v1.26 modified fit app and re-download the regular v1.02 app. well, actually, i don't know for sure if removing the application binaries from the directory was absolutely necessary, but that's neither here nor there. now that i had the new v1.26 app in the project directory, i was able to put my app_info.xml file back into the project directory and restart BOINC. sure enough, everything is working perfectly again, almost error-free...but i'll get to that in just a second. in the mean time, is there an easier way to download an updated application binary for anonymous platform hosts than removing the app_info.xml from the project directory and resetting the project?

ok, onto the handful of errors...actually they're invalids. of the 3, one's outcome is a validate error, while the other two's outcomes are "successes," but the validate state is reported as "work unit error - check skipped." this type of error is new to me...any ideas? and yes, these are modified fit tasks...here's a link to my INVALID TASKS.
ID: 59707 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sunny129
Avatar

Send message
Joined: 25 Jan 11
Posts: 271
Credit: 346,072,284
RAC: 0
300 million credit badge8 year member badgeextraordinary contributions badge
Message 59713 - Posted: 28 Aug 2013, 5:13:37 UTC

well the number of invalids continues to grow...i'm now up to 20 of them. i've made no hardware or driver changes since the new v1.26 app showed up. 19 of the 20 invalids are modified fit tasks.
ID: 59713 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileMumak
Avatar

Send message
Joined: 8 Apr 13
Posts: 89
Credit: 517,085,245
RAC: 0
500 million credit badge6 year member badgeextraordinary contributions badge
Message 59718 - Posted: 28 Aug 2013, 16:35:53 UTC

Here too - too many errors.
ID: 59718 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sunny129
Avatar

Send message
Joined: 25 Jan 11
Posts: 271
Credit: 346,072,284
RAC: 0
300 million credit badge8 year member badgeextraordinary contributions badge
Message 59719 - Posted: 28 Aug 2013, 16:50:05 UTC - in response to Message 59718.  

Here too - too many errors.

yup...looks like you're getting the same kind of invalids i'm getting - a 50/50 mix of "validate errors" and "completed - can't validate," where the "completed - can't validate" tasks apparently failed due to "work unit error - check skipped." granted, every last one of your invalids are modified fit tasks, whereas a vast majority of my invalids are modified fit tasks with a handful of regular MW@H invalids...but the rgular MW@H invalids are older than the rest, and they've stopped rolling in since having switched to crunching only MW@H tasks (and no modified fit tasks for now). i can confirm this much b/c the number of consecutive valid MW@H tasks continues to climb, while the number of consecutive valid modified fit tasks hardly breaks into double digits before dropping back down to zero and starting again.
ID: 59719 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileMumak
Avatar

Send message
Joined: 8 Apr 13
Posts: 89
Credit: 517,085,245
RAC: 0
500 million credit badge6 year member badgeextraordinary contributions badge
Message 59720 - Posted: 28 Aug 2013, 17:49:17 UTC

Now I've got 141 Invalids of "Milkyway@Home Separation (Modified Fit) v1.26" since yesterday. No other errors. Opted out...
ID: 59720 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
pioneer1

Send message
Joined: 19 Oct 08
Posts: 1
Credit: 6,209,315
RAC: 564
5 million credit badge10 year member badge
Message 59723 - Posted: 28 Aug 2013, 21:45:35 UTC

About 13 invalid WUs, all of them modified_fit 1.26 as of posting
ID: 59723 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 573
Credit: 56,634,187
RAC: 421,250
50 million credit badge6 year member badgeextraordinary contributions badge
Message 59725 - Posted: 28 Aug 2013, 23:24:24 UTC

Hey Guys,

Thanks for all of the reports. I'm looking into it all now. Will get back to you when I know more.

Jake W
ID: 59725 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
greg_be

Send message
Joined: 18 Aug 09
Posts: 90
Credit: 6,285,277
RAC: 4,354
5 million credit badge9 year member badge
Message 59727 - Posted: 29 Aug 2013, 1:52:47 UTC
Last modified: 29 Aug 2013, 1:54:39 UTC

All these tasks error out in 3seconds or less on my XP machine.

The error message is this: Reason: Access Violation (0xc0000005) at address 0x77C3554A read attempt to address 0x00000008
ID: 59727 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileRAMen
Avatar

Send message
Joined: 8 Apr 08
Posts: 45
Credit: 161,943,995
RAC: 0
100 million credit badge10 year member badge
Message 59728 - Posted: 29 Aug 2013, 5:17:59 UTC
Last modified: 29 Aug 2013, 5:27:22 UTC

FYI
GPU apps only
1.02 apps complete successfully
1.26 modified fit (opencl_amd_ati) all fail

2 x XP
GPU ati 4850 + 5850
q9300 + i7920
boinc 7.0.64 (x86)
catalyst 11.9 & 11.11

*After a few hours 1.26 errors may cause the 1.02 wu to fail as well
*Closing boinc completely (ctl+alt+del)to check all closed and restarting boinc allows 1.02 to work correctly again.

I have been aborting the 1.26 work units to allow the 1.02 to complete as all the errors seem to cause a bottle neck and WU fail to report bringing GPU processing to a halt.
ID: 59728 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Switeck

Send message
Joined: 17 Jan 13
Posts: 1
Credit: 31,056,707
RAC: 14,166
30 million credit badge6 year member badge
Message 59729 - Posted: 29 Aug 2013, 9:18:42 UTC

On XP Pro SP3, and getting Computational Error on Modified Fit WUs within 3 seconds of starting them.

I'm opting out of them unless I need to do more testing on them.
ID: 59729 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileryan

Send message
Joined: 5 Nov 10
Posts: 9
Credit: 4,995,748
RAC: 0
3 million credit badge8 year member badge
Message 59735 - Posted: 29 Aug 2013, 16:06:08 UTC

every mod fit WU I have recieved has comp error after a second or two
ID: 59735 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
greg_be

Send message
Joined: 18 Aug 09
Posts: 90
Credit: 6,285,277
RAC: 4,354
5 million credit badge9 year member badge
Message 59737 - Posted: 29 Aug 2013, 17:15:51 UTC

opting out of modified fit until there is an announcement that it is fixed.
ID: 59737 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
MBark

Send message
Joined: 3 May 09
Posts: 11
Credit: 54,187,229
RAC: 0
50 million credit badge9 year member badge
Message 59738 - Posted: 29 Aug 2013, 18:47:29 UTC

I'm opting out of modified fit until problem is fixed. Wasting way to much of my GPU's time. You should be giving us credit on the "modified fit" that don't validate because of a problem with the program. We have used our resourses and need the credit.

If you start giving credit for time wasted on a bug in Milkyway@Home's program(s), you'll have a lot of us return and process for you.
ID: 59738 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 573
Credit: 56,634,187
RAC: 421,250
50 million credit badge6 year member badgeextraordinary contributions badge
Message 59740 - Posted: 29 Aug 2013, 18:49:17 UTC

Hey Guys,

I took down the runs using the Broken Power Law option. I will look into fixing what looks like out of memory issues with it. Until then, I am going to be running Modified Fit runs again. This does not require an update luckily! If you are seeing any errors with the new runs named:

de_modfit_18_3s_126testwrap_2
ps_modfit_18_3s_126testwrap_2

please post them to the new runs post that was just put up.

Thank you,

Jake W
ID: 59740 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileritterm
Avatar

Send message
Joined: 16 Jun 08
Posts: 93
Credit: 366,671,520
RAC: 13,825
300 million credit badge10 year member badgeextraordinary contributions badge
Message 59741 - Posted: 29 Aug 2013, 19:07:56 UTC - in response to Message 59740.  
Last modified: 29 Aug 2013, 19:10:06 UTC

I took down the runs using the Broken Power Law option...

And I'm opting back in... :D Thanks for the quick response, Jack.

[edit]Or not...I'm still getting BPL's...[/edit]
ID: 59741 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 573
Credit: 56,634,187
RAC: 421,250
50 million credit badge6 year member badgeextraordinary contributions badge
Message 59742 - Posted: 29 Aug 2013, 19:38:42 UTC

Hey Ritterm,

If you give it an hour or two it should flush them out of the queue and then you should be getting the new ones. Sorry, Boinc is a bit weird when you end a run.

Thank you,

Jake W
ID: 59742 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
KIDH

Send message
Joined: 3 Aug 08
Posts: 19
Credit: 10,306,713
RAC: 44
10 million credit badge10 year member badge
Message 59743 - Posted: 29 Aug 2013, 19:45:29 UTC

ID: 59743 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileritterm
Avatar

Send message
Joined: 16 Jun 08
Posts: 93
Credit: 366,671,520
RAC: 13,825
300 million credit badge10 year member badgeextraordinary contributions badge
Message 59744 - Posted: 29 Aug 2013, 19:49:06 UTC - in response to Message 59742.  

If you give it an hour or two it should flush them out of the queue and then you should be getting the new ones. Sorry, Boinc is a bit weird when you end a run.

Oh, sure, no problem. I should have figured that it wouldn't be as easy or quick as we'd like. Keep up the good work.

ID: 59744 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : News : Separation Modified Fit v1.26 Release

©2019 Astroinformatics Group