Welcome to MilkyWay@home

New Nbody Version 1.50


Advanced search

Message boards : News : New Nbody Version 1.50
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Sidd
Project developer
Project tester
Project scientist

Send message
Joined: 19 May 14
Posts: 73
Credit: 356,131
RAC: 0
100 thousand credit badge5 year member badge
Message 63554 - Posted: 12 May 2015, 23:31:44 UTC

Hey all,

We have released a new version of Nbody. There are a few changes in this version. First and foremost, we changed the way dark and light matter in our model dwarf galaxy is assigned. Previously, we would have all the particles have the same mass and assign a certain number as dark or light, depending on the parameters of the simulation. This required a large number of bodies in order to get a good likelihood calculation. Now, we will have the same number of dark and light matter particles, but change the mass per light and dark matter particle in accordance to the parameters. This will allow us to lower the number of bodies from 50k to 20k, allowing for a much faster initialization and simulation run time.

Secondly, we have moved the assignment of dark and light matter from lua to c, which should also provide significant speed up in the run time.

Also, we fixed a number of bugs we found in the velocity assignment. All in all, a simulation should run at a fraction of the time previously. This will also hopefully fix the stalling issue some people have been having.

Finally, if you have any runs from the previously version, you can go ahead and abort them.

Since this is a new way of doing things, there may be some unforeseen issues. So, if there are any bugs let us know!
ID: 63554 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dartanian

Send message
Joined: 18 Jan 15
Posts: 23
Credit: 150,312,324
RAC: 0
100 million credit badge4 year member badge
Message 63555 - Posted: 13 May 2015, 12:05:08 UTC - in response to Message 63554.  

Doesn't work correctly on my end. It runs fast in the beginning of the simulation and gets slower as it gets to the end and then just stalls at 100% and at which point it has to be aborted because it just hangs. All my other computers have the same issue with this simulation.

Dartanian
ID: 63555 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileBlurf
Volunteer moderator
Project administrator

Send message
Joined: 13 Mar 08
Posts: 804
Credit: 26,380,161
RAC: 0
20 million credit badge10 year member badgeextraordinary contributions badge
Message 63557 - Posted: 13 May 2015, 14:18:00 UTC

Issues:

1) No checkpointing

2) Again they're running beyond 100% still.

ID: 63557 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Clemens

Send message
Joined: 24 Aug 13
Posts: 1
Credit: 5,013,571
RAC: 0
5 million credit badge6 year member badge
Message 63559 - Posted: 13 May 2015, 15:13:35 UTC

Same problem here.
ID: 63559 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Copyright

Send message
Joined: 2 May 15
Posts: 1
Credit: 247,719
RAC: 0
100 thousand credit badge4 year member badge
Message 63560 - Posted: 13 May 2015, 19:21:22 UTC

As well.
ID: 63560 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
RagingCain

Send message
Joined: 2 Feb 10
Posts: 1
Credit: 5,181,702
RAC: 0
5 million credit badge9 year member badge
Message 63562 - Posted: 13 May 2015, 23:29:09 UTC
Last modified: 13 May 2015, 23:42:55 UTC

Can confirm 2 cases of stalling at 100%.

Observed behavior leading up to 100%:
4 minute job turned into 17 minutes and counting. Time remaining 0s.

Still running. Rate of percentage completes is now 0.0005% per second.

It's slowing down exponentially until it his 99.999999%, roles over to 100% but never actually completes.
ID: 63562 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cphipps

Send message
Joined: 5 Aug 14
Posts: 3
Credit: 18,795,749
RAC: 7,537
10 million credit badge5 year member badge
Message 63563 - Posted: 14 May 2015, 3:22:44 UTC

Same here. Doesn't work correctly on my end. It runs fast in the beginning of the simulation and gets slower as it gets to the end and then just stalls at 100% and at which point it has to be aborted because it just hangs. All my other computers have the same issue with this simulation.

Claude
ID: 63563 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
HireMe.geek.nz

Send message
Joined: 12 Jun 09
Posts: 12
Credit: 370,542
RAC: 58
100 thousand credit badge10 year member badge
Message 63566 - Posted: 14 May 2015, 7:22:31 UTC - in response to Message 63554.  

Both the MT and single CPU versions get stuck at 99.999% and never finish on x86 Windows systems.

You need to release a bug fix version soon, as the current situation results in work being done but no CPU credit for it happening as you have to abort the improperly terminating work units.
ID: 63566 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileRichard Wayman

Send message
Joined: 7 May 15
Posts: 3
Credit: 2,353,818
RAC: 0
2 million credit badge4 year member badge
Message 63567 - Posted: 14 May 2015, 9:19:04 UTC

Same here. I sat and watched the first unit run. Everything was OK till it hit 90% then, it slowed at an exponential rate to 99.999% and stayed there for several hours until I got board and aborted it.
ID: 63567 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
M0CZY
Avatar

Send message
Joined: 26 Jun 09
Posts: 14
Credit: 176,642
RAC: 0
100 thousand credit badge10 year member badge
Message 63568 - Posted: 14 May 2015, 10:03:42 UTC

My 64-bit Linux machine has been running the Nbody 1.50 single and MT versions without any problems.
All my work units finish properly.
It would help a bit if my wingmen could be bothered to finish their work units so that I could see if they validate correctly.

Having read about their problems, I don't much fancy trying out the Windows version!
The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3
ID: 63568 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
M0CZY
Avatar

Send message
Joined: 26 Jun 09
Posts: 14
Credit: 176,642
RAC: 0
100 thousand credit badge10 year member badge
Message 63571 - Posted: 14 May 2015, 12:49:31 UTC
Last modified: 14 May 2015, 13:02:04 UTC

Message deleted by author.
The biggest threat to public safety and security is not terrorism, it is Government abuse of authority.

Bitcoin Donations: 1Le52kWoLz42fjfappoBmyg73oyvejKBR3
ID: 63571 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileFredguapo

Send message
Joined: 11 Nov 10
Posts: 1
Credit: 78,730,377
RAC: 7,387
50 million credit badge9 year member badge
Message 63572 - Posted: 14 May 2015, 13:52:18 UTC - in response to Message 63554.  

I am also having the same problem !


ID: 63572 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileWisesooth

Send message
Joined: 2 Oct 14
Posts: 39
Credit: 38,441,695
RAC: 28,372
30 million credit badge5 year member badge
Message 63574 - Posted: 14 May 2015, 15:25:11 UTC - in response to Message 63554.  

I have a task simulation of version 1.50 running on an i5 Intel with an Asus motherboard. The motherboard utility lets me monitor processor stats. It is using all four threads, but at a fraction of their capacity. The BOINC timer gets to 100% or 99.98% and stays there. I let the latest 1.50 simulation run for 19 hours.

Another machine uses an i7 Intel processor. It has been running a 1.50 simulation for 11 hours. This machine also runs SETI so it shares a thread to run a GPU task while any milkyway task is running. The milkyway task ties up all 8 threads, but uses only four at a fraction of their capacity. One thread occasionally peaks at around 60% while the other three run as low as 2%. This machine is a liquid cooled screamer. It is barely above idle. Hard drive and network activity is less than moderate or nil. It seems to be contemplating its wait states.

I cannot run a single simulation task to completion. I have no choice but to abort ALL simulations of any version. I have no problems with SETI or single-thread milkyway tasks. My machines speed up to capacity crunch mode as soon as I abort the simulation task.

I hope this info helps.

PS: The author of Sherlock Holmes once wrote something like this. When all alternatives are impossible, what remains is possible.
ID: 63574 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileRichard Wayman

Send message
Joined: 7 May 15
Posts: 3
Credit: 2,353,818
RAC: 0
2 million credit badge4 year member badge
Message 63577 - Posted: 14 May 2015, 21:11:08 UTC

I also noticed the same thing just by watching TThrottle. Even though it says nboby is using both cores of my crappy acer laptop it never gets above 50% usage of cpu (even if I try to force it to go above 50%), and it doesn't even go near the gpu.
ID: 63577 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jacob Klein

Send message
Joined: 22 Jun 11
Posts: 32
Credit: 16,941,123
RAC: 26,765
10 million credit badge8 year member badge
Message 63580 - Posted: 15 May 2015, 3:34:45 UTC
Last modified: 15 May 2015, 3:38:23 UTC

I'm also noticing the same behavior, on:
ps_nbody_5_12_15_orphan_sim_1_1431361804_28199_0
http://milkyway.cs.rpi.edu/milkyway/result.php?resultid=1117230409

Admins:
1: Is the behavior (reserving multiple cores, despite using only 1) ... expected behavior?
2: Is the behavior of going to 100%, then still running for hours/days after that ... expected behavior?
3: Will the task ever end?


It would help tremendously, if you could very thoroughly describe the expected behavior for these work units. People are aborting them, because the tasks look odd/broken, and if they're not broken, you need to do a better job of communicating your expectations.

Thanks in advance for your reply,
Jacob
ID: 63580 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
tlaubscher

Send message
Joined: 9 Feb 09
Posts: 1
Credit: 593,253
RAC: 0
500 thousand credit badge10 year member badge
Message 63581 - Posted: 15 May 2015, 4:50:32 UTC

V1.50(mt) doesn't work. Uses all 8 CPUs of my i7 processor but does nothing and blocks other BOINC Tasks.

I use Windows 7 64 bit
ID: 63581 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Captiosus

Send message
Joined: 9 Apr 14
Posts: 24
Credit: 3,811,350
RAC: 0
3 million credit badge5 year member badge
Message 63582 - Posted: 15 May 2015, 6:52:08 UTC

Hmm, seems the problem with milkyway nbody still remains even though its been updated. M0CZY says it works in linux. That begs the question: if Nbody wont run right in windows, why not do it in a linux VM like some other projects do?

And for me both single thread and MT Nbody exhibit the stalling bug.
ID: 63582 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Daniel SIMON

Send message
Joined: 14 Apr 15
Posts: 1
Credit: 802,987
RAC: 704
500 thousand credit badge4 year member badge
Message 63583 - Posted: 15 May 2015, 8:59:42 UTC - in response to Message 63554.  

I have problem with N-Body simulation 1.5. Initially program runs fast but when reaching 99% of achievement it seems to slow down and never stops. Sorry but I will stop it manually in order to allow other processes to run.
ID: 63583 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Lee (Sarge) Coin

Send message
Joined: 10 Jan 15
Posts: 9
Credit: 40,687,059
RAC: 40,418
30 million credit badge4 year member badge
Message 63587 - Posted: 15 May 2015, 13:36:39 UTC

Nbody v1.5 looping. 5 min. task Im aborting after 4+ hours running 8 processers. I7, Win 7, 12 GB Ram, 2 TB HD.

Leelan Coin
leelan.coin@gmail.com

Name ps_nbody_5_12_15_orphan_sim_1_1431361804_27915_0
Workunit 823277835
Created 14 May 2015, 14:43:11 UTC
Sent 14 May 2015, 15:23:55 UTC
Report deadline 26 May 2015, 15:23:55 UTC
Received ---
Server state In progress
Outcome ---
Client state New
Exit status 0 (0x0)
Computer ID 605363
Run time
CPU time
Validate state Initial
Credit 0.00
Device peak FLOPS 32.39 GFLOPS
Application version MilkyWay@Home N-Body Simulation v1.50 (mt)
Stderr output

Lee Coin
leelan.coin@gmail.com
ID: 63587 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
guk16k

Send message
Joined: 26 Jul 09
Posts: 1
Credit: 48,163,440
RAC: 0
30 million credit badge10 year member badge
Message 63588 - Posted: 15 May 2015, 15:09:55 UTC
Last modified: 15 May 2015, 15:11:32 UTC

I'm forced to stop all "n-body" processes
Very long calculation (10H+)
ID: 63588 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
1 · 2 · Next

Message boards : News : New Nbody Version 1.50

©2019 Astroinformatics Group