Welcome to MilkyWay@home

Error with N-Body Simulation v1.60 (mt) needing library


Advanced search

Questions and Answers : Unix/Linux : Error with N-Body Simulation v1.60 (mt) needing library
Message board moderation

To post messages, you must log in.

AuthorMessage
Jake

Send message
Joined: 27 Oct 14
Posts: 2
Credit: 4,218,452
RAC: 11
3 million credit badge5 year member badge
Message 64569 - Posted: 25 May 2016, 2:18:48 UTC

Its been a couple weeks and I've accumulated 15 computation errors with this specific application. The error message is

<core_client_version>7.6.31</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/milkyway.cs.rpi.edu_milkyway/milkyway_nbody_1.60_x86_64-pc-linux-gnu__mt: error while loading shared libraries: libgomp.so.1: cannot open shared object file: No such file or directory
</stderr_txt>
]]>

These started showing up after I reinstalled to ubuntu 16.04 server (from ubuntu 12.04 server) and I believe this is having an issue since the library it's trying to access must be depreciated and has been removed from ubuntu. Just curious if anyone else has this issue and if installing said library had any effects. All the other tasks from other applications and projects all complete properly so the problem seems to be specific to just this application.

Also, is there any way to opt out of just this one application?
ID: 64569 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
alanb1951

Send message
Joined: 16 Mar 10
Posts: 45
Credit: 34,307,782
RAC: 35,615
30 million credit badge9 year member badgeextraordinary contributions badge
Message 64587 - Posted: 29 May 2016, 1:43:36 UTC - in response to Message 64569.  

I run XUbuntu 16.04 (rather than Ubuntu Server) and it has the libgomp package installed! I'm not sure whether that's by default or as a side-effect of some package I've added - I've checked out all my Linux boxes (14.04 and 16.04) and all seem to have some version of said package installed...

For what it's worth, when I look in Synaptic (Package Manager) it's in Local/main (and the Libraries section...)

As for not running nbody... If you visit "My account" on the web site and click on the "Preferences for this project" link ("MilkyWay@Home preferences") there are options to select what applications you'll get work from.

Uncheck both the NBody simulation option and the "accept work from other applications" option - make sure you edit the correct set of preferences if your machine is attached to other than default...

Hope this helps...

Good luck - Al.
ID: 64587 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : Error with N-Body Simulation v1.60 (mt) needing library

©2019 Astroinformatics Group