Welcome to MilkyWay@home

New Version of MW@home for Mac (1.37)


Advanced search

Message boards : News : New Version of MW@home for Mac (1.37)
Message board moderation

To post messages, you must log in.

AuthorMessage
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 1
50 million credit badge6 year member badgeextraordinary contributions badge
Message 64750 - Posted: 24 Jun 2016, 19:07:49 UTC

Hey Mac Users,

I just released a new version of MilkyWay@home Separation that will run much faster on Macs. (Expect about a factor of 7-8 speed up). If you guys see any issues with the new application post them here.

I only released this new application under the official project and not the Modfit project since we are slowly phasing out the Modfit project.

Enjoy the weekend,

Jake
ID: 64750 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jean-Pierre HARLE

Send message
Joined: 25 Sep 08
Posts: 10
Credit: 56,038,086
RAC: 74,147
50 million credit badge10 year member badge
Message 64751 - Posted: 24 Jun 2016, 20:30:14 UTC - in response to Message 64750.  

Good job, Jake ! It works !
Thank you.
ID: 64751 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
paris
Avatar

Send message
Joined: 26 Apr 08
Posts: 78
Credit: 29,823,545
RAC: 15,713
20 million credit badge10 year member badge
Message 64752 - Posted: 24 Jun 2016, 23:14:22 UTC

Just got my first 1.37 unit finished. Much, much better. Thank you for your hard work and expertise. I hope you have a good weekend.

Plus SETI Classic = 21,082 WUs
ID: 64752 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nigel Garvey

Send message
Joined: 2 Apr 11
Posts: 13
Credit: 2,719,816
RAC: 2,433
2 million credit badge8 year member badge
Message 64754 - Posted: 26 Jun 2016, 19:10:00 UTC - in response to Message 64750.  

Thanks, Jake. I've not received the new version yet as I've been away for a couple of days, but Jean-Pierre and paris seem very pleased. I'm looking forward to trying it out for myself when my BOINC client gets round to MW@H again.
NG
ID: 64754 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Pierce.Moore

Send message
Joined: 3 Jan 10
Posts: 2
Credit: 535,603
RAC: 2
500 thousand credit badge9 year member badge
Message 64755 - Posted: 26 Jun 2016, 19:31:43 UTC
Last modified: 26 Jun 2016, 19:33:38 UTC

This is exciting news! I've been crunching for MilkyWay@Home for a long time, though admittedly took a break from it all for a while. I have had MW@Home prioritized pretty high and things generally go well.

Recently, though, I've been noticing that my RAC for MW@Home is very low. I haven't been able to figure out why until today when I came home to this:

(Edit: Not sure why these images are blowing up the page layout. Are images not scaled down to responsive size with CSS?)



:( 4 days of computing time, and the job errored out. I have attached the full job debug output below. Is this the new application you released or the old one?

ID: 64755 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Pierce.Moore

Send message
Joined: 3 Jan 10
Posts: 2
Credit: 535,603
RAC: 2
500 thousand credit badge9 year member badge
Message 64756 - Posted: 26 Jun 2016, 20:41:44 UTC - in response to Message 64755.  
Last modified: 26 Jun 2016, 20:42:34 UTC

I apologize for double-posting but since I can't update my original reply anymore I had to.

Just wanted to confirm that adding
max-width: 100%;
to the
img
tag in
main.css
on line 68 makes all images in posts responsive in a way that will significantly improve the user experience.

ID: 64756 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 1
50 million credit badge6 year member badgeextraordinary contributions badge
Message 64760 - Posted: 27 Jun 2016, 12:42:14 UTC

Hi Pierce,

Holy large images!!! From what I can see and what I think you are asking, you want to know why N-body kind of sucks for getting credit and why they always error. The answer is it is a beta application that is currently under heavy development by Sidd. He will be releasing a new application today (hopefully) that might solve these super long compute times and errors. Otherwise, if they remain problematic you can always turn off getting N-body work units through the project preferences.

Jake
ID: 64760 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Robert Kapernick

Send message
Joined: 21 Dec 09
Posts: 8
Credit: 11,923,115
RAC: 10,384
10 million credit badge9 year member badge
Message 65267 - Posted: 26 Sep 2016, 4:24:13 UTC

The last 2 days (24-25 Sept.) all of my MW@home 1.37 (opencl_ati_101) have failed. A total of 41 tasks.

All say Computational Error and show an elapsed time of 1 or mostly 2 seconds.

I am running an iMac 3.4 GHz i7 with 16 GB of memory, 2 GB AMD Radeon 6970M, using OS X 10.9.5

I have had an occasional comp error previously but nothing like this.

Any suggestions?

Robert
ID: 65267 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jean-Pierre HARLE

Send message
Joined: 25 Sep 08
Posts: 10
Credit: 56,038,086
RAC: 74,147
50 million credit badge10 year member badge
Message 65268 - Posted: 26 Sep 2016, 10:47:41 UTC

Exactly the same problem on a MacBook Pro using OS X 10.8.3.

I hope that Jake will quickly fix the bug... as usual ;-))

Jean-Pierre
ID: 65268 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 1
50 million credit badge6 year member badgeextraordinary contributions badge
Message 65270 - Posted: 26 Sep 2016, 14:00:14 UTC

Hey,

Strange, I didn't make any changes to the Mac Application. I will look into it though.

Jake
ID: 65270 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Robert Kapernick

Send message
Joined: 21 Dec 09
Posts: 8
Credit: 11,923,115
RAC: 10,384
10 million credit badge9 year member badge
Message 65302 - Posted: 27 Sep 2016, 4:52:09 UTC - in response to Message 65270.  

FYI

As of 0440 UTC Sept 27 I have 73 tasks listed in the error tasks in my account and another 47 on my computer waiting submission. They are all 1.37 (opencl_ati_101) tasks. All of the MW@home 1.37 tasks run normal with no errors. I have not noticed any mass comp errors prior to approx. 23-24 Sept.

Thanks Robert
ID: 65302 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 1
50 million credit badge6 year member badgeextraordinary contributions badge
Message 65309 - Posted: 27 Sep 2016, 13:46:43 UTC

Hey Robert,

The graphics card you are using does not support double precision, or at least the drivers written by Apple do not. Our application requires double precision for our GPU work units to ensure the most accurate scientific results.

Jean-Pierre HARLE,

It looks like you are having a similar problem, but it isn't recognizing it well for some reason. Have you been able to crunch GPU work units in the past?

Jake
ID: 65309 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jean-Pierre HARLE

Send message
Joined: 25 Sep 08
Posts: 10
Credit: 56,038,086
RAC: 74,147
50 million credit badge10 year member badge
Message 65326 - Posted: 27 Sep 2016, 19:46:08 UTC - in response to Message 65309.  

Hi Jake,

My computer can't crunch GPU work units. Why do I receive now such work units ? That was not the case previously...

All the MilkyWay@Home v1.37 (opencl_ati_101) tasks run 2 s and bug, all the MilkyWay@Home v1.37 run normally, as usual. This problem started just when you restarted the database after it was was down, 3 days ago.

Best regards.

Jean-Pierre
ID: 65326 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 1
50 million credit badge6 year member badgeextraordinary contributions badge
Message 65327 - Posted: 27 Sep 2016, 19:54:49 UTC - in response to Message 65326.  

Hey Jean-Pierre,

I updated the BOINC scheduler right around that time and it changed how it decides who gets work units. To stop receiving them go to http://milkyway.cs.rpi.edu/milkyway/prefs.php?subset=project and change your GPU settings to "no."

Jake
ID: 65327 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jean-Pierre HARLE

Send message
Joined: 25 Sep 08
Posts: 10
Credit: 56,038,086
RAC: 74,147
50 million credit badge10 year member badge
Message 65333 - Posted: 27 Sep 2016, 21:06:22 UTC - in response to Message 65327.  

Hey Jake,

All is OK now again ! Thank you very much !

Best regards.

Jean-Pierre
ID: 65333 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : News : New Version of MW@home for Mac (1.37)

©2019 Astroinformatics Group