Welcome to MilkyWay@home

Linux AMD RX480 GPU Still Crashing MW App


Advanced search

Message boards : Number crunching : Linux AMD RX480 GPU Still Crashing MW App
Message board moderation

To post messages, you must log in.

AuthorMessage
Paul

Send message
Joined: 3 Oct 16
Posts: 1
Credit: 44,467
RAC: 0
10 thousand credit badge2 year member badge
Message 66575 - Posted: 28 Aug 2017, 6:03:55 UTC

Hi All,

Could someone please help me figure out what is going on with MW GPU app? It's been broken for over a year, but I've upgraded every component since this problem started and nothing has fixed it.

I'm sure you know, but it's very difficult to diagnose these app failures, but, after the failed task is returned, I see this in the task log:

<core_client_version>7.8.0</core_client_version>
<![CDATA[
<message>
process exited with code 193 (0xc1, -63)
</message>
<stderr_txt>
<search_application> milkyway_separation 1.46 Linux x86_64 double OpenCL </search_application>
Reading preferences ended prematurely
BOINC GPU type suggests using OpenCL vendor 'Advanced Micro Devices, Inc.'
Setting process priority to 0 (13): Permission denied
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Switching to Parameter File 'astronomy_parameters.txt'
<number_WUs> 5 </number_WUs>
<number_params_per_WU> 20 </number_params_per_WU>
Using AVX path
Found 2 platforms
Platform 0 information:
Name: Clover
Version: OpenCL 1.1 Mesa 17.1.7
Vendor: Mesa
Extensions: cl_khr_icd
Profile: FULL_PROFILE
Platform 1 information:
Name: Portable Computing Language
Version: OpenCL 2.0 pocl 0.14, LLVM 4.0.0
Vendor: The pocl project
Extensions: cl_khr_icd
Profile: FULL_PROFILE
Didn't find preferred platform
Using device 0 on platform 0
Found 1 CL device
Device 'AMD POLARIS10 (DRM 3.15.0 / 4.12.8-300.fc26.x86_64, LLVM 4.0.0)' (AMD:0x1002) (CL_DEVICE_TYPE_GPU)
Board:
Driver version: 17.1.7
Version: OpenCL 1.1 Mesa 17.1.7
Compute capability: 0.0
Max compute units: 36
Clock frequency: 1288 Mhz
Global mem size: 8588091392
Local mem size: 32768
Max const buf size: 2147483647
Double extension: cl_khr_fp64
SIGSEGV: segmentation violation

Exiting...

</stderr_txt>
]]>
ID: 66575 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jake Weiss
Volunteer moderator
Project developer
Project tester
Project scientist

Send message
Joined: 25 Feb 13
Posts: 580
Credit: 75,271,794
RAC: 402
50 million credit badge6 year member badgeextraordinary contributions badge
Message 66577 - Posted: 28 Aug 2017, 15:02:46 UTC

Hi Paul,

It looks like you are running on the open source GPU drivers. This is a known issue that we are still trying to find a solution to. AMD stopped supporting newer Linux kernels with their proprietary drivers. I've personally tried several times over the last year to try to find a solution to this problem, but I haven't had much luck. I can give it another try later this week when I free up one of our development computers to put an AMD graphics card in.

Sorry.

Jake
ID: 66577 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Linux AMD RX480 GPU Still Crashing MW App

©2019 Astroinformatics Group