Welcome to MilkyWay@home

New nbody runs July 2


Advanced search

Message boards : News : New nbody runs July 2
Message board moderation

To post messages, you must log in.

AuthorMessage
Sidd
Project developer
Project tester
Project scientist

Send message
Joined: 19 May 14
Posts: 73
Credit: 356,131
RAC: 0
100 thousand credit badge5 year member badge
Message 67646 - Posted: 2 Jul 2018, 16:54:17 UTC

Hey All,

I just put up some new nbody runs. They will be the first to run off the new version (v170). I waited some time to put these up so the queue would clear out of the old workunits.

Please let me know if anyone encounters any issues with these runs.

As always, thank you for you continuing support,
Sidd
ID: 67646 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Aurum

Send message
Joined: 11 Jul 17
Posts: 9
Credit: 639,846,364
RAC: 2,761,005
500 million credit badge2 year member badge
Message 67650 - Posted: 3 Jul 2018, 11:07:45 UTC

I never get any nbody WUs. I have both checked in my milkyway preferences. Any idea why not???
ID: 67650 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileab1vl-pi
Avatar

Send message
Joined: 14 Jun 18
Posts: 4
Credit: 332,789
RAC: 0
100 thousand credit badge1 year member badge
Message 67656 - Posted: 5 Jul 2018, 14:14:34 UTC

Hey Sid,

Noob here... I'm noticing (I think) that the nbody WUs seem to grab precedence from Wus already in progress, but maybe I am mis-reading my task window. I notice this when restarting computers after resting them at night.

Unrelated: I never see any transfer activity in the Transfers window. But Wus show Ready to Report, eventually disappear, and my project total keeps incrementing up. So I presume all is well. Just curious.

tnx!

chuck
ID: 67656 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Michael McMullen

Send message
Joined: 30 Nov 17
Posts: 2
Credit: 28,510,959
RAC: 110,582
20 million credit badge1 year member badge
Message 67660 - Posted: 8 Jul 2018, 20:03:55 UTC

Turned on Nbodys again. They still cease making progress after a while, but keep the processors. Turned off Nbodys and aborted those in my que.
ID: 67660 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
greg_be

Send message
Joined: 18 Aug 09
Posts: 90
Credit: 6,689,387
RAC: 3,976
5 million credit badge10 year member badge
Message 67693 - Posted: 30 Jul 2018, 16:04:55 UTC

Getting checkpoint errors on Nbody and Milkway tasks.
Nothing works
ID: 67693 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Kris

Send message
Joined: 31 May 18
Posts: 1
Credit: 359,781
RAC: 0
100 thousand credit badge1 year member badge
Message 67698 - Posted: 2 Aug 2018, 12:00:38 UTC

I am getting errors with work units on Milkyway. WU's don't seem to be going down in the ETA, I had one say was going to take 731 days, up from the 4 hours when it downloaded.

Seems there's some issue somewhere.
ID: 67698 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileab1vl-pi
Avatar

Send message
Joined: 14 Jun 18
Posts: 4
Credit: 332,789
RAC: 0
100 thousand credit badge1 year member badge
Message 67700 - Posted: 6 Aug 2018, 21:07:12 UTC - in response to Message 67646.  
Last modified: 6 Aug 2018, 21:07:36 UTC

Sidd,

Starting to see nbody WUs stall after running for a few hours. Remaining time stops decrementing but can be induced to decrement by suspending and restarting. Both computers seen with this problem are dual core WIN7 SP1 with BOINC 7.12.1. One is Intel. Other is AMD. One has GPU other does not.

As a result I am not making a few nbody deadlines. Single core WUs seem to run normally.
ID: 67700 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
sjmielh

Send message
Joined: 9 Aug 09
Posts: 8
Credit: 3,536,699
RAC: 1,146
3 million credit badge10 year member badgeextraordinary contributions badge
Message 67711 - Posted: 18 Aug 2018, 6:59:56 UTC

Hi Sidd,

Will there be a Mac version again for the new nbody run?
ID: 67711 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
YWinger

Send message
Joined: 2 Sep 16
Posts: 5
Credit: 15,640,843
RAC: 2
10 million credit badge2 year member badge
Message 67713 - Posted: 19 Aug 2018, 18:11:54 UTC - in response to Message 67646.  

I am experiencing problems with N-Body simulation 1.7. I am seeing almost no CPU activity although 8 CPUs are assigned. Elapsed time is accruing but remaining time is increasing as well. No progress. A 3-1/2 hour work unit has 19 hours elapsed and now shows 4-1/4 hours remaining. I suspended all N-Body 1.7 work units and Home 1.46 work units were then picked up; all CPUs now running at around 75%. Please advise.
ID: 67713 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sidd
Project developer
Project tester
Project scientist

Send message
Joined: 19 May 14
Posts: 73
Credit: 356,131
RAC: 0
100 thousand credit badge5 year member badge
Message 67716 - Posted: 21 Aug 2018, 17:29:05 UTC - in response to Message 67711.  

Hey,

There seems to be an issue with openmp and the newest versions of mac, in that it is seemingly not supported anymore. We have someone working on that and will hopefully have a multi-threaded mac application soon. We have a single threaded application, but there was an error in putting it out; we are also looking into that.

All in all, we are currently working on getting our mac users an Nbody binary, but it may take some time unfortunately.

Thank you for your support,
Sidd
ID: 67716 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sidd
Project developer
Project tester
Project scientist

Send message
Joined: 19 May 14
Posts: 73
Credit: 356,131
RAC: 0
100 thousand credit badge5 year member badge
Message 67717 - Posted: 21 Aug 2018, 17:33:49 UTC - in response to Message 67713.  

Hey,

That seems a bit odd. I would go ahead and cancel it. It could be that the workunit got stuck somehow. I will look into why that is.

Thanks for letting us know,
Sidd
ID: 67717 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
YWinger

Send message
Joined: 2 Sep 16
Posts: 5
Credit: 15,640,843
RAC: 2
10 million credit badge2 year member badge
Message 67722 - Posted: 23 Aug 2018, 13:34:56 UTC - in response to Message 67717.  

More info on the N-Body issue.

Some are allocating 8 CPUs and only using 15%-20% of 4 CPUs.

Examples:
de_nbody_7_23_2018_v170_20k__data_1_1533467104_35769_0 de_nbody_7-23-2018_v170_20k__data_2_1533467104_35738_0
ID: 67722 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
YWinger

Send message
Joined: 2 Sep 16
Posts: 5
Credit: 15,640,843
RAC: 2
10 million credit badge2 year member badge
Message 67723 - Posted: 23 Aug 2018, 19:26:48 UTC - in response to Message 67722.  

For the two I mentioned earlier, between 11:00 and 13:36 their progress stayed at 71.234% and 61.237% and so I canceled them.
ID: 67723 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
YWinger

Send message
Joined: 2 Sep 16
Posts: 5
Credit: 15,640,843
RAC: 2
10 million credit badge2 year member badge
Message 67728 - Posted: 26 Aug 2018, 20:23:56 UTC - in response to Message 67717.  

I am still seeing issues with the N-Body. The work units get picked up and then they stall out while retaining the CPUs so other work units don't get processed.

The following example shows a 1.25 - 1.50 hour work unit that ran for almost 12 hours and attained only 7.52% completion. Estimated remaining time went from 1.5 hours to over 8 days.

8/25/2018
7:08:02 PM | Milkyway@Home | Starting task de_nbody_7_23_2018_v170_20k__data_2_1533467104_174546_0

2018-08-26
08:23 | Running (8 CPUs) - but 5 other single-CPU jobs running, plus 1 partial with GPU. All N-Body task estimates between 01:15 and 01:30
7.52% | 11:56:08 | 6d 02:49:41

12:50 |
7.52% | 15:56:28 | 8d 04:05:40
ID: 67728 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : News : New nbody runs July 2

©2019 Astroinformatics Group