Welcome to MilkyWay@home

Separation tasks immediately segfault


Advanced search

Questions and Answers : Unix/Linux : Separation tasks immediately segfault
Message board moderation

To post messages, you must log in.

AuthorMessage
Nethershaw

Send message
Joined: 5 Mar 11
Posts: 1
Credit: 4,831,741
RAC: 0
3 million credit badge8 year member badge
Message 68999 - Posted: 31 Aug 2019, 18:12:54 UTC

milkyway_1.46_x[31149]: segfault at 0 ip 00007f26d6f65052 sp 000000000080c278 error 6 in libclangAST.so.8[7f26d6d96000+2fb000]

Every MilkyWay@Home Separation task I run immediately encounters a segmentation fault and dumps a core. I'm running a Radeon RX Vega 10 on Gentoo Linux. I run numerous GPU tasks for other projects, but I do not have this problem with any of them. I'd very much like to participate, but I need more information to solve this problem. Here's my most recent result (there's not much to see here, sadly):

https://milkyway.cs.rpi.edu/milkyway/result.php?resultid=303606180

Considering the segfault is in libclangAST.so.8, could the problem possibly be with the Clang library I have installed, or perhaps its particular version (8.0.1)?
ID: 68999 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : Separation tasks immediately segfault

©2019 Astroinformatics Group