Welcome to MilkyWay@home

GPU app teaser


Advanced search

Message boards : Application Code Discussion : GPU app teaser
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 15 · 16 · 17 · 18 · 19 · Next

AuthorMessage
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 29560 - Posted: 21 Aug 2009, 15:51:14 UTC - in response to Message 29533.  

As I said, I hope the GPU application is updated to include the changes made to the ATI drivers that took place over six months ago. Soon new video cards will be released which will not run on the 8.12 drivers (not without the .ini 'hack').

But that change would most certainly break the app on all WinXP machines, as ATI obviously introduced a bug with Cat 9.3 they have still not fixed. And to copy and rename three files is normally not that much of an effort. There are a lot of people running new driver versions with Vista and Win7 ;)
ID: 29560 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Liranan

Send message
Joined: 20 Aug 09
Posts: 8
Credit: 41,276,077
RAC: 0
30 million credit badge12 year member badge
Message 31192 - Posted: 19 Sep 2009, 15:52:12 UTC - in response to Message 29560.  

As I said, I hope the GPU application is updated to include the changes made to the ATI drivers that took place over six months ago. Soon new video cards will be released which will not run on the 8.12 drivers (not without the .ini 'hack').

But that change would most certainly break the app on all WinXP machines, as ATI obviously introduced a bug with Cat 9.3 they have still not fixed. And to copy and rename three files is normally not that much of an effort. There are a lot of people running new driver versions with Vista and Win7 ;)


Renaming the files isn't hard work but it doesn't work and this is after several Windows and driver reinstallations. The application NEEDS updating! I don't care whether they create two different applications, one for XP and one for Vista/Win 7 but with the advent of the 5870 (which I'm going to buy) Milkey Way at home is going to lose out.

I am aware that BOINC are working on ATI recognition and usability through the client application itself but this application by MW is months overdue.
ID: 31192 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCrunch3r
Volunteer developer
Avatar

Send message
Joined: 17 Feb 08
Posts: 363
Credit: 258,227,990
RAC: 0
200 million credit badge13 year member badge
Message 31206 - Posted: 19 Sep 2009, 19:09:50 UTC - in response to Message 31192.  

As I said, I hope the GPU application is updated to include the changes made to the ATI drivers that took place over six months ago. Soon new video cards will be released which will not run on the 8.12 drivers (not without the .ini 'hack').

But that change would most certainly break the app on all WinXP machines, as ATI obviously introduced a bug with Cat 9.3 they have still not fixed. And to copy and rename three files is normally not that much of an effort. There are a lot of people running new driver versions with Vista and Win7 ;)


Renaming the files isn't hard work but it doesn't work and this is after several Windows and driver reinstallations. The application NEEDS updating! I don't care whether they create two different applications, one for XP and one for Vista/Win 7 but with the advent of the 5870 (which I'm going to buy) Milkey Way at home is going to lose out.

I am aware that BOINC are working on ATI recognition and usability through the client application itself but this application by MW is months overdue.


I'm not sure why you're referring to "them". The ATI app was written by Gipsel and NOT the MW team, so it's up to him to do it or not.

Besides that, if the MW team could ever come up with an ATI app by themselfs, which i highly doubt ( it's a micacle that they got the cuda thing going, after all), it should be easy for the server scheduler to send a matching app for whatever driver version is installed on the requesting host.

The boinc client includes the driver version/CAL version in it's work request ...



Join Support science! Joinc Team BOINC United now!
ID: 31206 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileKevint
Avatar

Send message
Joined: 22 Nov 07
Posts: 285
Credit: 1,076,786,368
RAC: 0
1 billion credit badge14 year member badge
Message 31229 - Posted: 20 Sep 2009, 5:00:20 UTC - in response to Message 31192.  
Last modified: 20 Sep 2009, 5:05:11 UTC

Renaming the files isn't hard work but it doesn't work and this is after several Windows and driver reinstallations. The application NEEDS updating! I don't care whether they create two different applications, one for XP and one for Vista/Win 7 but with the advent of the 5870 (which I'm going to buy) Milkey Way at home is going to lose out.
I am aware that BOINC are working on ATI recognition and usability through the client application itself but this application by MW is months overdue.



The "they" you speak if of NOT the BOINC staff - if it were left up to DA and the bunch it would still be months if not a year out.

Crunch3r is the one credited for getting this done . I think Gispel had some input to it, forgive me if I am missing someone here that I am not aware of.
But I do know for certain that DA and group had nothing to do with the implementation of ATI/CAL into BOINC core.


And the ATI app was not written by the MW staff. As mentioned by Crunch3r, it was Gispel that did this work.

It took the MW staff MONTHS to even get a working version for CUDA - and I have to wonder how well that code is really doing. Not well from what I have heard and seen.

The MW/CAL app is an optimized app, and in my opinion does not need updating any more than it is. You don't have to run it you know.... There are stock apps that you can crunch with and not have to worry about renaming any files or doing anything special to get them to run.
.
ID: 31229 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 31266 - Posted: 21 Sep 2009, 0:03:13 UTC - in response to Message 31192.  
Last modified: 21 Sep 2009, 0:04:36 UTC

The application NEEDS updating! I don't care whether they create two different applications, one for XP and one for Vista/Win 7 but with the advent of the 5870 (which I'm going to buy) Milkey Way at home is going to lose out.

What do you want to hear? That I don't care about you not beeing able to copy some lousy files?
And I don't NEED to do anything. It was just a voluntary effort from my side, because I got curious how fast it would be. What did I get from that? A load of work and nothing else. I could have spent my time also with something more important. I don't need that some pissed off guy probably just too stupid to follow simple instructions tries to tell me what I have to do.

Your case is very simple. Windows tells you it can't find a file. That means the appropriate file is not in the appropriate location. You have to fix that. Go figure!
ID: 31266 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileCappy [Team Musketeers]
Avatar

Send message
Joined: 3 Oct 07
Posts: 71
Credit: 33,212,009
RAC: 0
30 million credit badge14 year member badge
Message 31267 - Posted: 21 Sep 2009, 0:18:57 UTC

readme file :) its our best friend :)
ID: 31267 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge13 year member badge
Message 31289 - Posted: 21 Sep 2009, 16:09:11 UTC - in response to Message 31266.  

And I don't NEED to do anything. It was just a voluntary effort from my side, because I got curious how fast it would be. What did I get from that? A load of work and nothing else. I could have spent my time also with something more important.

The work put in by Gipsel and others is awesome and quite rightly he didn't NEED to do it or let any of us benefit from it. Cheers Gipsel and testers etc. You're the best!



ID: 31289 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfilePaul D. Buck

Send message
Joined: 12 Apr 08
Posts: 621
Credit: 161,934,067
RAC: 0
100 million credit badge13 year member badge
Message 31601 - Posted: 27 Sep 2009, 0:24:00 UTC - in response to Message 31266.  

What did I get from that? A load of work and nothing else.

Though it is of little value, you have my thanks and admiration. For what it is worth, I repeat the thanks ...

If for no other reason than it shows that the ATI cards are just as capable and valuable in GPU work as the Nvidia cards.
ID: 31601 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilecenit

Send message
Joined: 16 Mar 09
Posts: 58
Credit: 1,129,612
RAC: 0
1 million credit badge12 year member badge
Message 32326 - Posted: 12 Oct 2009, 14:32:23 UTC - in response to Message 31601.  

What did I get from that? A load of work and nothing else.

Though it is of little value, you have my thanks and admiration. For what it is worth, I repeat the thanks ...

Dear Gipsel, you have my thanks and admiration too. Your dedication to this project is really fantastic, without even being in the MW team you seem to give the best support.
ID: 32326 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Edgeman

Send message
Joined: 19 Oct 09
Posts: 10
Credit: 8,583,453
RAC: 0
5 million credit badge12 year member badge
Message 32550 - Posted: 19 Oct 2009, 16:13:11 UTC

I am a complete newb, and this thread is far too long to read through the entire thing.
I have a Q6600 with an HD4850 in it, on Win7x64, sitting idle. I was running SETI on the CPU, but if I can use the ATI card to accomplish something, I want to.
Can someone provide a coles-notes version of this thread maybe?
ID: 32550 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profilebanditwolf
Avatar

Send message
Joined: 12 Nov 07
Posts: 2425
Credit: 524,164
RAC: 0
500 thousand credit badge14 year member badge
Message 32553 - Posted: 19 Oct 2009, 16:42:53 UTC - in response to Message 32550.  

I am a complete newb, and this thread is far too long to read through the entire thing.
I have a Q6600 with an HD4850 in it, on Win7x64, sitting idle. I was running SETI on the CPU, but if I can use the ATI card to accomplish something, I want to.
Can someone provide a coles-notes version of this thread maybe?

Just connect up to Mw like any other project. There are opti apps if you want to use them.
Doesn't expecting the unexpected make the unexpected the expected?
If it makes sense, DON'T do it.
ID: 32553 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Edgeman

Send message
Joined: 19 Oct 09
Posts: 10
Credit: 8,583,453
RAC: 0
5 million credit badge12 year member badge
Message 32577 - Posted: 20 Oct 2009, 13:02:51 UTC

Well, I found the app in this thread, put it into the right folder I believe (programdata/boinc/projects/milkyway), and BOINC seems to pick it up now...
But all the results I got ended with computation error, so I've put the whole system on hold and don't know where to go from here :/

System:
Asus P5B Deluxe
Intel Q6600 factory clocks
ATI Radeon HD 4850 factory clocks
single stick of 1 GB DDR2
Windows 7 Enterprise x64
Latest ATI Catalyst drivers for Win7x64

And the system doesn't really do anything except torrents and BOINC, so interface lagging is not an issue for me.

Any ideas how to solve the computation errors?
Is there anything I can submit to help development?
ID: 32577 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Edgeman

Send message
Joined: 19 Oct 09
Posts: 10
Credit: 8,583,453
RAC: 0
5 million credit badge12 year member badge
Message 32578 - Posted: 20 Oct 2009, 13:44:36 UTC

nvm, I've been given a better link than the one I found here and will try out a different version of the app/instructions when I get home and am not stuck with RDP.
Will report then.
ID: 32578 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge13 year member badgeextraordinary contributions badge
Message 32579 - Posted: 20 Oct 2009, 15:51:14 UTC - in response to Message 32578.  

nvm, I've been given a better link than the one I found here and will try out a different version of the app/instructions when I get home and am not stuck with RDP.
Will report then.

If you are logged in through RDP the application can't access the graphics card. This is more or less a limitation of Windows (applies to CUDA apps, too) as it uses a virtual graphics card driver for the remote sessions (which doesn't support GPGPU computations of course).

The application has to run in the console session. The latest BOINC release (6.10.15) has some code added to detect a remote desktop connection and pauses the GPU application execution. If you have to run it remote you may try VNC (I use UltraVNC) *without* the mirror driver. The responsiveness will be worse, but it works.
ID: 32579 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profileverstapp
Avatar

Send message
Joined: 26 Jan 09
Posts: 589
Credit: 497,834,261
RAC: 0
300 million credit badge12 year member badge
Message 32587 - Posted: 20 Oct 2009, 21:21:29 UTC

There are a lot of computation errors going around nowadays, about half of each batch of 48WUs on my 'general use' PC ends up that way. Almost none on my crunchers. Doesn't seem to be hurting the rac though, probably because they fail as soon as they start and don't waste much time crunching before failing.
3 of my 6 4870s I access via TightVNC, without problems.
Cheers,

PeterV

.
ID: 32587 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Edgeman

Send message
Joined: 19 Oct 09
Posts: 10
Credit: 8,583,453
RAC: 0
5 million credit badge12 year member badge
Message 32588 - Posted: 20 Oct 2009, 22:02:32 UTC
Last modified: 20 Oct 2009, 22:29:15 UTC

Alright, got the ATI app working. Was crunching through WU's in 45-60 seconds apiece... right up until it locked up and reset the card :/
Temperature went from ~40C to ~85C...
Added a second 120mm fan blowing at the card, and it locked up even faster... was only around 65C at the time.

Not sure what's causing the lockups, as I can't see any way to keep this thing cooler other than replacing the whole hs/f with watercooling or something else outrageous...



EDIT: I closed GPUZ and now it's running WU's just fine, almost 1 credit per second based on the numbers I'm seeing...
Fantastic work!
ID: 32588 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
bobgoblin

Send message
Joined: 8 Dec 07
Posts: 60
Credit: 67,028,931
RAC: 0
50 million credit badge13 year member badge
Message 32701 - Posted: 24 Oct 2009, 12:25:20 UTC - in response to Message 32587.  
Last modified: 24 Oct 2009, 12:31:10 UTC

duplicate entry
ID: 32701 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
bobgoblin

Send message
Joined: 8 Dec 07
Posts: 60
Credit: 67,028,931
RAC: 0
50 million credit badge13 year member badge
Message 32703 - Posted: 24 Oct 2009, 12:29:28 UTC - in response to Message 32587.  

There are a lot of computation errors going around nowadays, about half of each batch of 48WUs on my 'general use' PC ends up that way. Almost none on my crunchers. Doesn't seem to be hurting the rac though, probably because they fail as soon as they start and don't waste much time crunching before failing.
3 of my 6 4870s I access via TightVNC, without problems.



I'm seeing several wu's with computation errors too but not in that great number. I noticed some running version .20, and my GPU would lock up every now and then, hd 4850 1g with catalyst 9.9. so I installed version .20b. but now the lock ups are happening more frequently, so I upgraded catalyst to version 9.10 last night. It only ran a few hours and locked up again.

It seems that if they fail right away, then the gpu doesn't lock up. But if they fail after they've been crunching for a few seconds or near the end, it locks up the gpu
ID: 32703 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
bobgoblin

Send message
Joined: 8 Dec 07
Posts: 60
Credit: 67,028,931
RAC: 0
50 million credit badge13 year member badge
Message 32731 - Posted: 25 Oct 2009, 14:19:09 UTC - in response to Message 32703.  
Last modified: 25 Oct 2009, 14:21:17 UTC

There are a lot of computation errors going around nowadays, about half of each batch of 48WUs on my 'general use' PC ends up that way. Almost none on my crunchers. Doesn't seem to be hurting the rac though, probably because they fail as soon as they start and don't waste much time crunching before failing.
3 of my 6 4870s I access via TightVNC, without problems.



I'm seeing several wu's with computation errors too but not in that great number. I noticed some running version .20, and my GPU would lock up every now and then, hd 4850 1g with catalyst 9.9. so I installed version .20b. but now the lock ups are happening more frequently, so I upgraded catalyst to version 9.10 last night. It only ran a few hours and locked up again.

It seems that if they fail right away, then the gpu doesn't lock up. But if they fail after they've been crunching for a few seconds or near the end, it locks up the gpu



I figured out my own problem. The issue of MW locking up on the gpu had been going on all along. I had been running multiples, 3 @ the same time. I would notice much later that only 2 or 1 were running, then close Boinc and restart. But I had switched over to running only 1 @ a time, and several weeks later I began having the intermittent problem of MW not processing at all as the 1 unit has locked up and cannot release the next to process.

I finally realized the two issues were the same issue and started running 2 units at the same time again.
ID: 32731 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Edgeman

Send message
Joined: 19 Oct 09
Posts: 10
Credit: 8,583,453
RAC: 0
5 million credit badge12 year member badge
Message 32771 - Posted: 26 Oct 2009, 14:01:10 UTC

I've got a 512 MB 4850, running 1 unit at a time, catalyst 9.9, Windows 7 x64, app 20b, seems to be running fine, no lockups that I've seen.
Is this card capable of running 2 WU's at a time without incident?
ID: 32771 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 . . . 15 · 16 · 17 · 18 · 19 · Next

Message boards : Application Code Discussion : GPU app teaser

©2021 Astroinformatics Group