Welcome to MilkyWay@home

GLIBC version


Advanced search

Questions and Answers : Unix/Linux : GLIBC version
Message board moderation

To post messages, you must log in.

AuthorMessage
Mateusz Nowak

Send message
Joined: 4 Oct 07
Posts: 4
Credit: 13,246
RAC: 0
10 thousand credit badge10 year member badge
Message 480 - Posted: 17 Nov 2007, 13:01:59 UTC
Last modified: 17 Nov 2007, 13:04:28 UTC

Hi.

I'm using Mandriva 2006, which has GLIBC version 2.3, but application for this project is linked against version 2.4, resulting in "compute errors" (for example:
Result 247167)

I know my distribution is quite old, but many other projects (and BOINC obviously ;) run here without problem.

Would it be possible to support such old systems, or at least warn users about minimum required version of GLIBC?

Mateusz
ID: 480 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Mateusz Nowak

Send message
Joined: 4 Oct 07
Posts: 4
Credit: 13,246
RAC: 0
10 thousand credit badge10 year member badge
Message 870 - Posted: 2 Dec 2007, 5:17:43 UTC

The new application (1.12) is still linked against 2.4 (result 568490, ldd confirms). I'm pointing this out, because you wrote in the news that something has been done about it. Maybe you could try static linking? Other projects seems to go that way.

Anyway, this project is very interesting, and as soon as my laptop (with Windows) returns from repairs I'll attach it here.

Mateusz
ID: 870 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
saccia

Send message
Joined: 14 Nov 07
Posts: 2
Credit: 108,200
RAC: 0
100 thousand credit badge10 year member badge
Message 920 - Posted: 4 Dec 2007, 21:05:45 UTC - in response to Message 870.  

As an aside, you may way to consider trying to upgrade your distro. Even the official BOINC client (5.10.21) no longer supports anything below glibc 2.4. The official BOINC changed sometime around the late releases of 5.8.x. Mainly it was done to coincide with their updated compiler which gave some pretty good enhancements to the benchmarks that made the benchmarks more in line with those on Windows platforms. I would think that a lot more apps in the future will start being compiled on newer gcc and glibc versions to get these improvements in the science apps themselves.
ID: 920 · Rating: 1 · rate: Rate + / Rate - Report as offensive     Reply Quote
Mateusz Nowak

Send message
Joined: 4 Oct 07
Posts: 4
Credit: 13,246
RAC: 0
10 thousand credit badge10 year member badge
Message 925 - Posted: 4 Dec 2007, 21:53:08 UTC - in response to Message 920.  

Actually I'm using official 5.10.21 on this computer and I'm quite happy with better benchmarks than 5.8.x :) I'm considering upgrade, but as for now it's not possible. Anyway I'll use my laptop to crunch for this project (as soon as it will be back)

Mateusz
ID: 925 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Temujin

Send message
Joined: 12 Oct 07
Posts: 77
Credit: 404,471,187
RAC: 0
300 million credit badge10 year member badge
Message 1037 - Posted: 13 Dec 2007, 15:39:43 UTC - in response to Message 925.  

Is it possible to install glibc 2.4 just for a single user or application?

I have a whole bunch of glibc < 2.4 machines which can't be upgraded to glibc 2.4 (internal business policy) but could have glibc 2.4 installed "locally" if its possible.
ID: 1037 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Desti

Send message
Joined: 1 Sep 07
Posts: 3
Credit: 1,222,303
RAC: 0
1 million credit badge10 year member badge
Message 1065 - Posted: 14 Dec 2007, 17:51:52 UTC

Maybe in a chroot environment or in a virtual machine.
Linux Users Everywhere @ BOINC
ID: 1065 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileConan
Avatar

Send message
Joined: 2 Jan 08
Posts: 105
Credit: 65,396,973
RAC: 0
50 million credit badge10 year member badge
Message 1255 - Posted: 2 Jan 2008, 13:36:11 UTC

I have just joined this project and all downloaded WU's have failed with Error 1.
I am using Fedora Core 3 which uses "libc 2.3.6".
Has this issue been seen to or do we just dump this project?

I have just connected another Fedora Core machine but this one runs version FC6, with "libc 2.5", just to see if that one will work.

I have found no note anywhere on this project by the Admin staff that "libc 2.4" or higher is required.
ID: 1255 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Dotsch

Send message
Joined: 31 Aug 07
Posts: 20
Credit: 1,022
RAC: 0
1 credit badge10 year member badge
Message 1281 - Posted: 3 Jan 2008, 1:53:04 UTC - in response to Message 1255.  

I have just joined this project and all downloaded WU's have failed with Error 1.
I am using Fedora Core 3 which uses "libc 2.3.6".
Has this issue been seen to or do we just dump this project?

I have just connected another Fedora Core machine but this one runs version FC6, with "libc 2.5", just to see if that one will work.

I have found no note anywhere on this project by the Admin staff that "libc 2.4" or higher is required.

Please be patient. Travis (the project admin) awnsers questions normaly very quickly. But as there are no awnsers these days, it looks he is still in vacation.

It looks like the Linux application requires a GLIBC >= 2.4.
ID: 1281 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileConan
Avatar

Send message
Joined: 2 Jan 08
Posts: 105
Credit: 65,396,973
RAC: 0
50 million credit badge10 year member badge
Message 1394 - Posted: 8 Jan 2008, 10:53:04 UTC

Does anyone know if you can upgrade the "glibc" library on an older Linux Distro without updating the Distro itself ?

I am loathe to update my two FC3 installs as it runs so smoothly without problems on all the Boinc projects I do (other than Milkyway that is).

Also updating the software may cause Boinc to see it as another computer and give it an all new identity, which I probably wont be able to merge and stuffs up my stats.

Boinc Client does support older operating systems very nicely as I am running 5.10.21 on these Linux Fedora Core 3 systems without problems.

So this is just a compilation issue with the MilkyWay application.

Is it possible to somehow make it so that pre 'glibc 2.4' and post 'glibc 2.4' all can work ? (Probably a lot of work but a lot more computers would be able to come on board if it could be done).

Thanks.

(Remember to keep smiling as it makes others wonder what you have been up to)
ID: 1394 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
ProfileKeck_Komputers
Avatar

Send message
Joined: 29 Aug 07
Posts: 20
Credit: 1,113,209
RAC: 179
1 million credit badge10 year member badge
Message 1397 - Posted: 8 Jan 2008, 18:30:23 UTC

If you copy the old data directory to the new install BOINC will usually keep the same host info. I personally do not worry about new hosts anymore because sometimes you get them no matter what you do.
BOINC WIKI

BOINCing since 2002/12/8
ID: 1397 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Kenneth Larsen

Send message
Joined: 6 Oct 07
Posts: 2
Credit: 906,408
RAC: 0
500 thousand credit badge10 year member badge
Message 1607 - Posted: 27 Jan 2008, 13:24:49 UTC

You should be able to upgrade GLIBC on your current installation, although I do not know Fedora. Isn't it available in the package manager?
ID: 1607 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Questions and Answers : Unix/Linux : GLIBC version

©2019 Astroinformatics Group