Welcome to MilkyWay@home

3rd.in - optimized apps


Advanced search

Message boards : Number crunching : 3rd.in - optimized apps
Message board moderation

To post messages, you must log in.

Previous · 1 . . . 26 · 27 · 28 · 29 · 30 · 31 · 32 . . . 40 · Next

AuthorMessage
Ironworker16
Avatar

Send message
Joined: 31 Jan 09
Posts: 31
Credit: 69,908,565
RAC: 0
50 million credit badge10 year member badge
Message 30235 - Posted: 5 Sep 2009, 11:58:34 UTC

What I have noticed is that my RAC has went up over 2000 since installing 0.19g.
ID: 30235 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileKevint
Avatar

Send message
Joined: 22 Nov 07
Posts: 285
Credit: 1,076,786,368
RAC: 0
1 billion credit badge10 year member badge
Message 30286 - Posted: 6 Sep 2009, 15:39:33 UTC



I am not seeing a benefit in "upgrading" what are the mods made besides priority ?
.
ID: 30286 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileDan T. Morris
Avatar

Send message
Joined: 17 Mar 08
Posts: 165
Credit: 410,228,216
RAC: 0
300 million credit badge10 year member badge
Message 30289 - Posted: 6 Sep 2009, 16:00:12 UTC - in response to Message 30286.  



I am not seeing a benefit in "upgrading" what are the mods made besides priority ?


Neither am I...Did I miss something?

It seems to be the same on my test machine..


ID: 30289 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge10 year member badgeextraordinary contributions badge
Message 30290 - Posted: 6 Sep 2009, 16:15:58 UTC - in response to Message 30289.  
Last modified: 6 Sep 2009, 16:23:29 UTC



I am not seeing a benefit in "upgrading" what are the mods made besides priority ?


Neither am I...Did I miss something?

It seems to be the same on my test machine..

You are not missing anything. There is only one further change besides the priority in 0.19g (but 0.20 will have much more ;).

If you dedicate the system to Milkyway or at least reserve a core for feeding the GPU(s) 0.19g won't make an improvement. It may even loose slightly to 0.19f as it has an increased GPU polling interval (didn't show an disadvantage on my test system but quite some people report it to be slower though). If you use all available cores to run some CPU applications and run MW in addition to that, the higher priority will help quite a bit. The priority was actually also the reason the update to the CUDA app dropped the times almost to the half ;)
ID: 30290 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileDan T. Morris
Avatar

Send message
Joined: 17 Mar 08
Posts: 165
Credit: 410,228,216
RAC: 0
300 million credit badge10 year member badge
Message 30291 - Posted: 6 Sep 2009, 16:37:53 UTC - in response to Message 30290.  

Thanks CP... I thought that I had missed something on an earlier post.

Thank you for the information.. Oh and thank you very much for your hard work on these apps. You are the man....

SM....
ID: 30291 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileFarscape
Avatar

Send message
Joined: 6 Apr 09
Posts: 26
Credit: 866,483,032
RAC: 944
500 million credit badge10 year member badge
Message 30443 - Posted: 10 Sep 2009, 5:29:08 UTC

I don't know exactly what changed in 19g BUT - I haven't had a crash in 9 hours (as opposed to about a 2-3 hour max between crashes). I am running Catalyst 9.8 on Vista 64-bit with a 4870x2. This is the first time in several months that I haven't crashed repeatedly - THANKS a BUNCH CP!!!!

So far so good.....
ID: 30443 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileSenilix

Send message
Joined: 8 Aug 08
Posts: 30
Credit: 74,566,409
RAC: 0
50 million credit badge10 year member badge
Message 30445 - Posted: 10 Sep 2009, 11:33:05 UTC - in response to Message 30025.  

If I have the optimised app and app_info file from zslip will that stop me getting the new CUDA wu that are out for NVIDEA GPU's.


They should work together okay


The app_info from zslip only affects work for ATI GPUs. The 6.*.* versions of BOINC that detect CUDA will start or stop work for CUDA, not the presence of any app_info for ATI.


Doesn't work for me. After shutting down the BOINC client and copying the optimized app and the app_info file, BOINC discarded all of my CUDA wus:

10.09.2009 13:22:49 Milkyway@home Found app_info.xml; using anonymous platform
10.09.2009 13:22:49 Milkyway@home [error] No application found for task: windows_intelx86 20 cuda23; discarding

Then it started to download CPU wus only - never got any CUDA wu.

My best guess is that one would need an app_info file with entries for the optimized CPU app and the CUDA app as well. Any help with that would be appreciated.


ID: 30445 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile(_KoDAk_)

Send message
Joined: 13 Jul 08
Posts: 33
Credit: 21,285,010
RAC: 0
20 million credit badge10 year member badge
Message 30462 - Posted: 10 Sep 2009, 22:04:18 UTC
Last modified: 10 Sep 2009, 22:06:51 UTC

i got new app (win7x64-driver 9.5 boinc -6.6.38)
astronomy_0.19g_ATI.exe
work's gut
but were x64 app???
ID: 30462 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 30464 - Posted: 10 Sep 2009, 23:07:18 UTC - in response to Message 30462.  

i got new app (win7x64-driver 9.5 boinc -6.6.38)
astronomy_0.19g_ATI.exe
work's gut
but were x64 app???

It's right there in brilliantsite.com and offers ati_0.19g_win64.zip.exe if you click on Win64 which will extract astronomy_0.19g_ATI_x64.exe;

version 0.19g : Win32_x87, Win32_SSE2, Win64




ID: 30464 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile(_KoDAk_)

Send message
Joined: 13 Jul 08
Posts: 33
Credit: 21,285,010
RAC: 0
20 million credit badge10 year member badge
Message 30473 - Posted: 11 Sep 2009, 8:00:28 UTC

No it is not
I use http://www.brilliantsite.com/milkyway/win-ati-19g/ati_0.19g_win64.zip but boinc
loads astronomy_0.19g_ATI.exe
and in the folder of the project are
astronomy_0.19g_ATI.exe
astronomy_0.19g_ATI_SSE2.exe
astronomy_0.19g_ATI_x64.exe
ID: 30473 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 30474 - Posted: 11 Sep 2009, 9:34:20 UTC - in response to Message 30473.  

No it is not
I use http://www.brilliantsite.com/milkyway/win-ati-19g/ati_0.19g_win64.zip but boinc
loads astronomy_0.19g_ATI.exe
and in the folder of the project are
astronomy_0.19g_ATI.exe
astronomy_0.19g_ATI_SSE2.exe
astronomy_0.19g_ATI_x64.exe

You should only have one file beginning astronomy_0.19g_ATI_... in the projects/milkyway.cs.rpi.edu_milkyway folder. Which file is that which is most appropriate for your PC.

In your case I suspect you want astronomy_0.19g_ATI_x64.exe, and you should delete the other 2.



ID: 30474 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile(_KoDAk_)

Send message
Joined: 13 Jul 08
Posts: 33
Credit: 21,285,010
RAC: 0
20 million credit badge10 year member badge
Message 30481 - Posted: 11 Sep 2009, 12:57:17 UTC
Last modified: 11 Sep 2009, 12:58:45 UTC

ok del
but bounc not run's
and in folder i see --
astronomy_0.19_ATI_SSE2f.exe
astronomy_0.19_ATI_x64f.exe
astronomy_0.19g_ATI_x64.exe

p.s. after 10 min OK

senks
ID: 30481 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 30483 - Posted: 11 Sep 2009, 14:08:13 UTC - in response to Message 30481.  
Last modified: 11 Sep 2009, 14:08:54 UTC

ok del
but bounc not run's
and in folder i see --
astronomy_0.19_ATI_SSE2f.exe
astronomy_0.19_ATI_x64f.exe
astronomy_0.19g_ATI_x64.exe

p.s. after 10 min OK

senks

You're welcome. Glad you got it working.

ID: 30483 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Misfit
Avatar

Send message
Joined: 27 Aug 07
Posts: 915
Credit: 1,503,319
RAC: 0
1 million credit badge10 year member badge
Message 30553 - Posted: 12 Sep 2009, 4:44:43 UTC - in response to Message 30089.  

The 'zslip' optimized apps web page has been transferred to;

http://www.brilliantsite.com/milkyway

zslip.com will redirect to the above link for a while, until the meter runs out...

Dude you need to PM me with stuff like this.
me@rescam.org
ID: 30553 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileGalaxyIce
Avatar

Send message
Joined: 6 Apr 08
Posts: 2018
Credit: 100,142,856
RAC: 0
100 million credit badge10 year member badge
Message 30613 - Posted: 12 Sep 2009, 20:36:27 UTC - in response to Message 30553.  
Last modified: 12 Sep 2009, 20:38:35 UTC

The 'zslip' optimized apps web page has been transferred to;

http://www.brilliantsite.com/milkyway

zslip.com will redirect to the above link for a while, until the meter runs out...

Dude you need to PM me with stuff like this.

It's OK, zslip will still work until the beginning of November. Then I have one less website to worry about. brilliantsite will do the job nicely ;)

ID: 30613 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileSimplex0
Avatar

Send message
Joined: 11 Nov 07
Posts: 232
Credit: 178,229,009
RAC: 18
100 million credit badge10 year member badge
Message 30621 - Posted: 12 Sep 2009, 21:56:31 UTC - in response to Message 30200.  

Yes I noticed processing time increased by just over 50% with 0.19g. Couldn't get GPU load over about 60% no matter what wait factor I tried. GPU processing was jerky with load occasionally falling to zero. Not as jerky as Collatz with -k512 but the same kind of effect. Runs really cool like Collatz too. Mucked around with it for half an hour then changed back to 0.19f and went to bed.


Duuuh!
Same problem here after instaling BOINC 6.10.4 and 0.19g.
I will rol back to BOINC 6.4.7 and se if that's solve the problem.
ID: 30621 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Misfit
Avatar

Send message
Joined: 27 Aug 07
Posts: 915
Credit: 1,503,319
RAC: 0
1 million credit badge10 year member badge
Message 30637 - Posted: 13 Sep 2009, 4:08:01 UTC - in response to Message 30613.  

The 'zslip' optimized apps web page has been transferred to;

http://www.brilliantsite.com/milkyway

zslip.com will redirect to the above link for a while, until the meter runs out...

Dude you need to PM me with stuff like this.

It's OK, zslip will still work until the beginning of November. Then I have one less website to worry about. brilliantsite will do the job nicely ;)

Too late, I already changed the fwd.
me@rescam.org
ID: 30637 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Cluster Physik

Send message
Joined: 26 Jul 08
Posts: 627
Credit: 94,940,203
RAC: 0
50 million credit badge10 year member badgeextraordinary contributions badge
Message 30640 - Posted: 13 Sep 2009, 4:53:48 UTC

My 0.20 versions for CPUs are ready and available for download here.

Most important change from the scientific side is an improved accuracy (better than the stock app ;), which exactly matches the results of the new 0.20 ATI versions (have to run the last tests on that, will be posted tomorrow if nothing goes wrong).

But it also got slightly faster and there are now 64bit versions in the package which add some more percents to the performance (about 15% on a Phenom with a 2stream WU). And as always, read the included readme.txt!
ID: 30640 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileSimplex0
Avatar

Send message
Joined: 11 Nov 07
Posts: 232
Credit: 178,229,009
RAC: 18
100 million credit badge10 year member badge
Message 30644 - Posted: 13 Sep 2009, 6:56:43 UTC - in response to Message 30640.  
Last modified: 13 Sep 2009, 7:22:13 UTC

Tank you CP!
ID: 30644 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ProfileGary Roberts

Send message
Joined: 1 Mar 09
Posts: 56
Credit: 1,984,937,499
RAC: 0
1 billion credit badge10 year member badge
Message 30646 - Posted: 13 Sep 2009, 7:23:03 UTC - in response to Message 30644.  

The readme file was not that informative.

It actually said exactly what it needed to say.

Which one is the GPU application Win64_SSE3 or Win64 or all of them?

None of them. Go back and actually read the message - particularly the bit in bold. Then wait for tomorrow ;-).

@CP - Thanks for the nice little speedup. I'm running it on a 2.66GHz Northwood P4 and a 3s task has dropped from about 83 mins to 73 mins approximately. Pretty much the 10% or so you stated. No problems so far. I look forward to the ATI app tomorrow.

Cheers,
Gary.
ID: 30646 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Previous · 1 . . . 26 · 27 · 28 · 29 · 30 · 31 · 32 . . . 40 · Next

Message boards : Number crunching : 3rd.in - optimized apps

©2020 Astroinformatics Group