Welcome to MilkyWay@home

Posts by Conan

1) Message boards : Number crunching : New team member lots of pendings or invalids. (Message 71097)
Posted 3 Sep 2021 by ProfileConan
Post:
G'Day Rick,

From what I can see, most of the Validaion Inconclusive work units are just waiting for a wingman to return their work so it can be compared to your work and then validated.
They are marked as pending as they are still waiting on the other person.

The invalids I am not sure about, possibly just not agreeing with the other person's returned result. Other people who know more might be able to expand on that.

Conan
2) Message boards : News : New Separation Runs 6/9/2021 (Message 71049)
Posted 3 Aug 2021 by ProfileConan
Post:
Thanks Jim and Al. That seems to make sense.

Upgrading may be an issue as I have the last version output by BOINC themselves.

The later versions seem to have a lot to do with the distributors of the various Linux versions.
I have tried some in the past but I don't like the way they store my data all over the place and I lose control as it all goes to root control.

But there is a way I think to take back that control and install a later version my way, I will have to think about it and have a go at a later date.

Conan
3) Message boards : News : New Separation Runs 6/9/2021 (Message 71045)
Posted 2 Aug 2021 by ProfileConan
Post:
All Linux Separation work units are failing with the following error

Task 276551426
Name de_modfit_85_bundle4_4s_south4s_gapfix_1627399316_3938308_0
Workunit 145671322
Created 1 Aug 2021, 16:42:15 UTC
Sent 1 Aug 2021, 16:53:15 UTC
Report deadline 13 Aug 2021, 16:53:15 UTC
Received 2 Aug 2021, 22:00:35 UTC
Server state Over
Outcome Computation error
Client state Compute error
Exit status 1 (0x00000001) Unknown error code
Computer ID 448629
Run time 2 sec
CPU time
Validate state Invalid
Credit 0.00
Device peak FLOPS 4.33 GFLOPS
Application version Milkyway@home Separation v1.46
x86_64-pc-linux-gnu
Peak disk usage 0.01 MB
Stderr output

<core_client_version>7.4.25</core_client_version>
<![CDATA[
<message>
process exited with code 1 (0x1, -255)
</message>
<stderr_txt>
<search_application> milkyway_separation 1.46 Linux x86_64 double </search_application>
Reading preferences ended prematurely
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Switching to Parameter File 'astronomy_parameters.txt'
<number_WUs> 4 </number_WUs>
<number_params_per_WU> 26 </number_params_per_WU>
stream sigma 0.0 is invalid
Failed to get stream constants
07:58:52 (32011): called boinc_finish(1)

</stderr_txt

Windows is working OK on Separation WUs, N-Body works fine on same Linux computer, using just CPU for both WU types.

Conan
4) Message boards : Number crunching : Running N-Body work units (Message 65979)
Posted 30 Nov 2016 by ProfileConan
Post:
After a bit of an absence from the project I have come back to run some of the N-Body simulations after reading about it in an astronomy magazine.

I recently also started running an older 8 core/16 thread xeon server picked up cheaply.

I have been noticing a few things about these Multi-Threaded work units (mt).

The first thing you of course notice is the very low credit per work unit. Searching other results as well as mine I have seen as low as 1.48 credits for a WU and as high as 41 credits, with most around the 15 to 26 credit mark.

Second thing is this credit to some degree seems related to the benchmark figures.

Third thing is the more cores running the WU the less credit per hour you will get.
This is due to the extra CPU time run up by the extra cores.

A 4 core machine may take a RUN time of 800 seconds for a CPU time of 3,200 seconds (this is approximate).
My 16 core machine drops the RUN time to 500 seconds but the CPU time goes up to 8,000 seconds in doing so.

This then means that if 26 credits are awarded then the 4 core computer gets 29.25 cr/h and is doing OK, however my 16 core only gets 11.7 cr/h.

The WU's only run a short time, however a number get downloaded at once and take some time to work through, stopping my computer from running any other projects.

With credit per hour measured against CPU time not RUN time I don't get much reward for these work units.

Yes I could limit the number of cores being used but that is a lot of mucking around and will affect other projects that I run (which is over 2 dozen).

I was surprised that a Multi Threaded aplication is not awarding the effort of extra cores being used to solve the problem, less cores more reward.

So does this application become less efficient after a certain number of cores are reached? If so that should be stated to anyone wanting to run the application.

Thanks
Conan
5) Message boards : News : Nbody Status Update (Message 63848)
Posted 3 Aug 2015 by ProfileConan
Post:
You mentioned about compiling nbody on an XP machine. Last I recalled, XP was only 32 bit. You seem to be doing a lot of floating point arithmetic. Are you doing double-precision? If so, wouldn't a 64-bit compiled version have to use different code and at least a 64-bit compiler? Am I missing something?


I understood that Windows XP came in both 32 and 64 Bit flavours, not just 32 Bit.
But as Sidd took down the Windows app for N-Body due to a bug that appears to yet be fixed then this is probably a mute point.

I just came back to run a few N-Body work units on my Linux computers, but as none are currently available I will have to wait.

Conan
6) Message boards : Number crunching : Listed Application GigaFLOP estimations (Message 63765)
Posted 24 Jun 2015 by ProfileConan
Post:
I was looking through the currently available Applications for Milkyway and found that there must be thousands of Macs running this project.

When I say thousands I mean many thousands as the GigaFLOP output for the
Mac OS X 10.5 running Intel 64 bit 1.36(opencl_nvidia_101) shows 31,422,013,947,084 GigaFLOPS

Nvidia must be very happy as well.

I suppose it could be a computing cluster supplying the processing power?

Very impressive output.

Conan
7) Message boards : News : Separation Modified Fit v1.28 Release (Message 59994)
Posted 25 Sep 2013 by ProfileConan
Post:
Just wondering if the Max # Errors could be increased?

Currently at 2, but with a Total # WUs of 9 and Total # Success at 6 it is not adding up.

I have successfully completed a WU only to find I was granted 0.00 as could not validate See Here.

It seems odd to me that some 'Modified Fit' work units need only a quorum of 1 but others need more, usually the slightly longer running ones it seems.

And quite often the 'Minimum Quorum' is 2 but 'Initial Replication' is 1 and credit is granted on the 1 work unit, again seems odd.

Conan
8) Message boards : Number crunching : Catalyst is not OK (Message 59993)
Posted 25 Sep 2013 by ProfileConan
Post:
I receive this message and I am not even using the video card, only have CPU selected in preferences.

Conan
9) Message boards : Number crunching : MT and single-CPU point differences (Message 59873)
Posted 10 Sep 2013 by ProfileConan
Post:
Re-started running some CPU Milkyway tasks and found that the Milkyway@home N-BODY Simulation v1.36 (mt) tasks are giving a lot less points than the other Milkyway@home applications.

On 6 Core Linux 64 bit computer

Milkyway@home N-BODY Simulation (mt) v1.36, Run Time= 1,260.27s, CPU Time= 6,598.42s gives 70.84 points (See WU 424213680)
Milkyway@home v1.01, Run Time= 3852.00s, CPU Time= 3816.61s gives 106.88 points (See WU 424348905)
Milkyway@home Separation (Modified Fit) v1.26, Run Time= 14,881.84s, CPU Time= 14,763.36s gives 213.76 points (See WU 419384816)
Milkyway@home Separation (Modified Fit) v1.26, Run Time= 9,136.92s, CPU Time= 9,071.21s gives 267.19 points (See WU 423885082)

A 4 core computer is similar.

It is not adding up to me when a Multi-Thread Application uses all available CPU resources (stopping other work from taking place) but awards less for doing so.

Conan
10) Message boards : Number crunching : Computation errors (Message 59843)
Posted 7 Sep 2013 by ProfileConan
Post:
Checked it Blurf, but it does not apply that I can see and there is no solution other than maybe a reset of the project.

But in my case I was being sent 64 Bit work to a 32 Bit computer and they just don't work, after de-selecting Modfit all now working.
There is no 32 Bit Modfit work.

Thanks
Conan
11) Message boards : Number crunching : Computation errors (Message 59832)
Posted 6 Sep 2013 by ProfileConan
Post:
Modfit errors for me as the system keeps sending me the Modfit Separation work units to my 32 Bit Windows computer.
I believe that they are 64 bit for Windows, hence why they are failing.

Have de-selected them now.

Conan
12) Message boards : Number crunching : couple of ps_separation tasks are having fits (Message 57245)
Posted 13 Feb 2013 by ProfileConan
Post:
All mine do the same as well, it doesn't seem to stop them from running and they seem to validate.
Both 32 bit Win XP and 64 bit Fedora 16 Linux

Conan
13) Message boards : Number crunching : Error with request of data for calculations. (Message 57244)
Posted 13 Feb 2013 by ProfileConan
Post:
Cosmology@Home needs to be Reset to stop the error

Cosmology@Home | If this happens repeatedly you may need to reset the project.

The error is probably affecting MilkyWay"s access to the net as BOINC Manager tries to work out what is going on.

Conan
14) Message boards : Number crunching : All work Units giving "Computational Error" (Message 52764)
Posted 1 Feb 2012 by ProfileConan
Post:
G'Day mark,
I have just run some test work units and found my reliable machine was giving the same errors as you are getting.
A Reset did not work.
A detach/reattach did not work (I did this twice).
A Reboot of the computer actually got things working again, so if you haven't done this it could be worth a try.

(My other computer with same software and graphic cards has no problem (although it did give a BSOD with Milkyway running).

Conan
15) Message boards : Number crunching : All(?) results are Validate Errors (Message 47955)
Posted 17 Apr 2011 by ProfileConan
Post:
Well after finding that all work was getting validate errors I went looking for an answer and found that for the last 4 days to maybe a week I have been getting this problem.
I did not realise that the applications were no longer usable and had kept processing 0.23 apps which it now seems have been wasting electricity and I didn't know it.

Have now downloaded the new application and adjusted the app_info.xml file for the correct application number and all now running fine.

That is a quite a few thousand lost credits.

Conan.
16) Message boards : Number crunching : admin response very bad (Message 46609)
Posted 18 Mar 2011 by ProfileConan
Post:
The delay in getting a WU verified is all part of the afore mentioned Server Work that the project is working on presently.
With the improvements and upgrades to the server you should find that work units will be verified a lot quicker and you will get your credit a lot quicker.

I too have noticed the delay in getting credit for work done.
I have not worried about it as I know it will be verified fairly soon and I will get my credit.

No need to leave the project it is getting improved on with work unit improvements and Server improvements. Also hopefully even all the stuck work units might then be cleaned out as well.

Conan.
17) Message boards : News : Updated separation to 0.50 (Message 45541)
Posted 13 Jan 2011 by ProfileConan
Post:
This is becoming frustrating... Call me the guy from the ICE AGE but i'm not understanding a thing of what we are doing here... The process of it all is beyond me... Can someone explain to me in short, concise, "English" in what way is my PC contributing BOINC via Milkyway server (Whatever) in finding extraterrestrials...

it's tough i know... to have someone as ignorant as me but... just someone humour me with an explanation... I'll be grateful for life!


G'Day Niburujoe,

BOINC is a platform through which many projects can be launched all doing different things.

SETI also uses the BOINC platform (the first project to do so) and it's purpose is to find signs of Alien life.

It is just one of a number of Astronomy projects, some others being:-

Einstein_____(searches for Pulsars, gravity waves and such)
Cosmology____(trying to understand the universe (I think))
MilkyWay_____(as Matt said trying to get a better idea how big and massive
_____________ Milkyway really is)
Orbit________(tracking space junk including asteroids and meteors)
Constellation____(various space and science projects)

plus a few others.

So as you can see you wont find Aliens here at Milkyway but you may help us find out more about the Galaxy in which we live.

Conan.
18) Message boards : Number crunching : Getting lots of Invalid Wus - Help? (Message 42425)
Posted 28 Sep 2010 by ProfileConan
Post:
I too am having problems with work units that error out.

I have three 5870 cards, all the same type with one in one computer and two in the other.
The single card is running just fine without a problem or an error.

The two card set up is the one with the issues.
I was wondering why my RAC was not moving up very fast on the dual card machine so I checked the work units.
A very large number were getting 0.00 and classed as invalid.
Nearly all were paired with a 64 bit computer and when another 64 bit computer was added to check results I was always kicked out of the Quorum.

I have a large pending amount as well, this is probably related to the inconclusive results but all are now getting 0.00 as well when quorum is met.

Settings are the same on all cards, app_info file is at default settings.

I have now stopped these two cards from doing Milkyway and gone back to DNETC which is having no such problems at all, leaving my single card doing Milkyway.

I seem to recall I may of had this problem before with my 4870 cards, so I stopped them as well.

I now have new cards and updated the application as well but still have the same issue.

Not sure what is going on. I did down clock the single card but as I was doing Collatz as a backup project I put it back to normal a it all slowed down.
19) Message boards : Number crunching : Many "errors while computing" in the stats! (Message 38891)
Posted 20 Apr 2010 by ProfileConan
Post:
I have been away from Milkyway for a while as I was doing DNETC but it started to run "xfer_error" errors at the rate of 25%.
So I switched back to Milky to test the cards.
Not a good move unfortunately, as all I kept getting were VPU reset errors, I did not get those before on any project and was not getting them when I last left.
Updated to the latest 0.23 version but nothing changed, as soon as I try to do some work on the same Windows computer that is running Milky the computer freezes then a VPU errors reset. Only the one card locks up and a suspend/resume will allow the WU to start again with a much longer run time as the process time does not stop only percent done stops.

I have now switched to Collatz and after again updating the app version, it is running great with no hassles and I can use the computer at the same time without it freezing.

I am using two 4800 cards, heat does not appear a problem and the cards are standard.

So I am at a loss as to why I can no longer run Milkyway
20) Message boards : Number crunching : Milestones II (Message 36526)
Posted 14 Feb 2010 by ProfileConan
Post:
18,000,000 in Milkyway

40,000,000 in BOINC Overall Total.

Doing my bit for Science.


Next 20

©2021 Astroinformatics Group