Welcome to MilkyWay@home

Posts by GaryG

1) Message boards : Number crunching : MilkyWay not up loading new workunits (Message 59168)
Posted 29 Jun 2013 by GaryG
Post:
I believe what you are seeing is the following:

1) The Milkway applications only allow a small number of tasks in progress.
2) Often a request for new tasks results in a no tasks available message.
3) The scheduler always tries to keep the cache full on the client.

As a result, when no tasks are available, the scheduler will fill the queue with tasks from the other projects, hence the don't need any message. On my systems this always results in Milkway getting swamped out by the other projects. My solution is to run each project solo. Einstein and Seti used to run fairly well together but, as the GPU apps have matured, even that is getting more complicated. One app seems to get preference over the other when running more than 1x.

Just some observations from my systems.
2) Message boards : News : Separation Modified Fit Release (Message 58997)
Posted 20 Jun 2013 by GaryG
Post:
Has the app_name been changed for the modified fit version or are mods required to the app_config? I have an app_config file and specify GPU usage at .5 for 2x and the modified fit only runs 1x. The app_config works running 2x with the earlier versions.

Edit: I found the name in client_state and added the following to the app_config file. All works as expected now.

<app>
<name>milkyway_separation__modified_fit</name>
<gpu_versions>
<gpu_usage>0.50</gpu_usage>
<cpu_usage>0.20</cpu_usage>
</gpu_versions>
</app>
3) Message boards : Number crunching : Calculation error on all received WUs (Message 58986)
Posted 20 Jun 2013 by GaryG
Post:
Hi,

every work unit I get is calcualted until 100% and then results in 'calculation error'. All of those are either de_separation or ps_separation.

Application is Milkyway@home 1.02 (opencl_amd_ati).

I tried it ~1 week ago with one batch of workunits and I tried it again today.

This is one of the results: http://milkyway.cs.rpi.edu/milkyway/result.php?resultid=504866748

I guess this is the problem


Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Error reading astronomy parameters from file 'astronomy_parameters.txt'
Trying old parameters file



but I can't find such a file on my PC (I tried sudo updatedb && locate astronomy_parameters.txt with no result)

I another thread it had already been said that that error may not be the cause for the calculation error.

The only other thing I found in the log was this:


"/tmp/OCL9J0yxF.cl", line 30: warning: OpenCL extension is now part of core
#pragma OPENCL EXTENSION cl_khr_fp64 : enable


but it says right there it's just a warning.


I had the same exact errors yesterday and a reboot of the machine cleared it up for me.
4) Message boards : Number crunching : de_separation_21_2s_sscon_1_1371083750_xxxx errors (Message 58979)
Posted 19 Jun 2013 by GaryG
Post:
I am getting a lot of errors on this set for example:

http://milkyway.cs.rpi.edu/milkyway/result.php?resultid=504843684

Following are some selected lines from the error:

Incorrect function.
(0x1) - exit code 1 (0x1)
-----
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Error reading astronomy parameters from file 'astronomy_parameters.txt'
Trying old parameters file
----
Failed to read star points item
(2): No such file or directory

Any one have any ideas on how to correct this? All the other runs are completing OK.

Edit: Never mind, a reboot seems to have cleared up the problem.
5) Message boards : News : update for users not getting CPU workunits (Message 58834)
Posted 13 Jun 2013 by GaryG
Post:
I am on the list of those unable to get CPU tasks and looking at the project properties in BOINC it says, Project has no apps for CPU
It would seem the server is telling the client that it does not support the CPU versions.
6) Message boards : News : changes finished (Message 58541)
Posted 7 Jun 2013 by GaryG
Post:
After changes I become application MilkyWay@Home 0.82 (ati14).
Before was MilkyWay@Home 1.02 (opencl_amd_ati).

What's happened?

My system:
BOINC 7.0.64, Win7/32, AMD Phenom II X4 955 + AMD HD7950


My system also went to the .082 version and it has made my system totally unresponsive, input to the system is very intermittent. I have to shut off GPU usage for this project until this is resolved.
7) Message boards : Number crunching : Computational Error? (Message 58284)
Posted 15 May 2013 by GaryG
Post:
I'm not a geek but I'm not totally helpless, nevertheless, I have no clue what to do to to clear the fact that my Milkyway@home has computational errors. Any suggestions to get things right - or should I go to another project?


If you select the tasks link from your account page and then select one of the error tasks, left hand most column, it will display the results of the task. I selected a couple and in both cases the error is the same:


<core_client_version>7.0.65</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>
../../projects/milkyway.cs.rpi.edu_milkyway/milkyway: error while loading shared libraries: libboinc_api.so.6: cannot open shared object file: No such file or directory

</stderr_txt>
]]>

I do not use Linux, but it could be a missing file or perhaps a permissions issue. Maybe someone who runs Linux will post with further ideas. Don't give up this is a great project.
8) Message boards : Number crunching : [Resolved] Task credits (Message 57931)
Posted 15 Apr 2013 by GaryG
Post:
The parameters are different for each run the system generates, as a result the amount of processing time varies and the credit granted.
9) Message boards : News : New Separation Runs Started (Message 57714)
Posted 29 Mar 2013 by GaryG
Post:
Got two of these in row after a restart, which results in a client lockup. These always have the 87600:00:00 time estimate and always crash my client. This is making extremely difficult to run tasks on my system. Any chance these are going to be corrected?

ps_separation_82_3s_dr8_2_1358941502_29566368_1

<core_client_version>7.0.33</core_client_version>
<![CDATA[
<message>
- exit code -1073740940 (0xc0000374)
</message>
<stderr_txt>
BOINC: parse gpu_opencl_dev_index 0
<search_application> milkyway_separation 1.02 Windows x86 double OpenCL </search_application>
Unrecognized XML in project preferences: max_gfx_cpu_pct
Skipping: 5
Skipping: /max_gfx_cpu_pct
Unrecognized XML in project preferences: allow_non_preferred_apps
Skipping: 1
Skipping: /allow_non_preferred_apps
Unrecognized XML in project preferences: nbody_graphics_poll_period
Skipping: 30
Skipping: /nbody_graphics_poll_period
Unrecognized XML in project preferences: nbody_graphics_float_speed
Skipping: 5
Skipping: /nbody_graphics_float_speed
Unrecognized XML in project preferences: nbody_graphics_textured_point_size
Skipping: 250
Skipping: /nbody_graphics_textured_point_size
Unrecognized XML in project preferences: nbody_graphics_point_point_size
Skipping: 40
Skipping: /nbody_graphics_point_point_size
BOINC GPU type suggests using OpenCL vendor 'NVIDIA Corporation'
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Error reading astronomy parameters from file 'astronomy_parameters.txt'
Trying old parameters file
Integral area { 1819239215, 1769234796, 1008738314 } will overflow progress calculation

</stderr_txt>
]]>
10) Message boards : News : New Separation Runs Started (Message 57713)
Posted 29 Mar 2013 by GaryG
Post:
Well I am not sure what is happening but I woke up with the system down and unable to restart again. Again had to dump the Milkyway directory to recover.
The task was from the de_separation_82_3s_dr8_3 group.
11) Message boards : News : New Separation Runs Started (Message 57708)
Posted 29 Mar 2013 by GaryG
Post:
I thought the nbody's were CPU only, the ones with the 87600:00:00 time estimate come in marked for the GPU. My system appears to try to start them on the GPU and I am wondering if this is what caused the crash?
12) Message boards : News : New Separation Runs Started (Message 57706)
Posted 28 Mar 2013 by GaryG
Post:
I got the same time estimate, 87600:00:00, on an AMD card. The task locked up the BOINC client and it would not restart. I ended up renaming the milky way directory and restarting. A new directory was created and all the nbody's ended up in a computation error, I had suspended the GPU tasks prior to this so they were recovered and all is running again.
13) Message boards : News : New N-Body Release (Message 57299)
Posted 20 Feb 2013 by GaryG
Post:
I have an extremely long one as well

http://milkyway.cs.rpi.edu/milkyway/workunit.php?wuid=294575850

It has been running for 124 hours and is not quite 42% done. The deadline is the 23rd, which I won't make, but it has run to completion on one other system so it is possible.
14) Message boards : News : New N-Body Runs (Message 56959)
Posted 20 Jan 2013 by GaryG
Post:
I just aborted two, one for 1368 hours and one for 8071 hours, both received today with a 1/31 deadline. The estimated time on the longer jobs appears to be about 3+ times the actual runtime on my system, one with 195 hours estimated ran in 54+. Even factoring that in, I could not complete these two by the deadline. I have also noticed several jobs with estimated time in minutes that have run 15 to 30+ hours. Maybe as more are completed the estimates can be made better.
15) Message boards : Number crunching : MW app is misidentifying gpu (Message 56937)
Posted 17 Jan 2013 by GaryG
Post:
Is Use Nvidia GPU selected in your Milkyway preferences? I forgot to change it when I switched to an AMD card awhile back.
16) Message boards : Application Code Discussion : 2 calculation at the same time (Message 56726)
Posted 4 Jan 2013 by GaryG
Post:
The count variable needs to be set to .5 for 2x, .33 for 3x, etc.

Edit: Note that when switching to/from app_info usage, your current cache of jobs may be aborted. After having tried both ways, I have reverted to not using app_info as there does not appear to be an advantage in performance. On an ATI GPU times were doubled when running 2x and on a NVida GPU it takes longer (not as good at handling floating point doubles as the ATI). If you are running apps other than Milkyway, running more than 1x will hurt the other apps performance. As always your milage may vary.
17) Message boards : Cafe MilkyWay : Milestones IV (Message 56537)
Posted 16 Dec 2012 by GaryG
Post:
Congratulations to Wrend, Chris and microchip, thats what I love about the project everyone contributes what they can to further the project.

As for myself, just passed 10,000,000 and looking forward to the next 10M.
18) Message boards : News : validator back up (Message 56426)
Posted 8 Dec 2012 by GaryG
Post:
Great news, thanks for all the efforts.
19) Message boards : Number crunching : Validator stopped. (Message 56403)
Posted 6 Dec 2012 by GaryG
Post:
I have looked at my pendings and starting on Dec 4 most of my tasks have no wingman assigned. The ones with a wingman assigned are processing normally. I am rapidly approaching 800 pendings and wondering if there is any news on this issue.
20) Message boards : Number crunching : Example app_info.xml (Message 56295)
Posted 25 Nov 2012 by GaryG
Post:
Glad you got it working, I found most of what I know by searching the message boards. I started running the optimized apps for Seti@Home and it is required there.


Next 20

©2019 Astroinformatics Group