Welcome to MilkyWay@home

Posts by TJ

1) Message boards : Number crunching : sometimes my computer uses 2 or 1 gpu's (Message 62534)
Posted 10 Oct 2014 by TJ
Post:
I have no issues with 2 nVidia GPU's in one rig and also one nVidia and one AMD in the same rig works perfect together.
2) Message boards : Number crunching : sometimes my computer uses 2 or 1 gpu's (Message 62530)
Posted 9 Oct 2014 by TJ
Post:
I just read the prior thread about the amd's are for gaming and ignore parts of the programming that crunchers use. I am in the beginning of putting together a new rig. It sounds like it's time to switch to Nividia. Any comment?

nVidia cards are more versatile as projects who supports GPU, work on nVidia but not always on AMD. However it depends on the project you will do. Here at MilkyWay double precision is necessary and then AMD is a lot faster then nVidia.
Updting drivers with nVidia is far more easy then with AMD, but others will say the opposite. In my experience AMD does not clear all of the old stuff and to remove everything manually takes a lot lof time and effort.
3) Message boards : Number crunching : Some "strange" crunchers (Message 62513)
Posted 8 Oct 2014 by TJ
Post:
Thanks Blurf for letting us know.
This was the answer I was looking for.
4) Message boards : Number crunching : Some "strange" crunchers (Message 62485)
Posted 5 Oct 2014 by TJ
Post:
I don't know, "Aborted bu user" means a manual action from the user or not?
5) Message boards : Number crunching : Some "strange" crunchers (Message 62475)
Posted 5 Oct 2014 by TJ
Post:
I see several Completed, can't validate messages at my results and while checking there I see at least two wing(wo)men with about 4000 results all Aborted by user. This is not helping the project. Can it be investigated?

PS: if moderators have a better name for this thread, please change it.


Please link some examples. Thanks

Hello Blurf,

Here are some links to computers, there are many more...

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=557095

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=555648

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=590516

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=285657

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=453518

http://milkyway.cs.rpi.edu/milkyway/show_host_detail.php?hostid=588454

If you then click on the tasks you will see. The third one is outrageous!
6) Message boards : Number crunching : Some "strange" crunchers (Message 62468)
Posted 4 Oct 2014 by TJ
Post:
I see several Completed, can't validate messages at my results and while checking there I see at least two wing(wo)men with about 4000 results all Aborted by user. This is not helping the project. Can it be investigated?

PS: if moderators have a better name for this thread, please change it.
7) Message boards : Number crunching : All WU de_80_DR8_xxx error out after 6 seconds (Message 61818)
Posted 1 Jun 2014 by TJ
Post:
The title says it all, that is what happening on my rig with AMD 5870.
8) Message boards : News : N-Body 1.38 (Message 60536)
Posted 7 Dec 2013 by TJ
Post:
These N-Body 1.38 simulation WU's use 8 cores of my i7 with HT on. If I set to use only 90% of the cores to use, si that I can use one for GPU feeding, they don't run anymore, waiting to run.
Why is that? In the past these N-Body's run with all the available cores.
Thanks.
9) Message boards : Number crunching : Computation errors. (Message 60142)
Posted 11 Oct 2013 by TJ
Post:
All my WU's failed after updating to driver 13.1. Now I updated to the latest driver, 13.9 on a HD5870 and BOINC 7.0.64
Now MilkyWay@Home v1.02 (opencl_amd_ati) all have computation error in seconds, but the Milkyway@Home Separation (Modified Fit) v1.28 (opencl_amd_ati) run fine.
Other projects do good as well.
Is this still the driver update since begin this year, adn is only 12.1 good for MilkyWay@home?
10) Message boards : Number crunching : Computational Error? (Message 58462)
Posted 31 May 2013 by TJ
Post:
AMD is again changing their software to favor gamers and not crunchers, they are working on it but don't hold your breath! If you ever find a version that is stable and just works AND you are not a gamer, then don't upgrade unless you hear the new one is MUCH faster and has been tested by others with your configuration. I am still running version 11.9 on one of my pc's and it works here just fine.


I agree completely!! Updating GPU software/drivers is almost always in-favour of the gamer. 13.4 is currently on my "thou shall not pass" software list.

I agree too, but there was an issue with my 12.x version and Einstein@home.
You have 13.4 drivers and MilkyWay is working with no errors, do I understand that from your post correctly?
Then I must update at once.
Thanks.
11) Message boards : Number crunching : Computational Error? (Message 58436)
Posted 29 May 2013 by TJ
Post:
I have Catalyst 13.3 for a while on my rig and all MilkyWay's will error out.
Going lower got problems with installing, de-istalling and a lot of pain. Eventually the one proper installed had an app missing according to BOINC and wouldn't crunch Einstein and Albert at home.
They run smooth now, but MW don't. So I have to wait for a new good driver or an update of the MW-app.
12) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57602)
Posted 21 Mar 2013 by TJ
Post:
I did try to re-install 13.1 again for several times, as an update, as clean install with first removing, booting and such, but then the message that opencl app was missing. I give in, Windows and AMD win this time.
Next time Linux and nVidia.
13) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57586)
Posted 21 Mar 2013 by TJ
Post:
Okay this morning again several hours updating AMD stuff. Version 10 and 12 installed no joy, even extra errors on my systems with graphics and display.
Installing and re-installing is bad for windows as well.
I have eventually installed AMD 13.3 beta and now my displays are stable, no flickering and Einstein@home is running the OpenCL.
Milyway not they error out immediately.
Well Einstein@home is my main project, thus until fixed no more Milkyway for the AMD rig.


What OS are you using? If you are using XP you CAN NOT go beyond version 12.1 as OpenCL support for XP was dropped after that. See this page http://www.hal6000.com/seti/boinc_ati_gpu_cheat_sheet.htm which has the download links at the bottom of it.

Win7 x64 ultimate
14) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57560)
Posted 19 Mar 2013 by TJ
Post:
Okay this morning again several hours updating AMD stuff. Version 10 and 12 installed no joy, even extra errors on my systems with graphics and display.
Installing and re-installing is bad for windows as well.
I have eventually installed AMD 13.3 beta and now my displays are stable, no flickering and Einstein@home is running the OpenCL.
Milyway not they error out immediately.
Well Einstein@home is my main project, thus until fixed no more Milkyway for the AMD rig.
15) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57559)
Posted 19 Mar 2013 by TJ
Post:

My guess is you are using 7.0.28, which has a bug in OpenCL detection.


You are right but I have crunched 1000's of WU for both Einstein and Milkyway with this version.
16) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57552)
Posted 19 Mar 2013 by TJ
Post:
Okay I am now more then 4 hours installing and de-installing amd drivers.
The 13.1 driver does not work any more an any project. Messages are:
3/19/2013 1:16:08 AM | | ATI GPU 0: ATI Radeon HD 5800 series (Cypress) (CAL version 1.4.1741, 1024MB, 991MB available, 5440 GFLOPS peak)
3/19/2013 1:16:08 AM | | ATI GPU 1: ATI Radeon HD 5800 series (Cypress) (CAL version 1.4.1741, 1024MB, 991MB available, 5440 GFLOPS peak)
3/19/2013 1:16:08 AM | | App version needs OpenCL but GPU doesn't support it
3/19/2013 1:16:08 AM | Albert@Home | Application uses missing ATI GPU
3/19/2013 1:16:08 AM | | App version needs OpenCL but GPU doesn't support it
3/19/2013 1:16:08 AM | Einstein@Home | Application uses missing ATI GPU
3/19/2013 1:16:08 AM | | App version needs OpenCL but GPU doesn't support it
3/19/2013 1:16:08 AM | Milkyway@Home | Application uses missing ATI GPU
3/19/2013 1:16:12 AM | Milkyway@Home | Sending scheduler request: To fetch work.
3/19/2013 1:16:12 AM | Milkyway@Home | Requesting new tasks for ATI
3/19/2013 1:16:15 AM | | App version needs OpenCL but GPU doesn't support it
3/19/2013 1:16:15 AM | Milkyway@Home | Scheduler request completed: got 11 new tasks
3/19/2013 1:16:15 AM | Milkyway@Home | [error] App version uses non-existent ATI GPU
3/19/2013 1:16:15 AM | Milkyway@Home | [error] Missing coprocessor for task ps_separation_21_sSgr_1_1358941502_25162321_0; aborting
3/19/2013 1:16:15 AM | Milkyway@Home | [error] Missing coprocessor for task ps_separation_21_sSgr_1_1358941502_25162323_0; aborting
3/19/2013 1:16:15 AM | Milkyway@Home | [error] Missing coprocessor for task ps_separation_21_sSgr_1_1358941502_24699976_1; aborting
3/19/2013 1:16:15 AM | Milkyway@Home | [error] Missing coprocessor for task ps_separation_21_sSgr_1_1358941502_25162326_0; aborting
3/19/2013 1:16:15 AM | Milkyway@Home | [error] Missing coprocessor for task ps_separation_21_sSgr_1_1358941502_25162327_0; aborting
3/19/2013 1:16:15 AM | Milkyway@Home | [error] Missing coprocessor for task ps_separation_21_sSgr_1_1358941502_25162324_0; aborting
end so on and so on...

What am I doing wrong? Which version of AMD should I use?
17) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57491)
Posted 13 Mar 2013 by TJ
Post:
Indeed Einstein@home is working for me fine too, but Milkyway not. Previous drivers gave issues with flickering screens, sometimes a window with browser maximized got complete white, or one WU stuck. Seems running for hours and needed hours more. Had to suspend it, wait and then start again. Within 2 minutes WU is ready then. So that is why I update to beta driver.

Will see is a 12.x driver will work.


On the other hand my system is now running smooth and no more flickering windows, especially in the BOINC tray. Einstein@home (my main project) runs fine as well. So I keep the beta drivers for a while, and thus no Milkyway at the moment.
18) Message boards : Number crunching : After driver update all gpu wu's fail (Message 57490)
Posted 12 Mar 2013 by TJ
Post:
Indeed Einstein@home is working for me fine too, but Milkyway not. Previous drivers gave issues with flickering screens, sometimes a window with browser maximized got complete white, or one WU stuck. Seems running for hours and needed hours more. Had to suspend it, wait and then start again. Within 2 minutes WU is ready then. So that is why I update to beta driver.

Will see is a 12.x driver will work.
19) Message boards : Number crunching : Computation errors (Message 57473)
Posted 10 Mar 2013 by TJ
Post:
I will try the update, thanks.

One more thing to mention:
I have updated the AMD drivers to latest beta ones, as I got spontaneous reboots of the system when doing gpu (Einstein or Milkyway).
Screens blink as well at times.
Seems to be stable now with Einstein and Rosetta for 24 hours.
Win7 64bit and AMD HD5870 (1GB).
20) Message boards : Number crunching : Computation errors (Message 57467)
Posted 9 Mar 2013 by TJ
Post:
All taks error out immediately with BOINC 7.0.28. See these :416025759 (I can not get it clickable).
Is it something on my end?
Einstein@home is now running on the GPU's and Rosetta@home on 5 CPU's, thus one CPU left.
This is the eroor message (for all last 33 tasks):
Stderr output

<core_client_version>7.0.28</core_client_version>
<![CDATA[
<message>
Incorrect function. (0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
BOINC: parse gpu_opencl_dev_index 0
<search_application> milkyway_separation 1.02 Windows x86_64 double OpenCL </search_application>
Unrecognized XML in project preferences: nvidia_block_amount
Skipping: 128
Skipping: /nvidia_block_amount
BOINC GPU type suggests using OpenCL vendor 'Advanced Micro Devices, Inc.'
Error loading Lua script 'astronomy_parameters.txt': [string "number_parameters: 4..."]:1: '<name>' expected near '4'
Error reading astronomy parameters from file 'astronomy_parameters.txt'
Trying old parameters file
Using SSE4.1 path
Found 1 platform
Platform 0 information:
Name: AMD Accelerated Parallel Processing
Version: OpenCL 1.2 AMD-APP (1124.2)
Vendor: Advanced Micro Devices, Inc.
Extensions: cl_khr_icd cl_amd_event_callback cl_amd_offline_devices cl_khr_d3d10_sharing cl_khr_d3d11_sharing
Profile: FULL_PROFILE
Using device 0 on platform 0
Found 2 CL devices
Device 'Cypress' (Advanced Micro Devices, Inc.:0x1002) (CL_DEVICE_TYPE_GPU)
Driver version: 1124.2 (VM)
Version: OpenCL 1.2 AMD-APP (1124.2)
Compute capability: 0.0
Max compute units: 20
Clock frequency: 850 Mhz
Global mem size: 1073741824
Local mem size: 32768
Max const buf size: 65536
Double extension: cl_khr_fp64
Build log:
--------------------------------------------------------------------------------
"C:\Users\TJ\AppData\Local\Temp\OCL4D8.tmp.cl", line 30: warning: OpenCL
extension is now part of core
#pragma OPENCL EXTENSION cl_khr_fp64 : enable
^


--------------------------------------------------------------------------------
clBuildProgram: Build failure (-11): CL_BUILD_PROGRAM_FAILURE
Error building program from source (-11): CL_BUILD_PROGRAM_FAILURE
Error creating integral program from source
Failed to calculate likelihood
<background_integral> 1.#QNAN0000000000 </background_integral>
<stream_integral> 1.#QNAN0000000000 1.#QNAN0000000000 1.#QNAN0000000000 </stream_integral>
<background_likelihood> 1.#QNAN0000000000 </background_likelihood>
<stream_only_likelihood> 1.#QNAN0000000000 1.#QNAN0000000000 1.#QNAN0000000000 </stream_only_likelihood>
<search_likelihood> 1.#QNAN0000000000 </search_likelihood>
00:10:58 (3332): called boinc_finish

</stderr_txt>
]]>


Next 20

©2019 Astroinformatics Group