Welcome to MilkyWay@home

Posts by Stephen Uitti

1) Message boards : Number crunching : Getting work units (Message 62829)
Posted 12 Dec 2014 by ProfileStephen Uitti
Post:
I've stumbled upon a solution to this issue. I removed the Milky Way project and added it back. Now the machine gets units, and crunches them. This fits the hypothesis that there was something wrong with the configuration files. It doesn't actually identify what was wrong. It feels a little like turning something off, then turning it back on, though nothing was ever turned off. It only took a minute, and took hardly any brain power, except for that part about coming up with the idea, which seemed to take a long time.

I suppose, if i care to, i could attempt to compare the new configuration files with a recent backup... Then, if it happens again, i might be able to edit the files in a slow and error prone way, but with great understanding, rather than quick and easy. I've got a three year badge for Milky Way, and this machine is the first machine crunching it. If i did the full analysis, and did a complete write up, i might be able to puzzle through it from scratch in three more years.
2) Message boards : Number crunching : Getting work units (Message 62827)
Posted 11 Dec 2014 by ProfileStephen Uitti
Post:
Yeah, well, this machine does have an issue with keeping units. Despite putting BOINC on a drive with 60 GB free, and telling it to go for it, and telling it to keep 9 days of units, it usually only has the units it is currently working on, possibly plus another one or two.
3) Message boards : Number crunching : Getting work units (Message 62826)
Posted 11 Dec 2014 by ProfileStephen Uitti
Post:
I turned off the n-body applications, because it does indeed do wacky things. For example, it ignores you if you tell it to use up to 2 cores, and lots of other things. The machine has 4 cores.
4) Message boards : Number crunching : Getting work units (Message 62825)
Posted 11 Dec 2014 by ProfileStephen Uitti
Post:
Other projects include Einstein, LHC, SETI and World Community Grid. Also some GPU projects: Collatz. But all the other CPU projects were set to "No New Tasks".
5) Message boards : Number crunching : Getting work units (Message 62756)
Posted 30 Nov 2014 by ProfileStephen Uitti
Post:
I've got two very similar Linux machines. Both are running BOINC 7.2.42. Both have 4 core AMD CPUs. One has no issues.

The problem child has a usable GPU, and I ran Milky Way on it for about a week earlier this month with no problems. The GPU (GTX 650ti) performance was not what I was hoping, so i wanted to run MW on CPUs. However, even when all four cores are idle, this machine says:
30-Nov-2014 11:18:20 [Milkyway@Home] update requested by user
30-Nov-2014 11:18:24 [Milkyway@Home] Sending scheduler request: Requested by user.
30-Nov-2014 11:18:24 [Milkyway@Home] Not requesting tasks: don't need
30-Nov-2014 11:18:27 [Milkyway@Home] Scheduler request completed

This machine ran MW on CPU cores before running on the GPU without incident.

The problem computer is machine ID 315265
The working computer is machine ID 570596

I have the machines in separate venues, but the compute configurations are identical.

One thing that is true is that the problem machine is considerably older, and has been upgraded repeatedly. It is possible that there are no original parts. But despite BOINC having been upgraded several times, the project files may date from 2011. Perhaps there's something in the xml or whatever config files on the machine that are messed up.

Another issue is that this problem machine pretty much only gets work units if it can execute them right away, for all projects. That's despite having projects set to retain a several day queue. I've looked at this for some time.

Any ideas on what i should attempt?
6) Message boards : News : New N-Body Runs (Message 61859)
Posted 9 Jun 2014 by ProfileStephen Uitti
Post:
One difference, the laptop running for days is Windows, the 4 core desktop is Linux.
7) Message boards : News : New N-Body Runs (Message 61858)
Posted 9 Jun 2014 by ProfileStephen Uitti
Post:
I have an N-Body 1.40 (mt) running on my laptop (id 563836), task id 758776399 (or 758776398), The laptop has two AMD cores. It's been running for 123 hours, and has about 8 hours left (it's at 93.998%). So, that's 5.5 days, total. I thought it might be stuck at first, but it makes percent progress. The CPU estimate was grossly low, and is low by an hour even still. It's due date is 6/15. I have another in the queue, not yet started, also due 6/15. It's not a sure thing that it could finish by the deadline.

I expect really poor credit from this, as the estimate was so dreadfully wrong. But we'll see.

I also have no idea why it shouldn't take more like twice the wall clock or so of my 4 core desktops.

I've heard in other forums of bad estimates due to BOINC using a CPU benchmark for an essentially FPU intensive app, or the other way around. Obviously, the best benchmark would be one where after a half hour or so, the current unit's progress would be used for the estimate. And, previous units of the exact same type would be used over BOINC's guess. I have no idea if this is in the control of Milky Way or BOINC, however.

I've allowed a 4 core desktop to do some units. Usually, Milky Way prevents my GPU from running. But Collatz is currently down, and some have finished. For example, 2,706.26 CPU seconds finishes in 739.62 seconds, which is like 12 minutes. but i get 27 credit, which is about a quarter of what i get for similar CPU time units. Perhaps the credit is based on wall clock instead of CPU time.
8) Message boards : Application Code Discussion : 4 core units stop GPU (Message 61824)
Posted 2 Jun 2014 by ProfileStephen Uitti
Post:
A machine with a 4 core CPU and Nvidia GPU runs Milky Way, but i tell it not to run on any GPUs. Machine ID 315265. Lately, when running MilkyWay@Home N-Body Simulation, it uses all 4 cores (which is OK), but whatever is running on the GPU is suspended until the MilkyWay unit is finished. Single core units don't do this. Since the CPUs can total less than 10,000 units a day total, while GTX 650 ti totals 130,000 units, this doesn't work for me. Is it likely that there's some setting that would let me run MilkyWay on CPUs only so that it doesn't shut down the GPUs? I tried telling it to use no more than 3 CPUs, but it ignored it. When i'm working on the machine, i can hear the fans spin down, telling me a new 4 core Milky Way unit has started.

At the moment, i've suspended MilkyWay@Home except on a 2 core laptop. The laptop has a feeble GPU, but it keeps crunching anyway (on other projects).




©2019 Astroinformatics Group